New upstream rrdtool release, v1.2.21
This commit is contained in:
parent
19329b9e22
commit
1767d1b0c2
@ -5,3 +5,4 @@ rrdtool-1.2.15.tar.gz
|
||||
rrdtool-1.2.17.tar.gz
|
||||
rrdtool-1.2.18.tar.gz
|
||||
rrdtool-1.2.19.tar.gz
|
||||
rrdtool-1.2.21.tar.gz
|
||||
|
@ -1,22 +0,0 @@
|
||||
diff -uNr bindings/python-orig/Makefile.am bindings/python/Makefile.am
|
||||
--- bindings/python-orig/Makefile.am 2007-03-31 11:21:43.000000000 +0100
|
||||
+++ bindings/python/Makefile.am 2007-03-31 11:24:47.000000000 +0100
|
||||
@@ -2,6 +2,7 @@
|
||||
|
||||
pyexec_PROGRAMS = rrdtoolmodule.so
|
||||
|
||||
+rrdtoolmodule_so_LDFLAGS = -module -shared
|
||||
rrdtoolmodule_so_LDADD = $(top_builddir)/src/librrd.la
|
||||
rrdtoolmodule_so_SOURCES = rrdtoolmodule.c
|
||||
|
||||
diff -uNr bindings/python-orig/Makefile.in bindings/python/Makefile.in
|
||||
--- bindings/python-orig/Makefile.in 2007-03-31 11:21:43.000000000 +0100
|
||||
+++ bindings/python/Makefile.in 2007-03-31 11:22:14.000000000 +0100
|
||||
@@ -233,6 +233,7 @@
|
||||
target_os = @target_os@
|
||||
target_vendor = @target_vendor@
|
||||
AM_CPPFLAGS = @CFLAGS@ -I$(top_srcdir)/src @PYTHON_INCLUDES@
|
||||
+rrdtoolmodule_so_LDFLAGS = -module -shared
|
||||
rrdtoolmodule_so_LDADD = $(top_builddir)/src/librrd.la
|
||||
rrdtoolmodule_so_SOURCES = rrdtoolmodule.c
|
||||
noinst_HEADERS = rrd_extra.h
|
24
rrdtool-1.2.21-python.patch
Normal file
24
rrdtool-1.2.21-python.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -urp rrdtool-1.2.21.orig/bindings/Makefile.am rrdtool-1.2.21/bindings/Makefile.am
|
||||
--- rrdtool-1.2.21.orig/bindings/Makefile.am 2007-05-01 16:42:02.000000000 -0400
|
||||
+++ rrdtool-1.2.21/bindings/Makefile.am 2007-05-02 10:38:19.000000000 -0400
|
||||
@@ -20,7 +20,7 @@ install-data-local:
|
||||
test -f perl-piped/Makefile && cd perl-piped && $(MAKE) install || true
|
||||
test -f perl-shared/Makefile && cd perl-shared && $(MAKE) install || true
|
||||
test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS) install || true
|
||||
- test -d python/build && cd python && rm -rf build && env LIBDIR=$(libdir) $(PYTHON) setup.py install --prefix=$(prefix) --exec-prefix=$(exec_prefix) || true
|
||||
+ test -d python/build && cd python && rm -rf build && env LIBDIR=$(libdir) $(PYTHON) setup.py install --prefix=$(DESTDIR)$(prefix) --exec-prefix=$(DESTDIR)$(exec_prefix) || true
|
||||
|
||||
# rules for buildung the ruby module
|
||||
ruby:
|
||||
diff -urp rrdtool-1.2.21.orig/bindings/Makefile.in rrdtool-1.2.21/bindings/Makefile.in
|
||||
--- rrdtool-1.2.21.orig/bindings/Makefile.in 2007-05-01 16:42:26.000000000 -0400
|
||||
+++ rrdtool-1.2.21/bindings/Makefile.in 2007-05-02 10:38:38.000000000 -0400
|
||||
@@ -542,7 +542,7 @@ install-data-local:
|
||||
test -f perl-piped/Makefile && cd perl-piped && $(MAKE) install || true
|
||||
test -f perl-shared/Makefile && cd perl-shared && $(MAKE) install || true
|
||||
test -f ruby/Makefile && cd ruby && $(MAKE) EPREFIX=$(exec_prefix) $(RUBY_MAKE_OPTIONS) install || true
|
||||
- test -d python/build && cd python && rm -rf build && env LIBDIR=$(libdir) $(PYTHON) setup.py install --prefix=$(prefix) --exec-prefix=$(exec_prefix) || true
|
||||
+ test -d python/build && cd python && rm -rf build && env LIBDIR=$(libdir) $(PYTHON) setup.py install --prefix=$(DESTDIR)$(prefix) --exec-prefix=$(DESTDIR)$(exec_prefix) || true
|
||||
|
||||
# rules for buildung the ruby module
|
||||
ruby:
|
13
rrdtool-1.2.21-tclbindings.patch
Normal file
13
rrdtool-1.2.21-tclbindings.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -urp rrdtool-1.2.21.orig/bindings/tcl/tclrrd.c rrdtool-1.2.21/bindings/tcl/tclrrd.c
|
||||
--- rrdtool-1.2.21.orig/bindings/tcl/tclrrd.c 2007-05-01 16:42:02.000000000 -0400
|
||||
+++ rrdtool-1.2.21/bindings/tcl/tclrrd.c 2007-05-02 09:44:32.000000000 -0400
|
||||
@@ -19,7 +19,7 @@
|
||||
#include <unistd.h>
|
||||
#include <tcl.h>
|
||||
#include "../../src/rrd_tool.h"
|
||||
-#include "../../rrd_format.h"
|
||||
+#include "../../src/rrd_format.h"
|
||||
|
||||
/* support pre-8.4 tcl */
|
||||
|
||||
Only in rrdtool-1.2.21.orig: rrdtool-1.2.21
|
13
rrdtool.spec
13
rrdtool.spec
@ -6,15 +6,16 @@
|
||||
|
||||
Summary: Round Robin Database Tool to store and display time-series data
|
||||
Name: rrdtool
|
||||
Version: 1.2.19
|
||||
Release: 2%{?dist}
|
||||
Version: 1.2.21
|
||||
Release: 1%{?dist}
|
||||
License: GPL
|
||||
Group: Applications/Databases
|
||||
URL: http://people.ee.ethz.ch/~oetiker/webtools/%{name}/
|
||||
Source0: http://people.ee.ethz.ch/~oetiker/webtools/%{name}/pub/%{name}-%{version}.tar.gz
|
||||
Source1: php4-svn%{php_rrd_svn}.tar.gz
|
||||
Patch0: rrdtool-1.2.13-php.patch
|
||||
Patch1: rrdtool-1.2.19-python.patch
|
||||
Patch1: rrdtool-1.2.21-tclbindings.patch
|
||||
Patch2: rrdtool-1.2.21-python.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: gcc-c++, openssl-devel, freetype-devel
|
||||
BuildRequires: libpng-devel, zlib-devel, libart_lgpl-devel >= 2.0
|
||||
@ -113,7 +114,8 @@ The %{name}-tcl package includes RRDtool bindings for Tcl.
|
||||
%patch0 -p0 -b .php
|
||||
%{__perl} -pi -e 's|../config.h|../rrd_config.h|g' php4/rrdtool.c
|
||||
%endif
|
||||
%patch1 -p0 -b .python
|
||||
%patch1 -p1 -b .tcl
|
||||
%patch2 -p1 -b .python
|
||||
|
||||
# Fix to find correct python dir on lib64
|
||||
%{__perl} -pi -e 's|get_python_lib\(0,0,prefix|get_python_lib\(1,0,prefix|g' \
|
||||
@ -272,6 +274,9 @@ find examples/ -type f -exec chmod 0644 {} \;
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue May 01 2007 Jarod Wilson <jwilson@redhat.com> 1.2.21-1
|
||||
- New upstream release
|
||||
|
||||
* Wed Apr 25 2007 Jarod Wilson <jwilson@redhat.com> 1.2.19-2
|
||||
- Define %%python_version *before* its needed (#237826)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user