Unfuzz compile patch.
This commit is contained in:
parent
dde4499be6
commit
db474668e1
@ -1,21 +0,0 @@
|
|||||||
--- compile.py~ 2006-04-10 17:32:27.000000000 +0300
|
|
||||||
+++ compile.py 2006-09-16 16:48:16.000000000 +0300
|
|
||||||
@@ -12,6 +12,7 @@
|
|
||||||
import sys
|
|
||||||
|
|
||||||
for f in sys.argv[2:]:
|
|
||||||
+ py_compile.compile(f, f + 'c', sys.argv[1] + f)
|
|
||||||
py_compile.compile(f, f + 'o', sys.argv[1] + f)
|
|
||||||
|
|
||||||
# compile.py ends here
|
|
||||||
--- Makefile~ 2006-06-29 00:19:16.000000000 +0300
|
|
||||||
+++ Makefile 2006-09-16 16:50:17.000000000 +0300
|
|
||||||
@@ -36,7 +36,7 @@
|
|
||||||
|
|
||||||
install:
|
|
||||||
-mkdir -p $(DESTDIR)$(LIBDIR) $(DESTDIR)$(BINDIR) $(DESTDIR)$(ETCDIR)/$(PACKAGE) $(DESTDIR)$(ETCDIR)/bash_completion.d $(DESTDIR)$(MANDIR)/man1
|
|
||||||
- cp -p *.py *.pyo $(DESTDIR)$(LIBDIR)
|
|
||||||
+ cp -p *.py *.pyc *.pyo $(DESTDIR)$(LIBDIR)
|
|
||||||
rm -f $(DESTDIR)$(LIBDIR)/compile.py*
|
|
||||||
if [ -z "$(POLICY)" ]; then \
|
|
||||||
sed -e 's/@VERSION@/$(VERSION)/' < rpmlint.py > $(DESTDIR)$(LIBDIR)/rpmlint.py ; \
|
|
23
rpmlint-0.85-compile.patch
Normal file
23
rpmlint-0.85-compile.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
diff -up rpmlint-0.85/compile.py.orig rpmlint-0.85/compile.py
|
||||||
|
--- rpmlint-0.85/compile.py.orig 2006-04-01 11:09:19.000000000 +0300
|
||||||
|
+++ rpmlint-0.85/compile.py 2008-10-23 23:33:03.000000000 +0300
|
||||||
|
@@ -12,6 +12,7 @@ import py_compile
|
||||||
|
import sys
|
||||||
|
|
||||||
|
for f in sys.argv[2:]:
|
||||||
|
+ py_compile.compile(f, f + 'c', sys.argv[1] + f)
|
||||||
|
py_compile.compile(f, f + 'o', sys.argv[1] + f)
|
||||||
|
|
||||||
|
# compile.py ends here
|
||||||
|
diff -up rpmlint-0.85/Makefile.orig rpmlint-0.85/Makefile
|
||||||
|
--- rpmlint-0.85/Makefile.orig 2008-10-23 22:47:48.000000000 +0300
|
||||||
|
+++ rpmlint-0.85/Makefile 2008-10-23 23:33:03.000000000 +0300
|
||||||
|
@@ -36,7 +36,7 @@ clean:
|
||||||
|
|
||||||
|
install:
|
||||||
|
-mkdir -p $(DESTDIR)$(LIBDIR) $(DESTDIR)$(BINDIR) $(DESTDIR)$(ETCDIR)/$(PACKAGE) $(DESTDIR)$(ETCDIR)/bash_completion.d $(DESTDIR)$(MANDIR)/man1
|
||||||
|
- cp -p *.py *.pyo $(DESTDIR)$(LIBDIR)
|
||||||
|
+ cp -p *.py *.pyc *.pyo $(DESTDIR)$(LIBDIR)
|
||||||
|
rm -f $(DESTDIR)$(LIBDIR)/compile.py*
|
||||||
|
sed -e 's/@VERSION@/$(VERSION)/' < rpmlint.py > $(DESTDIR)$(LIBDIR)/rpmlint.py
|
||||||
|
cp -p rpmlint rpmdiff $(DESTDIR)$(BINDIR)
|
@ -9,7 +9,7 @@ URL: http://rpmlint.zarb.org/
|
|||||||
Source0: http://rpmlint.zarb.org/download/%{name}-%{version}.tar.bz2
|
Source0: http://rpmlint.zarb.org/download/%{name}-%{version}.tar.bz2
|
||||||
Source1: %{name}.config
|
Source1: %{name}.config
|
||||||
Source2: %{name}-CHANGES.package.old
|
Source2: %{name}-CHANGES.package.old
|
||||||
Patch0: %{name}-0.77-compile.patch
|
Patch0: %{name}-0.85-compile.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
@ -30,7 +30,7 @@ and source packages can be checked.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0
|
%patch0 -p1
|
||||||
sed -i -e /MenuCheck/d Config.py
|
sed -i -e /MenuCheck/d Config.py
|
||||||
install -pm 644 %{SOURCE2} CHANGES.package.old
|
install -pm 644 %{SOURCE2} CHANGES.package.old
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user