24 lines
1020 B
Diff
24 lines
1020 B
Diff
diff -up rpmlint-0.85/compile.py.orig rpmlint-0.85/compile.py
|
|
--- rpmlint-0.85/compile.py.orig 2006-04-01 11:09:19.000000000 +0300
|
|
+++ rpmlint-0.85/compile.py 2008-10-23 23:33:03.000000000 +0300
|
|
@@ -12,6 +12,7 @@ import py_compile
|
|
import sys
|
|
|
|
for f in sys.argv[2:]:
|
|
+ py_compile.compile(f, f + 'c', sys.argv[1] + f)
|
|
py_compile.compile(f, f + 'o', sys.argv[1] + f)
|
|
|
|
# compile.py ends here
|
|
diff -up rpmlint-0.85/Makefile.orig rpmlint-0.85/Makefile
|
|
--- rpmlint-0.85/Makefile.orig 2008-10-23 22:47:48.000000000 +0300
|
|
+++ rpmlint-0.85/Makefile 2008-10-23 23:33:03.000000000 +0300
|
|
@@ -36,7 +36,7 @@ clean:
|
|
|
|
install:
|
|
-mkdir -p $(DESTDIR)$(LIBDIR) $(DESTDIR)$(BINDIR) $(DESTDIR)$(ETCDIR)/$(PACKAGE) $(DESTDIR)$(ETCDIR)/bash_completion.d $(DESTDIR)$(MANDIR)/man1
|
|
- cp -p *.py *.pyo $(DESTDIR)$(LIBDIR)
|
|
+ cp -p *.py *.pyc *.pyo $(DESTDIR)$(LIBDIR)
|
|
rm -f $(DESTDIR)$(LIBDIR)/compile.py*
|
|
sed -e 's/@VERSION@/$(VERSION)/' < rpmlint.py > $(DESTDIR)$(LIBDIR)/rpmlint.py
|
|
cp -p rpmlint rpmdiff $(DESTDIR)$(BINDIR)
|