re-import sources as agreed with the maintainer
This commit is contained in:
parent
fc2e12aad2
commit
6a689565a6
11
.gitignore
vendored
11
.gitignore
vendored
@ -1,2 +1,11 @@
|
||||
SOURCES/rpmlint-1.10.tar.gz
|
||||
/rpmlint-1.0.tar.bz2
|
||||
/rpmlint-1.1.tar.xz
|
||||
/rpmlint-1.2.tar.xz
|
||||
/rpmlint-1.3.tar.xz
|
||||
/rpmlint-1.4.tar.xz
|
||||
/rpmlint-1.5.tar.xz
|
||||
/rpmlint-1.6.tar.xz
|
||||
/rpmlint-1.7.tar.xz
|
||||
/rpmlint-1.8.tar.gz
|
||||
/rpmlint-1.9.tar.gz
|
||||
/rpmlint-1.10.tar.gz
|
||||
|
33
rpmlint-1.9-buildid-fixes.patch
Normal file
33
rpmlint-1.9-buildid-fixes.patch
Normal file
@ -0,0 +1,33 @@
|
||||
diff -up rpmlint-rpmlint-1.9/BinariesCheck.py.buildid rpmlint-rpmlint-1.9/BinariesCheck.py
|
||||
--- rpmlint-rpmlint-1.9/BinariesCheck.py.buildid 2017-07-17 09:45:17.415365410 -0400
|
||||
+++ rpmlint-rpmlint-1.9/BinariesCheck.py 2017-07-17 09:45:28.719085854 -0400
|
||||
@@ -294,7 +294,7 @@ usr_lib_regex = re.compile('^/usr/lib(64
|
||||
bin_regex = re.compile('^(/usr(/X11R6)?)?/s?bin/')
|
||||
soversion_regex = re.compile('.*?([0-9][.0-9]*)\\.so|.*\\.so\\.([0-9][.0-9]*).*')
|
||||
reference_regex = re.compile('\.la$|^/usr/lib(64)?/pkgconfig/')
|
||||
-usr_lib_exception_regex = re.compile(Config.getOption('UsrLibBinaryException', '^/usr/lib(64)?/(perl|python|ruby|menu|pkgconfig|ocaml|lib[^/]+\.(so|l?a)$|bonobo/servers/)'))
|
||||
+usr_lib_exception_regex = re.compile(Config.getOption('UsrLibBinaryException', r'^/usr/lib(64)?/(perl|python|ruby|menu|pkgconfig|ocaml|lib[^/]+\.(so|l?a)$|bonobo/servers/|\.build-id)'))
|
||||
srcname_regex = re.compile('(.*?)-[0-9]')
|
||||
invalid_dir_ref_regex = re.compile('/(home|tmp)(\W|$)')
|
||||
ocaml_mixed_regex = re.compile('^Caml1999X0\d\d$')
|
||||
diff -up rpmlint-rpmlint-1.9/FilesCheck.py.buildid rpmlint-rpmlint-1.9/FilesCheck.py
|
||||
--- rpmlint-rpmlint-1.9/FilesCheck.py.buildid 2017-07-17 09:45:37.733862908 -0400
|
||||
+++ rpmlint-rpmlint-1.9/FilesCheck.py 2017-07-17 09:46:33.053494782 -0400
|
||||
@@ -505,7 +505,7 @@ class FilesCheck(AbstractCheck.AbstractC
|
||||
printError(pkg, 'version-control-internal-file', f)
|
||||
elif f.endswith('/.htaccess'):
|
||||
printError(pkg, 'htaccess-file', f)
|
||||
- elif hidden_file_regex.search(f) and not f.startswith("/etc/skel/"):
|
||||
+ elif hidden_file_regex.search(f) and not f.startswith("/etc/skel/") and not f.endswith("/.build-id"):
|
||||
printWarning(pkg, 'hidden-file-or-dir', f)
|
||||
elif manifest_perl_regex.search(f):
|
||||
printWarning(pkg, 'manifest-in-perl-module', f)
|
||||
@@ -879,7 +879,7 @@ class FilesCheck(AbstractCheck.AbstractC
|
||||
printError(pkg, 'non-standard-dir-perm', f, "%o" % perm)
|
||||
if pkg.name not in filesys_packages and f in STANDARD_DIRS:
|
||||
printError(pkg, 'standard-dir-owned-by-package', f)
|
||||
- if hidden_file_regex.search(f):
|
||||
+ if hidden_file_regex.search(f) and not f.endswith("/.build-id"):
|
||||
printWarning(pkg, 'hidden-file-or-dir', f)
|
||||
|
||||
# symbolic link check
|
55
rpmlint-1.9-fix-uep.patch
Normal file
55
rpmlint-1.9-fix-uep.patch
Normal file
@ -0,0 +1,55 @@
|
||||
diff -up rpmlint-rpmlint-1.9/SpecCheck.py.fixuep rpmlint-rpmlint-1.9/SpecCheck.py
|
||||
--- rpmlint-rpmlint-1.9/SpecCheck.py.fixuep 2017-02-08 16:54:24.055208215 -0500
|
||||
+++ rpmlint-rpmlint-1.9/SpecCheck.py 2017-02-08 16:56:05.012862286 -0500
|
||||
@@ -404,8 +404,9 @@ class SpecCheck(AbstractCheck.AbstractCh
|
||||
if res:
|
||||
provs = Pkg.parse_deps(res.group(1))
|
||||
for prov in unversioned(provs):
|
||||
- printWarning(pkg, 'unversioned-explicit-provides',
|
||||
- prov)
|
||||
+ if not prov.startswith('/'):
|
||||
+ printWarning(pkg, 'unversioned-explicit-provides',
|
||||
+ prov)
|
||||
if compop_regex.search(prov):
|
||||
printWarning(pkg,
|
||||
'comparison-operator-in-deptoken',
|
||||
@@ -415,8 +416,9 @@ class SpecCheck(AbstractCheck.AbstractCh
|
||||
if res:
|
||||
obses = Pkg.parse_deps(res.group(1))
|
||||
for obs in unversioned(obses):
|
||||
- printWarning(pkg, 'unversioned-explicit-obsoletes',
|
||||
- obs)
|
||||
+ if not obs.startswith('/'):
|
||||
+ printWarning(pkg, 'unversioned-explicit-obsoletes',
|
||||
+ obs)
|
||||
if compop_regex.search(obs):
|
||||
printWarning(pkg,
|
||||
'comparison-operator-in-deptoken',
|
||||
diff -up rpmlint-rpmlint-1.9/test/spec/SpecCheck.spec.fixuep rpmlint-rpmlint-1.9/test/spec/SpecCheck.spec
|
||||
--- rpmlint-rpmlint-1.9/test/spec/SpecCheck.spec.fixuep 2017-02-08 16:56:28.492316699 -0500
|
||||
+++ rpmlint-rpmlint-1.9/test/spec/SpecCheck.spec 2017-02-08 16:56:57.105651818 -0500
|
||||
@@ -17,6 +17,8 @@ BuildRoot: %{_tmppath}/%{name}-%{ve
|
||||
Provides: unversioned-provides, versioned-provides = 1.0
|
||||
Obsoletes: versioned-obsoletes < 2.0
|
||||
Obsoletes: unversioned-obsoletes
|
||||
+Obsoletes: /usr/bin/unversioned-but-filename
|
||||
+Provides: /sbin/another-unversioned-but-filename
|
||||
|
||||
%description
|
||||
SpecCheck test.
|
||||
diff -up rpmlint-rpmlint-1.9/test/test.SpecCheck.py.fixuep rpmlint-rpmlint-1.9/test/test.SpecCheck.py
|
||||
--- rpmlint-rpmlint-1.9/test/test.SpecCheck.py.fixuep 2017-02-08 16:57:15.938214210 -0500
|
||||
+++ rpmlint-rpmlint-1.9/test/test.SpecCheck.py 2017-02-08 16:57:54.448319360 -0500
|
||||
@@ -25,10 +25,12 @@ class TestSpecCheck(unittest.TestCase):
|
||||
in out)
|
||||
self.assertTrue("unversioned-explicit-provides versioned-provides"
|
||||
not in out)
|
||||
+ self.assertTrue("unversioned-explicit-provides /" not in out)
|
||||
self.assertTrue("unversioned-explicit-obsoletes unversioned-obsoletes"
|
||||
in out)
|
||||
self.assertTrue("unversioned-explicit-obsoletes versioned-obsoletes"
|
||||
not in out)
|
||||
+ self.assertTrue("unversioned-explicit-obsoletes /" not in out)
|
||||
self.assertTrue("setup-not-quiet" in out)
|
||||
|
||||
if __name__ == '__main__':
|
13
rpmlint-1.9-py35magic.patch
Normal file
13
rpmlint-1.9-py35magic.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/FilesCheck.py b/FilesCheck.py
|
||||
index 112a9ec..b3465ca 100644
|
||||
--- a/FilesCheck.py
|
||||
+++ b/FilesCheck.py
|
||||
@@ -323,7 +323,7 @@ _python_magic_values = {
|
||||
'3.2': 3180,
|
||||
'3.3': 3230,
|
||||
'3.4': 3310,
|
||||
- '3.5': 3350,
|
||||
+ '3.5': 3351, # 3350 for < 3.5.2
|
||||
'3.6': 3379,
|
||||
}
|
||||
|
11
rpmlint-1.9-py36magic.patch
Normal file
11
rpmlint-1.9-py36magic.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- rpmlint-rpmlint-1.9/FilesCheck.py 2016-12-29 22:16:24.738320169 -0800
|
||||
+++ rpmlint-rpmlint-1.9/FilesCheck.py.new 2016-12-29 22:16:51.109411602 -0800
|
||||
@@ -324,7 +324,7 @@
|
||||
'3.3': 3230,
|
||||
'3.4': 3310,
|
||||
'3.5': 3350,
|
||||
- '3.6': 3361,
|
||||
+ '3.6': 3379,
|
||||
}
|
||||
|
||||
|
45
rpmlint-1.9-py3_b2s.patch
Normal file
45
rpmlint-1.9-py3_b2s.patch
Normal file
@ -0,0 +1,45 @@
|
||||
From 4875475c43098e37a4d5d4e2ee2f9dfea643cc78 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Ville=20Skytt=C3=A4?= <ville.skytta@iki.fi>
|
||||
Date: Fri, 7 Apr 2017 09:26:35 +0300
|
||||
Subject: [PATCH] Pkg.b2s: Pass through str as-is on Python 3
|
||||
|
||||
Things change, and we may start getting str where we previously got
|
||||
bytes, such as what has apparently now happened with some versions of
|
||||
the return value of magic.descriptor(fd) in Fedora Rawhide.
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1439941
|
||||
---
|
||||
Pkg.py | 4 ++--
|
||||
test/test.Pkg.py | 4 ++++
|
||||
2 files changed, 6 insertions(+), 2 deletions(-)
|
||||
|
||||
Index: rpmlint-rpmlint-1.9/Pkg.py
|
||||
===================================================================
|
||||
--- rpmlint-rpmlint-1.9.orig/Pkg.py
|
||||
+++ rpmlint-rpmlint-1.9/Pkg.py
|
||||
@@ -41,8 +41,8 @@ if sys.version_info[0] > 2:
|
||||
unicode = str
|
||||
|
||||
def b2s(b):
|
||||
- if b is None:
|
||||
- return None
|
||||
+ if b is None or isinstance(b, str):
|
||||
+ return b
|
||||
if isinstance(b, (list, tuple)):
|
||||
return [b2s(x) for x in b]
|
||||
return b.decode(errors='replace')
|
||||
Index: rpmlint-rpmlint-1.9/test/test.Pkg.py
|
||||
===================================================================
|
||||
--- rpmlint-rpmlint-1.9.orig/test/test.Pkg.py
|
||||
+++ rpmlint-rpmlint-1.9/test/test.Pkg.py
|
||||
@@ -30,5 +30,10 @@ class TestPkg(unittest.TestCase):
|
||||
):
|
||||
self.assertFalse(Pkg.rangeCompare(req, prov))
|
||||
|
||||
+ def test_b2s(self):
|
||||
+ for thing in ("foo", ["foo"]):
|
||||
+ self.assertEqual(thing, Pkg.b2s(thing))
|
||||
+
|
||||
+
|
||||
if __name__ == '__main__':
|
||||
unittest.main()
|
25
rpmlint-1.9-py3_test_b2s.patch
Normal file
25
rpmlint-1.9-py3_test_b2s.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From 73d62d4421a06a3282c1a71625b070e3ca58b624 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Ville=20Skytt=C3=A4?= <ville.skytta@iki.fi>
|
||||
Date: Fri, 7 Apr 2017 09:55:15 +0300
|
||||
Subject: [PATCH] Pkg.b2s: Add some more test cases
|
||||
|
||||
---
|
||||
test/test.Pkg.py | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
Index: rpmlint-rpmlint-1.9/test/test.Pkg.py
|
||||
===================================================================
|
||||
--- rpmlint-rpmlint-1.9.orig/test/test.Pkg.py
|
||||
+++ rpmlint-rpmlint-1.9/test/test.Pkg.py
|
||||
@@ -31,8 +31,10 @@ class TestPkg(unittest.TestCase):
|
||||
self.assertFalse(Pkg.rangeCompare(req, prov))
|
||||
|
||||
def test_b2s(self):
|
||||
- for thing in ("foo", ["foo"]):
|
||||
+ for thing in ("foo", ["foo"], None, []):
|
||||
self.assertEqual(thing, Pkg.b2s(thing))
|
||||
+ self.assertEqual("foo", Pkg.b2s(b"foo"))
|
||||
+ self.assertEqual(["foo"], Pkg.b2s([b"foo"]))
|
||||
|
||||
|
||||
if __name__ == '__main__':
|
102
rpmlint-1.9-unicodefix.patch
Normal file
102
rpmlint-1.9-unicodefix.patch
Normal file
@ -0,0 +1,102 @@
|
||||
diff -up rpmlint-rpmlint-1.9/FilesCheck.py.unicodefix rpmlint-rpmlint-1.9/FilesCheck.py
|
||||
--- rpmlint-rpmlint-1.9/FilesCheck.py.unicodefix 2016-07-08 10:45:32.988796231 -0400
|
||||
+++ rpmlint-rpmlint-1.9/FilesCheck.py 2016-07-08 10:47:07.520138612 -0400
|
||||
@@ -572,8 +572,14 @@ class FilesCheck(AbstractCheck.AbstractC
|
||||
|
||||
chunk = None
|
||||
istext = False
|
||||
- if os.access(pkgfile.path, os.R_OK):
|
||||
- (chunk, istext) = peek(pkgfile.path, pkg)
|
||||
+ res = None
|
||||
+ try:
|
||||
+ res = os.access(pkgfile.path, os.R_OK)
|
||||
+ except UnicodeError as e: # e.g. non-ASCII, C locale, python 3
|
||||
+ printWarning(pkg, 'inaccessible-filename', f, e)
|
||||
+ else:
|
||||
+ if res:
|
||||
+ (chunk, istext) = peek(pkgfile.path, pkg)
|
||||
|
||||
(interpreter, interpreter_args) = script_interpreter(chunk)
|
||||
|
||||
@@ -1304,6 +1310,11 @@ it in the rpm header indicates that it i
|
||||
but it actually is not in the filesystem. Because of this, some checks will
|
||||
be skipped.''',
|
||||
|
||||
+'inaccessible-filename',
|
||||
+'''An error occurred while trying to access this file due to some characters
|
||||
+in its name. Because of this, some checks will be skipped. Access could work
|
||||
+with some other locale settings.''',
|
||||
+
|
||||
'executable-crontab-file',
|
||||
'''This crontab file has executable bit set, which is refused by newer version
|
||||
of cron''',
|
||||
diff -up rpmlint-rpmlint-1.9/Filter.py.unicodefix rpmlint-rpmlint-1.9/Filter.py
|
||||
--- rpmlint-rpmlint-1.9/Filter.py.unicodefix 2016-07-08 10:43:35.135616091 -0400
|
||||
+++ rpmlint-rpmlint-1.9/Filter.py 2016-07-08 10:45:25.885845645 -0400
|
||||
@@ -9,6 +9,7 @@
|
||||
|
||||
from __future__ import print_function
|
||||
|
||||
+import codecs
|
||||
import locale
|
||||
import sys
|
||||
import textwrap
|
||||
@@ -25,17 +26,20 @@ _diagnostic = list()
|
||||
_badness_score = 0
|
||||
printed_messages = {"I": 0, "W": 0, "E": 0}
|
||||
|
||||
-__stdout = sys.stdout
|
||||
__preferred_encoding = locale.getpreferredencoding()
|
||||
if sys.version_info[0] < 3:
|
||||
- import codecs
|
||||
__stdout = codecs.getwriter(__preferred_encoding)(sys.stdout, 'replace')
|
||||
|
||||
+ def __print(s):
|
||||
+ if isinstance(s, str):
|
||||
+ s = s.decode(__preferred_encoding, 'replace')
|
||||
+ print(s, file=__stdout)
|
||||
+else:
|
||||
+ __stdout = codecs.getwriter(__preferred_encoding)(
|
||||
+ sys.stdout.buffer, 'replace')
|
||||
|
||||
-def __print(s):
|
||||
- if isinstance(s, str) and hasattr(s, 'decode'):
|
||||
- s = s.decode(__preferred_encoding, 'replace')
|
||||
- print(s, file=__stdout)
|
||||
+ def __print(s):
|
||||
+ print(s, file=__stdout)
|
||||
|
||||
|
||||
def printInfo(pkg, reason, *details):
|
||||
diff -up rpmlint-rpmlint-1.9/Makefile.unicodefix rpmlint-rpmlint-1.9/Makefile
|
||||
--- rpmlint-rpmlint-1.9/Makefile.unicodefix 2016-07-08 10:47:23.748025724 -0400
|
||||
+++ rpmlint-rpmlint-1.9/Makefile 2016-07-08 10:47:38.945919999 -0400
|
||||
@@ -22,10 +22,6 @@ PYTHON = /usr/bin/python
|
||||
# update this variable to create a new release
|
||||
VERSION := 1.9
|
||||
|
||||
-# for the [A-Z]* part
|
||||
-LC_ALL:=C
|
||||
-export LC_ALL
|
||||
-
|
||||
all: __version__.py __isocodes__.py
|
||||
|
||||
clean:
|
||||
diff -up rpmlint-rpmlint-1.9/test.sh.unicodefix rpmlint-rpmlint-1.9/test.sh
|
||||
--- rpmlint-rpmlint-1.9/test.sh.unicodefix 2016-07-08 10:47:52.116828374 -0400
|
||||
+++ rpmlint-rpmlint-1.9/test.sh 2016-07-08 10:48:34.045536691 -0400
|
||||
@@ -18,9 +18,14 @@ for i in $TESTPATH/test.*.py; do
|
||||
done
|
||||
|
||||
echo "Check that rpmlint executes with no unexpected errors"
|
||||
+echo "...in default locale"
|
||||
$PYTHON ./rpmlint -C $(pwd) test/*/*.rpm test/spec/*.spec >/dev/null
|
||||
rc=$?
|
||||
test $rc -eq 0 -o $rc -eq 64 || exit $rc
|
||||
+echo "...in the C locale"
|
||||
+LC_ALL=C $PYTHON ./rpmlint -C $(pwd) test/*/*.rpm test/spec/*.spec >/dev/null
|
||||
+rc=$?
|
||||
+test $rc -eq 0 -o $rc -eq 64 || exit $rc
|
||||
|
||||
echo "$PYTEST tests"
|
||||
$PYTEST -v || exit $?
|
234
rpmlint-CHANGES.package.old
Normal file
234
rpmlint-CHANGES.package.old
Normal file
@ -0,0 +1,234 @@
|
||||
* Thu Dec 6 2007 Ville Skyttä <ville.skytta@iki.fi> - 0.82-2
|
||||
- Remove leftover "Affero GPL" from last license list sync (Todd Zullinger).
|
||||
|
||||
* Thu Dec 6 2007 Ville Skyttä <ville.skytta@iki.fi> - 0.82-1
|
||||
- 0.82, fixes #362441, #388881, #399871, #409941.
|
||||
- Sync Fedora license list with Revision 0.61 (Wiki rev 98).
|
||||
|
||||
* Fri Sep 28 2007 Todd Zullinger <tmz@pobox.com>
|
||||
- Sync Fedora license list with Revision 0.55 (Wiki rev 92).
|
||||
|
||||
* Mon Sep 3 2007 Ville Skyttä <ville.skytta@iki.fi> - 0.81-1
|
||||
- 0.81, fixes #239611, #240840, #241471, #244835.
|
||||
- Improve Fedora license check (Todd Zullinger).
|
||||
- Sync Fedora license list with Wiki rev 87.
|
||||
|
||||
* Wed Aug 29 2007 Ville Skyttä <ville.skytta@iki.fi>
|
||||
- Sync Fedora license list with Wiki rev 84 (Todd Zullinger).
|
||||
|
||||
* Thu Aug 16 2007 Ville Skyttä <ville.skytta@iki.fi> - 0.80-3
|
||||
- Sync Fedora license list with Wiki rev 68.
|
||||
- Move pre-2006 changelog entries to CHANGES.package.old.
|
||||
|
||||
* Tue Jul 31 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 0.80-2
|
||||
- new fedora licensing scheme
|
||||
|
||||
* Thu May 31 2007 Ville Skyttä <ville.skytta@iki.fi>
|
||||
- Filter hardcoded-library-path errors for /lib/udev.
|
||||
|
||||
* Thu Apr 12 2007 Ville Skyttä <ville.skytta@iki.fi> - 0.80-1
|
||||
- 0.80, fixes #227389, #228645, #233795.
|
||||
- Accept "Redistributable, no modification permitted" as a valid license.
|
||||
- Filter messages about doc file dependencies on /bin/sh.
|
||||
- Add missing dependency on file.
|
||||
|
||||
* Fri Feb 2 2007 Ville Skyttä <ville.skytta@iki.fi> - 0.79-1
|
||||
- 0.79, fixes #211417, #212491, #214605, #218250, #219068, #220061, #221116,
|
||||
#222585, and #226879.
|
||||
- Accept *.elX disttags in default config.
|
||||
|
||||
* Sun Oct 15 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.78-2
|
||||
- Accumulated bugfixes since 0.78: #209876, #209889, #210110, 210261.
|
||||
- Filter messages about gpg-pubkeys for now.
|
||||
|
||||
* Sun Sep 24 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.78-1
|
||||
- 0.78, fixes #198605, #198616, #198705, #198707, #200032, #206383.
|
||||
- /etc/profile.d/* filtering no longer needed.
|
||||
|
||||
* Sat Sep 16 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.77-2
|
||||
- Filter false positives for /etc/profile.d/* file modes.
|
||||
- Ship *.pyc and *.pyo as usual.
|
||||
|
||||
* Thu Jun 29 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.77-1
|
||||
- 0.77, fixes #194466, #195962, #196008, #196985.
|
||||
- Make "disttag" configurable using the DistRegex config file option.
|
||||
- Sync standard users and groups with the FC setup package.
|
||||
- Disable MenuCheck by default, it's currently Mandriva specific.
|
||||
- Use upstream default valid License tag list, fixes #191078.
|
||||
- Use upstream default valid Group tag list (dynamically retrieved from
|
||||
the GROUPS file shipped with rpm).
|
||||
- Allow /usr/libexec, fixes #195992.
|
||||
|
||||
* Tue Apr 11 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.76-1
|
||||
- 0.76.
|
||||
|
||||
* Mon Mar 27 2006 Ville Skyttä <ville.skytta@iki.fi>
|
||||
- Don't pass -T to objdump for *.debug files (#185227).
|
||||
- lib64 library path fixes (#185228).
|
||||
|
||||
* Wed Mar 15 2006 Ville Skyttä <ville.skytta@iki.fi>
|
||||
- Accept zlib License (#185501).
|
||||
|
||||
* Tue Feb 28 2006 Ville Skyttä <ville.skytta@iki.fi>
|
||||
- Accept Ruby License (#183384) and SIL Open Font License (#176405).
|
||||
|
||||
* Sat Feb 18 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.75-1
|
||||
- 0.75 + -devel Epoch version check patch from CVS.
|
||||
|
||||
* Tue Jan 17 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.71-3
|
||||
- Sync with upstream CVS as of 2006-01-15, includes improved versions of
|
||||
most of the earlier patches.
|
||||
- Add dependency on binutils.
|
||||
|
||||
* Sun Nov 20 2005 Ville Skyttä <ville.skytta@iki.fi> - 0.71-2
|
||||
- Take file based dependencies into account in dangling symlink checks
|
||||
(completes the fix for #165839).
|
||||
- Skip some checks for binaries not understood by objdump (#165173).
|
||||
- Improve long descriptions of some script warnings.
|
||||
- Fix command output parsing in non-English locales.
|
||||
- Import Enrico's latest DocFilesCheck (with some local tweaks).
|
||||
- Use rm instead of %%exclude.
|
||||
|
||||
* Wed Nov 16 2005 Ville Skyttä <ville.skytta@iki.fi>
|
||||
- Add DocFilesCheck from Enrico Scholz.
|
||||
|
||||
* Sat Sep 3 2005 Ville Skyttä <ville.skytta@iki.fi>
|
||||
- Improve accuracy of doc, info and games path regexps.
|
||||
- Improve error message when invoked on non-rpm files.
|
||||
- Filter more Mandriva specific warnings.
|
||||
|
||||
* Sat Aug 13 2005 Ville Skyttä <ville.skytta@iki.fi>
|
||||
- Add dangling symlink exceptions tuned for Fedora to default config
|
||||
(partially fixes #165839).
|
||||
|
||||
* Wed Aug 10 2005 Ville Skyttä <ville.skytta@iki.fi> - 0.71-1
|
||||
- 0.71, confmsg patch and bits from initvars patch applied upstream.
|
||||
- Filter out Mandriva-specific errors about missing locales-* deps (#165457).
|
||||
- Patch to not warn about non-empty *.bs (in Perl packages).
|
||||
- Patch to clarify PreReq explanation, make it a warning instead of an error.
|
||||
- Patch to warn about use of BuildPreReq.
|
||||
|
||||
* Thu Jul 7 2005 Ville Skyttä <ville.skytta@iki.fi> - 0.70-4
|
||||
- Fix false "positives" from libtool archives confused as scripts,
|
||||
non-executable scripts installed in docs, FE disttags, unsuccessfully
|
||||
expanded shell variables and quotation in init scripts.
|
||||
|
||||
* Mon Jun 20 2005 Ville Skyttä <ville.skytta@iki.fi> - 0.70-3
|
||||
- 0.70, use sed instead of perl during build.
|
||||
- Default configuration improvements: allow Development/Debug group (for
|
||||
debuginfo packages), filter out errors/warnings about non-indexed jars,
|
||||
invalid LC_MESSAGES and man page dirs, and library packages containing
|
||||
something else in addition to libraries.
|
||||
- Make info about non-config files in /etc more accurate.
|
||||
- Patch to warn about services that default to enabled after "chkconfig add",
|
||||
not the other way around.
|
||||
|
||||
* Thu May 26 2005 Ville Skyttä <ville.skytta@iki.fi> - 0.69-3
|
||||
- Filter out more not-that-useful messages in the default config.
|
||||
|
||||
* Sat Apr 16 2005 Ville Skyttä <ville.skytta@iki.fi> - 0.69-2
|
||||
- 0.69.
|
||||
- Simplify bash-completion snippet installation, remove triggers.
|
||||
- Default configuration improvements: filter messages about missing packager,
|
||||
Mandriva specific package naming conventions, %%ghost files without
|
||||
%%post scriptlets, and 0664 source permissions.
|
||||
- Exclude check-install.py, it doesn't currently work with rpm >= 4.2.
|
||||
- Convert docs to UTF-8.
|
||||
- Improve summary.
|
||||
|
||||
* Sun Mar 13 2005 Ville Skyttä <ville.skytta@iki.fi> - 0.68-2
|
||||
- 0.68, siteperl patch applied upstream.
|
||||
- Fix "no-dependency-on" filtering in default config.
|
||||
- Add LaTeX Project Public License to default config.
|
||||
- Remove upstream-only %%changelog entries.
|
||||
|
||||
* Sun Feb 13 2005 Ville Skyttä <ville.skytta@iki.fi> - 0:0.67-1
|
||||
- 0.67.
|
||||
- Patch to catch more site_perl directories.
|
||||
- Default config improvements: filter Distribution and Vendor warnings,
|
||||
use empty string instead of None for release extension (fixes -i).
|
||||
|
||||
* Sat Jan 29 2005 Ville Skyttä <ville.skytta@iki.fi> - 0:0.65-1
|
||||
- Update to 0.65.
|
||||
|
||||
* Sat Jan 1 2005 Ville Skyttä <ville.skytta@iki.fi> - 0:0.64-1
|
||||
- Update to 0.64.
|
||||
- Default config tweaks: don't mandate Epochs nor "fdr" in Release.
|
||||
|
||||
* Tue Oct 19 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.61-0.fdr.2
|
||||
- Requires cpio (bug 2169).
|
||||
|
||||
* Sun Oct 3 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.61-0.fdr.1
|
||||
- Update to 0.61.
|
||||
|
||||
* Mon Aug 16 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.60-0.fdr.1
|
||||
- Update to 0.60.
|
||||
|
||||
* Mon May 3 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.59-0.fdr.1
|
||||
- Update to 0.59.
|
||||
|
||||
* Sun Feb 22 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.57.1-0.fdr.1
|
||||
- Update to 0.57.1.
|
||||
|
||||
* Wed Feb 11 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.56-0.fdr.1
|
||||
- Update to 0.56.
|
||||
|
||||
* Mon Feb 2 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.55-0.fdr.3
|
||||
- Correctly %%ghost %%{_sysconfdir}/rpmlint/config? (bug 1251).
|
||||
|
||||
* Sun Feb 1 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.55-0.fdr.2
|
||||
- Add back %%ghost handling of not-installed compiled versions of *.py.
|
||||
|
||||
* Fri Jan 30 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.55-0.fdr.1
|
||||
- Update to 0.55.
|
||||
- Spec cleanups.
|
||||
|
||||
* Tue Dec 23 2003 Ville Skyttä <ville.skytta@iki.fi> - 0:0.53-0.fdr.1
|
||||
- Update to 0.53.
|
||||
|
||||
* Thu Oct 2 2003 Ville Skyttä <ville.skytta@iki.fi> - 0:0.52-0.fdr.2
|
||||
- Add list of valid shells for post'n'friends scriptlets into default config.
|
||||
|
||||
* Sat Sep 13 2003 Ville Skyttä <ville.skytta@iki.fi> - 0:0.52-0.fdr.1
|
||||
- Update to 0.52.
|
||||
|
||||
* Thu Sep 4 2003 Ville Skyttä <ville.skytta@iki.fi> - 0:0.51.1-0.fdr.4
|
||||
- Filter more Mdk-specific warnings in default config.
|
||||
|
||||
* Wed Sep 3 2003 Ville Skyttä <ville.skytta@iki.fi> - 0:0.51.1-0.fdr.3
|
||||
- Upstream tarball reappeared, use it.
|
||||
|
||||
* Sun Aug 24 2003 Ville Skyttä <ville.skytta@iki.fi> - 0:0.51.1-0.fdr.2
|
||||
- Filter Mdk-specific python-related stuff in the default config.
|
||||
|
||||
* Fri Aug 15 2003 Ville Skyttä <ville.skytta@iki.fi> - 0:0.51.1-0.fdr.1
|
||||
- Update to 0.51.1.
|
||||
- Own %%ghost'ed *.py{c,o}, and ditto for the config file.
|
||||
- Add list of valid licenses to default config.
|
||||
- Set "Fedora Linux" as suggested distribution in default config.
|
||||
- Clean up %%doc list.
|
||||
|
||||
* Fri May 9 2003 Ville Skyttä <ville.skytta@iki.fi> - 0:0.50-0.fdr.1
|
||||
- Update to 0.50, all patches now applied upstream.
|
||||
|
||||
* Mon May 5 2003 Ville Skyttä <ville.skytta@iki.fi> - 0:0.49-0.fdr.2
|
||||
- %%{buildroot} -> $RPM_BUILD_ROOT.
|
||||
- Filter out mdk-specific "no-dependancy perl-base" messages in config.
|
||||
|
||||
* Thu May 1 2003 Ville Skyttä <ville.skytta@iki.fi> - 0:0.49-0.fdr.1
|
||||
- Update to 0.49.
|
||||
|
||||
* Sun Apr 20 2003 Ville Skyttä <ville.skytta@iki.fi> - 0:0.49-0.fdr.0.1.cvs20030420
|
||||
- Add one more strict Epoch checking patch.
|
||||
- Slightly enhanced default config.
|
||||
|
||||
* Fri Apr 11 2003 Ville Skyttä <ville.skytta@iki.fi> - 0:0.49-0.fdr.0.1.cvs20030411
|
||||
- Patch to work with installed packages (including -a) and rpm 4.2.
|
||||
- Remove spurious rpm-devel BuildRequirement.
|
||||
|
||||
* Tue Apr 8 2003 Ville Skyttä <ville.skytta@iki.fi> - 0:0.49-0.fdr.0.1.cvs20030408
|
||||
- Patch to work with packages signed with an unknown key.
|
||||
- Save .spec in UTF-8.
|
||||
|
||||
* Sun Mar 30 2003 Ville Skyttä <ville.skytta@iki.fi> - 0:0.49-0.fdr.0.1.cvs20030330
|
||||
- First Fedora release, based on upstream spec.
|
17
tests/tests.yml
Normal file
17
tests/tests.yml
Normal file
@ -0,0 +1,17 @@
|
||||
---
|
||||
#
|
||||
# 1minutetip --buildroot rhel8
|
||||
#
|
||||
|
||||
- hosts: localhost
|
||||
tags:
|
||||
- classic
|
||||
roles:
|
||||
- role: standard-test-source
|
||||
- role: standard-test-basic
|
||||
required_packages:
|
||||
- python3-pytest
|
||||
tests:
|
||||
- unittests:
|
||||
dir: "source"
|
||||
run: PYTHON=/usr/libexec/platform-python PYTEST=py.test-3 sh test.sh
|
Loading…
Reference in New Issue
Block a user