56 lines
3.1 KiB
Diff
56 lines
3.1 KiB
Diff
diff -up rpmlint-rpmlint-1.9/SpecCheck.py.fixuep rpmlint-rpmlint-1.9/SpecCheck.py
|
|
--- rpmlint-rpmlint-1.9/SpecCheck.py.fixuep 2017-02-08 16:54:24.055208215 -0500
|
|
+++ rpmlint-rpmlint-1.9/SpecCheck.py 2017-02-08 16:56:05.012862286 -0500
|
|
@@ -404,8 +404,9 @@ class SpecCheck(AbstractCheck.AbstractCh
|
|
if res:
|
|
provs = Pkg.parse_deps(res.group(1))
|
|
for prov in unversioned(provs):
|
|
- printWarning(pkg, 'unversioned-explicit-provides',
|
|
- prov)
|
|
+ if not prov.startswith('/'):
|
|
+ printWarning(pkg, 'unversioned-explicit-provides',
|
|
+ prov)
|
|
if compop_regex.search(prov):
|
|
printWarning(pkg,
|
|
'comparison-operator-in-deptoken',
|
|
@@ -415,8 +416,9 @@ class SpecCheck(AbstractCheck.AbstractCh
|
|
if res:
|
|
obses = Pkg.parse_deps(res.group(1))
|
|
for obs in unversioned(obses):
|
|
- printWarning(pkg, 'unversioned-explicit-obsoletes',
|
|
- obs)
|
|
+ if not obs.startswith('/'):
|
|
+ printWarning(pkg, 'unversioned-explicit-obsoletes',
|
|
+ obs)
|
|
if compop_regex.search(obs):
|
|
printWarning(pkg,
|
|
'comparison-operator-in-deptoken',
|
|
diff -up rpmlint-rpmlint-1.9/test/spec/SpecCheck.spec.fixuep rpmlint-rpmlint-1.9/test/spec/SpecCheck.spec
|
|
--- rpmlint-rpmlint-1.9/test/spec/SpecCheck.spec.fixuep 2017-02-08 16:56:28.492316699 -0500
|
|
+++ rpmlint-rpmlint-1.9/test/spec/SpecCheck.spec 2017-02-08 16:56:57.105651818 -0500
|
|
@@ -17,6 +17,8 @@ BuildRoot: %{_tmppath}/%{name}-%{ve
|
|
Provides: unversioned-provides, versioned-provides = 1.0
|
|
Obsoletes: versioned-obsoletes < 2.0
|
|
Obsoletes: unversioned-obsoletes
|
|
+Obsoletes: /usr/bin/unversioned-but-filename
|
|
+Provides: /sbin/another-unversioned-but-filename
|
|
|
|
%description
|
|
SpecCheck test.
|
|
diff -up rpmlint-rpmlint-1.9/test/test.SpecCheck.py.fixuep rpmlint-rpmlint-1.9/test/test.SpecCheck.py
|
|
--- rpmlint-rpmlint-1.9/test/test.SpecCheck.py.fixuep 2017-02-08 16:57:15.938214210 -0500
|
|
+++ rpmlint-rpmlint-1.9/test/test.SpecCheck.py 2017-02-08 16:57:54.448319360 -0500
|
|
@@ -25,10 +25,12 @@ class TestSpecCheck(unittest.TestCase):
|
|
in out)
|
|
self.assertTrue("unversioned-explicit-provides versioned-provides"
|
|
not in out)
|
|
+ self.assertTrue("unversioned-explicit-provides /" not in out)
|
|
self.assertTrue("unversioned-explicit-obsoletes unversioned-obsoletes"
|
|
in out)
|
|
self.assertTrue("unversioned-explicit-obsoletes versioned-obsoletes"
|
|
not in out)
|
|
+ self.assertTrue("unversioned-explicit-obsoletes /" not in out)
|
|
self.assertTrue("setup-not-quiet" in out)
|
|
|
|
if __name__ == '__main__':
|