- update to 4.11.2-rc2 (http://rpm.org/wiki/Releases/4.11.1)
- drop upstreamed patches
This commit is contained in:
parent
17960b66b2
commit
7879e3bd92
1
.gitignore
vendored
1
.gitignore
vendored
@ -8,3 +8,4 @@
|
|||||||
/rpm-4.11.0-beta1.tar.bz2
|
/rpm-4.11.0-beta1.tar.bz2
|
||||||
/rpm-4.11.0.1.tar.bz2
|
/rpm-4.11.0.1.tar.bz2
|
||||||
/rpm-4.11.1-rc1.tar.bz2
|
/rpm-4.11.1-rc1.tar.bz2
|
||||||
|
/rpm-4.11.1-rc2.tar.bz2
|
||||||
|
@ -1,27 +0,0 @@
|
|||||||
commit eacb69f779cc5fd7b651d7a7cf450b327e5735f8
|
|
||||||
Author: Panu Matilainen <pmatilai@redhat.com>
|
|
||||||
Date: Tue Jun 11 09:51:48 2013 +0300
|
|
||||||
|
|
||||||
Fix regression on addressing main package by its name (RhBug:972994)
|
|
||||||
|
|
||||||
- The main package name is not known when we start parsing the preamble,
|
|
||||||
so newPackage() is called with NULL name and the early callers use
|
|
||||||
NULL to find it. Populate the name as soon as we know it so
|
|
||||||
various "%foo -n <name>" operations work on the main package too,
|
|
||||||
which got broken by commit 9929459f9967ecfe0a05d557bc42531944faa70a.
|
|
||||||
(cherry picked from commit fed1298af7911145c953da8910fd5f2f15976374)
|
|
||||||
|
|
||||||
diff --git a/build/parsePreamble.c b/build/parsePreamble.c
|
|
||||||
index f7cc167..e4b1f94 100644
|
|
||||||
--- a/build/parsePreamble.c
|
|
||||||
+++ b/build/parsePreamble.c
|
|
||||||
@@ -670,6 +670,9 @@ static rpmRC handlePreambleTag(rpmSpec spec, Package pkg, rpmTagVal tag,
|
|
||||||
if (rpmCharCheck(spec, field, strlen(field), ".-_+%{}"))
|
|
||||||
goto exit;
|
|
||||||
headerPutString(pkg->header, tag, field);
|
|
||||||
+ /* Main pkg name is unknown at the start, populate as soon as we can */
|
|
||||||
+ if (pkg == spec->packages)
|
|
||||||
+ pkg->name = rpmstrPoolId(spec->pool, field, 1);
|
|
||||||
break;
|
|
||||||
case RPMTAG_VERSION:
|
|
||||||
case RPMTAG_RELEASE:
|
|
@ -1,27 +0,0 @@
|
|||||||
commit 389d260ca41a277de49ca0154966d549945d8635
|
|
||||||
Author: Kyle McMartin <kmcmarti@redhat.com>
|
|
||||||
Date: Sun Jun 16 12:48:46 2013 -0400
|
|
||||||
|
|
||||||
debugedit: handle aarch64 debug_info relocations (RhBug:974860)
|
|
||||||
|
|
||||||
AArch64 generates a relocation which must be handled similar to other
|
|
||||||
architectures. Adding this patch allows debugedit to run against the
|
|
||||||
kernel debuginfo.
|
|
||||||
|
|
||||||
Signed-off-by: Panu Matilainen <pmatilai@redhat.com>
|
|
||||||
|
|
||||||
diff --git a/tools/debugedit.c b/tools/debugedit.c
|
|
||||||
index a658d5b..434bab0 100644
|
|
||||||
--- a/tools/debugedit.c
|
|
||||||
+++ b/tools/debugedit.c
|
|
||||||
@@ -1158,6 +1158,10 @@ edit_dwarf2 (DSO *dso)
|
|
||||||
if (rtype != R_ALPHA_REFLONG)
|
|
||||||
goto fail;
|
|
||||||
break;
|
|
||||||
+ case EM_AARCH64:
|
|
||||||
+ if (rtype != R_AARCH64_ABS32)
|
|
||||||
+ goto fail;
|
|
||||||
+ break;
|
|
||||||
default:
|
|
||||||
fail:
|
|
||||||
error (1, 0, "%s: Unhandled relocation %d in .debug_info section",
|
|
14
rpm.spec
14
rpm.spec
@ -12,7 +12,7 @@
|
|||||||
%define rpmhome /usr/lib/rpm
|
%define rpmhome /usr/lib/rpm
|
||||||
|
|
||||||
%define rpmver 4.11.1
|
%define rpmver 4.11.1
|
||||||
%define snapver rc1
|
%define snapver rc2
|
||||||
%define srcver %{rpmver}%{?snapver:-%{snapver}}
|
%define srcver %{rpmver}%{?snapver:-%{snapver}}
|
||||||
|
|
||||||
%define bdbname libdb
|
%define bdbname libdb
|
||||||
@ -22,7 +22,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: %{?snapver:0.%{snapver}.}4%{?dist}
|
Release: %{?snapver:0.%{snapver}.}1%{?dist}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
||||||
@ -49,10 +49,6 @@ Patch6: rpm-4.9.0-armhfp-logic.patch
|
|||||||
# Patches already in upstream
|
# Patches already in upstream
|
||||||
# Filter soname dependencies by name
|
# Filter soname dependencies by name
|
||||||
Patch100: rpm-4.11.x-filter-soname-deps.patch
|
Patch100: rpm-4.11.x-filter-soname-deps.patch
|
||||||
# Fix regression on addressing main package by its name
|
|
||||||
Patch101: rpm-4.11.1-rc1-lookup-mainpkg.patch
|
|
||||||
# handle aarch64 debug_info relocations
|
|
||||||
Patch102: rpm-4.11.x-aarch64-debugedit.patch
|
|
||||||
|
|
||||||
# These are not yet upstream
|
# These are not yet upstream
|
||||||
Patch301: rpm-4.6.0-niagara.patch
|
Patch301: rpm-4.6.0-niagara.patch
|
||||||
@ -232,8 +228,6 @@ packages on a system.
|
|||||||
%patch4 -p1 -b .use-gpg2
|
%patch4 -p1 -b .use-gpg2
|
||||||
|
|
||||||
%patch100 -p1 -b .filter-soname-deps
|
%patch100 -p1 -b .filter-soname-deps
|
||||||
%patch101 -p1 -b .lookup-mainpkg
|
|
||||||
%patch102 -p1 -b .aarch64-debugedit
|
|
||||||
|
|
||||||
%patch301 -p1 -b .niagara
|
%patch301 -p1 -b .niagara
|
||||||
%patch302 -p1 -b .geode
|
%patch302 -p1 -b .geode
|
||||||
@ -467,6 +461,10 @@ exit 0
|
|||||||
%doc COPYING doc/librpm/html/*
|
%doc COPYING doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jun 20 2013 Panu Matilainen <pmatilai@redhat.com> - 4.11.1-0.rc2.1
|
||||||
|
- update to 4.11.2-rc2 (http://rpm.org/wiki/Releases/4.11.1)
|
||||||
|
- drop upstreamed patches
|
||||||
|
|
||||||
* Mon Jun 17 2013 Panu Matilainen <pmatilai@redhat.com> - 4.11.1-0.rc1.4
|
* Mon Jun 17 2013 Panu Matilainen <pmatilai@redhat.com> - 4.11.1-0.rc1.4
|
||||||
- handle aarch64 debug_info relocations in debugedit (#974860)
|
- handle aarch64 debug_info relocations in debugedit (#974860)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user