- handle aarch64 debug_info relocations in debugedit (#974860)
This commit is contained in:
parent
090b90d00e
commit
17960b66b2
27
rpm-4.11.x-aarch64-debugedit.patch
Normal file
27
rpm-4.11.x-aarch64-debugedit.patch
Normal file
@ -0,0 +1,27 @@
|
||||
commit 389d260ca41a277de49ca0154966d549945d8635
|
||||
Author: Kyle McMartin <kmcmarti@redhat.com>
|
||||
Date: Sun Jun 16 12:48:46 2013 -0400
|
||||
|
||||
debugedit: handle aarch64 debug_info relocations (RhBug:974860)
|
||||
|
||||
AArch64 generates a relocation which must be handled similar to other
|
||||
architectures. Adding this patch allows debugedit to run against the
|
||||
kernel debuginfo.
|
||||
|
||||
Signed-off-by: Panu Matilainen <pmatilai@redhat.com>
|
||||
|
||||
diff --git a/tools/debugedit.c b/tools/debugedit.c
|
||||
index a658d5b..434bab0 100644
|
||||
--- a/tools/debugedit.c
|
||||
+++ b/tools/debugedit.c
|
||||
@@ -1158,6 +1158,10 @@ edit_dwarf2 (DSO *dso)
|
||||
if (rtype != R_ALPHA_REFLONG)
|
||||
goto fail;
|
||||
break;
|
||||
+ case EM_AARCH64:
|
||||
+ if (rtype != R_AARCH64_ABS32)
|
||||
+ goto fail;
|
||||
+ break;
|
||||
default:
|
||||
fail:
|
||||
error (1, 0, "%s: Unhandled relocation %d in .debug_info section",
|
8
rpm.spec
8
rpm.spec
@ -22,7 +22,7 @@
|
||||
Summary: The RPM package management system
|
||||
Name: rpm
|
||||
Version: %{rpmver}
|
||||
Release: %{?snapver:0.%{snapver}.}3%{?dist}
|
||||
Release: %{?snapver:0.%{snapver}.}4%{?dist}
|
||||
Group: System Environment/Base
|
||||
Url: http://www.rpm.org/
|
||||
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
||||
@ -51,6 +51,8 @@ Patch6: rpm-4.9.0-armhfp-logic.patch
|
||||
Patch100: rpm-4.11.x-filter-soname-deps.patch
|
||||
# Fix regression on addressing main package by its name
|
||||
Patch101: rpm-4.11.1-rc1-lookup-mainpkg.patch
|
||||
# handle aarch64 debug_info relocations
|
||||
Patch102: rpm-4.11.x-aarch64-debugedit.patch
|
||||
|
||||
# These are not yet upstream
|
||||
Patch301: rpm-4.6.0-niagara.patch
|
||||
@ -231,6 +233,7 @@ packages on a system.
|
||||
|
||||
%patch100 -p1 -b .filter-soname-deps
|
||||
%patch101 -p1 -b .lookup-mainpkg
|
||||
%patch102 -p1 -b .aarch64-debugedit
|
||||
|
||||
%patch301 -p1 -b .niagara
|
||||
%patch302 -p1 -b .geode
|
||||
@ -464,6 +467,9 @@ exit 0
|
||||
%doc COPYING doc/librpm/html/*
|
||||
|
||||
%changelog
|
||||
* Mon Jun 17 2013 Panu Matilainen <pmatilai@redhat.com> - 4.11.1-0.rc1.4
|
||||
- handle aarch64 debug_info relocations in debugedit (#974860)
|
||||
|
||||
* Tue Jun 11 2013 Panu Matilainen <pmatilai@redhat.com> - 4.11.1-0.rc1.3
|
||||
- disable autoconf config.site processing in builds (#962837)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user