- fail hard if patch isn't found (#461347)
This commit is contained in:
parent
d125466134
commit
2b2e2bf0cb
19
rpm-4.5.90-patches.patch
Normal file
19
rpm-4.5.90-patches.patch
Normal file
@ -0,0 +1,19 @@
|
|||||||
|
commit ce1db5af7036df54a21abab9a5d70b06a821fff4
|
||||||
|
Author: Jindrich Novy <jnovy@redhat.com>
|
||||||
|
Date: Sat Sep 6 15:30:40 2008 +0200
|
||||||
|
|
||||||
|
Fail hard if patch isn't found (rhbz#461347)
|
||||||
|
|
||||||
|
diff --git a/build/parsePrep.c b/build/parsePrep.c
|
||||||
|
index fcc28c8..2be0693 100644
|
||||||
|
--- a/build/parsePrep.c
|
||||||
|
+++ b/build/parsePrep.c
|
||||||
|
@@ -538,7 +538,7 @@ int parsePrep(rpmSpec spec)
|
||||||
|
}
|
||||||
|
if (res && !spec->force) {
|
||||||
|
/* fixup from RPMRC_FAIL do*Macro() codes for now */
|
||||||
|
- res = PART_ERROR;
|
||||||
|
+ nextPart = PART_ERROR;
|
||||||
|
goto exit;
|
||||||
|
}
|
||||||
|
}
|
7
rpm.spec
7
rpm.spec
@ -18,7 +18,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: 0.%{snapver}.4
|
Release: 0.%{snapver}.5
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
||||||
@ -36,6 +36,7 @@ Patch200: rpm-4.5.90-archivesize.patch
|
|||||||
Patch201: rpm-4.5.90-noarch-subpackages.patch
|
Patch201: rpm-4.5.90-noarch-subpackages.patch
|
||||||
Patch202: rpm-4.5.90-segfault.patch
|
Patch202: rpm-4.5.90-segfault.patch
|
||||||
Patch203: rpm-4.5.90-macrofix.patch
|
Patch203: rpm-4.5.90-macrofix.patch
|
||||||
|
Patch204: rpm-4.5.90-patches.patch
|
||||||
|
|
||||||
# These are not yet upstream
|
# These are not yet upstream
|
||||||
Patch300: rpm-4.5.90-posttrans.patch
|
Patch300: rpm-4.5.90-posttrans.patch
|
||||||
@ -170,6 +171,7 @@ that will manipulate RPM packages and databases.
|
|||||||
%patch201 -p1 -b .noarch-subpackages
|
%patch201 -p1 -b .noarch-subpackages
|
||||||
%patch202 -p1 -b .segfault
|
%patch202 -p1 -b .segfault
|
||||||
%patch203 -p1 -b .macrofix
|
%patch203 -p1 -b .macrofix
|
||||||
|
%patch204 -p1 -b .patches
|
||||||
|
|
||||||
# needs a bit of upstream love first...
|
# needs a bit of upstream love first...
|
||||||
#%patch300 -p1 -b .posttrans
|
#%patch300 -p1 -b .posttrans
|
||||||
@ -348,6 +350,9 @@ exit 0
|
|||||||
%doc doc/librpm/html/*
|
%doc doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Sep 06 2008 Jindrich Novy <jnovy@redhat.com>
|
||||||
|
- fail hard if patch isn't found (#461347)
|
||||||
|
|
||||||
* Mon Sep 01 2008 Jindrich Novy <jnovy@redhat.com>
|
* Mon Sep 01 2008 Jindrich Novy <jnovy@redhat.com>
|
||||||
- fix parsing of boolean expressions in spec (#456103)
|
- fix parsing of boolean expressions in spec (#456103)
|
||||||
(unbreaks pam, jpilot and maybe other builds)
|
(unbreaks pam, jpilot and maybe other builds)
|
||||||
|
Loading…
Reference in New Issue
Block a user