- fix parsing of boolean expressions in spec (#456103)
This commit is contained in:
parent
42d9f1aba7
commit
d125466134
19
rpm-4.5.90-macrofix.patch
Normal file
19
rpm-4.5.90-macrofix.patch
Normal file
@ -0,0 +1,19 @@
|
||||
commit 3b9636cd69b81b6e23331bb797c0fdde79e97316
|
||||
Author: Jindrich Novy <jnovy@redhat.com>
|
||||
Date: Thu Aug 14 13:08:09 2008 +0200
|
||||
|
||||
Accept numerical characters in macro expansion (related to rhbz#456103)
|
||||
|
||||
diff --git a/build/expression.c b/build/expression.c
|
||||
index 970ec05..83a4021 100644
|
||||
--- a/build/expression.c
|
||||
+++ b/build/expression.c
|
||||
@@ -272,7 +272,7 @@ static int rdToken(ParseState state)
|
||||
char *temp;
|
||||
size_t ts;
|
||||
|
||||
- for (ts=1; p[ts] && (risalpha(p[ts]) || p[ts] == '_'); ts++);
|
||||
+ for (ts=1; p[ts] && (risalnum(p[ts]) || p[ts] == '_'); ts++);
|
||||
temp = xmalloc(ts+1);
|
||||
memcpy(temp, p, ts);
|
||||
p += ts-1;
|
8
rpm.spec
8
rpm.spec
@ -18,7 +18,7 @@
|
||||
Summary: The RPM package management system
|
||||
Name: rpm
|
||||
Version: %{rpmver}
|
||||
Release: 0.%{snapver}.3
|
||||
Release: 0.%{snapver}.4
|
||||
Group: System Environment/Base
|
||||
Url: http://www.rpm.org/
|
||||
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
||||
@ -35,6 +35,7 @@ Patch100: rpm-4.6.x-no-pkgconfig-reqs.patch
|
||||
Patch200: rpm-4.5.90-archivesize.patch
|
||||
Patch201: rpm-4.5.90-noarch-subpackages.patch
|
||||
Patch202: rpm-4.5.90-segfault.patch
|
||||
Patch203: rpm-4.5.90-macrofix.patch
|
||||
|
||||
# These are not yet upstream
|
||||
Patch300: rpm-4.5.90-posttrans.patch
|
||||
@ -168,6 +169,7 @@ that will manipulate RPM packages and databases.
|
||||
%patch200 -p1 -b .archivesize
|
||||
%patch201 -p1 -b .noarch-subpackages
|
||||
%patch202 -p1 -b .segfault
|
||||
%patch203 -p1 -b .macrofix
|
||||
|
||||
# needs a bit of upstream love first...
|
||||
#%patch300 -p1 -b .posttrans
|
||||
@ -346,6 +348,10 @@ exit 0
|
||||
%doc doc/librpm/html/*
|
||||
|
||||
%changelog
|
||||
* Mon Sep 01 2008 Jindrich Novy <jnovy@redhat.com>
|
||||
- fix parsing of boolean expressions in spec (#456103)
|
||||
(unbreaks pam, jpilot and maybe other builds)
|
||||
|
||||
* Tue Aug 26 2008 Jindrich Novy <jnovy@redhat.com>
|
||||
- add support for noarch subpackages
|
||||
- fix segfault in case of insufficient disk space detected (#460146)
|
||||
|
Loading…
Reference in New Issue
Block a user