import qclib-2.2.1-1.el8

This commit is contained in:
CentOS Sources 2021-05-18 02:33:32 -04:00 committed by Stepan Oksanichenko
parent 7fd8871b3e
commit eac85a39b3
5 changed files with 21 additions and 97 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/qclib-2.1.0.tgz
SOURCES/qclib-2.2.1.tar.gz

View File

@ -1 +1 @@
143b479d1978eddcad14923b7f6de69ecfc90048 SOURCES/qclib-2.1.0.tgz
3ad53d7edd10e47125687e4e6023c0f11fc9e3e9 SOURCES/qclib-2.2.1.tar.gz

View File

@ -1,52 +0,0 @@
From f9f4404f0ee2f788d7ff195a50322a5480d72fed Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Wed, 22 Apr 2020 09:51:22 +0200
Subject: [PATCH 1/2] introduce DOCDIR
With a DOCDIR variable in the Makefile the distributions can set the docs
location to their preferred place.
Fixes: https://bugzilla.redhat.com/show_bug.cgi?id=1306280
---
Makefile | 15 ++++++++-------
1 file changed, 8 insertions(+), 7 deletions(-)
diff --git a/Makefile b/Makefile
index 9f48fcb..700783a 100644
--- a/Makefile
+++ b/Makefile
@@ -6,6 +6,7 @@
# bugfix: Bugfixes only
VERSION = 2.1.0
VERM = $(shell echo $(VERSION) | cut -d '.' -f 1)
+DOCDIR ?= /usr/share/doc/packages/
CFLAGS ?= -g -Wall -O2
CFILES = query_capacity.c query_capacity_data.c query_capacity_sysinfo.c \
query_capacity_sysfs.c query_capacity_hypfs.c query_capacity_sthyi.c
@@ -72,16 +73,16 @@ install: libqc.a libqc.so.$(VERSION)
ln -sr $(DESTDIR)/usr/lib64/libqc.so.$(VERSION) $(DESTDIR)/usr/lib64/libqc.so.$(VERM)
ln -sr $(DESTDIR)/usr/lib64/libqc.so.$(VERSION) $(DESTDIR)/usr/lib64/libqc.so
install -Dm 644 query_capacity.h $(DESTDIR)/usr/include/query_capacity.h
- install -Dm 644 README $(DESTDIR)/usr/share/doc/packages/qclib/README
- install -Dm 644 LICENSE $(DESTDIR)/usr/share/doc/packages/qclib/LICENSE
+ install -Dm 644 README $(DESTDIR)/$(DOCDIR)/qclib/README
+ install -Dm 644 LICENSE $(DESTDIR)/$(DOCDIR)/qclib/LICENSE
installdoc: doc
echo " INSTALLDOC"
- install -dm 755 $(DESTDIR)/usr/share/doc/packages/qclib/html
- cp -r html/* $(DESTDIR)/usr/share/doc/packages/qclib/html
- chmod 644 $(DESTDIR)/usr/share/doc/packages/qclib/html/search/*
- chmod 644 $(DESTDIR)/usr/share/doc/packages/qclib/html/*
- chmod 755 $(DESTDIR)/usr/share/doc/packages/qclib/html/search
+ install -dm 755 $(DESTDIR)/$(DOCDIR)/qclib/html
+ cp -r html/* $(DESTDIR)/$(DOCDIR)/qclib/html
+ chmod 644 $(DESTDIR)/$(DOCDIR)/qclib/html/search/*
+ chmod 644 $(DESTDIR)/$(DOCDIR)/qclib/html/*
+ chmod 755 $(DESTDIR)/$(DOCDIR)/qclib/html/search
clean:
echo " CLEAN"
--
2.21.1

View File

@ -1,37 +0,0 @@
From 58e01a3e2f0c7f84a9942e34ef31ef17182e243f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Wed, 22 Apr 2020 09:53:52 +0200
Subject: [PATCH 2/2] introduce LDFLAGS
With an LDFLAGS variable distributions can pass their system-wide linker
options to the build.
Fixes: https://bugzilla.redhat.com/show_bug.cgi?id=1552658
---
Makefile | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 700783a..4495356 100644
--- a/Makefile
+++ b/Makefile
@@ -8,6 +8,7 @@ VERSION = 2.1.0
VERM = $(shell echo $(VERSION) | cut -d '.' -f 1)
DOCDIR ?= /usr/share/doc/packages/
CFLAGS ?= -g -Wall -O2
+LDFLAGS ?=
CFILES = query_capacity.c query_capacity_data.c query_capacity_sysinfo.c \
query_capacity_sysfs.c query_capacity_hypfs.c query_capacity_sthyi.c
OBJECTS = $(patsubst %.c,%.o,$(CFILES))
@@ -41,7 +42,7 @@ libqc.a: $(OBJECTS)
$(AR) rcs $@ $^
libqc.so.$(VERSION): $(OBJECTS)
- $(LINK) -Wl,-soname,libqc.so.$(VERM) -shared $^ -o $@
+ $(LINK) $(LDFLAGS) -Wl,-soname,libqc.so.$(VERM) -shared $^ -o $@
-rm libqc.so.$(VERM) 2>/dev/null
ln -s libqc.so.$(VERSION) libqc.so.$(VERM)
--
2.21.1

View File

@ -1,14 +1,10 @@
Name: qclib
Version: 2.1.0
Version: 2.2.1
Release: 1%{?dist}
Summary: Library for extraction of system information for Linux on z Systems
License: BSD
URL: http://www.ibm.com/developerworks/linux/linux390/qclib.html
Source0: http://public.dhe.ibm.com/software/dw/linux390/ht_src/%{name}-%{version}.tgz
# https://bugzilla.redhat.com/show_bug.cgi?id=1306280
Patch0: %{name}-2.1.0-docdir.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=1552658
Patch1: %{name}-2.1.0-ldflags.patch
Source0: http://public.dhe.ibm.com/software/dw/linux390/ht_src/%{name}-%{version}.tar.gz
ExclusiveArch: s390 s390x
BuildRequires: gcc
BuildRequires: glibc-static
@ -68,7 +64,11 @@ make test-sh test
%dir %{_docdir}/%{name}
%license %{_docdir}/%{name}/LICENSE
%doc %{_docdir}/%{name}/README
%{_bindir}/zhypinfo
%{_bindir}/zname
%{_libdir}/libqc.so.*
%{_mandir}/man8/zhypinfo.8*
%{_mandir}/man8/zname.8*
%files devel
%doc %{_docdir}/%{name}/html/
@ -80,6 +80,19 @@ make test-sh test
%changelog
* Fri Oct 16 2020 Dan Horák <dhorak@redhat.com> - 2.2.1-1
- updated to 2.2.1 (#1847431)
- Resolves: #1847431
* Thu Sep 24 2020 Dan Horák <dhorak@redhat.com> - 2.2.0-2
- fix linking of the new tools
- Related: #1868700
* Thu Sep 24 2020 Dan Horák <dhorak@redhat.com> - 2.2.0-1
- updated to 2.2.0 (#1847431)
- add utility commands (#1868700)
- Resolves: #1847431 #1868700
* Wed Apr 22 2020 Dan Horák <dhorak@redhat.com> - 2.1.0-1
- updated to 2.1.0 (#1780305)
- Resolves: #1780305