import qclib-2.1.0-1.el8

This commit is contained in:
CentOS Sources 2020-11-03 06:44:50 -05:00 committed by Stepan Oksanichenko
parent eea27e9391
commit 7fd8871b3e
7 changed files with 70 additions and 49 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/qclib-2.0.1.tgz
SOURCES/qclib-2.1.0.tgz

View File

@ -1 +1 @@
fba3cf3becbf609d08bc5245412fe875c626e826 SOURCES/qclib-2.0.1.tgz
143b479d1978eddcad14923b7f6de69ecfc90048 SOURCES/qclib-2.1.0.tgz

View File

@ -1,20 +0,0 @@
diff -up qclib-1.3.1/Makefile.ldflags qclib-1.3.1/Makefile
--- qclib-1.3.1/Makefile.ldflags 2018-03-12 10:36:52.428425169 +0100
+++ qclib-1.3.1/Makefile 2018-03-12 10:37:27.328425169 +0100
@@ -8,6 +8,7 @@ VERSION = 1.3.1
VERM = $(shell echo $(VERSION) | cut -d '.' -f 1)
DOCDIR ?= /usr/share/doc/packages/
CFLAGS ?= -g -Wall -O2
+LDFLAGS ?=
CFILES = query_capacity.c query_capacity_data.c query_capacity_sysinfo.c query_capacity_ocf.c \
query_capacity_hypfs.c query_capacity_sthyi.c
OBJECTS = $(patsubst %.c,%.o,$(CFILES))
@@ -38,7 +39,7 @@ libqc.a: $(OBJECTS)
$(AR) rcs $@ $^
libqc.so.$(VERSION): $(OBJECTS)
- $(LINK) -Wl,-soname,libqc.so.$(VERM) -shared $^ -o $@
+ $(LINK) $(LDFLAGS) -Wl,-soname,libqc.so.$(VERM) -shared $^ -o $@
-rm libqc.so.$(VERM) 2>/dev/null
ln -s libqc.so.$(VERSION) libqc.so.$(VERM)

View File

@ -1,11 +0,0 @@
diff -up qclib-2.0.1/query_capacity.c.orig qclib-2.0.1/query_capacity.c
--- qclib-2.0.1/query_capacity.c.orig 2020-05-14 12:19:06.002068645 +0200
+++ qclib-2.0.1/query_capacity.c 2020-05-14 12:19:22.949968994 +0200
@@ -520,6 +520,7 @@ static struct qc_mtype mtypes[] = {
{3907, "IBM z14 ZR1", "IBM LinuxONE Rockhopper II"},
{3906, "IBM z14", "IBM LinuxONE Emperor II"},
{8561, "IBM z15", "IBM LinuxONE III"},
+ {8562, "IBM z15 Model T02", "IBM LinuxONE III Model LT2"},
{0, NULL, NULL}
};

View File

@ -1,15 +1,29 @@
diff -up qclib-1.3.1/Makefile.docdir qclib-1.3.1/Makefile
--- qclib-1.3.1/Makefile.docdir 2017-10-24 07:02:42.000000000 +0200
+++ qclib-1.3.1/Makefile 2017-12-04 14:15:08.000000000 +0100
From f9f4404f0ee2f788d7ff195a50322a5480d72fed Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Wed, 22 Apr 2020 09:51:22 +0200
Subject: [PATCH 1/2] introduce DOCDIR
With a DOCDIR variable in the Makefile the distributions can set the docs
location to their preferred place.
Fixes: https://bugzilla.redhat.com/show_bug.cgi?id=1306280
---
Makefile | 15 ++++++++-------
1 file changed, 8 insertions(+), 7 deletions(-)
diff --git a/Makefile b/Makefile
index 9f48fcb..700783a 100644
--- a/Makefile
+++ b/Makefile
@@ -6,6 +6,7 @@
# bugfix: Bugfixes only
VERSION = 2.0.1
VERSION = 2.1.0
VERM = $(shell echo $(VERSION) | cut -d '.' -f 1)
+DOCDIR ?= /usr/share/doc/packages/
CFLAGS ?= -g -Wall -O2
CFILES = query_capacity.c query_capacity_data.c query_capacity_sysinfo.c query_capacity_ocf.c \
query_capacity_hypfs.c query_capacity_sthyi.c
@@ -69,16 +70,16 @@ install: libqc.a libqc.so.$(VERSION)
CFILES = query_capacity.c query_capacity_data.c query_capacity_sysinfo.c \
query_capacity_sysfs.c query_capacity_hypfs.c query_capacity_sthyi.c
@@ -72,16 +73,16 @@ install: libqc.a libqc.so.$(VERSION)
ln -sr $(DESTDIR)/usr/lib64/libqc.so.$(VERSION) $(DESTDIR)/usr/lib64/libqc.so.$(VERM)
ln -sr $(DESTDIR)/usr/lib64/libqc.so.$(VERSION) $(DESTDIR)/usr/lib64/libqc.so
install -Dm 644 query_capacity.h $(DESTDIR)/usr/include/query_capacity.h
@ -33,3 +47,6 @@ diff -up qclib-1.3.1/Makefile.docdir qclib-1.3.1/Makefile
clean:
echo " CLEAN"
--
2.21.1

View File

@ -0,0 +1,37 @@
From 58e01a3e2f0c7f84a9942e34ef31ef17182e243f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Wed, 22 Apr 2020 09:53:52 +0200
Subject: [PATCH 2/2] introduce LDFLAGS
With an LDFLAGS variable distributions can pass their system-wide linker
options to the build.
Fixes: https://bugzilla.redhat.com/show_bug.cgi?id=1552658
---
Makefile | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 700783a..4495356 100644
--- a/Makefile
+++ b/Makefile
@@ -8,6 +8,7 @@ VERSION = 2.1.0
VERM = $(shell echo $(VERSION) | cut -d '.' -f 1)
DOCDIR ?= /usr/share/doc/packages/
CFLAGS ?= -g -Wall -O2
+LDFLAGS ?=
CFILES = query_capacity.c query_capacity_data.c query_capacity_sysinfo.c \
query_capacity_sysfs.c query_capacity_hypfs.c query_capacity_sthyi.c
OBJECTS = $(patsubst %.c,%.o,$(CFILES))
@@ -41,7 +42,7 @@ libqc.a: $(OBJECTS)
$(AR) rcs $@ $^
libqc.so.$(VERSION): $(OBJECTS)
- $(LINK) -Wl,-soname,libqc.so.$(VERM) -shared $^ -o $@
+ $(LINK) $(LDFLAGS) -Wl,-soname,libqc.so.$(VERM) -shared $^ -o $@
-rm libqc.so.$(VERM) 2>/dev/null
ln -s libqc.so.$(VERSION) libqc.so.$(VERM)
--
2.21.1

View File

@ -1,16 +1,14 @@
Name: qclib
Version: 2.0.1
Release: 1%{?dist}.1
Version: 2.1.0
Release: 1%{?dist}
Summary: Library for extraction of system information for Linux on z Systems
License: BSD
URL: http://www.ibm.com/developerworks/linux/linux390/qclib.html
Source0: http://public.dhe.ibm.com/software/dw/linux390/ht_src/%{name}-%{version}.tgz
# https://bugzilla.redhat.com/show_bug.cgi?id=1306280
Patch0: %{name}-2.0.0-docdir.patch
Patch0: %{name}-2.1.0-docdir.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=1552658
Patch1: %{name}-1.3.1-ldflags.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=1834712
Patch2: %{name}-2.0.1-z15-t02.patch
Patch1: %{name}-2.1.0-ldflags.patch
ExclusiveArch: s390 s390x
BuildRequires: gcc
BuildRequires: glibc-static
@ -82,9 +80,9 @@ make test-sh test
%changelog
* Thu May 14 2020 Dan Horák <dhorak@redhat.com> - 2.0.1-1.1
- Add support for new z15 (#1834712)
- Resolves: #1834712
* Wed Apr 22 2020 Dan Horák <dhorak@redhat.com> - 2.1.0-1
- updated to 2.1.0 (#1780305)
- Resolves: #1780305
* Mon Jan 13 2020 Dan Horák <dhorak@redhat.com> - 2.0.1-1
- updated to 2.0.1 (#1790369)