7eb10c8dbe
* Sat Aug 21 2010 David Malcolm <dmalcolm@redhat.com> - 3.2-0.0.a1 - 3.2a1; add alphatag - rework %%files in the light of PEP 3147 (__pycache__) - drop our configuration patch to Setup.dist (patch 0): setup.py should do a better job of things, and the %%files explicitly lists our modules (r82746 appears to break the old way of doing things). This leads to various modules changing from "foomodule.so" to "foo.so". It also leads to the optimized build dropping the _sha1, _sha256 and _sha512 modules, but these are provided by _hashlib; _weakref becomes a builtin module; xxsubtype goes away (it's only for testing/devel purposes) - fixup patches 3, 4, 6, 8, 102, 103, 105, 111 for the rebase - remove upstream patches: 7 (system expat), 106, 107, 108 (audioop reformat plus CVE-2010-1634 and CVE-2010-2089), 109 (CVE-2008-5983) - add machinery for rebuilding "configure" and friends, using the correct version of autoconf (patch 300) - patch the debug build's usage of COUNT_ALLOCS to be less verbose (patch 125) - "modulator" was removed upstream - drop "-b" from patch applications affecting .py files to avoid littering the installation tree
147 lines
6.8 KiB
Diff
147 lines
6.8 KiB
Diff
diff -up Python-3.2a1/Lib/distutils/command/install.py.lib64 Python-3.2a1/Lib/distutils/command/install.py
|
|
--- Python-3.2a1/Lib/distutils/command/install.py.lib64 2010-07-22 08:50:05.000000000 -0400
|
|
+++ Python-3.2a1/Lib/distutils/command/install.py 2010-08-02 18:33:15.667001759 -0400
|
|
@@ -47,14 +47,14 @@ else:
|
|
INSTALL_SCHEMES = {
|
|
'unix_prefix': {
|
|
'purelib': '$base/lib/python$py_version_short/site-packages',
|
|
- 'platlib': '$platbase/lib/python$py_version_short/site-packages',
|
|
+ 'platlib': '$platbase/lib64/python$py_version_short/site-packages',
|
|
'headers': '$base/include/python$py_version_short/$dist_name',
|
|
'scripts': '$base/bin',
|
|
'data' : '$base',
|
|
},
|
|
'unix_home': {
|
|
'purelib': '$base/lib/python',
|
|
- 'platlib': '$base/lib/python',
|
|
+ 'platlib': '$base/lib64/python',
|
|
'headers': '$base/include/python/$dist_name',
|
|
'scripts': '$base/bin',
|
|
'data' : '$base',
|
|
diff -up Python-3.2a1/Lib/distutils/sysconfig.py.lib64 Python-3.2a1/Lib/distutils/sysconfig.py
|
|
--- Python-3.2a1/Lib/distutils/sysconfig.py.lib64 2010-07-23 05:43:17.000000000 -0400
|
|
+++ Python-3.2a1/Lib/distutils/sysconfig.py 2010-08-02 18:33:15.669000547 -0400
|
|
@@ -117,8 +117,12 @@ def get_python_lib(plat_specific=0, stan
|
|
prefix = plat_specific and EXEC_PREFIX or PREFIX
|
|
|
|
if os.name == "posix":
|
|
+ if plat_specific or standard_lib:
|
|
+ lib = "lib64"
|
|
+ else:
|
|
+ lib = "lib"
|
|
libpython = os.path.join(prefix,
|
|
- "lib", "python" + get_python_version())
|
|
+ lib, "python" + get_python_version())
|
|
if standard_lib:
|
|
return libpython
|
|
else:
|
|
diff -up Python-3.2a1/Lib/site.py.lib64 Python-3.2a1/Lib/site.py
|
|
--- Python-3.2a1/Lib/site.py.lib64 2010-06-27 17:45:24.000000000 -0400
|
|
+++ Python-3.2a1/Lib/site.py 2010-08-02 18:34:30.584001242 -0400
|
|
@@ -283,12 +283,16 @@ def getsitepackages():
|
|
if sys.platform in ('os2emx', 'riscos'):
|
|
sitepackages.append(os.path.join(prefix, "Lib", "site-packages"))
|
|
elif os.sep == '/':
|
|
+ sitepackages.append(os.path.join(prefix, "lib64",
|
|
+ "python" + sys.version[:3],
|
|
+ "site-packages"))
|
|
sitepackages.append(os.path.join(prefix, "lib",
|
|
"python" + sys.version[:3],
|
|
"site-packages"))
|
|
sitepackages.append(os.path.join(prefix, "lib", "site-python"))
|
|
else:
|
|
sitepackages.append(prefix)
|
|
+ sitepackages.append(os.path.join(prefix, "lib64", "site-packages"))
|
|
sitepackages.append(os.path.join(prefix, "lib", "site-packages"))
|
|
if sys.platform == "darwin":
|
|
# for framework builds *only* we add the standard Apple
|
|
diff -up Python-3.2a1/Makefile.pre.in.lib64 Python-3.2a1/Makefile.pre.in
|
|
--- Python-3.2a1/Makefile.pre.in.lib64 2010-08-02 18:33:15.000000000 -0400
|
|
+++ Python-3.2a1/Makefile.pre.in 2010-08-02 18:35:07.147000664 -0400
|
|
@@ -100,7 +100,7 @@ LIBDIR= @libdir@
|
|
MANDIR= @mandir@
|
|
INCLUDEDIR= @includedir@
|
|
CONFINCLUDEDIR= $(exec_prefix)/include
|
|
-SCRIPTDIR= $(prefix)/lib
|
|
+SCRIPTDIR= $(prefix)/lib64
|
|
|
|
# Detailed destination directories
|
|
BINLIBDEST= $(LIBDIR)/python$(VERSION)
|
|
diff -up Python-3.2a1/Modules/getpath.c.lib64 Python-3.2a1/Modules/getpath.c
|
|
--- Python-3.2a1/Modules/getpath.c.lib64 2010-07-23 12:05:35.000000000 -0400
|
|
+++ Python-3.2a1/Modules/getpath.c 2010-08-02 18:35:50.857000717 -0400
|
|
@@ -117,8 +117,8 @@
|
|
#endif
|
|
|
|
#ifndef PYTHONPATH
|
|
-#define PYTHONPATH PREFIX "/lib/python" VERSION ":" \
|
|
- EXEC_PREFIX "/lib/python" VERSION "/lib-dynload"
|
|
+#define PYTHONPATH PREFIX "/lib64/python" VERSION ":" \
|
|
+ EXEC_PREFIX "/lib64/python" VERSION "/lib-dynload"
|
|
#endif
|
|
|
|
#ifndef LANDMARK
|
|
@@ -129,7 +129,7 @@ static wchar_t prefix[MAXPATHLEN+1];
|
|
static wchar_t exec_prefix[MAXPATHLEN+1];
|
|
static wchar_t progpath[MAXPATHLEN+1];
|
|
static wchar_t *module_search_path = NULL;
|
|
-static wchar_t *lib_python = L"lib/python" VERSION;
|
|
+static wchar_t *lib_python = L"lib64/python" VERSION;
|
|
|
|
/* In principle, this should use HAVE__WSTAT, and _wstat
|
|
should be detected by autoconf. However, no current
|
|
@@ -603,7 +603,7 @@ calculate_path(void)
|
|
}
|
|
else
|
|
wcsncpy(zip_path, L"" PREFIX, MAXPATHLEN);
|
|
- joinpath(zip_path, L"lib/python00.zip");
|
|
+ joinpath(zip_path, L"lib64/python00.zip");
|
|
bufsz = wcslen(zip_path); /* Replace "00" with version */
|
|
zip_path[bufsz - 6] = VERSION[0];
|
|
zip_path[bufsz - 5] = VERSION[2];
|
|
@@ -613,7 +613,7 @@ calculate_path(void)
|
|
fprintf(stderr,
|
|
"Could not find platform dependent libraries <exec_prefix>\n");
|
|
wcsncpy(exec_prefix, L"" EXEC_PREFIX, MAXPATHLEN);
|
|
- joinpath(exec_prefix, L"lib/lib-dynload");
|
|
+ joinpath(exec_prefix, L"lib64/lib-dynload");
|
|
}
|
|
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
|
|
|
|
--- Python-3.2a1/setup.py.lib64 2010-07-23 15:25:47.000000000 -0400
|
|
+++ Python-3.2a1/setup.py 2010-08-02 18:36:51.521000448 -0400
|
|
@@ -343,7 +343,7 @@ class PyBuildExt(build_ext):
|
|
|
|
def detect_modules(self):
|
|
# Ensure that /usr/local is always used
|
|
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
|
|
+ add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib64')
|
|
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
|
|
|
|
# Add paths specified in the environment variables LDFLAGS and
|
|
@@ -587,11 +587,11 @@ class PyBuildExt(build_ext):
|
|
elif curses_library:
|
|
readline_libs.append(curses_library)
|
|
elif self.compiler.find_library_file(lib_dirs +
|
|
- ['/usr/lib/termcap'],
|
|
+ ['/usr/lib64/termcap'],
|
|
'termcap'):
|
|
readline_libs.append('termcap')
|
|
exts.append( Extension('readline', ['readline.c'],
|
|
- library_dirs=['/usr/lib/termcap'],
|
|
+ library_dirs=['/usr/lib64/termcap'],
|
|
extra_link_args=readline_extra_link_args,
|
|
libraries=readline_libs) )
|
|
else:
|
|
@@ -628,8 +628,8 @@ class PyBuildExt(build_ext):
|
|
if krb5_h:
|
|
ssl_incs += krb5_h
|
|
ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,
|
|
- ['/usr/local/ssl/lib',
|
|
- '/usr/contrib/ssl/lib/'
|
|
+ ['/usr/local/ssl/lib64',
|
|
+ '/usr/contrib/ssl/lib64/'
|
|
] )
|
|
|
|
if (ssl_incs is not None and
|