Update to 3.9.0b4
This commit is contained in:
parent
7367fec47d
commit
efdda005ea
@ -1,4 +1,4 @@
|
||||
From b53918a16e7d96cfb6d36cccdd0556b734d1709b Mon Sep 17 00:00:00 2001
|
||||
From 95cba782ed45e6683de1e68ba3f2f4918e678151 Mon Sep 17 00:00:00 2001
|
||||
From: David Malcolm <dmalcolm@redhat.com>
|
||||
Date: Wed, 13 Jan 2010 21:25:18 +0000
|
||||
Subject: [PATCH] 00001: Fixup distutils/unixccompiler.py to remove standard
|
||||
@ -29,5 +29,5 @@ index 4d7a6de740..353086a648 100644
|
||||
include_dirs=None, extra_preargs=None, extra_postargs=None):
|
||||
fixed_args = self._fix_compile_args(None, macros, include_dirs)
|
||||
--
|
||||
2.26.2
|
||||
2.23.0
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From df3fd42f934cec4fe31c80c111be149a457bdda8 Mon Sep 17 00:00:00 2001
|
||||
From c6c75ba765d56ab91478cf63f8a1db3a0c9c7b6e Mon Sep 17 00:00:00 2001
|
||||
From: David Malcolm <dmalcolm@redhat.com>
|
||||
Date: Mon, 18 Jan 2010 17:59:07 +0000
|
||||
Subject: [PATCH] 00111: Don't try to build a libpythonMAJOR.MINOR.a
|
||||
@ -21,7 +21,7 @@ Co-authored-by: Miro Hrončok <miro@hroncok.cz>
|
||||
1 file changed, 2 insertions(+), 19 deletions(-)
|
||||
|
||||
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
||||
index 652efb4ba1..b8bae4f767 100644
|
||||
index dede88711e..07e3380781 100644
|
||||
--- a/Makefile.pre.in
|
||||
+++ b/Makefile.pre.in
|
||||
@@ -582,7 +582,7 @@ clinic: check-clean-src $(srcdir)/Modules/_blake2/blake2s_impl.c
|
||||
@ -55,7 +55,7 @@ index 652efb4ba1..b8bae4f767 100644
|
||||
$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
|
||||
|
||||
############################################################################
|
||||
@@ -1623,17 +1617,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
||||
@@ -1622,17 +1616,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
||||
else true; \
|
||||
fi; \
|
||||
done
|
||||
@ -74,5 +74,5 @@ index 652efb4ba1..b8bae4f767 100644
|
||||
$(INSTALL_DATA) Programs/python.o $(DESTDIR)$(LIBPL)/python.o
|
||||
$(INSTALL_DATA) $(srcdir)/Modules/config.c.in $(DESTDIR)$(LIBPL)/config.c.in
|
||||
--
|
||||
2.26.2
|
||||
2.23.0
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From c18d7cb5e0217a9fb75801075354dd31d423ec66 Mon Sep 17 00:00:00 2001
|
||||
From 7471b64da4786004c290e6ca6637cad231e319a3 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
|
||||
Date: Wed, 15 Aug 2018 15:36:29 +0200
|
||||
Subject: [PATCH] 00189: Instead of bundled wheels, use our RPM packaged wheels
|
||||
@ -9,7 +9,7 @@ We keep them in /usr/share/python-wheels
|
||||
1 file changed, 22 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/Lib/ensurepip/__init__.py b/Lib/ensurepip/__init__.py
|
||||
index 545fce656f..f86992c90c 100644
|
||||
index 21320a8319..dffe4ce389 100644
|
||||
--- a/Lib/ensurepip/__init__.py
|
||||
+++ b/Lib/ensurepip/__init__.py
|
||||
@@ -1,3 +1,5 @@
|
||||
@ -43,19 +43,19 @@ index 545fce656f..f86992c90c 100644
|
||||
+ return str(max(_wheels[pkg], key=distutils.version.LooseVersion))
|
||||
+
|
||||
|
||||
-_SETUPTOOLS_VERSION = "41.2.0"
|
||||
-_SETUPTOOLS_VERSION = "47.1.0"
|
||||
+_SETUPTOOLS_VERSION = _get_most_recent_wheel_version("setuptools")
|
||||
|
||||
-_PIP_VERSION = "19.2.3"
|
||||
-_PIP_VERSION = "20.1.1"
|
||||
+_PIP_VERSION = _get_most_recent_wheel_version("pip")
|
||||
|
||||
_PROJECTS = [
|
||||
("setuptools", _SETUPTOOLS_VERSION),
|
||||
("setuptools", _SETUPTOOLS_VERSION, "py3"),
|
||||
@@ -108,13 +122,10 @@ def _bootstrap(*, root=None, upgrade=False, user=False,
|
||||
# additional paths that need added to sys.path
|
||||
additional_paths = []
|
||||
for project, version in _PROJECTS:
|
||||
- wheel_name = "{}-{}-py2.py3-none-any.whl".format(project, version)
|
||||
for project, version, py_tag in _PROJECTS:
|
||||
- wheel_name = "{}-{}-{}-none-any.whl".format(project, version, py_tag)
|
||||
- whl = resources.read_binary(
|
||||
- _bundled,
|
||||
- wheel_name,
|
||||
@ -70,5 +70,5 @@ index 545fce656f..f86992c90c 100644
|
||||
additional_paths.append(os.path.join(tmpdir, wheel_name))
|
||||
|
||||
--
|
||||
2.26.2
|
||||
2.23.0
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From a76c823ee9a498534526aa6ad3d36d589793a6f7 Mon Sep 17 00:00:00 2001
|
||||
From 3002acfa2d914e7d7056d03f6dc25c8d2dfdeca9 Mon Sep 17 00:00:00 2001
|
||||
From: Michal Cyprian <m.cyprian@gmail.com>
|
||||
Date: Mon, 26 Jun 2017 16:32:56 +0200
|
||||
Subject: [PATCH] 00251: Change user install location
|
||||
@ -40,7 +40,7 @@ index aaa300efa9..f8d453912a 100644
|
||||
else:
|
||||
if self.exec_prefix is None:
|
||||
diff --git a/Lib/site.py b/Lib/site.py
|
||||
index e981a14208..63e05ff2ad 100644
|
||||
index 9e617afb00..db14f715f9 100644
|
||||
--- a/Lib/site.py
|
||||
+++ b/Lib/site.py
|
||||
@@ -353,7 +353,14 @@ def getsitepackages(prefixes=None):
|
||||
@ -60,5 +60,5 @@ index e981a14208..63e05ff2ad 100644
|
||||
if os.path.isdir(sitedir):
|
||||
addsitedir(sitedir, known_paths)
|
||||
--
|
||||
2.26.2
|
||||
2.23.0
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From a0fbb970b2a9bbc692f9f920059929af1e14f5ab Mon Sep 17 00:00:00 2001
|
||||
From fdd4f023f6d677f05ba0eeedc37bee72d0be9968 Mon Sep 17 00:00:00 2001
|
||||
From: Petr Viktorin <pviktori@redhat.com>
|
||||
Date: Mon, 28 Aug 2017 17:16:46 +0200
|
||||
Subject: [PATCH] 00274: Upstream uses Debian-style architecture naming, change
|
||||
@ -29,7 +29,7 @@ index ba37cf99e2..52a9ec6662 100755
|
||||
ppc64le | powerpc64little)
|
||||
basic_machine=powerpc64le-unknown
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index bb327f68eb..fc0293ec4a 100644
|
||||
index 7bbceb10d8..047676a168 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -759,9 +759,9 @@ cat >> conftest.c <<EOF
|
||||
@ -82,5 +82,5 @@ index bb327f68eb..fc0293ec4a 100644
|
||||
s390x-linux-gnu
|
||||
# elif defined(__s390__)
|
||||
--
|
||||
2.26.2
|
||||
2.23.0
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 69431032d7a0928e3908438fdc1ac60dda77516a Mon Sep 17 00:00:00 2001
|
||||
From 956dc7afea819be2e45ab0eac6a9f7155ec871f1 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
|
||||
Date: Thu, 11 Jul 2019 13:44:13 +0200
|
||||
Subject: [PATCH] 00328: Restore pyc to TIMESTAMP invalidation mode as default
|
||||
@ -51,5 +51,5 @@ index d4a68c9320..ed09874023 100644
|
||||
return wrapper
|
||||
|
||||
--
|
||||
2.26.2
|
||||
2.23.0
|
||||
|
||||
|
@ -14,7 +14,7 @@ URL: https://www.python.org/
|
||||
# WARNING When rebasing to a new Python version,
|
||||
# remember to update the python3-docs package as well
|
||||
%global general_version %{pybasever}.0
|
||||
%global prerel b3
|
||||
%global prerel b4
|
||||
%global upstream_version %{general_version}%{?prerel}
|
||||
Version: %{general_version}%{?prerel:~%{prerel}}
|
||||
Release: 1%{?dist}
|
||||
@ -267,8 +267,8 @@ Patch189: 00189-use-rpm-wheels.patch
|
||||
# The versions are written in Lib/ensurepip/__init__.py, this patch removes them.
|
||||
# When the bundled setuptools/pip wheel is updated, the patch no longer applies cleanly.
|
||||
# In such cases, the patch needs to be amended and the versions updated here:
|
||||
%global pip_version 19.2.3
|
||||
%global setuptools_version 41.2.0
|
||||
%global pip_version 20.1.1
|
||||
%global setuptools_version 47.1.0
|
||||
|
||||
# 00251
|
||||
# Set values of prefix and exec_prefix in distutils install command
|
||||
@ -1596,6 +1596,9 @@ CheckPython optimized
|
||||
# ======================================================
|
||||
|
||||
%changelog
|
||||
* Sat Jul 04 2020 Tomas Hrnciar <thrnciar@redhat.com> - 3.9.0~b4-1
|
||||
- Update to 3.9.0b4
|
||||
|
||||
* Wed Jun 10 2020 Miro Hrončok <mhroncok@redhat.com> - 3.9.0~b3-1
|
||||
- Update to 3.9.0b3
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (Python-3.9.0b3.tar.xz) = c06a6b874fbce93ec37402034158a7bab44cab775d6da467eaddc1eb402663415f9d788e657a204f17dffe5fa6f379379f9215b5198ec5071565486b6f0e4a2a
|
||||
SHA512 (Python-3.9.0b3.tar.xz.asc) = a1575d21e2e811cee424cd93b80fd7f12d284da9e3be5fd87ac9cd3d391e33da19f459a17dea308a0d20a31bb7375b1e352876e809027caa05a00bcf5a24f423
|
||||
SHA512 (Python-3.9.0b4.tar.xz) = 1c9bac850159352effb163b41590b3e9c05100b449798b5615f7a51a59a3877fe9558d593bb47c24915226637e3394e7864a1b1555cd6c5b5e5e308972208ecf
|
||||
SHA512 (Python-3.9.0b4.tar.xz.asc) = 8e2682ca5c8327ba54c8d8a6b71a2b7ca059907776ec7aa7e817da991c2017d701beb6e6cac0e4cc0783864fd00fda677baa78e89202d52e3c859efd9c4a7dd6
|
||||
|
Loading…
Reference in New Issue
Block a user