Update to 3.9.8
This commit is contained in:
parent
010c643aae
commit
dc16576a77
@ -9,7 +9,7 @@ Subject: [PATCH] 00001: Fixup distutils/unixccompiler.py to remove standard
|
|||||||
1 file changed, 9 insertions(+)
|
1 file changed, 9 insertions(+)
|
||||||
|
|
||||||
diff --git a/Lib/distutils/unixccompiler.py b/Lib/distutils/unixccompiler.py
|
diff --git a/Lib/distutils/unixccompiler.py b/Lib/distutils/unixccompiler.py
|
||||||
index f0792de74a..4d837936c6 100644
|
index d00c48981e..0283a28c19 100644
|
||||||
--- a/Lib/distutils/unixccompiler.py
|
--- a/Lib/distutils/unixccompiler.py
|
||||||
+++ b/Lib/distutils/unixccompiler.py
|
+++ b/Lib/distutils/unixccompiler.py
|
||||||
@@ -82,6 +82,15 @@ class UnixCCompiler(CCompiler):
|
@@ -82,6 +82,15 @@ class UnixCCompiler(CCompiler):
|
||||||
|
@ -21,10 +21,10 @@ Co-authored-by: Miro Hrončok <miro@hroncok.cz>
|
|||||||
1 file changed, 2 insertions(+), 19 deletions(-)
|
1 file changed, 2 insertions(+), 19 deletions(-)
|
||||||
|
|
||||||
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
||||||
index 6ce7a614dc..2cf3cb184e 100644
|
index 11230fa563..dc763e7197 100644
|
||||||
--- a/Makefile.pre.in
|
--- a/Makefile.pre.in
|
||||||
+++ b/Makefile.pre.in
|
+++ b/Makefile.pre.in
|
||||||
@@ -589,7 +589,7 @@ clinic: check-clean-src $(srcdir)/Modules/_blake2/blake2s_impl.c
|
@@ -588,7 +588,7 @@ clinic: check-clean-src $(srcdir)/Modules/_blake2/blake2s_impl.c
|
||||||
$(PYTHON_FOR_REGEN) $(srcdir)/Tools/clinic/clinic.py --make --srcdir $(srcdir)
|
$(PYTHON_FOR_REGEN) $(srcdir)/Tools/clinic/clinic.py --make --srcdir $(srcdir)
|
||||||
|
|
||||||
# Build the interpreter
|
# Build the interpreter
|
||||||
@ -33,7 +33,7 @@ index 6ce7a614dc..2cf3cb184e 100644
|
|||||||
$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
|
$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
|
||||||
|
|
||||||
platform: $(BUILDPYTHON) pybuilddir.txt
|
platform: $(BUILDPYTHON) pybuilddir.txt
|
||||||
@@ -637,12 +637,6 @@ sharedmods: $(BUILDPYTHON) pybuilddir.txt Modules/_math.o
|
@@ -636,12 +636,6 @@ sharedmods: $(BUILDPYTHON) pybuilddir.txt Modules/_math.o
|
||||||
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
|
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
|
||||||
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
|
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
|
||||||
|
|
||||||
@ -46,7 +46,7 @@ index 6ce7a614dc..2cf3cb184e 100644
|
|||||||
libpython$(LDVERSION).so: $(LIBRARY_OBJS) $(DTRACE_OBJS)
|
libpython$(LDVERSION).so: $(LIBRARY_OBJS) $(DTRACE_OBJS)
|
||||||
if test $(INSTSONAME) != $(LDLIBRARY); then \
|
if test $(INSTSONAME) != $(LDLIBRARY); then \
|
||||||
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM); \
|
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM); \
|
||||||
@@ -724,7 +718,7 @@ Makefile Modules/config.c: Makefile.pre \
|
@@ -723,7 +717,7 @@ Makefile Modules/config.c: Makefile.pre \
|
||||||
@echo "The Makefile was updated, you may need to re-run make."
|
@echo "The Makefile was updated, you may need to re-run make."
|
||||||
|
|
||||||
|
|
||||||
@ -55,7 +55,7 @@ index 6ce7a614dc..2cf3cb184e 100644
|
|||||||
$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
|
$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
|
||||||
|
|
||||||
############################################################################
|
############################################################################
|
||||||
@@ -1652,17 +1646,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
@@ -1651,17 +1645,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
||||||
else true; \
|
else true; \
|
||||||
fi; \
|
fi; \
|
||||||
done
|
done
|
||||||
|
@ -8,11 +8,11 @@ We keep them in /usr/share/python-wheels
|
|||||||
Downstream only: upstream bundles
|
Downstream only: upstream bundles
|
||||||
We might eventually pursuit upstream support, but it's low prio
|
We might eventually pursuit upstream support, but it's low prio
|
||||||
---
|
---
|
||||||
Lib/ensurepip/__init__.py | 33 ++++++++++++++++++++++-----------
|
Lib/ensurepip/__init__.py | 37 ++++++++++++++++++++++++++-----------
|
||||||
1 file changed, 22 insertions(+), 11 deletions(-)
|
1 file changed, 26 insertions(+), 11 deletions(-)
|
||||||
|
|
||||||
diff --git a/Lib/ensurepip/__init__.py b/Lib/ensurepip/__init__.py
|
diff --git a/Lib/ensurepip/__init__.py b/Lib/ensurepip/__init__.py
|
||||||
index 7b03970c93..5bd16a6c59 100644
|
index 2a140a2624..5bd16a6c59 100644
|
||||||
--- a/Lib/ensurepip/__init__.py
|
--- a/Lib/ensurepip/__init__.py
|
||||||
+++ b/Lib/ensurepip/__init__.py
|
+++ b/Lib/ensurepip/__init__.py
|
||||||
@@ -1,3 +1,5 @@
|
@@ -1,3 +1,5 @@
|
||||||
@ -21,7 +21,7 @@ index 7b03970c93..5bd16a6c59 100644
|
|||||||
import os
|
import os
|
||||||
import os.path
|
import os.path
|
||||||
import sys
|
import sys
|
||||||
@@ -6,16 +8,28 @@ import tempfile
|
@@ -6,13 +8,29 @@ import tempfile
|
||||||
import subprocess
|
import subprocess
|
||||||
from importlib import resources
|
from importlib import resources
|
||||||
|
|
||||||
@ -30,13 +30,13 @@ index 7b03970c93..5bd16a6c59 100644
|
|||||||
|
|
||||||
|
|
||||||
__all__ = ["version", "bootstrap"]
|
__all__ = ["version", "bootstrap"]
|
||||||
|
-_SETUPTOOLS_VERSION = "58.1.0"
|
||||||
|
-_PIP_VERSION = "21.2.4"
|
||||||
|
+
|
||||||
+_WHEEL_DIR = "/usr/share/python-wheels/"
|
+_WHEEL_DIR = "/usr/share/python-wheels/"
|
||||||
|
+
|
||||||
-_SETUPTOOLS_VERSION = "57.4.0"
|
|
||||||
+_wheels = {}
|
+_wheels = {}
|
||||||
|
+
|
||||||
-_PIP_VERSION = "21.2.3"
|
|
||||||
+def _get_most_recent_wheel_version(pkg):
|
+def _get_most_recent_wheel_version(pkg):
|
||||||
+ prefix = os.path.join(_WHEEL_DIR, "{}-".format(pkg))
|
+ prefix = os.path.join(_WHEEL_DIR, "{}-".format(pkg))
|
||||||
+ _wheels[pkg] = {}
|
+ _wheels[pkg] = {}
|
||||||
@ -51,10 +51,11 @@ index 7b03970c93..5bd16a6c59 100644
|
|||||||
+_SETUPTOOLS_VERSION = _get_most_recent_wheel_version("setuptools")
|
+_SETUPTOOLS_VERSION = _get_most_recent_wheel_version("setuptools")
|
||||||
+
|
+
|
||||||
+_PIP_VERSION = _get_most_recent_wheel_version("pip")
|
+_PIP_VERSION = _get_most_recent_wheel_version("pip")
|
||||||
|
+
|
||||||
_PROJECTS = [
|
_PROJECTS = [
|
||||||
("setuptools", _SETUPTOOLS_VERSION, "py3"),
|
("setuptools", _SETUPTOOLS_VERSION, "py3"),
|
||||||
@@ -105,13 +119,10 @@ def _bootstrap(*, root=None, upgrade=False, user=False,
|
("pip", _PIP_VERSION, "py3"),
|
||||||
|
@@ -101,13 +119,10 @@ def _bootstrap(*, root=None, upgrade=False, user=False,
|
||||||
# additional paths that need added to sys.path
|
# additional paths that need added to sys.path
|
||||||
additional_paths = []
|
additional_paths = []
|
||||||
for project, version, py_tag in _PROJECTS:
|
for project, version, py_tag in _PROJECTS:
|
||||||
|
@ -13,11 +13,11 @@ URL: https://www.python.org/
|
|||||||
|
|
||||||
# WARNING When rebasing to a new Python version,
|
# WARNING When rebasing to a new Python version,
|
||||||
# remember to update the python3-docs package as well
|
# remember to update the python3-docs package as well
|
||||||
%global general_version %{pybasever}.7
|
%global general_version %{pybasever}.8
|
||||||
#global prerel ...
|
#global prerel ...
|
||||||
%global upstream_version %{general_version}%{?prerel}
|
%global upstream_version %{general_version}%{?prerel}
|
||||||
Version: %{general_version}%{?prerel:~%{prerel}}
|
Version: %{general_version}%{?prerel:~%{prerel}}
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: Python
|
License: Python
|
||||||
|
|
||||||
|
|
||||||
@ -305,7 +305,7 @@ Patch1: 00001-rpath.patch
|
|||||||
# See https://bugzilla.redhat.com/show_bug.cgi?id=556092
|
# See https://bugzilla.redhat.com/show_bug.cgi?id=556092
|
||||||
Patch111: 00111-no-static-lib.patch
|
Patch111: 00111-no-static-lib.patch
|
||||||
|
|
||||||
# 00189 # ab9a031e2a429afce5c3e1777633d5305b956ea6
|
# 00189 # d06cf137c00fd3907b436fdb92a8f007a7f2fb50
|
||||||
# Instead of bundled wheels, use our RPM packaged wheels
|
# Instead of bundled wheels, use our RPM packaged wheels
|
||||||
#
|
#
|
||||||
# We keep them in /usr/share/python-wheels
|
# We keep them in /usr/share/python-wheels
|
||||||
@ -317,8 +317,8 @@ Patch189: 00189-use-rpm-wheels.patch
|
|||||||
# The versions are written in Lib/ensurepip/__init__.py, this patch removes them.
|
# The versions are written in Lib/ensurepip/__init__.py, this patch removes them.
|
||||||
# When the bundled setuptools/pip wheel is updated, the patch no longer applies cleanly.
|
# When the bundled setuptools/pip wheel is updated, the patch no longer applies cleanly.
|
||||||
# In such cases, the patch needs to be amended and the versions updated here:
|
# In such cases, the patch needs to be amended and the versions updated here:
|
||||||
%global pip_version 21.2.3
|
%global pip_version 21.2.4
|
||||||
%global setuptools_version 57.4.0
|
%global setuptools_version 58.1.0
|
||||||
|
|
||||||
# 00251 # 2eabd04356402d488060bc8fe316ad13fc8a3356
|
# 00251 # 2eabd04356402d488060bc8fe316ad13fc8a3356
|
||||||
# Change user install location
|
# Change user install location
|
||||||
@ -1783,6 +1783,9 @@ CheckPython optimized
|
|||||||
# ======================================================
|
# ======================================================
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 08 2021 Tomáš Hrnčiar <thrnciar@redhat.com> - 3.9.8-1
|
||||||
|
- Update to 3.9.8
|
||||||
|
|
||||||
* Tue Sep 14 2021 Sahana Prasad <sahana@redhat.com> - 3.9.7-2
|
* Tue Sep 14 2021 Sahana Prasad <sahana@redhat.com> - 3.9.7-2
|
||||||
- Rebuilt with OpenSSL 3.0.0
|
- Rebuilt with OpenSSL 3.0.0
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (Python-3.9.7.tar.xz) = 55139776ab58a40f9e1e70613d7071d559ef9e51e32a77791422aac134322c21a49f0348c42813214b69789c589367eae43e16d4ae838a73daf37617e966b735
|
SHA512 (Python-3.9.8.tar.xz) = 5d5b46a242525b2e6a7f9c69c63c6d7cd985e1443a7d9b716107e75f14fef7b5c9c2e5e8a90adbbbf5f7a8b90a483d01e18c1732470e6e54b611b5aba9f99fe1
|
||||||
SHA512 (Python-3.9.7.tar.xz.asc) = 7ff9f845f520efab3b4a0e95da3ffe055ee5777a4173a5b2cc1fd2419dc2b4faf30d1e711e372df36e34bc971ecfcde88a7cd815cfe2d8080ccb575a1ae8e101
|
SHA512 (Python-3.9.8.tar.xz.asc) = 1329a8e114feb010bb3618472cddd9fdea59fc38e9583002eb457e1c0cf1716bd7c0d51887e91b9eef09c3977879aa4be9909e5997be7dfdcca08ca04794bfaf
|
||||||
|
Loading…
Reference in New Issue
Block a user