Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/python3.9.git#8a32dad017ea976df1c1eff8710cf45bf468202c
This commit is contained in:
parent
ce226d00fa
commit
d1b63c87a8
@ -9,7 +9,7 @@ Subject: [PATCH] 00001: Fixup distutils/unixccompiler.py to remove standard
|
||||
1 file changed, 9 insertions(+)
|
||||
|
||||
diff --git a/Lib/distutils/unixccompiler.py b/Lib/distutils/unixccompiler.py
|
||||
index 4d7a6de740..353086a648 100644
|
||||
index f0792de74a..4d837936c6 100644
|
||||
--- a/Lib/distutils/unixccompiler.py
|
||||
+++ b/Lib/distutils/unixccompiler.py
|
||||
@@ -82,6 +82,15 @@ class UnixCCompiler(CCompiler):
|
||||
|
@ -21,7 +21,7 @@ Co-authored-by: Miro Hrončok <miro@hroncok.cz>
|
||||
1 file changed, 2 insertions(+), 19 deletions(-)
|
||||
|
||||
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
||||
index 77f91e72b1..bb4069b18a 100644
|
||||
index f128444b98..22f25e159d 100644
|
||||
--- a/Makefile.pre.in
|
||||
+++ b/Makefile.pre.in
|
||||
@@ -586,7 +586,7 @@ clinic: check-clean-src $(srcdir)/Modules/_blake2/blake2s_impl.c
|
||||
@ -55,7 +55,7 @@ index 77f91e72b1..bb4069b18a 100644
|
||||
$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
|
||||
|
||||
############################################################################
|
||||
@@ -1630,17 +1624,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
||||
@@ -1631,17 +1625,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
||||
else true; \
|
||||
fi; \
|
||||
done
|
||||
|
@ -13,8 +13,8 @@ URL: https://www.python.org/
|
||||
|
||||
# WARNING When rebasing to a new Python version,
|
||||
# remember to update the python3-docs package as well
|
||||
%global general_version %{pybasever}.0
|
||||
#global prerel ...
|
||||
%global general_version %{pybasever}.1
|
||||
%global prerel rc1
|
||||
%global upstream_version %{general_version}%{?prerel}
|
||||
Version: %{general_version}%{?prerel:~%{prerel}}
|
||||
Release: 1%{?dist}
|
||||
@ -237,6 +237,7 @@ BuildRequires: tar
|
||||
BuildRequires: tcl-devel
|
||||
BuildRequires: tix-devel
|
||||
BuildRequires: tk-devel
|
||||
BuildRequires: tzdata
|
||||
|
||||
%if %{with valgrind}
|
||||
BuildRequires: valgrind-devel
|
||||
@ -515,6 +516,9 @@ Recommends: %{pkgname}%{?_isa} = %{version}-%{release}
|
||||
# we recommend it when tk is already installed (for better UX)
|
||||
Recommends: (%{pkgname}-tkinter%{?_isa} = %{version}-%{release} if tk%{?_isa})
|
||||
|
||||
# The zoneinfo module needs tzdata
|
||||
Requires: tzdata
|
||||
|
||||
# https://fedoraproject.org/wiki/Changes/Move_usr_bin_python_into_separate_package
|
||||
# In Fedora 31, several "unversioned" files like /usr/bin/pydoc and all the
|
||||
# "unversioned" provides were moved from python2 to python3.
|
||||
@ -694,6 +698,9 @@ Provides: bundled(python3dist(pip)) = %{pip_version}
|
||||
Provides: bundled(python3dist(setuptools)) = %{setuptools_version}
|
||||
%endif
|
||||
|
||||
# The zoneinfo module needs tzdata
|
||||
Requires: tzdata
|
||||
|
||||
# The description for the flat package (SRPM and built)
|
||||
%description
|
||||
Python %{pybasever} package for developers.
|
||||
@ -1736,6 +1743,9 @@ CheckPython optimized
|
||||
# ======================================================
|
||||
|
||||
%changelog
|
||||
* Fri Nov 27 2020 Tomas Hrnciar <thrnciar@redhat.com> - 3.9.1~rc1-1
|
||||
- Update to 3.9.1rc1
|
||||
|
||||
* Tue Oct 06 2020 Miro Hrončok <mhroncok@redhat.com> - 3.9.0-1
|
||||
- Update to 3.9.0 final
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (Python-3.9.0.tar.xz) = b141039c9701a8cb0d15cd11a279153077524af4d0599e7d2c7279d4c18d05fda06b33ef82342d875de996c7117b7dc6eb154dc3669d38a1efa99801aeec6c5e
|
||||
SHA512 (Python-3.9.0.tar.xz.asc) = 443ea4135cd30bfed7691d81351900f7e3c2620ca86aa19df3a57d283c440947a952e35ce8b4ba48426c128d80a3502276dd4438203eda1b7eda54da95e292a0
|
||||
SHA512 (Python-3.9.1rc1.tar.xz) = 1e74eb2f2587e9069c01b08370de7bfc41a569c855463f01ea9f6d31dad90f0fab3a6738179513321e8320a45865ee63e61915cd66f5c143165b2db921fe2bde
|
||||
SHA512 (Python-3.9.1rc1.tar.xz.asc) = 3f9e9d50b392a2b4b316d2e874e0be9c37bf60845ae73987d3713e7849554030b4da6917bb6a1c3022681500d8c618d3693b45d63f372528bee60be73746eb42
|
||||
|
Loading…
Reference in New Issue
Block a user