- patch Makefile.pre.in to avoid building static library (patch 6, bug
556092)
This commit is contained in:
parent
6859f23088
commit
aa4aef22cc
50
python-3.1.1-no-static-lib.patch
Normal file
50
python-3.1.1-no-static-lib.patch
Normal file
@ -0,0 +1,50 @@
|
|||||||
|
diff -up Python-3.1.1/Makefile.pre.in.no-static-lib Python-3.1.1/Makefile.pre.in
|
||||||
|
--- Python-3.1.1/Makefile.pre.in.no-static-lib 2010-01-17 15:42:11.945858717 -0500
|
||||||
|
+++ Python-3.1.1/Makefile.pre.in 2010-01-17 16:44:32.788859363 -0500
|
||||||
|
@@ -405,7 +405,7 @@ coverage:
|
||||||
|
|
||||||
|
|
||||||
|
# Build the interpreter
|
||||||
|
-$(BUILDPYTHON): Modules/python.o $(LIBRARY) $(LDLIBRARY)
|
||||||
|
+$(BUILDPYTHON): Modules/python.o $(LDLIBRARY)
|
||||||
|
$(LINKCC) $(LDFLAGS) $(LINKFORSHARED) -o $@ \
|
||||||
|
Modules/python.o \
|
||||||
|
$(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
|
||||||
|
@@ -421,18 +421,6 @@ sharedmods: $(BUILDPYTHON)
|
||||||
|
*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' ./$(BUILDPYTHON) -E $(srcdir)/setup.py build;; \
|
||||||
|
esac
|
||||||
|
|
||||||
|
-# Build static library
|
||||||
|
-# avoid long command lines, same as LIBRARY_OBJS
|
||||||
|
-$(LIBRARY): $(LIBRARY_OBJS)
|
||||||
|
- -rm -f $@
|
||||||
|
- $(AR) $(ARFLAGS) $@ Modules/getbuildinfo.o
|
||||||
|
- $(AR) $(ARFLAGS) $@ $(PARSER_OBJS)
|
||||||
|
- $(AR) $(ARFLAGS) $@ $(OBJECT_OBJS)
|
||||||
|
- $(AR) $(ARFLAGS) $@ $(PYTHON_OBJS)
|
||||||
|
- $(AR) $(ARFLAGS) $@ $(MODULE_OBJS) $(SIGNAL_OBJS)
|
||||||
|
- $(AR) $(ARFLAGS) $@ $(MODOBJS)
|
||||||
|
- $(RANLIB) $@
|
||||||
|
-
|
||||||
|
libpython$(VERSION).so: $(LIBRARY_OBJS)
|
||||||
|
if test $(INSTSONAME) != $(LDLIBRARY); then \
|
||||||
|
$(LDSHARED) $(LDFLAGS) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
|
||||||
|
@@ -973,18 +961,6 @@ libainstall: all
|
||||||
|
else true; \
|
||||||
|
fi; \
|
||||||
|
done
|
||||||
|
- @if test -d $(LIBRARY); then :; else \
|
||||||
|
- if test "$(PYTHONFRAMEWORKDIR)" = no-framework; then \
|
||||||
|
- if test "$(SO)" = .dll; then \
|
||||||
|
- $(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBPL) ; \
|
||||||
|
- else \
|
||||||
|
- $(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
|
||||||
|
- $(RANLIB) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
|
||||||
|
- fi; \
|
||||||
|
- else \
|
||||||
|
- echo Skip install of $(LIBRARY) - use make frameworkinstall; \
|
||||||
|
- fi; \
|
||||||
|
- fi
|
||||||
|
$(INSTALL_DATA) Modules/config.c $(DESTDIR)$(LIBPL)/config.c
|
||||||
|
$(INSTALL_DATA) Modules/python.o $(DESTDIR)$(LIBPL)/python.o
|
||||||
|
$(INSTALL_DATA) $(srcdir)/Modules/config.c.in $(DESTDIR)$(LIBPL)/config.c.in
|
10
python3.spec
10
python3.spec
@ -24,7 +24,7 @@
|
|||||||
Summary: Version 3 of the Python programming language aka Python 3000
|
Summary: Version 3 of the Python programming language aka Python 3000
|
||||||
Name: python3
|
Name: python3
|
||||||
Version: %{pybasever}.1
|
Version: %{pybasever}.1
|
||||||
Release: 16%{?dist}
|
Release: 17%{?dist}
|
||||||
License: Python
|
License: Python
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
Source: http://python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
|
Source: http://python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
|
||||||
@ -69,6 +69,10 @@ Patch5: python-3.1.1-install-tkinter-tests.patch
|
|||||||
# (The resulting test support code is in the tkinter subpackage, but
|
# (The resulting test support code is in the tkinter subpackage, but
|
||||||
# this is not a major problem)
|
# this is not a major problem)
|
||||||
|
|
||||||
|
# Patch the Makefile.pre.in so that the generated Makefile doesn't try to build
|
||||||
|
# a libpythonMAJOR.MINOR.a (bug 550692):
|
||||||
|
Patch6: python-3.1.1-no-static-lib.patch
|
||||||
|
|
||||||
Patch102: python-3.1.1-lib64.patch
|
Patch102: python-3.1.1-lib64.patch
|
||||||
|
|
||||||
# http://bugs.python.org/issue6999 -- fixed in r75062
|
# http://bugs.python.org/issue6999 -- fixed in r75062
|
||||||
@ -163,6 +167,7 @@ done
|
|||||||
%patch3 -p1 -b .remove-mimeaudio-tests
|
%patch3 -p1 -b .remove-mimeaudio-tests
|
||||||
%patch4 -p1 -b .apply-our-changes-to-expected-shebang
|
%patch4 -p1 -b .apply-our-changes-to-expected-shebang
|
||||||
%patch5 -p1 -b .install-tkinter-tests
|
%patch5 -p1 -b .install-tkinter-tests
|
||||||
|
%patch6 -p1 -b .no-static-lib
|
||||||
|
|
||||||
%if "%{_lib}" == "lib64"
|
%if "%{_lib}" == "lib64"
|
||||||
%patch102 -p1 -b .lib64
|
%patch102 -p1 -b .lib64
|
||||||
@ -492,6 +497,9 @@ rm -fr $RPM_BUILD_ROOT
|
|||||||
%{pylibdir}/tkinter/test
|
%{pylibdir}/tkinter/test
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Jan 17 2010 David Malcolm <dmalcolm@redhat.com> - 3.1.1-17
|
||||||
|
- patch Makefile.pre.in to avoid building static library (patch 6, bug 556092)
|
||||||
|
|
||||||
* Fri Jan 15 2010 David Malcolm <dmalcolm@redhat.com> - 3.1.1-16
|
* Fri Jan 15 2010 David Malcolm <dmalcolm@redhat.com> - 3.1.1-16
|
||||||
- use the %%{_isa} macro to ensure that the python-devel dependency on python
|
- use the %%{_isa} macro to ensure that the python-devel dependency on python
|
||||||
is for the correct multilib arch (#555943)
|
is for the correct multilib arch (#555943)
|
||||||
|
Loading…
Reference in New Issue
Block a user