- Fix an incompatibility between pyexpat and the system expat-2.0.1 that
led to a segfault running test_pyexpat.py (patch 110; upstream issue 9054; rhbz#610312)
This commit is contained in:
parent
5c9590b543
commit
03b7fb2d62
14
python-3.1.2-fix-expat-issue9054.patch
Normal file
14
python-3.1.2-fix-expat-issue9054.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
Index: Modules/pyexpat.c
|
||||||
|
===================================================================
|
||||||
|
--- Modules/pyexpat.c (revision 81539)
|
||||||
|
+++ Modules/pyexpat.c (working copy)
|
||||||
|
@@ -415,6 +415,9 @@
|
||||||
|
PyObject *args;
|
||||||
|
PyObject *temp;
|
||||||
|
|
||||||
|
+ if (!have_handler(self, CharacterData))
|
||||||
|
+ return -1;
|
||||||
|
+
|
||||||
|
args = PyTuple_New(1);
|
||||||
|
if (args == NULL)
|
||||||
|
return -1;
|
13
python3.spec
13
python3.spec
@ -40,7 +40,7 @@
|
|||||||
Summary: Version 3 of the Python programming language aka Python 3000
|
Summary: Version 3 of the Python programming language aka Python 3000
|
||||||
Name: python3
|
Name: python3
|
||||||
Version: %{pybasever}.2
|
Version: %{pybasever}.2
|
||||||
Release: 10%{?dist}
|
Release: 11%{?dist}
|
||||||
License: Python
|
License: Python
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
Source: http://python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
|
Source: http://python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
|
||||||
@ -219,6 +219,11 @@ Patch108: python-3.1.2-CVE-2010-2089.patch
|
|||||||
# the old layout before the whitespace cleanup of release31-maint in r81033):
|
# the old layout before the whitespace cleanup of release31-maint in r81033):
|
||||||
Patch109: python-3.1.2-CVE-2008-5983.patch
|
Patch109: python-3.1.2-CVE-2008-5983.patch
|
||||||
|
|
||||||
|
# Fix an incompatibility between pyexpat and the system expat-2.0.1 that led to
|
||||||
|
# a segfault running test_pyexpat.py (rhbz:610312)
|
||||||
|
# Sent upstream as http://bugs.python.org/issue9054
|
||||||
|
Patch110: python-3.1.2-fix-expat-issue9054.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
BuildRequires: readline-devel, openssl-devel, gmp-devel
|
BuildRequires: readline-devel, openssl-devel, gmp-devel
|
||||||
BuildRequires: ncurses-devel, gdbm-devel, zlib-devel, expat-devel
|
BuildRequires: ncurses-devel, gdbm-devel, zlib-devel, expat-devel
|
||||||
@ -377,6 +382,8 @@ rm -r Modules/zlib || exit 1
|
|||||||
%patch108 -p1 -b .CVE-2010-2089
|
%patch108 -p1 -b .CVE-2010-2089
|
||||||
%patch109 -p1 -b .CVE-2008-5983
|
%patch109 -p1 -b .CVE-2008-5983
|
||||||
|
|
||||||
|
%patch110 -p0 -b .fix-expat-issue9054
|
||||||
|
|
||||||
# Currently (2010-01-15), http://docs.python.org/library is for 2.6, and there
|
# Currently (2010-01-15), http://docs.python.org/library is for 2.6, and there
|
||||||
# are many differences between 2.6 and the Python 3 library.
|
# are many differences between 2.6 and the Python 3 library.
|
||||||
#
|
#
|
||||||
@ -1057,6 +1064,10 @@ rm -fr %{buildroot}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 2 2010 David Malcolm <dmalcolm@redhat.com> - 3.1.2-11
|
||||||
|
- Fix an incompatibility between pyexpat and the system expat-2.0.1 that led to
|
||||||
|
a segfault running test_pyexpat.py (patch 110; upstream issue 9054; rhbz#610312)
|
||||||
|
|
||||||
* Fri Jun 4 2010 David Malcolm <dmalcolm@redhat.com> - 3.1.2-10
|
* Fri Jun 4 2010 David Malcolm <dmalcolm@redhat.com> - 3.1.2-10
|
||||||
- ensure that the compiler is invoked with "-fwrapv" (rhbz#594819)
|
- ensure that the compiler is invoked with "-fwrapv" (rhbz#594819)
|
||||||
- reformat whitespace in audioop.c (patch 106)
|
- reformat whitespace in audioop.c (patch 106)
|
||||||
|
Loading…
Reference in New Issue
Block a user