34 lines
696 B
Diff
34 lines
696 B
Diff
From e5c0583e1a92932322f721825a6812c74df8ba28 Mon Sep 17 00:00:00 2001
|
|
From: Karolina Surma <ksurma@redhat.com>
|
|
Date: Fri, 20 Oct 2023 14:23:47 +0200
|
|
Subject: [PATCH] Prevent circular dependency with Sphinx
|
|
|
|
---
|
|
pyproject.toml | 4 +---
|
|
1 file changed, 1 insertion(+), 3 deletions(-)
|
|
|
|
diff --git a/pyproject.toml b/pyproject.toml
|
|
index d704e4e..0f9680f 100644
|
|
--- a/pyproject.toml
|
|
+++ b/pyproject.toml
|
|
@@ -39,15 +39,13 @@ classifiers = [
|
|
"Topic :: Text Processing",
|
|
"Topic :: Utilities",
|
|
]
|
|
-dependencies = [
|
|
- "Sphinx>=5",
|
|
-]
|
|
dynamic = ["version"]
|
|
|
|
[project.optional-dependencies]
|
|
test = [
|
|
"pytest",
|
|
"html5lib",
|
|
+ "Sphinx",
|
|
]
|
|
lint = [
|
|
"flake8",
|
|
--
|
|
2.41.0
|
|
|