Update to 2.0.4
This commit is contained in:
parent
1a64728bbd
commit
dbc63ca3dc
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
/sphinxcontrib-htmlhelp-*.tar.gz
|
||||
/sphinxcontrib_htmlhelp-*.tar.gz
|
||||
|
33
Prevent-circular-dependency-with-Sphinx.patch
Normal file
33
Prevent-circular-dependency-with-Sphinx.patch
Normal file
@ -0,0 +1,33 @@
|
||||
From e5c0583e1a92932322f721825a6812c74df8ba28 Mon Sep 17 00:00:00 2001
|
||||
From: Karolina Surma <ksurma@redhat.com>
|
||||
Date: Fri, 20 Oct 2023 14:23:47 +0200
|
||||
Subject: [PATCH] Prevent circular dependency with Sphinx
|
||||
|
||||
---
|
||||
pyproject.toml | 4 +---
|
||||
1 file changed, 1 insertion(+), 3 deletions(-)
|
||||
|
||||
diff --git a/pyproject.toml b/pyproject.toml
|
||||
index d704e4e..0f9680f 100644
|
||||
--- a/pyproject.toml
|
||||
+++ b/pyproject.toml
|
||||
@@ -39,15 +39,13 @@ classifiers = [
|
||||
"Topic :: Text Processing",
|
||||
"Topic :: Utilities",
|
||||
]
|
||||
-dependencies = [
|
||||
- "Sphinx>=5",
|
||||
-]
|
||||
dynamic = ["version"]
|
||||
|
||||
[project.optional-dependencies]
|
||||
test = [
|
||||
"pytest",
|
||||
"html5lib",
|
||||
+ "Sphinx",
|
||||
]
|
||||
lint = [
|
||||
"flake8",
|
||||
--
|
||||
2.41.0
|
||||
|
@ -6,27 +6,27 @@
|
||||
%bcond tests %[%{with check} && %{undefined rhel}]
|
||||
|
||||
Name: python-%{pypi_name}
|
||||
Version: 2.0.3
|
||||
Version: 2.0.4
|
||||
Release: 1%{?dist}
|
||||
Summary: Sphinx extension for HTML help files
|
||||
License: BSD-2-Clause
|
||||
URL: http://sphinx-doc.org/
|
||||
Source0: %{pypi_source}
|
||||
Source0: %{pypi_source sphinxcontrib_htmlhelp}
|
||||
BuildArch: noarch
|
||||
|
||||
# Sphinx requires sphinxcontrib-* packages, they've started requiring Sphinx
|
||||
# In the RPM environment the dependencies are handled correctly without it
|
||||
# Remove the runtime requirement on Sphinx from this package
|
||||
# See: https://github.com/sphinx-doc/sphinx/issues/11567
|
||||
# At the same time, Sphinx is a wanted test dependency
|
||||
Patch: Prevent-circular-dependency-with-Sphinx.patch
|
||||
|
||||
BuildRequires: gettext
|
||||
BuildRequires: python%{python3_pkgversion}-devel
|
||||
|
||||
%if %{with check}
|
||||
BuildRequires: python%{python3_pkgversion}-sphinx >= 1:2
|
||||
%if %{with tests}
|
||||
BuildRequires: python%{python3_pkgversion}-pytest
|
||||
BuildRequires: python%{python3_pkgversion}-html5lib
|
||||
%endif
|
||||
%endif
|
||||
|
||||
%generate_buildrequires
|
||||
%pyproject_buildrequires
|
||||
%pyproject_buildrequires %{?with_tests: -x test}
|
||||
|
||||
|
||||
%description
|
||||
@ -42,7 +42,7 @@ sphinxcontrib-htmlhelp is a sphinx extension which renders HTML help files.
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -p1 -n %{pypi_name}-%{version}
|
||||
%autosetup -p1 -n sphinxcontrib_htmlhelp-%{version}
|
||||
find -name '*.mo' -delete
|
||||
|
||||
|
||||
@ -89,6 +89,10 @@ popd
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Aug 24 2023 Karolina Surma <ksurma@redhat.com> - 2.0.4-1
|
||||
- update to 2.0.4
|
||||
Resolves: rhbz#2231932
|
||||
|
||||
* Fri Aug 11 2023 Tom Callaway <spot@fedoraproject.org> - 2.0.3-1
|
||||
- update to 2.0.3
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (sphinxcontrib-htmlhelp-2.0.3.tar.gz) = b405d222eaf07974fafee6cf2e20dc2dbdfe076b4fb63ac159402ad6198bccb53a23b3761bed958fa8269624d447950c27f59adfa31e6a072efb1a625f759487
|
||||
SHA512 (sphinxcontrib_htmlhelp-2.0.4.tar.gz) = 5f1c4619b986060fb6213e23b5339b7b5d57abdb8f6034473116c9ea7c3d04cf0985115141c5325cb93bac330eb6109d2e81327f53fda78838c9ed5435469b29
|
||||
|
Loading…
Reference in New Issue
Block a user