python-sphinxcontrib-htmlhelp was removed due to minimization efforts prior to public launch
This commit is contained in:
parent
a10ab05c9c
commit
c7bc641025
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +0,0 @@
|
||||
/sphinxcontrib-htmlhelp-*.tar.gz
|
||||
/sphinxcontrib_htmlhelp-*.tar.gz
|
31
16.patch
31
16.patch
@ -1,31 +0,0 @@
|
||||
From 248ff52b3c3d39c20cdaef3052ac7507a407733a Mon Sep 17 00:00:00 2001
|
||||
From: Takeshi KOMIYA <i.tkomiya@gmail.com>
|
||||
Date: Sat, 17 Jul 2021 18:55:20 +0900
|
||||
Subject: [PATCH] Fix #9457: RemovedInSphinx50Warning on testing
|
||||
|
||||
---
|
||||
tests/test_htmlhelp.py | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/tests/test_htmlhelp.py b/tests/test_htmlhelp.py
|
||||
index a74c66a..8774d4b 100644
|
||||
--- a/tests/test_htmlhelp.py
|
||||
+++ b/tests/test_htmlhelp.py
|
||||
@@ -21,7 +21,7 @@
|
||||
def test_build_htmlhelp(app, status, warning):
|
||||
app.build()
|
||||
|
||||
- hhp = (app.outdir / 'pythondoc.hhp').text()
|
||||
+ hhp = (app.outdir / 'pythondoc.hhp').read_text()
|
||||
assert 'Compiled file=pythondoc.chm' in hhp
|
||||
assert 'Contents file=pythondoc.hhc' in hhp
|
||||
assert 'Default Window=pythondoc' in hhp
|
||||
@@ -84,7 +84,7 @@ def assert_sitemap(node, name, filename):
|
||||
assert node[1].attrib == {'name': 'Local', 'value': filename}
|
||||
|
||||
# .hhc file
|
||||
- hhc = (app.outdir / 'pythondoc.hhc').text()
|
||||
+ hhc = (app.outdir / 'pythondoc.hhc').read_text()
|
||||
tree = HTMLParser(namespaceHTMLElements=False).parse(hhc)
|
||||
items = tree.find('.//body/ul')
|
||||
assert len(items) == 4
|
@ -1,3 +0,0 @@
|
||||
# python-sphinxcontrib-htmlhelp
|
||||
|
||||
The python-sphinxcontrib-htmlhelp package
|
1
dead.package
Normal file
1
dead.package
Normal file
@ -0,0 +1 @@
|
||||
python-sphinxcontrib-htmlhelp was removed due to minimization efforts prior to public launch
|
@ -1,163 +0,0 @@
|
||||
# RHEL does not include html5lib, without which the tests fail
|
||||
%bcond tests %{undefined rhel}
|
||||
|
||||
Name: python-sphinxcontrib-htmlhelp
|
||||
Version: 2.0.4
|
||||
Release: 2%{?dist}
|
||||
Summary: Sphinx extension for HTML help files
|
||||
License: BSD-2-Clause
|
||||
URL: http://sphinx-doc.org/
|
||||
Source: %{pypi_source sphinxcontrib_htmlhelp}
|
||||
BuildArch: noarch
|
||||
|
||||
BuildRequires: gettext
|
||||
BuildRequires: python%{python3_pkgversion}-devel
|
||||
|
||||
|
||||
%description
|
||||
sphinxcontrib-htmlhelp is a sphinx extension which renders HTML help files.
|
||||
|
||||
|
||||
%package -n python%{python3_pkgversion}-sphinxcontrib-htmlhelp
|
||||
Summary: %{summary}
|
||||
|
||||
%description -n python%{python3_pkgversion}-sphinxcontrib-htmlhelp
|
||||
sphinxcontrib-htmlhelp is a sphinx extension which renders HTML help files.
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -p1 -n sphinxcontrib_htmlhelp-%{version}
|
||||
find -name '*.mo' -delete
|
||||
|
||||
|
||||
%generate_buildrequires
|
||||
%pyproject_buildrequires %{?with_tests: -x test}
|
||||
|
||||
|
||||
%build
|
||||
for po in $(find -name '*.po'); do
|
||||
msgfmt --output-file=${po%.po}.mo ${po}
|
||||
done
|
||||
%pyproject_wheel
|
||||
|
||||
|
||||
%install
|
||||
%pyproject_install
|
||||
|
||||
# Move language files to /usr/share
|
||||
pushd %{buildroot}%{python3_sitelib}
|
||||
for lang in `find sphinxcontrib/htmlhelp/locales -maxdepth 1 -mindepth 1 -type d -not -path '*/\.*' -printf "%f "`;
|
||||
do
|
||||
test $lang == __pycache__ && continue
|
||||
install -d %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES
|
||||
mv sphinxcontrib/htmlhelp/locales/$lang/LC_MESSAGES/*.mo %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/
|
||||
done
|
||||
rm -rf sphinxcontrib/htmlhelp/locales
|
||||
ln -s %{_datadir}/locale sphinxcontrib/htmlhelp/locales
|
||||
popd
|
||||
|
||||
|
||||
%find_lang sphinxcontrib.htmlhelp
|
||||
|
||||
|
||||
%check
|
||||
%py3_check_import sphinxcontrib.htmlhelp
|
||||
%if %{with tests}
|
||||
%{__python3} -m pytest
|
||||
%endif
|
||||
|
||||
|
||||
%files -n python%{python3_pkgversion}-sphinxcontrib-htmlhelp -f sphinxcontrib.htmlhelp.lang
|
||||
%license LICENSE
|
||||
%doc README.rst
|
||||
%{python3_sitelib}/sphinxcontrib/
|
||||
%{python3_sitelib}/sphinxcontrib_htmlhelp*.dist-info
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Nov 16 2023 Miro Hrončok <mhroncok@redhat.com> - 2.0.4-2
|
||||
- Remove a patch to drop the runtime dependency on Sphinx
|
||||
- It is no longer needed, python3-sphinx-7.2.6-2+ no longer Requires this
|
||||
|
||||
* Thu Aug 24 2023 Karolina Surma <ksurma@redhat.com> - 2.0.4-1
|
||||
- update to 2.0.4
|
||||
Resolves: rhbz#2231932
|
||||
|
||||
* Fri Aug 11 2023 Tom Callaway <spot@fedoraproject.org> - 2.0.3-1
|
||||
- update to 2.0.3
|
||||
|
||||
* Thu Aug 10 2023 Karolina Surma <ksurma@redhat.com> - 2.0.0-12
|
||||
- Declare the license as an SPDX expression
|
||||
|
||||
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Fri Jun 16 2023 Python Maint <python-maint@redhat.com> - 2.0.0-10
|
||||
- Rebuilt for Python 3.12
|
||||
|
||||
* Tue Jun 13 2023 Python Maint <python-maint@redhat.com> - 2.0.0-9
|
||||
- Bootstrap for Python 3.12
|
||||
|
||||
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Thu Jul 07 2022 Karolina Surma <ksurma@redhat.com> - 2.0.0-6
|
||||
- Fix compatibility with Sphinx 5
|
||||
|
||||
* Mon Jun 13 2022 Python Maint <python-maint@redhat.com> - 2.0.0-5
|
||||
- Rebuilt for Python 3.11
|
||||
|
||||
* Mon Jun 13 2022 Python Maint <python-maint@redhat.com> - 2.0.0-4
|
||||
- Bootstrap for Python 3.11
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Fri Jun 11 2021 Karolina Surma <ksurma@redhat.com> - 2.0.0-1
|
||||
- Update to 2.0.0
|
||||
Resolves: rhbz#1963358
|
||||
|
||||
* Thu Jun 03 2021 Python Maint <python-maint@redhat.com> - 1.0.3-5
|
||||
- Rebuilt for Python 3.10
|
||||
|
||||
* Wed Jun 02 2021 Python Maint <python-maint@redhat.com> - 1.0.3-4
|
||||
- Bootstrap for Python 3.10
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Thu Jun 04 2020 Charalampos Stratakis <cstratak@redhat.com> - 1.0.3-1
|
||||
- Update to 1.0.3 (#1699073)
|
||||
|
||||
* Sat May 23 2020 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-8
|
||||
- Rebuilt for Python 3.9
|
||||
|
||||
* Fri May 22 2020 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-7
|
||||
- Bootstrap for Python 3.9
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-5
|
||||
- Rebuilt for Python 3.8.0rc1 (#1748018)
|
||||
|
||||
* Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-4
|
||||
- Rebuilt for Python 3.8
|
||||
|
||||
* Thu Aug 15 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-3
|
||||
- Bootstrap for Python 3.8
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri Mar 01 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-1
|
||||
- Initial package
|
Loading…
Reference in New Issue
Block a user