Remove a patch to drop the runtime dependency on Sphinx
It is no longer needed, python3-sphinx-7.2.6-2+ no longer Requires this
This commit is contained in:
parent
2d8a61f736
commit
a10ab05c9c
@ -1,33 +0,0 @@
|
||||
From e5c0583e1a92932322f721825a6812c74df8ba28 Mon Sep 17 00:00:00 2001
|
||||
From: Karolina Surma <ksurma@redhat.com>
|
||||
Date: Fri, 20 Oct 2023 14:23:47 +0200
|
||||
Subject: [PATCH] Prevent circular dependency with Sphinx
|
||||
|
||||
---
|
||||
pyproject.toml | 4 +---
|
||||
1 file changed, 1 insertion(+), 3 deletions(-)
|
||||
|
||||
diff --git a/pyproject.toml b/pyproject.toml
|
||||
index d704e4e..0f9680f 100644
|
||||
--- a/pyproject.toml
|
||||
+++ b/pyproject.toml
|
||||
@@ -39,15 +39,13 @@ classifiers = [
|
||||
"Topic :: Text Processing",
|
||||
"Topic :: Utilities",
|
||||
]
|
||||
-dependencies = [
|
||||
- "Sphinx>=5",
|
||||
-]
|
||||
dynamic = ["version"]
|
||||
|
||||
[project.optional-dependencies]
|
||||
test = [
|
||||
"pytest",
|
||||
"html5lib",
|
||||
+ "Sphinx",
|
||||
]
|
||||
lint = [
|
||||
"flake8",
|
||||
--
|
||||
2.41.0
|
||||
|
@ -1,24 +1,15 @@
|
||||
# when bootstrapping sphinx, we cannot even run an import check
|
||||
%bcond check 1
|
||||
# RHEL does not include html5lib, without which the tests fail
|
||||
%bcond tests %[%{with check} && %{undefined rhel}]
|
||||
%bcond tests %{undefined rhel}
|
||||
|
||||
Name: python-sphinxcontrib-htmlhelp
|
||||
Version: 2.0.4
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Sphinx extension for HTML help files
|
||||
License: BSD-2-Clause
|
||||
URL: http://sphinx-doc.org/
|
||||
Source: %{pypi_source sphinxcontrib_htmlhelp}
|
||||
BuildArch: noarch
|
||||
|
||||
# Sphinx requires sphinxcontrib-* packages, they've started requiring Sphinx
|
||||
# In the RPM environment the dependencies are handled correctly without it
|
||||
# Remove the runtime requirement on Sphinx from this package
|
||||
# See: https://github.com/sphinx-doc/sphinx/issues/11567
|
||||
# At the same time, Sphinx is a wanted test dependency
|
||||
Patch: Prevent-circular-dependency-with-Sphinx.patch
|
||||
|
||||
BuildRequires: gettext
|
||||
BuildRequires: python%{python3_pkgversion}-devel
|
||||
|
||||
@ -69,13 +60,11 @@ popd
|
||||
%find_lang sphinxcontrib.htmlhelp
|
||||
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%py3_check_import sphinxcontrib.htmlhelp
|
||||
%if %{with tests}
|
||||
%{__python3} -m pytest
|
||||
%endif
|
||||
%endif
|
||||
|
||||
|
||||
%files -n python%{python3_pkgversion}-sphinxcontrib-htmlhelp -f sphinxcontrib.htmlhelp.lang
|
||||
@ -86,6 +75,10 @@ popd
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Nov 16 2023 Miro Hrončok <mhroncok@redhat.com> - 2.0.4-2
|
||||
- Remove a patch to drop the runtime dependency on Sphinx
|
||||
- It is no longer needed, python3-sphinx-7.2.6-2+ no longer Requires this
|
||||
|
||||
* Thu Aug 24 2023 Karolina Surma <ksurma@redhat.com> - 2.0.4-1
|
||||
- update to 2.0.4
|
||||
Resolves: rhbz#2231932
|
||||
|
Loading…
Reference in New Issue
Block a user