Update to 1.0.5

Upstream changed the build backend to flit, hence the migration to
pyproject macros as a part of the update.
This commit is contained in:
Karolina Surma 2023-08-22 15:11:39 +02:00
parent 6094bcd72c
commit e215bdcbb5
4 changed files with 55 additions and 14 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
/sphinxcontrib-devhelp-*.tar.gz /sphinxcontrib-devhelp-*.tar.gz
/sphinxcontrib_devhelp-*.tar.gz

View File

@ -0,0 +1,32 @@
From e680b4403819e0afbf5bef6a95227899cade6ae9 Mon Sep 17 00:00:00 2001
From: Karolina Surma <ksurma@redhat.com>
Date: Fri, 20 Oct 2023 14:03:31 +0200
Subject: [PATCH] Prevent circular dependency with Sphinx
---
pyproject.toml | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/pyproject.toml b/pyproject.toml
index a8cbb00..6518bb6 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -39,14 +39,12 @@ classifiers = [
"Topic :: Text Processing",
"Topic :: Utilities",
]
-dependencies = [
- "Sphinx>=5",
-]
dynamic = ["version"]
[project.optional-dependencies]
test = [
"pytest",
+ "Sphinx",
]
lint = [
"flake8",
--
2.41.0

View File

@ -4,22 +4,23 @@
%bcond_without check %bcond_without check
Name: python-%{pypi_name} Name: python-%{pypi_name}
Version: 1.0.2 Version: 1.0.5
Release: 15%{?dist} Release: 1%{?dist}
Summary: Sphinx extension for Devhelp documents Summary: Sphinx extension for Devhelp documents
License: BSD-2-Clause License: BSD-2-Clause
URL: http://sphinx-doc.org/ URL: http://sphinx-doc.org/
Source0: %{pypi_source} Source0: %{pypi_source sphinxcontrib_devhelp}
BuildArch: noarch BuildArch: noarch
# Sphinx requires sphinxcontrib-* packages, they've started requiring Sphinx
# In the RPM environment the dependencies are handled correctly without it
# Remove the runtime requirement on Sphinx from this package
# See: https://github.com/sphinx-doc/sphinx/issues/11567
Patch: Prevent-circular-dependency-with-Sphinx.patch
BuildRequires: gettext BuildRequires: gettext
BuildRequires: python%{python3_pkgversion}-devel BuildRequires: python%{python3_pkgversion}-devel
BuildRequires: python%{python3_pkgversion}-setuptools
%if %{with check}
BuildRequires: python%{python3_pkgversion}-pytest
BuildRequires: python%{python3_pkgversion}-sphinx >= 1:2
%endif
%description %description
sphinxcontrib-devhelp is a sphinx extension which outputs Devhelp document. sphinxcontrib-devhelp is a sphinx extension which outputs Devhelp document.
@ -33,8 +34,12 @@ Summary: %{summary}
sphinxcontrib-devhelp is a sphinx extension which outputs Devhelp document. sphinxcontrib-devhelp is a sphinx extension which outputs Devhelp document.
%generate_buildrequires
%pyproject_buildrequires %{?with_check: -x test}
%prep %prep
%autosetup -n %{pypi_name}-%{version} %autosetup -n sphinxcontrib_devhelp-%{version}
find -name '*.mo' -delete find -name '*.mo' -delete
@ -42,11 +47,11 @@ find -name '*.mo' -delete
for po in $(find -name '*.po'); do for po in $(find -name '*.po'); do
msgfmt --output-file=${po%.po}.mo ${po} msgfmt --output-file=${po%.po}.mo ${po}
done done
%py3_build %pyproject_wheel
%install %install
%py3_install %pyproject_install
# Move language files to /usr/share # Move language files to /usr/share
pushd %{buildroot}%{python3_sitelib} pushd %{buildroot}%{python3_sitelib}
@ -74,11 +79,14 @@ popd
%license LICENSE %license LICENSE
%doc README.rst %doc README.rst
%{python3_sitelib}/sphinxcontrib/ %{python3_sitelib}/sphinxcontrib/
%{python3_sitelib}/sphinxcontrib_devhelp-%{version}-py%{python3_version}-*.pth %{python3_sitelib}/sphinxcontrib_devhelp-%{version}.dist-info/
%{python3_sitelib}/sphinxcontrib_devhelp-%{version}-py%{python3_version}.egg-info/
%changelog %changelog
* Mon Aug 21 2023 Karolina Surma <ksurma@redhat.com> - 1.0.5-1
- Update to 1.0.5
Fixes: rhbz#2230147
* Wed Aug 09 2023 Karolina Surma <ksurma@redhat.com> - 1.0.2-15 * Wed Aug 09 2023 Karolina Surma <ksurma@redhat.com> - 1.0.2-15
- Declare the license as an SPDX expression - Declare the license as an SPDX expression

View File

@ -1 +1 @@
SHA512 (sphinxcontrib-devhelp-1.0.2.tar.gz) = 83b46eaf26df3932ea2136cfda1c0fca4fc08ce8bca564845b3efe5bb00d6c8c93991f4edd4913d4ec796e2d85bd2c7265adf28e98f42e8094daeb5ac11a0eb1 SHA512 (sphinxcontrib_devhelp-1.0.5.tar.gz) = 4412f9711b981c8e3beaa9940c09d02c21dc5e303a0ab80ca401f4cc5444bd159070a065a20c0e6f721202c05d880f20244ca5ff32df5911c8a4ba3d00ed9121