Upstream changed the build backend to flit, hence the migration to pyproject macros as a part of the update.
33 lines
679 B
Diff
33 lines
679 B
Diff
From e680b4403819e0afbf5bef6a95227899cade6ae9 Mon Sep 17 00:00:00 2001
|
|
From: Karolina Surma <ksurma@redhat.com>
|
|
Date: Fri, 20 Oct 2023 14:03:31 +0200
|
|
Subject: [PATCH] Prevent circular dependency with Sphinx
|
|
|
|
---
|
|
pyproject.toml | 4 +---
|
|
1 file changed, 1 insertion(+), 3 deletions(-)
|
|
|
|
diff --git a/pyproject.toml b/pyproject.toml
|
|
index a8cbb00..6518bb6 100644
|
|
--- a/pyproject.toml
|
|
+++ b/pyproject.toml
|
|
@@ -39,14 +39,12 @@ classifiers = [
|
|
"Topic :: Text Processing",
|
|
"Topic :: Utilities",
|
|
]
|
|
-dependencies = [
|
|
- "Sphinx>=5",
|
|
-]
|
|
dynamic = ["version"]
|
|
|
|
[project.optional-dependencies]
|
|
test = [
|
|
"pytest",
|
|
+ "Sphinx",
|
|
]
|
|
lint = [
|
|
"flake8",
|
|
--
|
|
2.41.0
|
|
|