- Update to 1.0 beta 1
This commit is contained in:
parent
e361c26ece
commit
140b900b5c
@ -1 +1 @@
|
||||
Sphinx-0.6.5.tar.gz
|
||||
Sphinx-1.0b1.tar.gz
|
||||
|
@ -1,56 +0,0 @@
|
||||
# HG changeset patch
|
||||
# Parent 552e51b26229a9a918c76a401f2f487bf81f2ee6
|
||||
|
||||
Index: Sphinx-0.6.5/sphinx/builders/html.py
|
||||
===================================================================
|
||||
--- Sphinx-0.6.5.orig/sphinx/builders/html.py
|
||||
+++ Sphinx-0.6.5/sphinx/builders/html.py
|
||||
@@ -10,6 +10,7 @@
|
||||
"""
|
||||
|
||||
import os
|
||||
+import sys
|
||||
import codecs
|
||||
import posixpath
|
||||
import cPickle as pickle
|
||||
@@ -91,10 +92,15 @@ class StandaloneHTMLBuilder(Builder):
|
||||
self.link_suffix = self.out_suffix
|
||||
|
||||
if self.config.language is not None:
|
||||
- jsfile = path.join(package_dir, 'locale', self.config.language,
|
||||
- 'LC_MESSAGES', 'sphinx.js')
|
||||
- if path.isfile(jsfile):
|
||||
- self.script_files.append('_static/translations.js')
|
||||
+ jsfile_list = [path.join(package_dir, 'locale',
|
||||
+ self.config.language, 'LC_MESSAGES', 'sphinx.js'),
|
||||
+ path.join(sys.prefix, 'share/sphinx/locale',
|
||||
+ self.config.language, 'sphinx.js')]
|
||||
+
|
||||
+ for jsfile in jsfile_list:
|
||||
+ if path.isfile(jsfile):
|
||||
+ self.script_files.append('_static/translations.js')
|
||||
+ break
|
||||
|
||||
def init_templates(self):
|
||||
Theme.init_themes(self)
|
||||
@@ -528,11 +534,15 @@ class StandaloneHTMLBuilder(Builder):
|
||||
f.close()
|
||||
# then, copy translations JavaScript file
|
||||
if self.config.language is not None:
|
||||
- jsfile = path.join(package_dir, 'locale', self.config.language,
|
||||
- 'LC_MESSAGES', 'sphinx.js')
|
||||
- if path.isfile(jsfile):
|
||||
- copyfile(jsfile, path.join(self.outdir, '_static',
|
||||
- 'translations.js'))
|
||||
+ jsfile_list = [path.join(package_dir, 'locale',
|
||||
+ self.config.language, 'LC_MESSAGES', 'sphinx.js'),
|
||||
+ path.join(sys.prefix, 'share/sphinx/locale',
|
||||
+ self.config.language, 'sphinx.js')]
|
||||
+ for jsfile in jsfile_list:
|
||||
+ if path.isfile(jsfile):
|
||||
+ copyfile(jsfile, path.join(self.outdir, '_static',
|
||||
+ 'translations.js'))
|
||||
+ break
|
||||
# then, copy over all user-supplied static files
|
||||
if self.theme:
|
||||
staticdirnames = [path.join(themepath, 'static')
|
@ -1,24 +0,0 @@
|
||||
# HG changeset patch
|
||||
# Parent 5da6d572bd088b04711b3bf70991c976d8f9c605
|
||||
|
||||
Index: Sphinx-0.6.5/setup.py
|
||||
===================================================================
|
||||
--- Sphinx-0.6.5.orig/setup.py
|
||||
+++ Sphinx-0.6.5/setup.py
|
||||
@@ -1,10 +1,13 @@
|
||||
# -*- coding: utf-8 -*-
|
||||
-import ez_setup
|
||||
-ez_setup.use_setuptools()
|
||||
+try:
|
||||
+ from setuptools import setup, find_packages
|
||||
+except ImportError:
|
||||
+ import ez_setup
|
||||
+ ez_setup.use_setuptools()
|
||||
+ from setuptools import setup, find_packages
|
||||
|
||||
import os
|
||||
import sys
|
||||
-from setuptools import setup, find_packages
|
||||
from distutils import log
|
||||
|
||||
import sphinx
|
@ -3,18 +3,17 @@
|
||||
%endif
|
||||
|
||||
%global upstream_name Sphinx
|
||||
%global prerel b1
|
||||
|
||||
Name: python-sphinx
|
||||
Version: 0.6.5
|
||||
Release: 2%{?dist}
|
||||
Version: 1.0
|
||||
Release: %{?prerel:0.}1.%{?prerel}%{?dist}
|
||||
Summary: Python documentation generator
|
||||
|
||||
Group: Development/Tools
|
||||
License: BSD
|
||||
URL: http://sphinx.pocoo.org/
|
||||
Source0: http://pypi.python.org/packages/source/S/%{upstream_name}/%{upstream_name}-%{version}.tar.gz
|
||||
Patch0: %{name}-0.6.5_setuptools.patch
|
||||
Patch1: %{name}-0.6.5_move_locale_files_outside_sitelib.patch
|
||||
Source0: http://pypi.python.org/packages/source/S/%{upstream_name}/%{upstream_name}-%{version}%{?prerel}.tar.gz
|
||||
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
BuildArch: noarch
|
||||
@ -76,10 +75,7 @@ This package contains documentation in reST and HTML formats.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n %{upstream_name}-%{version}
|
||||
%patch0 -p1 -b .setuptools
|
||||
%patch1 -p1 -b .language_files
|
||||
|
||||
%setup -q -n %{upstream_name}-%{version}%{?prerel}
|
||||
sed '1d' -i sphinx/pycode/pgen2/token.py
|
||||
|
||||
%build
|
||||
@ -98,11 +94,12 @@ rm -rf %{buildroot}
|
||||
%{__python} setup.py install --skip-build --root %{buildroot}
|
||||
|
||||
|
||||
pushd doc
|
||||
# Manpages not in beta release yet
|
||||
#pushd doc
|
||||
# Deliver man pages
|
||||
install -d %{buildroot}%{_mandir}/man1
|
||||
mv sphinx-*.1 %{buildroot}%{_mandir}/man1/
|
||||
popd
|
||||
#install -d %{buildroot}%{_mandir}/man1
|
||||
#mv sphinx-*.1 %{buildroot}%{_mandir}/man1/
|
||||
#popd
|
||||
|
||||
# Deliver rst files
|
||||
mv doc reST
|
||||
@ -145,7 +142,7 @@ make test
|
||||
%{python_sitelib}/*
|
||||
%{_datadir}/sphinx/
|
||||
%exclude %{_datadir}/sphinx/locale/*/sphinx.js
|
||||
%{_mandir}/man1/*
|
||||
#%{_mandir}/man1/*
|
||||
|
||||
%files doc
|
||||
%defattr(-,root,root,-)
|
||||
@ -153,6 +150,12 @@ make test
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed May 26 2010 Michel Salim <salimma@fedoraproject.org> - 1.0-0.1.b1
|
||||
- Update to 1.0 beta 1
|
||||
|
||||
* Tue May 25 2010 Michel Salim <salimma@fedoraproject.org> - 0.6.6-1
|
||||
- Update to 0.6.6
|
||||
|
||||
* Fri May 21 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.5-2
|
||||
- Few minor tweaks to Gareth's spec file update
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user