python-sphinx/python-sphinx-0.6.5_setuptools.patch
Toshio くらとみ e361c26ece - Few minor tweaks to Gareth's spec file update
Mon May 10 2010 Gareth Armstrong <gareth.armstrong@hp.com> - 0.6.5-1.hp
- Update to 0.6.5
- Initial import of python-sphinx from Fedora Rawhide for use in HP CMS
- Enforce that Sphinx requires Python 2.4 or later via an explicit BR
- Minor tweaks to spec file
- Move language files to %%{_datadir}, idea borrowed from Debian's sphinx
    package
- Deliver man pages for sphinx-build & sphinx-quickstart
- Deliver rst documentation files to reST directory in doc sub-package
- Add %%check section for Python2 and add BR on python-nose
2010-05-22 01:08:12 +00:00

25 lines
604 B
Diff

# HG changeset patch
# Parent 5da6d572bd088b04711b3bf70991c976d8f9c605
Index: Sphinx-0.6.5/setup.py
===================================================================
--- Sphinx-0.6.5.orig/setup.py
+++ Sphinx-0.6.5/setup.py
@@ -1,10 +1,13 @@
# -*- coding: utf-8 -*-
-import ez_setup
-ez_setup.use_setuptools()
+try:
+ from setuptools import setup, find_packages
+except ImportError:
+ import ez_setup
+ ez_setup.use_setuptools()
+ from setuptools import setup, find_packages
import os
import sys
-from setuptools import setup, find_packages
from distutils import log
import sphinx