This commit is contained in:
Rex Dieter 2014-02-13 09:59:45 -06:00
parent c7b024221f
commit ecd44644a0
4 changed files with 156 additions and 0 deletions

1
.gitignore vendored
View File

@ -0,0 +1 @@
/PyQt-gpl-5.2.tar.gz

View File

@ -0,0 +1,16 @@
arm uses standard qreal=double now by default, so either this
check is bogus, or needs to be refactored. Either way, it's
wrong for fedora.
diff -up PyQt-gpl-5.2/configure.py.qreal_arm PyQt-gpl-5.2/configure.py
--- PyQt-gpl-5.2/configure.py.qreal_arm 2014-01-07 10:19:54.000000000 -0600
+++ PyQt-gpl-5.2/configure.py 2014-01-09 16:41:18.884688047 -0600
@@ -482,7 +482,7 @@ int main(int argc, char **argv)
#endif
// This is the test used in qglobal.h.
-#if defined(QT_NO_FPU) || defined(Q_PROCESSOR_ARM) || defined(Q_OS_WINCE)
+#if defined(QT_NO_FPU) || defined(Q_OS_WINCE)
out << "PyQt_qreal_double\\n";
#endif

138
python-qt5.spec Normal file
View File

@ -0,0 +1,138 @@
Summary: Python bindings for Qt5
Name: python-qt5
Version: 5.2
Release: 2%{?dist}
# all BSD, except for GPLv2+ dbus bindings and examples
License: BSD and GPLv2+
Url: http://www.riverbankcomputing.com/software/pyqt/
Source0: http://downloads.sourceforge.net/project/pyqt/PyQt5/PyQt-%{version}/PyQt-gpl-%{version}.tar.gz
## upstreamable patches
# configure.py assumes qreal != double on arm, fail.
Patch50: PyQt-gpl-5.2-qreal_arm.patch
BuildRequires: chrpath
BuildRequires: findutils
BuildRequires: pkgconfig(dbus-1) pkgconfig(dbus-python)
BuildRequires: pkgconfig(phonon4qt5)
BuildRequires: pkgconfig(Qt5Core) >= 5.2.0
BuildRequires: pkgconfig(Qt5DBus) pkgconfig(Qt5Declarative)
BuildRequires: pkgconfig(Qt5Designer)
BuildRequires: pkgconfig(Qt5Gui) pkgconfig(Qt5Multimedia)
BuildRequires: pkgconfig(Qt5Network) pkgconfig(QtOpenGL)
BuildRequires: pkgconfig(Qt5Script)
BuildRequires: pkgconfig(Qt5Sql) pkgconfig(Qt5Svg) pkgconfig(Qt5Test)
BuildRequires: pkgconfig(Qt5X11Extras)
BuildRequires: pkgconfig(Qt5Xml) pkgconfig(Qt5XmlPatterns)
BuildRequires: pkgconfig(Qt5WebKit) pkgconfig(Qt5WebKitWidgets)
BuildRequires: python2-devel
BuildRequires: sip-devel >= 4.15.4
Requires: dbus-python
%{?_qt5_version:Requires: qt5-qtbase%{?_isa} >= %{_qt5_version}}
%{?_sip_api:Requires: sip-api(%{_sip_api_major}) >= %{_sip_api}}
%filter_provides_in %{python_sitearch} %{?_qt5_plugindir}
%filter_setup
%description
These are Python bindings for Qt5.
%package devel
Summary: Development files for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: qt5-qtbase-devel
Requires: sip-devel
%description devel
Files needed to build other bindings for C++ classes that inherit from any
of the Qt5 classes (e.g. KDE or your own).
%package doc
Summary: Developer documentation for %{name}
BuildArch: noarch
%description doc
%{summary}.
%prep
%setup -q -n PyQt-gpl-%{version}
%patch50 -p1 -b .qreal_arm
%build
PATH=%{_qt5_bindir}:$PATH ; export PATH
%{__python2} configure.py \
--assume-shared \
--confirm-license \
--no-timestamp \
--qmake=%{_qt5_qmake} \
--verbose
make %{?_smp_mflags}
%install
make install DESTDIR=%{buildroot} INSTALL_ROOT=%{buildroot}
# remove Python3 code from Python2 directory, fixes FTBFS like PyQt4 (#564633)
rm -rfv %{buildroot}%{python_sitearch}/PyQt5/uic/port_v3/
# remove Python2 code from Python3 directory (for when/if we support python3 here)
rm -rfv %{buildroot}%{python3_sitearch}/PyQt5/uic/port_v2/
%files
%doc NEWS README
%doc LICENSE
%{python_sitelib}/dbus/mainloop/pyqt5.so
%{_qt5_plugindir}/PyQt5/
%dir %{python_sitearch}/PyQt5/
%{python_sitearch}/PyQt5/__init__.py*
%{python_sitearch}/PyQt5/Qt.so
%{python_sitearch}/PyQt5/QtCore.so
%{python_sitearch}/PyQt5/QtDBus.so
%{python_sitearch}/PyQt5/QtDesigner.so
%{python_sitearch}/PyQt5/QtGui.so
%{python_sitearch}/PyQt5/QtHelp.so
%{python_sitearch}/PyQt5/QtMultimedia.so
%{python_sitearch}/PyQt5/QtMultimediaWidgets.so
%{python_sitearch}/PyQt5/QtNetwork.so
%{python_sitearch}/PyQt5/QtOpenGL.so
%{python_sitearch}/PyQt5/QtPrintSupport.so
%{python_sitearch}/PyQt5/QtQml.so
%{python_sitearch}/PyQt5/QtQuick.so
%{python_sitearch}/PyQt5/QtSql.so
%{python_sitearch}/PyQt5/QtSvg.so
%{python_sitearch}/PyQt5/QtTest.so
%{python_sitearch}/PyQt5/QtWebKit.so
%{python_sitearch}/PyQt5/QtWebKitWidgets.so
%{python_sitearch}/PyQt5/QtWidgets.so
%{python_sitearch}/PyQt5/QtX11Extras.so
%{python_sitearch}/PyQt5/QtXmlPatterns.so
%{python_sitearch}/PyQt5/_QOpenGLFunctions_2_0.so
%{python_sitearch}/PyQt5/uic/
%{_qt5_plugindir}/designer/libpyqt5.so
%files devel
%{_bindir}/pylupdate5
%{_bindir}/pyrcc5
%{_bindir}/pyuic5
%{_datadir}/sip/PyQt5/
%files doc
%doc doc/*
%doc examples/
%changelog
* Thu Feb 06 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-2
- BR: python2-devel, use %%__python2 macro
* Wed Jan 08 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-1
- PyQt-5.2

View File

@ -0,0 +1 @@
567a0a72a4e186e9b373c26a9dcf380d PyQt-gpl-5.2.tar.gz