RHEL 9.0.0 Alpha bootstrap

The content of this branch was automatically imported from Fedora ELN
with the following as its source:
https://src.fedoraproject.org/rpms/python-qt5#858f2cf54374311e718275859cf6f3fe58a0b9d3
This commit is contained in:
Troy Dawson 2020-10-14 20:04:56 -07:00
parent 43294b781c
commit e54f3858ef
9 changed files with 1116 additions and 0 deletions

20
.gitignore vendored
View File

@ -0,0 +1,20 @@
/PyQt5_gpl-5.8.tar.gz
/PyQt5_gpl-5.8.1.tar.gz
/PyQt5_gpl-5.8.2.tar.gz
/PyQt5_gpl-5.9.tar.gz
/PyQt5_gpl-5.9.1.tar.gz
/PyQt5_gpl-5.9.2.tar.gz
/PyQt5_gpl-5.10.tar.gz
/PyQt5_gpl-5.10.1.tar.gz
/PyQt5_gpl-5.10.2.dev1805251538.tar.gz
/PyQt5_gpl-5.11.2.tar.gz
/PyQt5_gpl-5.11.3.dev1808131157.tar.gz
/PyQt5_gpl-5.11.3.tar.gz
/PyQt5_gpl-5.12.1.tar.gz
/PyQt5_gpl-5.12.2.tar.gz
/PyQt5_gpl-5.12.3.tar.gz
/PyQt5_gpl-5.13.0.tar.gz
/PyQt5_gpl-5.13.1.tar.gz
/PyQt5-5.13.2.tar.gz
/PyQt5-5.14.2.tar.gz
/PyQt5-5.15.0.tar.gz

12
PyQt5-Timeline.patch Normal file
View File

@ -0,0 +1,12 @@
diff -up PyQt5-5.15.0/sip/QtCore/QtCoremod.sip.Timeline PyQt5-5.15.0/sip/QtCore/QtCoremod.sip
--- PyQt5-5.15.0/sip/QtCore/QtCoremod.sip.Timeline 2020-08-17 17:37:35.734819568 -0500
+++ PyQt5-5.15.0/sip/QtCore/QtCoremod.sip 2020-08-17 17:39:54.179090085 -0500
@@ -22,7 +22,7 @@
%Module(name=PyQt5.QtCore, call_super_init=True, default_VirtualErrorHandler=PyQt5, keyword_arguments="Optional", use_limited_api=True)
-%Timeline {Qt_5_0_0 Qt_5_0_1 Qt_5_0_2 Qt_5_1_0 Qt_5_1_1 Qt_5_2_0 Qt_5_2_1 Qt_5_3_0 Qt_5_3_1 Qt_5_3_2 Qt_5_4_0 Qt_5_4_1 Qt_5_4_2 Qt_5_5_0 Qt_5_5_1 Qt_5_6_0 Qt_5_6_1 Qt_5_6_2 Qt_5_6_3 Qt_5_6_4 Qt_5_6_5 Qt_5_6_6 Qt_5_6_7 Qt_5_6_8 Qt_5_6_9 Qt_5_7_0 Qt_5_7_1 Qt_5_8_0 Qt_5_8_1 Qt_5_9_0 Qt_5_9_1 Qt_5_9_2 Qt_5_9_3 Qt_5_9_4 Qt_5_9_5 Qt_5_9_6 Qt_5_9_7 Qt_5_9_8 Qt_5_9_9 Qt_5_10_0 Qt_5_10_1 Qt_5_11_0 Qt_5_11_1 Qt_5_11_2 Qt_5_11_3 Qt_5_12_0 Qt_5_12_1 Qt_5_12_2 Qt_5_12_3 Qt_5_12_4 Qt_5_13_0 Qt_5_14_0 Qt_5_15_0}
+%Timeline {Qt_5_0_0 Qt_5_0_1 Qt_5_0_2 Qt_5_1_0 Qt_5_1_1 Qt_5_2_0 Qt_5_2_1 Qt_5_3_0 Qt_5_3_1 Qt_5_3_2 Qt_5_4_0 Qt_5_4_1 Qt_5_4_2 Qt_5_5_0 Qt_5_5_1 Qt_5_6_0 Qt_5_6_1 Qt_5_6_2 Qt_5_6_3 Qt_5_6_4 Qt_5_6_5 Qt_5_6_6 Qt_5_6_7 Qt_5_6_8 Qt_5_6_9 Qt_5_7_0 Qt_5_7_1 Qt_5_8_0 Qt_5_8_1 Qt_5_9_0 Qt_5_9_1 Qt_5_9_2 Qt_5_9_3 Qt_5_9_4 Qt_5_9_5 Qt_5_9_6 Qt_5_9_7 Qt_5_9_8 Qt_5_9_9 Qt_5_10_0 Qt_5_10_1 Qt_5_11_0 Qt_5_11_1 Qt_5_11_2 Qt_5_11_3 Qt_5_12_0 Qt_5_12_1 Qt_5_12_2 Qt_5_12_3 Qt_5_12_4 Qt_5_13_0 Qt_5_13_1 Qt_5_13_2 Qt_5_14_0 Qt_5_14_2 Qt_5_15_0 Qt_5_15_1 Qt_5_15_2}
%Platforms {WS_X11 WS_WIN WS_MACX}

8
macros.pyqt5 Normal file
View File

@ -0,0 +1,8 @@
%pyqt5 @@NAME@@
%pyqt5_epoch @@EPOCH@@
%pyqt5_version @@VERSION@@
%pyqt5_evr @@EVR@@
%pyqt5_requires \
Requires: %{pyqt5} >= %{pyqt5_evr} \
%{nil}

8
pylupdate5.sh Normal file
View File

@ -0,0 +1,8 @@
#!/bin/sh
@PYTHON3@ -Ic "import PyQt5.pylupdate_main" &> /dev/null
if [ $? -eq 0 ]; then
exec @PYTHON3@ -Im PyQt5.pylupdate_main ${1+"$@"}
else
exec @PYTHON2@ -c "import sys; del sys.path[0]; import PyQt5.pylupdate_main; PyQt5.pylupdate_main.main()" ${1+"$@"}
fi

7
pyrcc5.sh Normal file
View File

@ -0,0 +1,7 @@
#!/bin/sh
@PYTHON3@ -Ic "import PyQt5.pyrcc_main" &> /dev/null
if [ $? -eq 0 ]; then
exec @PYTHON3@ -Im PyQt5.pyrcc_main ${1+"$@"}
else
exec @PYTHON2@ -c "import sys; del sys.path[0]; import PyQt5.pyrcc_main; PyQt5.pyrcc_main.main()" ${1+"$@"}
fi

1033
python-qt5.spec Normal file

File diff suppressed because it is too large Load Diff

20
python-qt5_sipdir.patch Normal file
View File

@ -0,0 +1,20 @@
diff -up PyQt5-5.14.2/configure.py.qt5_sipdir PyQt5-5.14.2/configure.py
--- PyQt5-5.14.2/configure.py.qt5_sipdir 2020-04-02 09:58:06.029642000 -0500
+++ PyQt5-5.14.2/configure.py 2020-04-04 14:50:00.549639237 -0500
@@ -25,6 +25,7 @@ import os
import shutil
import stat
import sys
+import sipconfig
# Initialise the constants.
@@ -511,7 +512,7 @@ class TargetConfiguration:
self.pyqt_bin_dir = py_config.bin_dir
self.pyqt_module_dir = py_config.module_dir
self.pyqt_stubs_dir = os.path.join(py_config.module_dir, 'PyQt5')
- self.pyqt_sip_dir = os.path.join(py_config.data_dir, 'sip', 'PyQt5')
+ self.pyqt_sip_dir = os.path.join(sipconfig.Configuration().default_sip_dir, 'PyQt5')
self.pyuic_interpreter = py_config.pyuic_interpreter
# Remaining values.

7
pyuic5.sh Normal file
View File

@ -0,0 +1,7 @@
#!/bin/sh
@PYTHON3@ -Ic "import PyQt5.uic.pyuic" &> /dev/null
if [ $? -eq 0 ]; then
exec @PYTHON3@ -Im PyQt5.uic.pyuic ${1+"$@"}
else
exec @PYTHON2@ -c "import sys; del sys.path[0]; import PyQt5.uic.pyuic; PyQt5.uic.pyuic.main()" ${1+"$@"}
fi

1
sources Normal file
View File

@ -0,0 +1 @@
SHA512 (PyQt5-5.15.0.tar.gz) = 35bcfef4d7ccfee04c1c4409d2af3d862f1e8e46d6ce743bfcfbaf43d2046bc58317824b0840f3db460ad280d1b7e896812268b36225198e916a1d9ea86823a9