Update to 5.15.6 + sync with Fedora
Resolves: bz#2061728
This commit is contained in:
parent
62cb7c65b9
commit
89ce8ccb9d
1
.gitignore
vendored
1
.gitignore
vendored
@ -18,3 +18,4 @@
|
||||
/PyQt5-5.13.2.tar.gz
|
||||
/PyQt5-5.14.2.tar.gz
|
||||
/PyQt5-5.15.0.tar.gz
|
||||
/PyQt5-5.15.6.tar.gz
|
||||
|
@ -1,9 +1,10 @@
|
||||
diff -up PyQt5-5.15.0/sip/QtCore/QtCoremod.sip.Timeline PyQt5-5.15.0/sip/QtCore/QtCoremod.sip
|
||||
--- PyQt5-5.15.0/sip/QtCore/QtCoremod.sip.Timeline 2020-08-17 17:37:35.734819568 -0500
|
||||
+++ PyQt5-5.15.0/sip/QtCore/QtCoremod.sip 2020-08-17 17:39:54.179090085 -0500
|
||||
diff --git a/sip/QtCore/QtCoremod.sip b/sip/QtCore/QtCoremod.sip
|
||||
index b525bc5..5bd2470 100644
|
||||
--- a/sip/QtCore/QtCoremod.sip
|
||||
+++ b/sip/QtCore/QtCoremod.sip
|
||||
@@ -22,7 +22,7 @@
|
||||
|
||||
%Module(name=PyQt5.QtCore, call_super_init=True, default_VirtualErrorHandler=PyQt5, keyword_arguments="Optional", use_limited_api=True)
|
||||
%Module(name=PyQt5.QtCore, call_super_init=True, default_VirtualErrorHandler=PyQt5, keyword_arguments="Optional", use_limited_api=True, py_ssize_t_clean=True)
|
||||
|
||||
-%Timeline {Qt_5_0_0 Qt_5_0_1 Qt_5_0_2 Qt_5_1_0 Qt_5_1_1 Qt_5_2_0 Qt_5_2_1 Qt_5_3_0 Qt_5_3_1 Qt_5_3_2 Qt_5_4_0 Qt_5_4_1 Qt_5_4_2 Qt_5_5_0 Qt_5_5_1 Qt_5_6_0 Qt_5_6_1 Qt_5_6_2 Qt_5_6_3 Qt_5_6_4 Qt_5_6_5 Qt_5_6_6 Qt_5_6_7 Qt_5_6_8 Qt_5_6_9 Qt_5_7_0 Qt_5_7_1 Qt_5_8_0 Qt_5_8_1 Qt_5_9_0 Qt_5_9_1 Qt_5_9_2 Qt_5_9_3 Qt_5_9_4 Qt_5_9_5 Qt_5_9_6 Qt_5_9_7 Qt_5_9_8 Qt_5_9_9 Qt_5_10_0 Qt_5_10_1 Qt_5_11_0 Qt_5_11_1 Qt_5_11_2 Qt_5_11_3 Qt_5_12_0 Qt_5_12_1 Qt_5_12_2 Qt_5_12_3 Qt_5_12_4 Qt_5_13_0 Qt_5_14_0 Qt_5_15_0}
|
||||
+%Timeline {Qt_5_0_0 Qt_5_0_1 Qt_5_0_2 Qt_5_1_0 Qt_5_1_1 Qt_5_2_0 Qt_5_2_1 Qt_5_3_0 Qt_5_3_1 Qt_5_3_2 Qt_5_4_0 Qt_5_4_1 Qt_5_4_2 Qt_5_5_0 Qt_5_5_1 Qt_5_6_0 Qt_5_6_1 Qt_5_6_2 Qt_5_6_3 Qt_5_6_4 Qt_5_6_5 Qt_5_6_6 Qt_5_6_7 Qt_5_6_8 Qt_5_6_9 Qt_5_7_0 Qt_5_7_1 Qt_5_8_0 Qt_5_8_1 Qt_5_9_0 Qt_5_9_1 Qt_5_9_2 Qt_5_9_3 Qt_5_9_4 Qt_5_9_5 Qt_5_9_6 Qt_5_9_7 Qt_5_9_8 Qt_5_9_9 Qt_5_10_0 Qt_5_10_1 Qt_5_11_0 Qt_5_11_1 Qt_5_11_2 Qt_5_11_3 Qt_5_12_0 Qt_5_12_1 Qt_5_12_2 Qt_5_12_3 Qt_5_12_4 Qt_5_13_0 Qt_5_13_1 Qt_5_13_2 Qt_5_14_0 Qt_5_14_2 Qt_5_15_0 Qt_5_15_1 Qt_5_15_2}
|
||||
|
@ -1,8 +0,0 @@
|
||||
#!/bin/sh
|
||||
@PYTHON3@ -Ic "import PyQt5.pylupdate_main" &> /dev/null
|
||||
if [ $? -eq 0 ]; then
|
||||
exec @PYTHON3@ -Im PyQt5.pylupdate_main ${1+"$@"}
|
||||
else
|
||||
exec @PYTHON2@ -c "import sys; del sys.path[0]; import PyQt5.pylupdate_main; PyQt5.pylupdate_main.main()" ${1+"$@"}
|
||||
|
||||
fi
|
@ -1,7 +0,0 @@
|
||||
#!/bin/sh
|
||||
@PYTHON3@ -Ic "import PyQt5.pyrcc_main" &> /dev/null
|
||||
if [ $? -eq 0 ]; then
|
||||
exec @PYTHON3@ -Im PyQt5.pyrcc_main ${1+"$@"}
|
||||
else
|
||||
exec @PYTHON2@ -c "import sys; del sys.path[0]; import PyQt5.pyrcc_main; PyQt5.pyrcc_main.main()" ${1+"$@"}
|
||||
fi
|
303
python-qt5.spec
303
python-qt5.spec
@ -1,13 +1,6 @@
|
||||
%if 0%{?fedora} || 0%{?rhel} > 6
|
||||
%global with_python3 1
|
||||
%global python3_dbus_dir %(%{__python3} -c "import dbus.mainloop; print(dbus.mainloop.__path__[0])" 2>/dev/null || echo "%{python3_sitearch}/dbus/mainloop")
|
||||
%endif
|
||||
# sip too old for python2 in EPEL
|
||||
%if 0%{?fedora} < 32 && 0%{?rhel} < 9
|
||||
%global with_python2 1
|
||||
%global python2_dbus_dir %(%{__python2} -c "import dbus.mainloop; print(dbus.mainloop.__path__[0])" 2>/dev/null || echo "%{python2_sitearch}/dbus/mainloop")
|
||||
%global enginio 1
|
||||
%endif
|
||||
|
||||
# enable/disable individual modules
|
||||
# drop power64, it's not supported yet (than)
|
||||
@ -22,18 +15,6 @@
|
||||
|
||||
%global rpm_macros_dir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
|
||||
|
||||
## f29+ no longer using separate sipdir for python3
|
||||
%global py3_sipdir %{_datadir}/sip/PyQt5
|
||||
#if 0%%{?fedora} < 29
|
||||
#global py3_sipdir %%{_datadir}/python3-sip/PyQt5
|
||||
#endif
|
||||
|
||||
%if 0%{?rhel} == 7
|
||||
%global py3_sip %{_bindir}/python3-sip
|
||||
%endif
|
||||
|
||||
%global sip_ver 4.19.23
|
||||
|
||||
# see also https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/JQQ66XJSIT2FGTK2YQY7AXMEH5IXMPUX/
|
||||
%undefine _strict_symbol_defs_build
|
||||
|
||||
@ -41,24 +22,19 @@
|
||||
|
||||
Summary: PyQt5 is Python bindings for Qt5
|
||||
Name: python-qt5
|
||||
Version: 5.15.0
|
||||
Release: 11%{?dist}
|
||||
Version: 5.15.6
|
||||
Release: 1%{?dist}
|
||||
|
||||
License: GPLv3
|
||||
Url: http://www.riverbankcomputing.com/software/pyqt/
|
||||
#Source0: https://www.riverbankcomputing.com/static/Downloads/PyQt5/%{version}/PyQt5-%{version}%{?snap:.%{snap}}.tar.gz
|
||||
Source0: https://files.pythonhosted.org/packages/8c/90/82c62bbbadcca98e8c6fa84f1a638de1ed1c89e85368241e9cc43fcbc320/PyQt5-%{version}.tar.gz
|
||||
Source0: https://pypi.python.org/packages/source/P/PyQt5/PyQt5-%{version}.tar.gz
|
||||
|
||||
Source1: macros.pyqt5
|
||||
# wrapper, see https://bugzilla.redhat.com/show_bug.cgi?id=1193107#c9
|
||||
Source2: pylupdate5.sh
|
||||
Source3: pyrcc5.sh
|
||||
Source4: pyuic5.sh
|
||||
|
||||
## upstream patches
|
||||
|
||||
## upstreamable patches
|
||||
Patch0: python-qt5_sipdir.patch
|
||||
# support newer Qt5 releases
|
||||
Patch1: PyQt5-Timeline.patch
|
||||
|
||||
@ -93,24 +69,10 @@ BuildRequires: pkgconfig(Qt5X11Extras)
|
||||
BuildRequires: pkgconfig(Qt5Xml) pkgconfig(Qt5XmlPatterns)
|
||||
BuildRequires: pkgconfig(Qt5WebChannel)
|
||||
BuildRequires: pkgconfig(Qt5WebSockets)
|
||||
%if 0%{?with_python2}
|
||||
BuildRequires: python27
|
||||
BuildRequires: python2-enum34
|
||||
%if 0%{?fedora} > 27
|
||||
%global python2_dbus python2-dbus
|
||||
%else
|
||||
%global python2_dbus dbus-python
|
||||
%endif
|
||||
BuildRequires: %{python2_dbus}
|
||||
BuildRequires: python2-pyqt5-sip >= %{sip_ver}
|
||||
BuildRequires: python2-sip-devel >= %{sip_ver}
|
||||
%endif # with_python2
|
||||
%if 0%{?with_python3}
|
||||
BuildRequires: python%{python3_pkgversion}-devel python%{python3_pkgversion}
|
||||
BuildRequires: python%{python3_pkgversion}-dbus
|
||||
BuildRequires: python%{python3_pkgversion}-pyqt5-sip >= %{sip_ver}
|
||||
BuildRequires: python%{python3_pkgversion}-sip-devel >= %{sip_ver}
|
||||
%endif # with_python3
|
||||
BuildRequires: %{py3_dist PyQt-builder} >= 1.1.0
|
||||
BuildRequires: %{py3_dist sip} >= 5.3
|
||||
|
||||
# when split out
|
||||
%if 0%{?webengine} || 0%{?webkit}
|
||||
@ -122,45 +84,6 @@ Obsoletes: python-qt5 < 5.5.1-10
|
||||
|
||||
%global __provides_exclude_from ^(%{_qt5_plugindir}/.*\\.so)$
|
||||
|
||||
%if 0%{?with_python2}
|
||||
%package -n python2-qt5
|
||||
Summary: Python 2 bindings for Qt5
|
||||
Requires: python2-qt5-base%{?_isa} = %{version}-%{release}
|
||||
BuildRequires: python27
|
||||
Requires: python2-enum34
|
||||
Provides: python2-PyQt5 = %{version}-%{release}
|
||||
Provides: python2-PyQt5%{?_isa} = %{version}-%{release}
|
||||
%{?python_provide:%python_provide python2-qt5}
|
||||
|
||||
%description -n python2-qt5
|
||||
%{summary}.
|
||||
|
||||
%package -n python2-qt5-base
|
||||
Summary: Python bindings for Qt5 base
|
||||
Requires: %{name}-rpm-macros = %{version}-%{release}
|
||||
%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
|
||||
%{?_sip_api:Requires: python2-pyqt5-sip-api(%{_sip_api_major}) >= %{_sip_api}}
|
||||
Requires: %{python2_dbus}
|
||||
Obsoletes: python-qt5 < 5.5.1-10
|
||||
Provides: python2-PyQt5-base = %{version}-%{release}
|
||||
Provides: python2-PyQt5-base%{?_isa} = %{version}-%{release}
|
||||
%{?python_provide:%python_provide python2-qt5-base}
|
||||
%description -n python2-qt5-base
|
||||
%{summary}.
|
||||
|
||||
%package -n python2-qt5-devel
|
||||
Summary: Development files for %{name}
|
||||
Requires: python2-qt5%{?_isa} = %{version}-%{release}
|
||||
Requires: qt5-qtbase-devel
|
||||
Requires: python2-sip-devel
|
||||
Provides: PyQt5-devel = %{version}-%{release}
|
||||
Provides: python2-PyQt5-devel = %{version}-%{release}
|
||||
%{?python_provide:%python_provide python2-qt5-devel}
|
||||
%description -n python2-qt5-devel
|
||||
Files needed to build other bindings for C++ classes that inherit from
|
||||
any of the Qt5 classes.
|
||||
%endif
|
||||
|
||||
%package rpm-macros
|
||||
Summary: RPM macros %{name}
|
||||
# when split out
|
||||
@ -188,11 +111,6 @@ Requires: python%{python3_pkgversion}-qt5-base%{?_isa} = %{version}-%{release}
|
||||
%package -n python%{python3_pkgversion}-qt5-base
|
||||
Summary: Python 3 bindings for Qt5 base
|
||||
%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
|
||||
%if 0%{?_python3_sip_api_major}
|
||||
%{?_python3_sip_api:Requires: python%{python3_pkgversion}-pyqt5-sip-api(%{_python3_sip_api_major}) >= %{_python3_sip_api}}
|
||||
%else
|
||||
%{?_sip_api:Requires: python%{python3_pkgversion}-pyqt5-sip-api(%{_sip_api_major}) >= %{_sip_api}}
|
||||
%endif
|
||||
Provides: python%{python3_pkgversion}-PyQt5-base = %{version}-%{release}
|
||||
Provides: python%{python3_pkgversion}-PyQt5-base%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-rpm-macros = %{version}-%{release}
|
||||
@ -205,7 +123,6 @@ Requires: python%{python3_pkgversion}-dbus
|
||||
Summary: Development files for python3-qt5
|
||||
Requires: python%{python3_pkgversion}-qt5%{?_isa} = %{version}-%{release}
|
||||
Requires: qt5-qtbase-devel
|
||||
Requires: python%{python3_pkgversion}-sip-devel
|
||||
Provides: python%{python3_pkgversion}-PyQt5-devel = %{version}-%{release}
|
||||
%{?python_provide:%python_provide python%{python3_pkgversion}-qt5-devel}
|
||||
%description -n python%{python3_pkgversion}-qt5-devel
|
||||
@ -220,17 +137,6 @@ BuildArch: noarch
|
||||
%{summary}.
|
||||
|
||||
%if 0%{?webengine}
|
||||
%if 0%{?with_python2}
|
||||
%package -n python2-qt5-webengine
|
||||
Summary: Python bindings for Qt5 WebEngine
|
||||
BuildRequires: pkgconfig(Qt5WebEngine)
|
||||
Obsoletes: python-qt5 < 5.5.1-10
|
||||
Requires: python2-qt5%{?_isa} = %{version}-%{release}
|
||||
%{?python_provide:%python_provide python2-qt5-webengine}
|
||||
%description -n python2-qt5-webengine
|
||||
%{summary}.
|
||||
%endif
|
||||
|
||||
%package -n python%{python3_pkgversion}-qt5-webengine
|
||||
Summary: Python3 bindings for Qt5 WebEngine
|
||||
BuildRequires: pkgconfig(Qt5WebEngine)
|
||||
@ -243,19 +149,6 @@ Requires: python%{python3_pkgversion}-qt5%{?_isa} = %{version}-%{release}
|
||||
%endif
|
||||
|
||||
%if 0%{?webkit}
|
||||
%if 0%{?with_python2}
|
||||
%package -n python2-qt5-webkit
|
||||
Summary: Python bindings for Qt5 Webkit
|
||||
BuildRequires: pkgconfig(Qt5WebKit)
|
||||
BuildRequires: pkgconfig(Qt5WebKitWidgets)
|
||||
Obsoletes: python3-webkit < 5.5.1-12
|
||||
Obsoletes: python-qt5 < 5.5.1-10
|
||||
Requires: python2-qt5%{?_isa} = %{version}-%{release}
|
||||
%{?python_provide:%python_provide python2-qt5-webkit}
|
||||
%description -n python2-qt5-webkit
|
||||
%{summary}.
|
||||
%endif
|
||||
|
||||
%package -n python%{python3_pkgversion}-qt5-webkit
|
||||
Summary: Python3 bindings for Qt5 Webkit
|
||||
BuildRequires: pkgconfig(Qt5WebKit)
|
||||
@ -271,7 +164,6 @@ Requires: python%{python3_pkgversion}-qt5%{?_isa} = %{version}-%{release}
|
||||
%prep
|
||||
%setup -q -n PyQt5-%{version}%{?snap:.%{snap}}
|
||||
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
|
||||
@ -280,67 +172,28 @@ Requires: python%{python3_pkgversion}-qt5%{?_isa} = %{version}-%{release}
|
||||
|
||||
PATH=%{_qt5_bindir}:$PATH ; export PATH
|
||||
|
||||
# Python 2 build:
|
||||
%if 0%{?with_python2}
|
||||
mkdir %{_target_platform}
|
||||
# copy sources, seems pure shadow build support broke with 5.9 -- rex
|
||||
cp -a * %{_target_platform}/ ||:
|
||||
pushd %{_target_platform}
|
||||
%{__python2} ./configure.py \
|
||||
--assume-shared \
|
||||
--confirm-license \
|
||||
--no-designer-plugin \
|
||||
--no-qml-plugin \
|
||||
--qmake=%{_qt5_qmake} \
|
||||
%{!?with_python3:--no-qsci-api}%{?with_python3:--qsci-api --qsci-api-destdir=%{_qt5_datadir}/qsci} \
|
||||
--verbose \
|
||||
--dbus=%{_includedir}/dbus-1.0/ \
|
||||
QMAKE_CFLAGS_RELEASE="%{optflags}" \
|
||||
QMAKE_CXXFLAGS_RELEASE="%{optflags} `pkg-config --cflags dbus-python`" \
|
||||
QMAKE_LFLAGS_RELEASE="%{?__global_ldflags}"
|
||||
|
||||
%make_build
|
||||
popd
|
||||
%endif # with_python2
|
||||
|
||||
# Python 3 build:
|
||||
%if 0%{?with_python3}
|
||||
mkdir %{_target_platform}-python3
|
||||
cp -a * %{_target_platform}-python3/ ||:
|
||||
pushd %{_target_platform}-python3
|
||||
%{__python3} ./configure.py \
|
||||
--assume-shared \
|
||||
sip-build \
|
||||
--no-make \
|
||||
--qt-shared \
|
||||
--confirm-license \
|
||||
--qmake=%{_qt5_qmake} \
|
||||
%{?with_python2:--no-qsci-api}%{!?with_python2:--qsci-api --qsci-api-destdir=%{_qt5_datadir}/qsci} \
|
||||
%{?py3_sip:--sip=%{_bindir}/python3-sip} \
|
||||
%{?py3_sipdir:--sipdir=%{py3_sipdir}} \
|
||||
--api-dir=%{_qt5_datadir}/qsci/api/python \
|
||||
--verbose \
|
||||
--dbus=%{_includedir}/dbus-1.0/ \
|
||||
QMAKE_CFLAGS_RELEASE="%{optflags}" \
|
||||
QMAKE_CXXFLAGS_RELEASE="%{optflags} `pkg-config --cflags dbus-python`" \
|
||||
QMAKE_LFLAGS_RELEASE="%{?__global_ldflags}"
|
||||
--pep484-pyi \
|
||||
--qmake-setting 'QMAKE_CFLAGS_RELEASE="%{optflags}"' \
|
||||
--qmake-setting 'QMAKE_CXXFLAGS_RELEASE="%{optflags} `pkg-config --cflags dbus-python`"' \
|
||||
--qmake-setting 'QMAKE_LFLAGS_RELEASE="%{?__global_ldflags}"'
|
||||
|
||||
%make_build
|
||||
popd
|
||||
%endif # with_python3
|
||||
%make_build -C build
|
||||
|
||||
|
||||
%install
|
||||
|
||||
# Python 3 build:
|
||||
%if 0%{?with_python3}
|
||||
%make_install INSTALL_ROOT=%{buildroot} -C %{_target_platform}-python3
|
||||
if [ "%{_prefix}" != "/usr" ]; then
|
||||
cp -ru %{buildroot}/usr/* %{buildroot}%{_prefix}/
|
||||
rm -rf %{buildroot}/usr/*
|
||||
fi
|
||||
%if "%py3_sipdir" == "%{_datadir}/sip/PyQt5"
|
||||
# copy files to old location for compat purposes temporarily
|
||||
mkdir -p %{buildroot}%{_datadir}/python3-sip
|
||||
cp -alf %{buildroot}%{py3_sipdir} \
|
||||
%{buildroot}%{_datadir}/python3-sip/PyQt5
|
||||
%endif
|
||||
%make_install INSTALL_ROOT=%{buildroot} -C build
|
||||
|
||||
if [ "%{_prefix}" != "/usr" ]; then
|
||||
cp -ru %{buildroot}/usr/* %{buildroot}%{_prefix}/ || echo "Nothing to copy"
|
||||
@ -353,29 +206,6 @@ fi
|
||||
|
||||
# ensure .so modules are executable for proper -debuginfo extraction
|
||||
find %{buildroot} -type f -name '*.so' | xargs chmod a+rx
|
||||
#for i in %%{buildroot}%%{python3_sitearch}/PyQt5/*.so %%{buildroot}%%{python3_dbus_dir}/pyqt5.so ; do
|
||||
#test -x $i || chmod a+rx $i
|
||||
#done
|
||||
%endif # with_python3
|
||||
|
||||
# Python 2 build:
|
||||
%if 0%{?with_python2}
|
||||
%make_install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
|
||||
if [ "%{_prefix}" != "/usr" ]; then
|
||||
cp -ru %{buildroot}/usr/* %{buildroot}%{_prefix}/
|
||||
rm -rf %{buildroot}/usr/*
|
||||
fi
|
||||
# ensure .so modules are executable for proper -debuginfo extraction
|
||||
find %{buildroot} -type f -name '*.so' | xargs chmod a+rx
|
||||
#for i in %%{buildroot}%%{python2_sitearch}/PyQt5/*.so %%{buildroot}%%{python2_dbus_dir}/pyqt5.so ; do
|
||||
#test -x $i || chmod a+rx $i
|
||||
#done
|
||||
%endif # with_python2
|
||||
|
||||
# remove Python3 code from Python2 directory, fixes FTBFS like PyQt4 (#564633)
|
||||
rm -rfv %{buildroot}%{python2_sitearch}/PyQt5/uic/port_v3/
|
||||
# remove Python2 code from Python3 directory (for when/if we support python3 here)
|
||||
rm -rfv %{buildroot}%{python3_sitearch}/PyQt5/uic/port_v2/
|
||||
|
||||
# rpm macros
|
||||
install -p -m644 -D %{SOURCE1} \
|
||||
@ -387,95 +217,10 @@ sed -i \
|
||||
-e "s|@@EVR@@|%{?epoch:%{epoch:}}%{version}-%{release}|g" \
|
||||
%{buildroot}%{rpm_macros_dir}/macros.pyqt5
|
||||
|
||||
%if 0%{?with_python3}
|
||||
# install wrappers to handle both/either python2/python3
|
||||
# TODO: consider alternatives? -- rex
|
||||
rm -fv %{buildroot}%{_bindir}/{pyrcc5,pylupdate5,pyuic5}
|
||||
install -p -m755 -D %{SOURCE2} %{buildroot}%{_bindir}/pylupdate5
|
||||
install -p -m755 -D %{SOURCE3} %{buildroot}%{_bindir}/pyrcc5
|
||||
install -p -m755 -D %{SOURCE4} %{buildroot}%{_bindir}/pyuic5
|
||||
sed -i \
|
||||
-e "s|@PYTHON3@|%{__python3}|g" \
|
||||
-e "s|@PYTHON2@|%{__python2}|g" \
|
||||
%{buildroot}%{_bindir}/{pyrcc5,pylupdate5,pyuic5}
|
||||
%endif
|
||||
|
||||
%if 0%{?with_python2}
|
||||
%files -n python2-qt5
|
||||
%if 0%{?enginio}
|
||||
%{python2_sitearch}/PyQt5/Enginio.so
|
||||
%endif
|
||||
%{python2_sitearch}/PyQt5/QtBluetooth.so
|
||||
%{python2_sitearch}/PyQt5/QtDesigner.so
|
||||
%{python2_sitearch}/PyQt5/QtHelp.so
|
||||
%{python2_sitearch}/PyQt5/QtLocation.so
|
||||
%{python2_sitearch}/PyQt5/QtMultimedia.so
|
||||
%{python2_sitearch}/PyQt5/QtMultimediaWidgets.so
|
||||
%{python2_sitearch}/PyQt5/QtNfc.so
|
||||
%{python2_sitearch}/PyQt5/QtPositioning.so
|
||||
%{python2_sitearch}/PyQt5/QtQml.so
|
||||
%{python2_sitearch}/PyQt5/QtQuick.so
|
||||
%{python2_sitearch}/PyQt5/QtQuickWidgets.so
|
||||
%{python2_sitearch}/PyQt5/QtSensors.so
|
||||
%{python2_sitearch}/PyQt5/QtSerialPort.so
|
||||
%{python2_sitearch}/PyQt5/QtSvg.so
|
||||
%{python2_sitearch}/PyQt5/QtWebChannel.so
|
||||
%{python2_sitearch}/PyQt5/QtWebSockets.so
|
||||
%{python2_sitearch}/PyQt5/QtX11Extras.so
|
||||
%{python2_sitearch}/PyQt5/QtXmlPatterns.so
|
||||
|
||||
%files -n python2-qt5-base
|
||||
%doc NEWS README
|
||||
%license LICENSE
|
||||
%{python2_dbus_dir}/pyqt5.so
|
||||
%dir %{python2_sitearch}/PyQt5/
|
||||
%{python2_sitearch}/PyQt5-%{version}%{?snap:.%{snap}}.dist-info
|
||||
%{python2_sitearch}/PyQt5/__init__.py*
|
||||
%{python2_sitearch}/PyQt5/Qt.so
|
||||
%{python2_sitearch}/PyQt5/QtCore.so
|
||||
%{python2_sitearch}/PyQt5/QtDBus.so
|
||||
%{python2_sitearch}/PyQt5/QtGui.so
|
||||
%{python2_sitearch}/PyQt5/QtNetwork.so
|
||||
%{python2_sitearch}/PyQt5/QtOpenGL.so
|
||||
%{python2_sitearch}/PyQt5/QtPrintSupport.so
|
||||
%{python2_sitearch}/PyQt5/QtSql.so
|
||||
%{python2_sitearch}/PyQt5/QtTest.so
|
||||
%{python2_sitearch}/PyQt5/QtWidgets.so
|
||||
%{python2_sitearch}/PyQt5/QtXml.so
|
||||
%{python2_sitearch}/PyQt5/_QOpenGLFunctions_2_0.so
|
||||
%{python2_sitearch}/PyQt5/_QOpenGLFunctions_2_1.so
|
||||
%{python2_sitearch}/PyQt5/_QOpenGLFunctions_4_1_Core.so
|
||||
# *was* in -devel
|
||||
%{_bindir}/pylupdate5
|
||||
%{_bindir}/pyrcc5
|
||||
%{_bindir}/pyuic5
|
||||
%{python2_sitearch}/PyQt5/uic/
|
||||
%{python2_sitearch}/PyQt5/pylupdate.so
|
||||
%{python2_sitearch}/PyQt5/pylupdate_main.py*
|
||||
%{python2_sitearch}/PyQt5/pyrcc.so
|
||||
%{python2_sitearch}/PyQt5/pyrcc_main.py*
|
||||
|
||||
%if 0%{?webengine}
|
||||
%files -n python2-qt5-webengine
|
||||
%{python2_sitearch}/PyQt5/QtWebEngine.*
|
||||
%{python2_sitearch}/PyQt5/QtWebEngineCore.*
|
||||
%{python2_sitearch}/PyQt5/QtWebEngineWidgets.*
|
||||
%endif
|
||||
|
||||
%if 0%{?webkit}
|
||||
%files -n python2-qt5-webkit
|
||||
%{python2_sitearch}/PyQt5/QtWebKit.*
|
||||
%{python2_sitearch}/PyQt5/QtWebKitWidgets.*
|
||||
%endif
|
||||
|
||||
%files -n python2-qt5-devel
|
||||
%{_datadir}/sip/PyQt5/
|
||||
%endif
|
||||
|
||||
%files rpm-macros
|
||||
%{rpm_macros_dir}/macros.pyqt5
|
||||
|
||||
%if 0%{?with_python3}
|
||||
%files -n python%{python3_pkgversion}-qt5
|
||||
%if 0%{?enginio}
|
||||
%{python3_sitearch}/PyQt5/Enginio.*
|
||||
@ -502,7 +247,7 @@ sed -i \
|
||||
%files -n python%{python3_pkgversion}-qt5-base
|
||||
%doc NEWS README
|
||||
%license LICENSE
|
||||
%{python3_dbus_dir}/pyqt5.so
|
||||
%{python3_dbus_dir}/pyqt5.abi3.so
|
||||
%dir %{python3_sitearch}/PyQt5/
|
||||
%{python3_sitearch}/PyQt5-%{version}%{?snap:.%{snap}}.dist-info
|
||||
%{python3_sitearch}/PyQt5/__pycache__/__init__.*
|
||||
@ -529,12 +274,14 @@ sed -i \
|
||||
%{_bindir}/pylupdate5
|
||||
%{_bindir}/pyrcc5
|
||||
%{_bindir}/pyuic5
|
||||
%{python3_sitearch}/PyQt5/pylupdate.so
|
||||
%{python3_sitearch}/PyQt5/pylupdate.abi3.so
|
||||
%{python3_sitearch}/PyQt5/pylupdate_main.py*
|
||||
%{python3_sitearch}/PyQt5/__pycache__/pylupdate_main*
|
||||
%{python3_sitearch}/PyQt5/pyrcc.so
|
||||
%{python3_sitearch}/PyQt5/pyrcc.abi3.so
|
||||
%{python3_sitearch}/PyQt5/pyrcc_main.py*
|
||||
%{python3_sitearch}/PyQt5/__pycache__/pyrcc_main*
|
||||
%{python3_sitearch}/PyQt5/py.typed
|
||||
%{python3_sitearch}/PyQt5/sip.pyi
|
||||
|
||||
%if 0%{?webengine}
|
||||
%files -n python%{python3_pkgversion}-qt5-webengine
|
||||
@ -550,11 +297,7 @@ sed -i \
|
||||
%endif
|
||||
|
||||
%files -n python%{python3_pkgversion}-qt5-devel
|
||||
%{py3_sipdir}/
|
||||
# compat location
|
||||
%dir %{_datadir}/python3-sip/
|
||||
%{_datadir}/python3-sip/PyQt5/
|
||||
%endif # with_python3
|
||||
%{python3_sitearch}/PyQt5/bindings/
|
||||
|
||||
%files doc
|
||||
#doc doc/*
|
||||
@ -567,6 +310,10 @@ sed -i \
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue May 03 2022 Jan Grulich <jgrulich@redhat.com> - 5.15.6-1
|
||||
- 5.15.6 + sync with Fedora
|
||||
Resolves: bz#2061728
|
||||
|
||||
* Wed Apr 06 2022 Jan Grulich <jgrulich@redhat.com> - 5.15.0-11
|
||||
- Rebuild (Qt 5.15.3)
|
||||
Resolves: bz#2061728
|
||||
|
@ -1,20 +0,0 @@
|
||||
diff -up PyQt5-5.14.2/configure.py.qt5_sipdir PyQt5-5.14.2/configure.py
|
||||
--- PyQt5-5.14.2/configure.py.qt5_sipdir 2020-04-02 09:58:06.029642000 -0500
|
||||
+++ PyQt5-5.14.2/configure.py 2020-04-04 14:50:00.549639237 -0500
|
||||
@@ -25,6 +25,7 @@ import os
|
||||
import shutil
|
||||
import stat
|
||||
import sys
|
||||
+import sipconfig
|
||||
|
||||
|
||||
# Initialise the constants.
|
||||
@@ -511,7 +512,7 @@ class TargetConfiguration:
|
||||
self.pyqt_bin_dir = py_config.bin_dir
|
||||
self.pyqt_module_dir = py_config.module_dir
|
||||
self.pyqt_stubs_dir = os.path.join(py_config.module_dir, 'PyQt5')
|
||||
- self.pyqt_sip_dir = os.path.join(py_config.data_dir, 'sip', 'PyQt5')
|
||||
+ self.pyqt_sip_dir = os.path.join(sipconfig.Configuration().default_sip_dir, 'PyQt5')
|
||||
self.pyuic_interpreter = py_config.pyuic_interpreter
|
||||
|
||||
# Remaining values.
|
@ -1,7 +0,0 @@
|
||||
#!/bin/sh
|
||||
@PYTHON3@ -Ic "import PyQt5.uic.pyuic" &> /dev/null
|
||||
if [ $? -eq 0 ]; then
|
||||
exec @PYTHON3@ -Im PyQt5.uic.pyuic ${1+"$@"}
|
||||
else
|
||||
exec @PYTHON2@ -c "import sys; del sys.path[0]; import PyQt5.uic.pyuic; PyQt5.uic.pyuic.main()" ${1+"$@"}
|
||||
fi
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (PyQt5-5.15.0.tar.gz) = 35bcfef4d7ccfee04c1c4409d2af3d862f1e8e46d6ce743bfcfbaf43d2046bc58317824b0840f3db460ad280d1b7e896812268b36225198e916a1d9ea86823a9
|
||||
SHA512 (PyQt5-5.15.6.tar.gz) = 65fd663cb70e8701e49bd4b39dc9384546cf2edd1b3bab259ca64b50908f48bdc02ca143f36cd6b429075f5616dcc7b291607dcb63afa176e828cded3b82f5c7
|
||||
|
Loading…
Reference in New Issue
Block a user