import python-qt5-5.15.0-10.el9
This commit is contained in:
commit
0aaff17dc4
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/PyQt5-5.15.0.tar.gz
|
1
.python-qt5.metadata
Normal file
1
.python-qt5.metadata
Normal file
@ -0,0 +1 @@
|
||||
928746291aca68a3bb9f1e56053728a942887ab8 SOURCES/PyQt5-5.15.0.tar.gz
|
12
SOURCES/PyQt5-Timeline.patch
Normal file
12
SOURCES/PyQt5-Timeline.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up PyQt5-5.15.0/sip/QtCore/QtCoremod.sip.Timeline PyQt5-5.15.0/sip/QtCore/QtCoremod.sip
|
||||
--- PyQt5-5.15.0/sip/QtCore/QtCoremod.sip.Timeline 2020-08-17 17:37:35.734819568 -0500
|
||||
+++ PyQt5-5.15.0/sip/QtCore/QtCoremod.sip 2020-08-17 17:39:54.179090085 -0500
|
||||
@@ -22,7 +22,7 @@
|
||||
|
||||
%Module(name=PyQt5.QtCore, call_super_init=True, default_VirtualErrorHandler=PyQt5, keyword_arguments="Optional", use_limited_api=True)
|
||||
|
||||
-%Timeline {Qt_5_0_0 Qt_5_0_1 Qt_5_0_2 Qt_5_1_0 Qt_5_1_1 Qt_5_2_0 Qt_5_2_1 Qt_5_3_0 Qt_5_3_1 Qt_5_3_2 Qt_5_4_0 Qt_5_4_1 Qt_5_4_2 Qt_5_5_0 Qt_5_5_1 Qt_5_6_0 Qt_5_6_1 Qt_5_6_2 Qt_5_6_3 Qt_5_6_4 Qt_5_6_5 Qt_5_6_6 Qt_5_6_7 Qt_5_6_8 Qt_5_6_9 Qt_5_7_0 Qt_5_7_1 Qt_5_8_0 Qt_5_8_1 Qt_5_9_0 Qt_5_9_1 Qt_5_9_2 Qt_5_9_3 Qt_5_9_4 Qt_5_9_5 Qt_5_9_6 Qt_5_9_7 Qt_5_9_8 Qt_5_9_9 Qt_5_10_0 Qt_5_10_1 Qt_5_11_0 Qt_5_11_1 Qt_5_11_2 Qt_5_11_3 Qt_5_12_0 Qt_5_12_1 Qt_5_12_2 Qt_5_12_3 Qt_5_12_4 Qt_5_13_0 Qt_5_14_0 Qt_5_15_0}
|
||||
+%Timeline {Qt_5_0_0 Qt_5_0_1 Qt_5_0_2 Qt_5_1_0 Qt_5_1_1 Qt_5_2_0 Qt_5_2_1 Qt_5_3_0 Qt_5_3_1 Qt_5_3_2 Qt_5_4_0 Qt_5_4_1 Qt_5_4_2 Qt_5_5_0 Qt_5_5_1 Qt_5_6_0 Qt_5_6_1 Qt_5_6_2 Qt_5_6_3 Qt_5_6_4 Qt_5_6_5 Qt_5_6_6 Qt_5_6_7 Qt_5_6_8 Qt_5_6_9 Qt_5_7_0 Qt_5_7_1 Qt_5_8_0 Qt_5_8_1 Qt_5_9_0 Qt_5_9_1 Qt_5_9_2 Qt_5_9_3 Qt_5_9_4 Qt_5_9_5 Qt_5_9_6 Qt_5_9_7 Qt_5_9_8 Qt_5_9_9 Qt_5_10_0 Qt_5_10_1 Qt_5_11_0 Qt_5_11_1 Qt_5_11_2 Qt_5_11_3 Qt_5_12_0 Qt_5_12_1 Qt_5_12_2 Qt_5_12_3 Qt_5_12_4 Qt_5_13_0 Qt_5_13_1 Qt_5_13_2 Qt_5_14_0 Qt_5_14_2 Qt_5_15_0 Qt_5_15_1 Qt_5_15_2}
|
||||
|
||||
%Platforms {WS_X11 WS_WIN WS_MACX}
|
||||
|
8
SOURCES/macros.pyqt5
Normal file
8
SOURCES/macros.pyqt5
Normal file
@ -0,0 +1,8 @@
|
||||
%pyqt5 @@NAME@@
|
||||
%pyqt5_epoch @@EPOCH@@
|
||||
%pyqt5_version @@VERSION@@
|
||||
%pyqt5_evr @@EVR@@
|
||||
|
||||
%pyqt5_requires \
|
||||
Requires: %{pyqt5} >= %{pyqt5_evr} \
|
||||
%{nil}
|
8
SOURCES/pylupdate5.sh
Normal file
8
SOURCES/pylupdate5.sh
Normal file
@ -0,0 +1,8 @@
|
||||
#!/bin/sh
|
||||
@PYTHON3@ -Ic "import PyQt5.pylupdate_main" &> /dev/null
|
||||
if [ $? -eq 0 ]; then
|
||||
exec @PYTHON3@ -Im PyQt5.pylupdate_main ${1+"$@"}
|
||||
else
|
||||
exec @PYTHON2@ -c "import sys; del sys.path[0]; import PyQt5.pylupdate_main; PyQt5.pylupdate_main.main()" ${1+"$@"}
|
||||
|
||||
fi
|
7
SOURCES/pyrcc5.sh
Normal file
7
SOURCES/pyrcc5.sh
Normal file
@ -0,0 +1,7 @@
|
||||
#!/bin/sh
|
||||
@PYTHON3@ -Ic "import PyQt5.pyrcc_main" &> /dev/null
|
||||
if [ $? -eq 0 ]; then
|
||||
exec @PYTHON3@ -Im PyQt5.pyrcc_main ${1+"$@"}
|
||||
else
|
||||
exec @PYTHON2@ -c "import sys; del sys.path[0]; import PyQt5.pyrcc_main; PyQt5.pyrcc_main.main()" ${1+"$@"}
|
||||
fi
|
20
SOURCES/python-qt5_sipdir.patch
Normal file
20
SOURCES/python-qt5_sipdir.patch
Normal file
@ -0,0 +1,20 @@
|
||||
diff -up PyQt5-5.14.2/configure.py.qt5_sipdir PyQt5-5.14.2/configure.py
|
||||
--- PyQt5-5.14.2/configure.py.qt5_sipdir 2020-04-02 09:58:06.029642000 -0500
|
||||
+++ PyQt5-5.14.2/configure.py 2020-04-04 14:50:00.549639237 -0500
|
||||
@@ -25,6 +25,7 @@ import os
|
||||
import shutil
|
||||
import stat
|
||||
import sys
|
||||
+import sipconfig
|
||||
|
||||
|
||||
# Initialise the constants.
|
||||
@@ -511,7 +512,7 @@ class TargetConfiguration:
|
||||
self.pyqt_bin_dir = py_config.bin_dir
|
||||
self.pyqt_module_dir = py_config.module_dir
|
||||
self.pyqt_stubs_dir = os.path.join(py_config.module_dir, 'PyQt5')
|
||||
- self.pyqt_sip_dir = os.path.join(py_config.data_dir, 'sip', 'PyQt5')
|
||||
+ self.pyqt_sip_dir = os.path.join(sipconfig.Configuration().default_sip_dir, 'PyQt5')
|
||||
self.pyuic_interpreter = py_config.pyuic_interpreter
|
||||
|
||||
# Remaining values.
|
7
SOURCES/pyuic5.sh
Normal file
7
SOURCES/pyuic5.sh
Normal file
@ -0,0 +1,7 @@
|
||||
#!/bin/sh
|
||||
@PYTHON3@ -Ic "import PyQt5.uic.pyuic" &> /dev/null
|
||||
if [ $? -eq 0 ]; then
|
||||
exec @PYTHON3@ -Im PyQt5.uic.pyuic ${1+"$@"}
|
||||
else
|
||||
exec @PYTHON2@ -c "import sys; del sys.path[0]; import PyQt5.uic.pyuic; PyQt5.uic.pyuic.main()" ${1+"$@"}
|
||||
fi
|
1064
SPECS/python-qt5.spec
Normal file
1064
SPECS/python-qt5.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user