Update to pyudev-0.18.1.

This commit is contained in:
mulhern 2015-12-21 14:06:12 -05:00
parent 02bcc6f8c5
commit a1e3905327
4 changed files with 62 additions and 27 deletions

1
.gitignore vendored
View File

@ -1,3 +1,4 @@
/pyudev-0.15.tar.gz
/pyudev-0.16.1.tar.gz
/pyudev-0.17.tar.gz
/pyudev-0.18.1.tar.gz

View File

@ -1,23 +0,0 @@
From 2aa590dcdeb8ced47e801b9fcef084959b8e2bc9 Mon Sep 17 00:00:00 2001
From: David Shea <dshea@redhat.com>
Date: Mon, 14 Sep 2015 13:34:17 -0400
Subject: [PATCH] Do not install the tests as a module.
---
setup.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
index 1920cec..a8044e9 100644
--- a/setup.py
+++ b/setup.py
@@ -52,5 +52,5 @@
'Topic :: System :: Hardware',
'Topic :: System :: Operating System Kernels :: Linux',
],
- packages=setuptools.find_packages(),
+ packages=setuptools.find_packages(exclude=['tests.*', 'tests']),
)
--
2.4.3

View File

@ -1,6 +1,6 @@
%global srcname pyudev
Name: python-%{srcname}
Version: 0.17
Version: 0.18.1
Release: 4%{?dist}
Summary: A libudev binding
@ -8,8 +8,6 @@ License: LGPLv2+
URL: http://pypi.python.org/pypi/pyudev
Source0: http://pypi.python.org/packages/source/p/%{srcname}/%{srcname}-%{version}.tar.gz
Patch0: 0001-Do-not-install-the-tests-as-a-module.patch
BuildArch: noarch
%description
@ -38,6 +36,9 @@ Requires: glibc
# Needed for libudev
Requires: systemd-libs
# Used for python2/3 compatibility
Requires: python-six
%description -n python2-%{srcname}
pyudev is a LGPL licensed, pure Python binding for libudev, the device
and hardware management and information library for Linux. It supports
@ -74,6 +75,18 @@ Qt4 integration for pyudev.
This package provides a module pyudev.pyqt4 that contains classes for
integrating a pyudev monitor with the Qt4 main loop.
%package -n python2-%{srcname}-qt5
Summary: Qt5 integration for pyudev
Requires: python-qt5
Requires: python2-%{srcname} = %{version}-%{release}
%description -n python2-%{srcname}-qt5
Qt5 integration for pyudev.
This package provides a module pyudev.pyqt5 that contains classes for
integrating a pyudev monitor with the Qt4 main loop.
%package -n python2-%{srcname}-pyside
Summary: PySide integration for pyudev
@ -108,6 +121,9 @@ BuildRequires: python3-setuptools
# Needed for libudev, loaded through ctypes
Requires: systemd-libs
# Used for python2/3 compatibility
Requires: python3-six
%description -n python3-%{srcname}
pyudev is a LGPL licensed, pure Python binding for libudev, the device
and hardware management and information library for Linux. It supports
@ -132,6 +148,18 @@ Qt4 integration for pyudev.
This package provides a module pyudev.pyqt4 that contains classes for
integrating a pyudev monitor with the Qt4 main loop.
%package -n python3-%{srcname}-qt5
Summary: Qt5 integration for pyudev
Requires: python3-qt5
Requires: python3-%{srcname} = %{version}-%{release}
%description -n python3-%{srcname}-qt5
Qt5 integration for pyudev.
This package provides a module pyudev.pyqt5 that contains classes for
integrating a pyudev monitor with the Qt5 main loop.
%prep
%autosetup -n %{srcname}-%{version}
rm -rf pyudev.egg-info
@ -151,6 +179,7 @@ rm -rf pyudev.egg-info
%{python2_sitelib}/pyudev-%{version}-*.egg-info
%exclude %{python2_sitelib}/pyudev/glib.py*
%exclude %{python2_sitelib}/pyudev/pyqt4.py*
%exclude %{python2_sitelib}/pyudev/pyqt5.py*
%exclude %{python2_sitelib}/pyudev/pyside.py*
%exclude %{python2_sitelib}/pyudev/wx.py*
@ -162,6 +191,10 @@ rm -rf pyudev.egg-info
%license COPYING
%{python2_sitelib}/pyudev/pyqt4.py*
%files -n python2-%{srcname}-qt5
%license COPYING
%{python2_sitelib}/pyudev/pyqt5.py*
%files -n python2-%{srcname}-pyside
%license COPYING
%{python2_sitelib}/pyudev/pyside.py*
@ -179,6 +212,8 @@ rm -rf pyudev.egg-info
%exclude %{python3_sitelib}/pyudev/__pycache__/glib.*
%exclude %{python3_sitelib}/pyudev/pyqt4.py
%exclude %{python3_sitelib}/pyudev/__pycache__/pyqt4.*
%exclude %{python3_sitelib}/pyudev/pyqt5.py
%exclude %{python3_sitelib}/pyudev/__pycache__/pyqt5.*
%exclude %{python3_sitelib}/pyudev/pyside.py
%exclude %{python3_sitelib}/pyudev/__pycache__/pyside.*
%exclude %{python3_sitelib}/pyudev/wx.py
@ -189,7 +224,29 @@ rm -rf pyudev.egg-info
%{python3_sitelib}/pyudev/pyqt4.py
%{python3_sitelib}/pyudev/__pycache__/pyqt4.*
%files -n python3-%{srcname}-qt5
%license COPYING
%{python3_sitelib}/pyudev/pyqt5.py
%{python3_sitelib}/pyudev/__pycache__/pyqt5.*
%changelog
* Mon Dec 21 2015 mulhern <amulhern@redhat.com> - 0.18.1
- Restore raising KeyError in astring, asint, asbool methods in Attributes
- Add dependency on six package
- pyudev sources now in src directory
- Added support for pyqt5 monitor observer
- Added discover module, which looks up a device on limited information
- DeviceNotFoundError is no longer a subtype of LookupError
- Attributes class no longer extends Mapping class
- Attributes class no longer inherits [] operator and other Mapping methods
- Attributes class object are no longer iterable or indexable and have no length
- Attributes.available_attributes property added
- Attributes.get() method, with usual semantics explicitly defined
- Device.from_* methods are deprecated, use Devices.from_* methods instead
- Device.from_device_number() now raises DeviceNotFoundByNumberError
- Devices.from_interface_index() method added
- Devices.from_kernel_device() method added
* Thu Dec 3 2015 David Shea <dshea@redhat.com> - 0.17-4
- Add requires for things that are required
- Split the main-loop integration modules into separate packages

View File

@ -1 +1 @@
0450afde50383538a987d16450853fb1 pyudev-0.17.tar.gz
12fd1a4061e5041366bfca921c4de29b pyudev-0.18.1.tar.gz