1bbbad6812
- Force non-blocking IO in pyudev.Monitor to avoid blocking on receiving the device - Set proper flags on pipe fs - Handle irregular polling events properly - Rename MonitorObserver GUI classes and deprecate the old ones - Remove patches for #1170337 and #1230773 that are now part of upstream - Switch to new packaging guidelines which renames python-pyudev to python2-pyudev
24 lines
628 B
Diff
24 lines
628 B
Diff
From 2aa590dcdeb8ced47e801b9fcef084959b8e2bc9 Mon Sep 17 00:00:00 2001
|
|
From: David Shea <dshea@redhat.com>
|
|
Date: Mon, 14 Sep 2015 13:34:17 -0400
|
|
Subject: [PATCH] Do not install the tests as a module.
|
|
|
|
---
|
|
setup.py | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index 1920cec..a8044e9 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -52,5 +52,5 @@
|
|
'Topic :: System :: Hardware',
|
|
'Topic :: System :: Operating System Kernels :: Linux',
|
|
],
|
|
- packages=setuptools.find_packages(),
|
|
+ packages=setuptools.find_packages(exclude=['tests.*', 'tests']),
|
|
)
|
|
--
|
|
2.4.3
|
|
|