- Rebase python-dns to version 2.2.1

Resolves: rhbz#2088661
- Disable DNSSEC tests using SHA1 due to crypto policies
  Resolves: rhbz#2107651
This commit is contained in:
Rafael Guterres Jeffman 2023-01-04 13:47:57 -03:00
parent 4347c18a4f
commit 4805994e38
5 changed files with 43 additions and 8 deletions

View File

@ -14,11 +14,11 @@ diff --git a/tests/test_async.py b/tests/test_async.py
index 0252f22..370c6bb 100644
--- a/tests/test_async.py
+++ b/tests/test_async.py
@@ -38,15 +38,8 @@ try:
@@ -38,15 +38,10 @@ try:
except Exception:
_ssl_available = False
-
-# Some tests require the internet to be available to run, so let's
-# skip those if it's not there.
-_network_available = True
@ -26,12 +26,12 @@ index 0252f22..370c6bb 100644
- socket.gethostbyname('dnspython.org')
-except socket.gaierror:
- _network_available = False
-
+# RHEL 9 build environment does not have provide external network access.
+_network_available = False
# Probe for IPv4 and IPv6
query_addresses = []
# Look for systemd-resolved, as it does dangling CNAME responses incorrectly.
#
diff --git a/tests/test_query.py b/tests/test_query.py
index 2cff377..99dc873 100644
--- a/tests/test_query.py

View File

@ -0,0 +1,27 @@
diff -Naur dnspython-2.2.1-orig/pyproject.toml dnspython-2.2.1/pyproject.toml
--- dnspython-2.2.1-orig/pyproject.toml 2023-01-04 12:32:36.727371811 -0300
+++ dnspython-2.2.1/pyproject.toml 2023-01-04 12:36:36.898599002 -0300
@@ -70,4 +70,3 @@
requires = ["poetry-core"]
build-backend = "poetry.core.masonry.api"
-[tool.setuptools_scm]
diff -Naur dnspython-2.2.1-orig/setup.cfg dnspython-2.2.1/setup.cfg
--- dnspython-2.2.1-orig/setup.cfg 2023-01-04 12:32:36.727371811 -0300
+++ dnspython-2.2.1/setup.cfg 2023-01-04 12:36:24.587382315 -0300
@@ -1,5 +1,6 @@
[metadata]
name = dnspython
+version = 2.2.1
author = Bob Halley
author_email = halley@dnspython.org
license = ISC
@@ -46,7 +47,7 @@
dns.rdtypes.CH
python_requires = >=3.6
test_suite = tests
-setup_requires = setuptools>=44; wheel; setuptools_scm[toml]>=3.4.3
+setup_requires = setuptools>=44
[options.extras_require]
DOH = httpx>=0.21.1; h2>=4.1.0; requests; requests-toolbelt

Binary file not shown.

View File

@ -13,8 +13,8 @@
%endif
Name: python-%{py_package_name}
Version: 2.1.0
Release: 6%{?dist}
Version: 2.2.1
Release: 1%{?dist}
Summary: DNS toolkit for Python
# The entire package is licensed with both licenses, see LICENSE file
@ -23,6 +23,8 @@ URL: http://www.dnspython.org
Source0: https://github.com/rthalley/%{pypi_name}/archive/v%{version}%{rctag}/%{pypi_name}-%{version}%{rctag}.tar.gz
Patch0: 0001-Skip-tests-that-require-external-network-connection_rhbz#1914296.patch
Patch1: 0002-Do-not-build-with-setuptools-scm_rhbz#2088661.patch
Patch2: 0003-Skip-DNSSEC-tests-with-SHA1_rhbz#2107651.patch
BuildArch: noarch
BuildRequires: python3-devel
@ -111,6 +113,12 @@ pytest -k "not testCanonicalNameDangling"
}
%changelog
* Fri Jan 05 2023 Rafael Jeffman <rjeffman@redhat.com> - 2.2.1-1
- Rebase to version 2.2.1
Resolves: rhbz#2088661
- Disable DNSSEC tests using SHA1 due to crypto policies
Resolves: rhbz#2107651
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 2.1.0-6
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
Related: rhbz#1991688

View File

@ -1 +1 @@
SHA512 (dnspython-2.1.0.tar.gz) = eb3ab812eb8769b4780055b801e4f89beb1cb3d3e5a4855e583dca83b794eb7fca8fc3ef401eea7c16c34452e801dec5a2c59304f4041a68c7214dea6076435a
SHA512 (dnspython-2.2.1.tar.gz) = ec545468f604d6131f07259ca154c4f71d445d12c336ac1da0d2f025d6478ada76320a7235119312fed85da071ef309d2531e541d3c2340a50deaf3f4dd7b4eb