import python-dns-1.15.0-7.module+el8+2540+b19c9b35
This commit is contained in:
commit
320230861b
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/dnspython-1.15.0.tar.gz
|
1
.python-dns.metadata
Normal file
1
.python-dns.metadata
Normal file
@ -0,0 +1 @@
|
||||
fcb8edb4b307f68a27cd356e7b44f53512b63b5e SOURCES/dnspython-1.15.0.tar.gz
|
12
SOURCES/test_fails_on_missing_file.patch
Normal file
12
SOURCES/test_fails_on_missing_file.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -ruN /home/avram/Desktop/dnspython-1.15.0.orig/tests/test_zone.py /home/avram/Desktop/dnspython-1.15.0/tests/test_zone.py
|
||||
--- a/tests/test_zone.py 2016-09-20 12:24:02.000000000 -0400
|
||||
+++ b/tests/test_zone.py 2016-10-04 07:59:39.717946790 -0400
|
||||
@@ -177,7 +177,7 @@
|
||||
def testToFileFilename(self):
|
||||
z = dns.zone.from_file(here('example'), 'example')
|
||||
try:
|
||||
- z.to_file('example3-filename.out')
|
||||
+ z.to_file(here('example3-filename.out'))
|
||||
ok = filecmp.cmp(here('example3-filename.out'),
|
||||
here('example3.good'))
|
||||
finally:
|
114
SPECS/python-dns.spec
Normal file
114
SPECS/python-dns.spec
Normal file
@ -0,0 +1,114 @@
|
||||
%global with_python3 0
|
||||
|
||||
Name: python-dns
|
||||
Version: 1.15.0
|
||||
Release: 7%{?dist}
|
||||
Summary: DNS toolkit for Python
|
||||
|
||||
Group: Development/Languages
|
||||
License: MIT
|
||||
URL: http://www.dnspython.org/
|
||||
|
||||
Source0: http://www.dnspython.org/kits/%{version}/dnspython-%{version}.tar.gz
|
||||
|
||||
BuildArch: noarch
|
||||
Patch0: test_fails_on_missing_file.patch
|
||||
|
||||
Provides: python2-dns = %{version}-%{release}
|
||||
BuildRequires: python2-devel
|
||||
BuildRequires: python2-setuptools
|
||||
|
||||
%if 0%{?with_python3}
|
||||
BuildRequires: python%{python3_pkgversion}-devel
|
||||
BuildRequires: python%{python3_pkgversion}-setuptools
|
||||
%endif
|
||||
|
||||
%description
|
||||
dnspython is a DNS toolkit for Python. It supports almost all record
|
||||
types. It can be used for queries, zone transfers, and dynamic
|
||||
updates. It supports TSIG authenticated messages and EDNS0.
|
||||
|
||||
dnspython provides both high and low level access to DNS. The high
|
||||
level classes perform queries for data of a given name, type, and
|
||||
class, and return an answer set. The low level classes allow direct
|
||||
manipulation of DNS zones, messages, names, and records.
|
||||
|
||||
%package -n python2-dns
|
||||
Summary: DNS toolkit for Python 2
|
||||
Group: Development/Languages
|
||||
%{?python_provide:%python_provide python2-dns}
|
||||
|
||||
%description -n python2-dns
|
||||
dnspython is a DNS toolkit for Python. It supports almost all record
|
||||
types. It can be used for queries, zone transfers, and dynamic
|
||||
updates. It supports TSIG authenticated messages and EDNS0.
|
||||
|
||||
dnspython provides both high and low level access to DNS. The high
|
||||
level classes perform queries for data of a given name, type, and
|
||||
class, and return an answer set. The low level classes allow direct
|
||||
manipulation of DNS zones, messages, names, and records.
|
||||
|
||||
%if 0%{?with_python3}
|
||||
%package -n python%{python3_pkgversion}-dns
|
||||
Summary: DNS toolkit for Python 3
|
||||
Group: Development/Languages
|
||||
%{?python_provide:%python_provide python%{python3_pkgversion}-dns}
|
||||
|
||||
%description -n python%{python3_pkgversion}-dns
|
||||
dnspython3 is a DNS toolkit for Python 3. It supports almost all
|
||||
record types. It can be used for queries, zone transfers, and dynamic
|
||||
updates. It supports TSIG authenticated messages and EDNS0.
|
||||
|
||||
dnspython3 provides both high and low level access to DNS. The high
|
||||
level classes perform queries for data of a given name, type, and
|
||||
class, and return an answer set. The low level classes allow direct
|
||||
manipulation of DNS zones, messages, names, and records.
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%setup -q -n dnspython-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
# strip exec permissions so that we don't pick up dependencies from docs
|
||||
find examples -type f | xargs chmod a-x
|
||||
|
||||
%build
|
||||
%py2_build
|
||||
|
||||
%if 0%{?with_python3}
|
||||
%py3_build
|
||||
%endif
|
||||
|
||||
%install
|
||||
%py2_install
|
||||
|
||||
%if 0%{?with_python3}
|
||||
%py3_install
|
||||
%endif
|
||||
|
||||
%check
|
||||
%{__python2} setup.py test
|
||||
|
||||
%if 0%{?with_python3}
|
||||
%{__python3} setup.py test
|
||||
%endif
|
||||
|
||||
%files -n python2-dns
|
||||
%defattr(-,root,root,-)
|
||||
# Add README.* when it is included with the source (commit a906279)
|
||||
%doc {ChangeLog,LICENSE,examples}
|
||||
%{python2_sitelib}/*egg-info
|
||||
%{python2_sitelib}/dns
|
||||
|
||||
%if 0%{?with_python3}
|
||||
%files -n python%{python3_pkgversion}-dns
|
||||
%defattr(-,root,root,-)
|
||||
# Add README.* when it is included with the source (commit a906279)
|
||||
%doc {ChangeLog,LICENSE,examples}
|
||||
%{python3_sitelib}/*egg-info
|
||||
%{python3_sitelib}/dns
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jul 18 2018 Lumír Balhar <lbalhar@redhat.com> - 1.15.0-8
|
||||
- First version for python27 module
|
Loading…
Reference in New Issue
Block a user