ppc64-diag/ppc64-diag-2.4.2-messagecatalog-location.patch
Vasant Hegde 469091fa69 Fix minor build issue. Also install PRRN hotplug script
into proper location.

Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
2013-09-15 17:28:52 +05:30

63 lines
3.2 KiB
Diff

diff -up ppc64-diag-2.4.2/ela/Makefile.msg_loc ppc64-diag-2.4.2/ela/Makefile
--- ppc64-diag-2.4.2/ela/Makefile.msg_loc 2011-06-29 10:50:51.000000000 -0400
+++ ppc64-diag-2.4.2/ela/Makefile 2011-09-09 14:51:01.000000000 -0400
@@ -72,17 +72,17 @@ catalogs.o: catalogs.h
install: all
@$(call install_sbin,$(CMDS),$(DESTDIR))
- @$(call install_files,$(CATALOG),744,$(DESTDIR)/etc/ppc64-diag/message_catalog)
- @$(call install_files,$(CATALOG_REGEX),744,$(DESTDIR)/etc/ppc64-diag/message_catalog/with_regex)
+ @$(call install_files,$(CATALOG),744,$(DESTDIR)/usr/share/ppc64-diag/message_catalog)
+ @$(call install_files,$(CATALOG_REGEX),744,$(DESTDIR)/usr/share/ppc64-diag/message_catalog/with_regex)
@$(call install_man,$(MANPAGES),$(DESTDIR))
- $(INSTALL) -d -m 755 $(DESTDIR)/var/log/ppc64-diag
+ $(INSTALL) -d -m 755 $(DESTDIR)/var/log/ppc64-diag
clean:
@rm -rf $(CMDS) *.o lex.*.c *.tab.c *.tab.h
uninstall:
@$(call uninstall_sbin,$(CMDS),$(DESTDIR))
- @$(call uninstall_files,$(CATALOG),$(DESTDIR)/etc/ppc64-diag/)
- @$(call uninstall_files,$(CATALOG_REGEX),$(DESTDIR)/etc/ppc64-diag/)
+ @$(call uninstall_files,$(CATALOG),$(DESTDIR)/usr/share/ppc64-diag/)
+ @$(call uninstall_files,$(CATALOG_REGEX),$(DESTDIR)/usr/share/ppc64-diag/)
@$(call uninstall_man,$(MANPAGES),$(DESTDIR)/usr/share/man/man8)
diff -up ppc64-diag-2.4.2/ela/catalogs.h.msg_loc ppc64-diag-2.4.2/ela/catalogs.h
--- ppc64-diag-2.4.2/ela/catalogs.h.msg_loc 2011-02-23 17:55:31.000000000 -0500
+++ ppc64-diag-2.4.2/ela/catalogs.h 2011-09-09 14:50:12.000000000 -0400
@@ -21,7 +21,7 @@ using namespace std;
#include <stdio.h>
#include <regex.h>
-#define ELA_CATALOG_DIR "/etc/ppc64-diag/message_catalog"
+#define ELA_CATALOG_DIR "/usr/share/ppc64-diag/message_catalog"
class Parser {
protected:
diff -up ppc64-diag-2.4.2/ela/explain_syslog.cpp.msg_loc ppc64-diag-2.4.2/ela/explain_syslog.cpp
--- ppc64-diag-2.4.2/ela/explain_syslog.cpp.msg_loc 2011-02-22 14:27:02.000000000 -0500
+++ ppc64-diag-2.4.2/ela/explain_syslog.cpp 2011-09-09 14:50:12.000000000 -0400
@@ -94,7 +94,7 @@ print_help(void)
printf(
"-b begin_time\tIgnore messages with timestamps prior to begin_time.\n"
"-C catalog_dir\tUse message catalog in catalog_dir. Defaults to\n"
-"\t\t\t/etc/ppc64-diag/message_catalog.\n"
+"\t\t\t/usr/share/ppc64-diag/message_catalog.\n"
"-d\t\tPrint debugging output on stderr.\n"
"-e end_time\tStop upon reading message with timestamp after end_time.\n"
"-h\t\tPrint this help text and exit.\n"
diff -up ppc64-diag-2.4.2/ela/syslog_to_svclog.cpp.msg_loc ppc64-diag-2.4.2/ela/syslog_to_svclog.cpp
--- ppc64-diag-2.4.2/ela/syslog_to_svclog.cpp.msg_loc 2011-07-11 05:43:41.000000000 -0400
+++ ppc64-diag-2.4.2/ela/syslog_to_svclog.cpp 2011-09-09 14:50:12.000000000 -0400
@@ -654,7 +654,7 @@ print_help(void)
printf(
"-b begin_time\tIgnore messages with timestamps prior to begin_time.\n"
"-C catalog_dir\tUse message catalog in catalog_dir. Defaults to\n"
-"\t\t\t/etc/ppc64-diag/message_catalog.\n"
+"\t\t\t/usr/share/ppc64-diag/message_catalog.\n"
"-d\t\tPrint debugging output on stderr.\n"
"-e end_time\tStop upon reading message with timestamp after end_time.\n"
"-F\t\tDon't stop at EOF; process newly logged messages as they occur.\n"