Fix minor build issue. Also install PRRN hotplug script

into proper location.

Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
This commit is contained in:
Vasant Hegde 2013-09-15 17:28:52 +05:30
parent 4b56bbd3cf
commit 469091fa69
3 changed files with 57 additions and 3 deletions

View File

@ -10,7 +10,7 @@ diff -up ppc64-diag-2.4.2/ela/Makefile.msg_loc ppc64-diag-2.4.2/ela/Makefile
+ @$(call install_files,$(CATALOG),744,$(DESTDIR)/usr/share/ppc64-diag/message_catalog)
+ @$(call install_files,$(CATALOG_REGEX),744,$(DESTDIR)/usr/share/ppc64-diag/message_catalog/with_regex)
@$(call install_man,$(MANPAGES),$(DESTDIR))
- $(INSTALL) -d -m 755 /var/log/ppc64-diag
- $(INSTALL) -d -m 755 $(DESTDIR)/var/log/ppc64-diag
+ $(INSTALL) -d -m 755 $(DESTDIR)/var/log/ppc64-diag
clean:

View File

@ -0,0 +1,48 @@
From ee73019f875b15e011f5af2c41386f780b5a65cb Mon Sep 17 00:00:00 2001
From: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
Date: Sun, 15 Sep 2013 17:13:57 +0530
Subject: [PATCH] Fix PRRN hotplug script location
Install PRRN Hotplug scripts into proper directory.
Signed-off-by: Vasant Hegde <hegdevasant@linux.vnet.ibm.com>
---
rtas_errd/Makefile | 4 ++--
rtas_errd/prrn.c | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/rtas_errd/Makefile b/rtas_errd/Makefile
index d5427d5..a255979 100644
--- a/rtas_errd/Makefile
+++ b/rtas_errd/Makefile
@@ -38,12 +38,12 @@ extract_platdump: $(EXTRACT_PLATDUMP_OBJS)
install: all
@$(call install_sbin,$(CMDS),$(DESTDIR))
@$(call install_files,$(SCRIPTS),744,$(DESTDIR)/etc)
- @$(call install_files,$(PRRN_HOTPLUG),744,$(DESTDIR)/etc/ppc64-diag)
+ @$(call install_files,$(PRRN_HOTPLUG),744,$(DESTDIR)/usr/libexec/ppc64-diag)
uninstall:
@$(call uninstall_sbin,$(CMDS),$(DESTDIR))
@$(call uninstall_files,$(SCRIPTS),$(DESTDIR)/etc)
- @$(call uninstall_files,$(PRRN_HOTPLUG),$(DESTDIR)/etc/ppc64-diag)
+ @$(call uninstall_files,$(PRRN_HOTPLUG),$(DESTDIR)/usr/libexec/ppc64-diag)
doc: $(DOXYGEN_CFG)
@echo "Creating doxygen docs..."
diff --git a/rtas_errd/prrn.c b/rtas_errd/prrn.c
index 8bfe7ac..71cebb9 100644
--- a/rtas_errd/prrn.c
+++ b/rtas_errd/prrn.c
@@ -39,7 +39,7 @@ static int prrn_log_fd = -1;
#define OFDT_BASE "/proc/device-tree"
#define OFDTPATH "/proc/ppc64/ofdt"
-#define PRRN_HOTPLUG "/etc/ppc64-diag/prrn_hotplug"
+#define PRRN_HOTPLUG "/usr/libexec/ppc64-diag/prrn_hotplug"
#define DRCONF_PATH "/proc/device-tree/ibm,dynamic-reconfiguration-memory/ibm,dynamic-memory"
static int write_prrn_log(const char *buf, int len)
--
1.7.11.7

View File

@ -1,6 +1,6 @@
Name: ppc64-diag
Version: 2.6.2
Release: 1%{?dist}
Release: 2%{?dist}
Summary: PowerLinux Platform Diagnostics
URL: http://sourceforge.net/projects/linux-diag/files/ppc64-diag/
Group: System Environment/Base
@ -22,6 +22,7 @@ Patch1: ppc64-diag-2.4.2-chkconfig.patch
Patch2: ppc64-diag-2.4.3-scriptlocation.patch
Patch3: ppc64-diag-unusedvar.patch
Patch4: ppc64-diag-2.6.1-lpdscriptloc.patch
Patch5: ppc64-diag-2.6.2-prrnscriptloc.patch
%description
This package contains various diagnostic tools for PowerLinux.
@ -43,6 +44,7 @@ administrators or connected service frameworks.
%patch2 -p1 -b .script_loc
%patch3 -p1 -b .unusevar
%patch4 -p1 -b .lpdscriptloc
%patch5 -p1 -b .prrnscriptloc
%build
make %{?_smp_mflags}
@ -68,7 +70,6 @@ rm -rf $RPM_BUILD_ROOT
%dir %{_sysconfdir}/%{name}/ses_pages
%{_mandir}/man8/*
%config(noreplace) %attr(644,root,root) %{_sysconfdir}/%{name}/ppc64-diag.config
%attr(744,root,root) %{_sysconfdir}/%{name}/prrn_hotplug
%attr(755,root,root) %{_sbindir}/*
%dir %{_datadir}/%{name}
%dir %attr(755,root,root) %{_datadir}/%{name}/message_catalog/
@ -79,6 +80,7 @@ rm -rf $RPM_BUILD_ROOT
%attr(755,root,root) %{_libexecdir}/%{name}/ppc64_diag_setup
%attr(755,root,root) %{_libexecdir}/%{name}/lp_diag_setup
%attr(755,root,root) %{_libexecdir}/%{name}/lp_diag_notify
%attr(744,root,root) %{_libexecdir}/%{name}/prrn_hotplug
%attr(644,root,root) %{_libexecdir}/%{name}/servevent_parse.pl
%attr(644,root,root) %{_datadir}/%{name}/message_catalog/cxgb3
%attr(644,root,root) %{_datadir}/%{name}/message_catalog/e1000e
@ -118,6 +120,10 @@ fi
%changelog
* Sun Sep 15 2013 Vasant Hegde <hegdevasant@linux.vnet.ibm.com> - 2.6.2-2
- Fix minor build issue.
- Fix PRRN hotplug script location issue
* Wed Aug 21 2013 Vasant Hegde <hegdevasant@linux.vnet.ibm.com> - 2.6.2
- Update to latest upstream 2.6.2