34 lines
992 B
Diff
34 lines
992 B
Diff
diff --git a/src/Makefile b/src/Makefile
|
|
index 977f80b..3d3b679 100644
|
|
--- a/src/Makefile
|
|
+++ b/src/Makefile
|
|
@@ -20,7 +20,6 @@ SUBDIRS = \
|
|
backend/utils/mb/conversion_procs \
|
|
backend/snowball \
|
|
include \
|
|
- interfaces \
|
|
backend/replication/libpqwalreceiver \
|
|
fe_utils \
|
|
bin \
|
|
diff --git a/src/Makefile.global.in b/src/Makefile.global.in
|
|
index d280a2d..724f3cf 100644
|
|
--- a/src/Makefile.global.in
|
|
+++ b/src/Makefile.global.in
|
|
@@ -454,7 +454,7 @@ endif
|
|
|
|
# This macro is for use by libraries linking to libpq. (Because libpgport
|
|
# isn't created with the same link flags as libpq, it can't be used.)
|
|
-libpq = -L$(libpq_builddir) -lpq
|
|
+libpq = -lpq
|
|
|
|
# This macro is for use by client executables (not libraries) that use libpq.
|
|
# We force clients to pull symbols from the non-shared libraries libpgport
|
|
@@ -480,7 +480,6 @@ endif
|
|
# Commonly used submake targets
|
|
|
|
submake-libpq:
|
|
- $(MAKE) -C $(libpq_builddir) all
|
|
|
|
submake-libpgport:
|
|
$(MAKE) -C $(top_builddir)/src/port all
|