postgresql/postgresql-no-libecpg.patch
Honza Horak 4663183844 Build with a private libpq
Related: #1967918
Also discussed in Fedora bug #1905584

Some extensions require to build with libpq as well, but this might be
a problem for the case server uses a private libpq, because extension
would pull in another libpq.so into the same process.

By adding new sub-packages private-libs and private-devel we can make sure
only a single copy of libpq is used by server, including the extensions.

Add dependency to libpq-devel to server-devel pkg if external libpq is used
in order to let extensions not to care about what libpq the server uses.
2021-06-16 16:04:32 +02:00

13 lines
431 B
Diff

diff -up postgresql-13.1/src/interfaces/Makefile.patch10 postgresql-13.1/src/interfaces/Makefile
--- postgresql-13.1/src/interfaces/Makefile.patch10 2021-02-02 21:33:23.235292305 +0100
+++ postgresql-13.1/src/interfaces/Makefile 2021-02-02 21:33:30.281365440 +0100
@@ -12,7 +12,7 @@ subdir = src/interfaces
top_builddir = ../..
include $(top_builddir)/src/Makefile.global
-SUBDIRS = libpq ecpg
+SUBDIRS = libpq
$(recurse)