3ab1d6bb3f
be turned for routine timezone updates.
60 lines
2.7 KiB
Diff
60 lines
2.7 KiB
Diff
PostgreSQL includes its own copy of the zic timezone database, which is great
|
|
for ensuring portable results but not so great from a package maintenance
|
|
perspective. Since the data is in the same format as is provided by the
|
|
Linux-standard /usr/share/zoneinfo files, we can avoid having to update
|
|
postgresql for timezone updates by just symlinking to those files.
|
|
|
|
It is allegedly desirable for the link in question to be a relative symlink.
|
|
I have strong doubts about this, not least because it requires the horrid
|
|
install-time kluge seen below --- we can't use a simple relative symlink when
|
|
making the temporary installation used for "make check", since that will be at
|
|
an indeterminate location compared to /usr/share. The actual relative link
|
|
also depends fundamentally upon knowing where the PG datadir will get
|
|
installed, namely /usr/share/pgsql.
|
|
|
|
And if you thought that was bad, it turns out that RPM has some fundamental
|
|
bugs that make it difficult or impossible to replace a directory with a
|
|
symlink during RPM upgrade. Rather than risk getting caught in that quagmire,
|
|
we choose to name the symlink something different than its predecessor
|
|
subdirectory. (This part of the hack could perhaps get undone someday, when
|
|
there is no longer any danger of someone trying to rpm-upgrade from an
|
|
installation that isn't patched this way.)
|
|
|
|
|
|
diff -Naur postgresql-8.2.4.orig/src/timezone/Makefile postgresql-8.2.4/src/timezone/Makefile
|
|
--- postgresql-8.2.4.orig/src/timezone/Makefile 2007-03-14 13:38:15.000000000 -0400
|
|
+++ postgresql-8.2.4/src/timezone/Makefile 2007-08-22 16:57:41.000000000 -0400
|
|
@@ -38,14 +38,18 @@
|
|
$(CC) $(CFLAGS) $(ZICOBJS) $(LDFLAGS) $(LIBS) -o $@$(X)
|
|
|
|
install: all installdirs
|
|
- ./zic -d '$(DESTDIR)$(datadir)/timezone' -p '$(POSIXRULES)' $(TZDATAFILES)
|
|
+ if [ x'$(DESTDIR)' = x`echo '$(DESTDIR)' | sed 's,tmp_check/install,,'` ] ; then \
|
|
+ ln -s '../zoneinfo' '$(DESTDIR)$(datadir)/zoneinfo' ; \
|
|
+ else \
|
|
+ ln -s '/usr/share/zoneinfo' '$(DESTDIR)$(datadir)/zoneinfo' ; \
|
|
+ fi
|
|
$(MAKE) -C tznames $@
|
|
|
|
installdirs:
|
|
$(mkinstalldirs) '$(DESTDIR)$(datadir)'
|
|
|
|
uninstall:
|
|
- rm -rf '$(DESTDIR)$(datadir)/timezone'
|
|
+ rm '$(DESTDIR)$(datadir)/zoneinfo'
|
|
$(MAKE) -C tznames $@
|
|
|
|
clean distclean maintainer-clean:
|
|
diff -Naur postgresql-8.2.4.orig/src/timezone/pgtz.c postgresql-8.2.4/src/timezone/pgtz.c
|
|
--- postgresql-8.2.4.orig/src/timezone/pgtz.c 2006-11-21 18:11:55.000000000 -0500
|
|
+++ postgresql-8.2.4/src/timezone/pgtz.c 2007-08-22 16:57:04.000000000 -0400
|
|
@@ -52,7 +52,7 @@
|
|
return tzdir;
|
|
|
|
get_share_path(my_exec_path, tzdir);
|
|
- strlcpy(tzdir + strlen(tzdir), "/timezone", MAXPGPATH - strlen(tzdir));
|
|
+ strlcpy(tzdir + strlen(tzdir), "/zoneinfo", MAXPGPATH - strlen(tzdir));
|
|
|
|
done_tzdir = true;
|
|
return tzdir;
|