Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/postgresql.git#8784e334e155766a725384a923da696750fe67a9
This commit is contained in:
parent
bc899ee692
commit
f04a1cf141
@ -3,10 +3,10 @@ PostgreSQL ecpg/initdb manual page fixes
|
||||
This was generated based on automatic Red Hat manual page scan (private
|
||||
RHBZ#948933).
|
||||
|
||||
diff -up ./doc/src/sgml/man1/ecpg.1.man948933 ./doc/src/sgml/man1/ecpg.1
|
||||
--- ./doc/src/sgml/man1/ecpg.1.man948933 2014-12-16 02:13:15.000000000 +0100
|
||||
+++ ./doc/src/sgml/man1/ecpg.1 2014-12-23 11:26:37.883644047 +0100
|
||||
@@ -80,6 +80,11 @@ INFORMIX_SE\&.
|
||||
diff -up postgresql-13.1/doc/src/sgml/man1/ecpg.1.patch6 postgresql-13.1/doc/src/sgml/man1/ecpg.1
|
||||
--- postgresql-13.1/doc/src/sgml/man1/ecpg.1.patch6 2020-11-09 23:38:03.000000000 +0100
|
||||
+++ postgresql-13.1/doc/src/sgml/man1/ecpg.1 2020-11-18 09:26:40.547324791 +0100
|
||||
@@ -81,6 +81,11 @@ ORACLE\&.
|
||||
Define a C preprocessor symbol\&.
|
||||
.RE
|
||||
.PP
|
||||
@ -15,10 +15,10 @@ diff -up ./doc/src/sgml/man1/ecpg.1.man948933 ./doc/src/sgml/man1/ecpg.1
|
||||
+Parse a header file, this option includes option \fB\-c\fR\&.
|
||||
+.RE
|
||||
+.PP
|
||||
\fB\-i\fR
|
||||
\fB\-h\fR
|
||||
.RS 4
|
||||
Parse system include files as well\&.
|
||||
@@ -128,6 +133,11 @@ Allow question mark as placeholder for c
|
||||
Process header files\&. When this option is specified, the output file extension becomes
|
||||
@@ -144,6 +149,11 @@ Allow question mark as placeholder for c
|
||||
.RE
|
||||
.RE
|
||||
.PP
|
||||
@ -30,10 +30,10 @@ diff -up ./doc/src/sgml/man1/ecpg.1.man948933 ./doc/src/sgml/man1/ecpg.1
|
||||
\fB\-t\fR
|
||||
.RS 4
|
||||
Turn on autocommit of transactions\&. In this mode, each SQL command is automatically committed unless it is inside an explicit transaction block\&. In the default mode, commands are committed only when
|
||||
diff -up ./doc/src/sgml/man1/initdb.1.man948933 ./doc/src/sgml/man1/initdb.1
|
||||
--- ./doc/src/sgml/man1/initdb.1.man948933 2014-12-16 02:13:21.000000000 +0100
|
||||
+++ ./doc/src/sgml/man1/initdb.1 2014-12-23 11:26:37.883644047 +0100
|
||||
@@ -281,6 +281,13 @@ determines that an error prevented it fr
|
||||
diff -up postgresql-13.1/doc/src/sgml/man1/initdb.1.patch6 postgresql-13.1/doc/src/sgml/man1/initdb.1
|
||||
--- postgresql-13.1/doc/src/sgml/man1/initdb.1.patch6 2020-11-09 23:38:05.000000000 +0100
|
||||
+++ postgresql-13.1/doc/src/sgml/man1/initdb.1 2020-11-18 09:25:05.082348424 +0100
|
||||
@@ -311,6 +311,13 @@ determines that an error prevented it fr
|
||||
.PP
|
||||
Other options:
|
||||
.PP
|
||||
|
@ -6,11 +6,10 @@ rhbz#1618698 change, rather provide pg_server_config binary, which int urn means
|
||||
that we'll have to fix only a minimal set of packages which really build
|
||||
PostgreSQL server modules.
|
||||
|
||||
diff --git a/src/bin/pg_config/Makefile b/src/bin/pg_config/Makefile
|
||||
index 02e6f9d..f7c844f 100644
|
||||
--- a/src/bin/pg_config/Makefile
|
||||
+++ b/src/bin/pg_config/Makefile
|
||||
@@ -11,28 +11,30 @@
|
||||
diff -up postgresql-13.1/src/bin/pg_config/Makefile.patch9 postgresql-13.1/src/bin/pg_config/Makefile
|
||||
--- postgresql-13.1/src/bin/pg_config/Makefile.patch9 2020-11-18 09:28:30.885453275 +0100
|
||||
+++ postgresql-13.1/src/bin/pg_config/Makefile 2020-11-18 09:31:33.926325327 +0100
|
||||
@@ -11,6 +11,8 @@
|
||||
PGFILEDESC = "pg_config - report configuration information"
|
||||
PGAPPICON=win32
|
||||
|
||||
@ -19,8 +18,9 @@ index 02e6f9d..f7c844f 100644
|
||||
subdir = src/bin/pg_config
|
||||
top_builddir = ../../..
|
||||
include $(top_builddir)/src/Makefile.global
|
||||
|
||||
OBJS= pg_config.o $(WIN32RES)
|
||||
@@ -19,22 +21,22 @@ OBJS = \
|
||||
$(WIN32RES) \
|
||||
pg_config.o
|
||||
|
||||
-all: pg_config
|
||||
+all: $(PG_CONFIG)
|
||||
@ -43,17 +43,16 @@ index 02e6f9d..f7c844f 100644
|
||||
|
||||
clean distclean maintainer-clean:
|
||||
- rm -f pg_config$(X) $(OBJS)
|
||||
+ rm -f $(PG_CONFIG) $(OBJS)
|
||||
+ rm -f $(PG_CONFIG) $(OBJS)
|
||||
rm -rf tmp_check
|
||||
|
||||
check:
|
||||
diff --git a/src/bin/pg_config/nls.mk b/src/bin/pg_config/nls.mk
|
||||
index 1d41f90..0f34f37 100644
|
||||
--- a/src/bin/pg_config/nls.mk
|
||||
+++ b/src/bin/pg_config/nls.mk
|
||||
diff -up postgresql-13.1/src/bin/pg_config/nls.mk.patch9 postgresql-13.1/src/bin/pg_config/nls.mk
|
||||
--- postgresql-13.1/src/bin/pg_config/nls.mk.patch9 2020-11-18 09:28:30.885453275 +0100
|
||||
+++ postgresql-13.1/src/bin/pg_config/nls.mk 2020-11-18 09:32:00.735599526 +0100
|
||||
@@ -1,4 +1,4 @@
|
||||
# src/bin/pg_config/nls.mk
|
||||
-CATALOG_NAME = pg_config
|
||||
+CATALOG_NAME = pg_server_config
|
||||
AVAIL_LANGUAGES = cs de es fr he it ja ko pl pt_BR ro ru sv tr uk vi zh_CN zh_TW
|
||||
AVAIL_LANGUAGES = cs de es fr he it ja ko pl pt_BR ru sv tr uk vi zh_CN
|
||||
GETTEXT_FILES = pg_config.c ../../common/config_info.c ../../common/exec.c
|
||||
|
@ -42,12 +42,12 @@ diff --git a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h
|
||||
index e278fa0..9ee15d4 100644
|
||||
--- a/src/include/pg_config_manual.h
|
||||
+++ b/src/include/pg_config_manual.h
|
||||
@@ -169,7 +169,7 @@
|
||||
* here's where to twiddle it. You can also override this at runtime
|
||||
* with the postmaster's -k switch.
|
||||
@@ -201,7 +201,7 @@
|
||||
* support them yet.
|
||||
*/
|
||||
#ifndef WIN32
|
||||
-#define DEFAULT_PGSOCKET_DIR "/tmp"
|
||||
+#define DEFAULT_PGSOCKET_DIR "/var/run/postgresql"
|
||||
|
||||
/*
|
||||
* This is the default event source for Windows event log.
|
||||
#else
|
||||
#define DEFAULT_PGSOCKET_DIR ""
|
||||
#endif
|
||||
|
@ -59,8 +59,8 @@
|
||||
|
||||
Summary: PostgreSQL client programs
|
||||
Name: postgresql
|
||||
%global majorversion 12
|
||||
Version: %{majorversion}.5
|
||||
%global majorversion 13
|
||||
Version: %{majorversion}.2
|
||||
Release: 1%{?dist}
|
||||
|
||||
# The PostgreSQL license is very similar to other MIT licenses, but the OSI
|
||||
@ -72,8 +72,8 @@ Url: http://www.postgresql.org/
|
||||
# in-place upgrade of an old database. In most cases it will not be critical
|
||||
# that this be kept up with the latest minor release of the previous series;
|
||||
# but update when bugs affecting pg_dump output are fixed.
|
||||
%global prevmajorversion 11
|
||||
%global prevversion %{prevmajorversion}.10
|
||||
%global prevmajorversion 12
|
||||
%global prevversion %{prevmajorversion}.6
|
||||
%global prev_prefix %{_libdir}/pgsql/postgresql-%{prevmajorversion}
|
||||
%global precise_version %{?epoch:%epoch:}%version-%release
|
||||
|
||||
@ -108,7 +108,6 @@ Patch2: postgresql-logging.patch
|
||||
Patch5: postgresql-var-run-socket.patch
|
||||
Patch8: postgresql-external-libpq.patch
|
||||
Patch9: postgresql-server-pg_config.patch
|
||||
Patch10: postgresql-12.5-contrib-dblink-expected-out.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: gcc
|
||||
@ -300,6 +299,7 @@ Summary: The Perl procedural language for PostgreSQL
|
||||
Requires: %{name}-server%{?_isa} = %precise_version
|
||||
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
|
||||
%if %runselftest
|
||||
BuildRequires: perl(Opcode)
|
||||
BuildRequires: perl(Data::Dumper)
|
||||
%endif
|
||||
|
||||
@ -393,7 +393,6 @@ goal of accelerating analytics queries.
|
||||
%patch5 -p1
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
|
||||
# We used to run autoconf here, but there's no longer any real need to,
|
||||
# since Postgres ships with a reasonably modern configure script.
|
||||
@ -441,10 +440,6 @@ cd ..
|
||||
# Fiddling with CFLAGS.
|
||||
|
||||
CFLAGS="${CFLAGS:-%optflags}"
|
||||
%ifarch %{power64}
|
||||
# See the bug #1051075, ppc64 should benefit from -O3
|
||||
CFLAGS=`echo $CFLAGS | xargs -n 1 | sed 's|-O2|-O3|g' | xargs -n 100`
|
||||
%endif
|
||||
# Strip out -ffast-math from CFLAGS....
|
||||
CFLAGS=`echo $CFLAGS|xargs -n 1|grep -v ffast-math|xargs -n 100`
|
||||
export CFLAGS
|
||||
@ -867,7 +862,7 @@ find_lang_bins ()
|
||||
find_lang_bins devel.lst pg_server_config
|
||||
find_lang_bins server.lst \
|
||||
initdb pg_basebackup pg_controldata pg_ctl pg_resetwal pg_rewind plpgsql \
|
||||
postgres pg_checksums
|
||||
postgres pg_checksums pg_verifybackup
|
||||
find_lang_bins contrib.lst \
|
||||
pg_archivecleanup pg_test_fsync pg_test_timing pg_waldump
|
||||
find_lang_bins main.lst \
|
||||
@ -1117,6 +1112,7 @@ make -C postgresql-setup-%{setup_version} check
|
||||
%{_bindir}/pg_resetwal
|
||||
%{_bindir}/pg_rewind
|
||||
%{_bindir}/pg_checksums
|
||||
%{_bindir}/pg_verifybackup
|
||||
%{_bindir}/postgres
|
||||
%{_bindir}/postgresql-setup
|
||||
%{_bindir}/postgresql-upgrade
|
||||
@ -1128,8 +1124,6 @@ make -C postgresql-setup-%{setup_version} check
|
||||
%{_datadir}/pgsql/extension/plpgsql*
|
||||
%{_datadir}/pgsql/information_schema.sql
|
||||
%{_datadir}/pgsql/postgres.bki
|
||||
%{_datadir}/pgsql/postgres.description
|
||||
%{_datadir}/pgsql/postgres.shdescription
|
||||
%{_datadir}/pgsql/snowball_create.sql
|
||||
%{_datadir}/pgsql/sql_features.txt
|
||||
%{_datadir}/pgsql/system_views.sql
|
||||
@ -1159,6 +1153,7 @@ make -C postgresql-setup-%{setup_version} check
|
||||
%{_mandir}/man1/pg_resetwal.*
|
||||
%{_mandir}/man1/pg_rewind.*
|
||||
%{_mandir}/man1/pg_checksums.*
|
||||
%{_mandir}/man1/pg_verifybackup.*
|
||||
%{_mandir}/man1/postgres.*
|
||||
%{_mandir}/man1/postgresql-new-systemd-unit.*
|
||||
%{_mandir}/man1/postgresql-setup.*
|
||||
@ -1229,7 +1224,9 @@ make -C postgresql-setup-%{setup_version} check
|
||||
|
||||
%if %plperl
|
||||
%files plperl -f plperl.lst
|
||||
%{_datadir}/pgsql/extension/bool_plperl*
|
||||
%{_datadir}/pgsql/extension/plperl*
|
||||
%{_libdir}/pgsql/bool_plperl.so
|
||||
%{_libdir}/pgsql/plperl.so
|
||||
%endif
|
||||
|
||||
@ -1263,6 +1260,15 @@ make -C postgresql-setup-%{setup_version} check
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Feb 16 2021 Honza Horak <hhorak@redhat.com> - 13.2-1
|
||||
- Update to 13.2
|
||||
|
||||
* Fri Feb 12 2021 Michal Schorm <mschorm@redhat.com> - 13.1-2
|
||||
- Remove ancient PPC64 hack
|
||||
|
||||
* Wed Jan 13 2021 Honza Horak <hhorak@redhat.com> - 13.1-1
|
||||
- Rebase to usptream release 13.1
|
||||
|
||||
* Wed Jan 13 2021 Patrik Novotný <panovotn@redhat.com> - 12.5-1
|
||||
- Rebase to upstream release 12.5
|
||||
Patch for libpq 13.x build time compatibility
|
||||
|
@ -1 +1 @@
|
||||
d /var/run/postgresql 0755 postgres postgres -
|
||||
d /run/postgresql 0755 postgres postgres -
|
||||
|
10
sources
10
sources
@ -1,6 +1,6 @@
|
||||
SHA512 (postgresql-11.10.tar.bz2) = 0cc0e9b0f76e00727dc699ea59a45d760d37d91ec736a62cbc9bda3e38eb1ef1565e4e399dd3ae96bad87f866e56e364f916de7740d8be6e1cfc2bf654dfbb68
|
||||
SHA512 (postgresql-11.10.tar.bz2.sha256) = 18ed6c3b51010a62bd0cffa600a23b5c2630bdc0f97fc207212d22be54c1977b53dcacbe7117a8dd5621245ef730e94278cb76bec219ad2767aeefd0f76c2b19
|
||||
SHA512 (postgresql-12.5.tar.bz2) = 9895bcb1bb26206500666ab4441e663ef83702d428b85a6ff177a4eaf44b0ae06b35d5c4da2672ccb4ec18296649af95bf2f0aed526afaa6a216a8c2d2c5627e
|
||||
SHA512 (postgresql-12.5.tar.bz2.sha256) = 5a05064eacb02458b02e57eafb983ffd282536fee390c4f13257f747bb74a2af3d56bd00de01c5c9934f64a7eeedbe0edc7a7f219d17f0ee912f34577b398151
|
||||
SHA512 (postgresql-12.6.tar.bz2) = 5742c9d861c53bbdd032972e63b706d24ccb39492474c446cf4edac235d57357f036e48727027819004177003c4328123148e3d767d2b3d7866a52f333f8d68d
|
||||
SHA512 (postgresql-12.6.tar.bz2.sha256) = 9eb88cdbe1c42fd460dbe766a1f15ed4191cedb503417fea9901c2e3c53f000e52ee5ff0c0042f32f0bba1e57f199ef16a4d9fff7474d45ae2d8362114f01ad4
|
||||
SHA512 (postgresql-13.2.tar.bz2) = 6d93cbae8de8637deeccd851fb676a12015e8e1efa6be2424f506f232db535c54b974b11f47ed4578575f90f6de1947b1647f399794b4ec242838efd4c5b2bce
|
||||
SHA512 (postgresql-13.2.tar.bz2.sha256) = 04f0daf7605be0d0df0860faa35cc079afc3e12e2986a17e4f22d71edb2da12731cd935d1e9e3a397713aeadc9ff88b5f4dea494456c1b639328fbdc0188fe7c
|
||||
SHA512 (postgresql-setup-8.5.tar.gz) = 5d31e31f3fdaa1564f6758ad7bcc17ffaac627b4665117d54b81e25e8309c03fc7d7cd53733891f80d3fc874474fa6b6d9a8d4765d1a9b9c31041baa66975241
|
||||
SHA512 (postgresql-12.5-US.pdf) = 0fcd669fd521e10b066ffe57f57172f363184b873ef8a01f22c26b8fcd11f40e976ea9a0e765fe8a3590e99361d16e402279634e17721a3c57994d25f9b0df29
|
||||
SHA512 (postgresql-13.2-US.pdf) = 07e1ff0c840d240ce7949e2449570c615f9fa8a07b31b53b5bb29b70b6fc596f5a1614a299a7f92d9038df77b2ebe8367f362da310daf06de44f39704bdb4529
|
||||
|
Loading…
Reference in New Issue
Block a user