Imports OL postgresql-13.13-1.0.1.module+el8.9.0+90098+1560b6c2

This commit is contained in:
eabdullin 2023-12-04 11:40:41 +03:00
parent 25689d678a
commit ece897ee98
7 changed files with 66 additions and 15 deletions

4
.gitignore vendored
View File

@ -1,4 +1,4 @@
SOURCES/postgresql-12.9.tar.bz2
SOURCES/postgresql-13.11-US.pdf
SOURCES/postgresql-13.11.tar.bz2
SOURCES/postgresql-13.13-US.pdf
SOURCES/postgresql-13.13.tar.bz2
SOURCES/postgresql-setup-8.7.tar.gz

View File

@ -1,4 +1,4 @@
d67d6bc7c6213f67c96ca766a6626c409356f3a2 SOURCES/postgresql-13.13-US.pdf
4e7eedca825034f1e249935a811fa30ce3b58d97 SOURCES/postgresql-13.13.tar.bz2
a79d8428850da50a65451e5e44771844c7f166d5 SOURCES/postgresql-12.9.tar.bz2
c7cc63d5caffcc5d4d8f31e07845722dc6db7787 SOURCES/postgresql-13.11-US.pdf
501acb24ba8539c08ba12b08adecd7559bf87e1b SOURCES/postgresql-13.11.tar.bz2
fb97095dc9648f9c31d58fcb406831da5e419ddf SOURCES/postgresql-setup-8.7.tar.gz
fb97095dc9648f9c31d58fcb406831da5e419ddf SOURCES/postgresql-setup-8.7.tar.gz

View File

@ -0,0 +1,38 @@
From df5ba865eb8a42147d23100b37322921ad98248a Mon Sep 17 00:00:00 2001
From: sagar sagar <sagar.sagar@oracle.com>
Date: Thu, 11 May 2023 15:49:37 +0530
Subject: [PATCH] Fixed postgresql service network binding issue during bootup
During the bootup, the postgresql service requires port bind to network
address to assign configured in /var/lib/pgsql/data/postgresql.conf but the
service is not able to do if the network service has not yet assigned an IP
address to the network interface.
By using "network-online.target" parameter in
/usr/lib/systemd/system/postgresql.service we are postponing the postgresql
service to run until we have not got the IP address assinged.
For more info :-
https://www.freedesktop.org/wiki/Software/systemd/NetworkTarget/
Orabug: 35103668
Signed-off-by: sagar sagar <sagar.sagar@oracle.com>
---
postgresql-setup-8.7/postgresql.service.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/postgresql-setup-8.7/postgresql.service.in b/postgresql-setup-8.7/postgresql.service.in
index c73c42a..893e6fa 100644
--- a/postgresql-setup-8.7/postgresql.service.in
+++ b/postgresql-setup-8.7/postgresql.service.in
@@ -6,7 +6,7 @@
[Unit]
Description=PostgreSQL database server
-After=network.target
+After=network-online.target
[Service]
Type=notify
--
2.31.1

View File

@ -1 +0,0 @@
4992ff647203566b670d4e54dc5317499a26856c93576d0ea951bdf6bee50bfb postgresql-13.11.tar.bz2

View File

@ -0,0 +1 @@
8af69c2599047a2ad246567d68ec4131aef116954d8c3e469e9789080b37a474 postgresql-13.13.tar.bz2

View File

@ -18,10 +18,10 @@ index bcdbd95..4bea236 100644
backend/replication/pgoutput \
fe_utils \
diff --git a/src/Makefile.global.in b/src/Makefile.global.in
index b9d86ac..29df69f 100644
index b75bafd..ddd381b 100644
--- a/src/Makefile.global.in
+++ b/src/Makefile.global.in
@@ -549,7 +549,7 @@ endif
@@ -576,7 +576,7 @@ endif
# How to link to libpq. (This macro may be used as-is by backend extensions.
# Client-side code should go through libpq_pgport or libpq_pgport_shlib,
# instead.)
@ -29,8 +29,8 @@ index b9d86ac..29df69f 100644
+libpq = -lpq
# libpq_pgport is for use by client executables (not libraries) that use libpq.
# We force clients to pull symbols from the non-shared libraries libpgport
@@ -579,7 +579,6 @@ endif
# We want clients to pull symbols from the non-shared libraries libpgport
@@ -619,7 +619,6 @@ endif
# Commonly used submake targets
submake-libpq: | submake-generated-headers

View File

@ -59,8 +59,8 @@
Summary: PostgreSQL client programs
Name: postgresql
%global majorversion 13
Version: %{majorversion}.11
Release: 2%{?dist}.alma.1
Version: %{majorversion}.13
Release: 1.0.1%{?dist}
# The PostgreSQL license is very similar to other MIT licenses, but the OSI
# recognizes it as an independent license, so we do as well.
@ -71,8 +71,8 @@ Url: http://www.postgresql.org/
# in-place upgrade of an old database. In most cases it will not be critical
# that this be kept up with the latest minor release of the previous series;
# but update when bugs affecting pg_dump output are fixed.
%global prevversion 12.9
%global prevmajorversion 12
%global prevversion %{prevmajorversion}.9
%global prev_prefix %{_libdir}/pgsql/postgresql-%{prevmajorversion}
%global precise_version %{?epoch:%epoch:}%version-%release
@ -109,6 +109,9 @@ Patch6: postgresql-man.patch
Patch8: postgresql-external-libpq.patch
Patch9: postgresql-server-pg_config.patch
#Oracle Patches
Patch1001: 1001-Fixed-postgresql-service-network-binding-issue.patch
BuildRequires: gcc
BuildRequires: perl(ExtUtils::MakeMaker) glibc-devel bison flex gawk
BuildRequires: perl(ExtUtils::Embed), perl-devel
@ -368,6 +371,7 @@ benchmarks.
%patch6 -p1
%patch8 -p1
%patch9 -p1
%patch1001 -p1
# We used to run autoconf here, but there's no longer any real need to,
# since Postgres ships with a reasonably modern configure script.
@ -1225,8 +1229,17 @@ make -C postgresql-setup-%{setup_version} check
%changelog
* Thu Oct 19 2023 Eduard Abdullin <eabdullin@almalinux.org> - 13.11-2.alma.1
- Update postgresql-setup to 8.7
* Thu Nov 30 2023 EL Errata <el-errata_ww@oracle.com> - 13.13-1.0.1
- Fixed postgresql port binding issue during bootup [Orabug: 35103668]
* Mon Nov 13 2023 Jorge San Emeterio <jsanemet@redhat.com> - 13.13-1
- Update to 13.13
- Fixes: CVE-2023-5868 CVE-2023-5869 CVE-2023-5870 CVE-2023-39417
- Resolves: RHEL-16085 RHEL-16123
* Thu Jun 22 2023 Jorge San Emeterio <jsanemet@redhat.com> - 13.11-2
- Update postgresql-setup to 8.7 (https://github.com/devexp-db/postgresql-setup/pull/35)
- Resolves: #2207933
* Tue Jun 13 2023 Jorge San Emeterio <jsanemet@redhat.com> - 13.11-1
- Update to 13.11