Update to PostgreSQL 8.3.7
This commit is contained in:
parent
18a2a1a2f2
commit
bc5e872454
@ -1,5 +1,5 @@
|
||||
postgresql-8.3.6.tar.bz2
|
||||
postgresql-8.3.7.tar.bz2
|
||||
PyGreSQL-3.8.1.tgz
|
||||
pgtcl1.6.2.tar.gz
|
||||
pgtcldocs-20070115.zip
|
||||
postgresql-8.3.6-US.pdf
|
||||
postgresql-8.3.7-US.pdf
|
||||
|
@ -4,12 +4,12 @@ for PostgreSQL, but it's not very tenable in the Fedora/RHEL world.
|
||||
Dike out the check.
|
||||
|
||||
|
||||
diff -Naur postgresql-8.3.6.orig/configure.in postgresql-8.3.6/configure.in
|
||||
--- postgresql-8.3.6.orig/configure.in 2008-09-18 23:04:12.000000000 -0400
|
||||
+++ postgresql-8.3.6/configure.in 2008-09-25 10:26:10.000000000 -0400
|
||||
diff -Naur postgresql-8.3.7.orig/configure.in postgresql-8.3.7/configure.in
|
||||
--- postgresql-8.3.7.orig/configure.in 2008-09-18 23:04:12.000000000 -0400
|
||||
+++ postgresql-8.3.7/configure.in 2008-09-25 10:26:10.000000000 -0400
|
||||
@@ -19,10 +19,6 @@
|
||||
|
||||
AC_INIT([PostgreSQL], [8.3.6], [pgsql-bugs@postgresql.org])
|
||||
AC_INIT([PostgreSQL], [8.3.7], [pgsql-bugs@postgresql.org])
|
||||
|
||||
-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.59], [], [m4_fatal([Autoconf version 2.59 is required.
|
||||
-Untested combinations of 'autoconf' and PostgreSQL versions are not
|
||||
|
@ -1,51 +0,0 @@
|
||||
Do not expose pg_trace.h (ie, <sys/sdt.h>) as something that every dependent
|
||||
package will need to #include successfully. Otherwise we'd need to make
|
||||
postgresql-devel Require: systemtap-sdt-devel, which doesn't seem like a
|
||||
desirable thing to do. This patch is already applied upstream and won't
|
||||
be needed in 8.3.7.
|
||||
|
||||
|
||||
diff -Naur postgresql-8.3.6.orig/src/backend/access/transam/xact.c postgresql-8.3.6/src/backend/access/transam/xact.c
|
||||
--- postgresql-8.3.6.orig/src/backend/access/transam/xact.c 2008-04-26 19:35:33.000000000 -0400
|
||||
+++ postgresql-8.3.6/src/backend/access/transam/xact.c 2009-03-10 21:17:26.000000000 -0400
|
||||
@@ -33,6 +33,7 @@
|
||||
#include "executor/spi.h"
|
||||
#include "libpq/be-fsstubs.h"
|
||||
#include "miscadmin.h"
|
||||
+#include "pg_trace.h"
|
||||
#include "pgstat.h"
|
||||
#include "storage/fd.h"
|
||||
#include "storage/lmgr.h"
|
||||
diff -Naur postgresql-8.3.6.orig/src/backend/storage/lmgr/lock.c postgresql-8.3.6/src/backend/storage/lmgr/lock.c
|
||||
--- postgresql-8.3.6.orig/src/backend/storage/lmgr/lock.c 2008-03-04 14:54:13.000000000 -0500
|
||||
+++ postgresql-8.3.6/src/backend/storage/lmgr/lock.c 2009-03-10 21:17:26.000000000 -0400
|
||||
@@ -36,6 +36,7 @@
|
||||
#include "access/twophase.h"
|
||||
#include "access/twophase_rmgr.h"
|
||||
#include "miscadmin.h"
|
||||
+#include "pg_trace.h"
|
||||
#include "pgstat.h"
|
||||
#include "utils/memutils.h"
|
||||
#include "utils/ps_status.h"
|
||||
diff -Naur postgresql-8.3.6.orig/src/backend/storage/lmgr/lwlock.c postgresql-8.3.6/src/backend/storage/lmgr/lwlock.c
|
||||
--- postgresql-8.3.6.orig/src/backend/storage/lmgr/lwlock.c 2008-01-01 14:45:52.000000000 -0500
|
||||
+++ postgresql-8.3.6/src/backend/storage/lmgr/lwlock.c 2009-03-10 21:17:26.000000000 -0400
|
||||
@@ -25,6 +25,7 @@
|
||||
#include "access/multixact.h"
|
||||
#include "access/subtrans.h"
|
||||
#include "miscadmin.h"
|
||||
+#include "pg_trace.h"
|
||||
#include "storage/ipc.h"
|
||||
#include "storage/proc.h"
|
||||
#include "storage/spin.h"
|
||||
diff -Naur postgresql-8.3.6.orig/src/include/c.h postgresql-8.3.6/src/include/c.h
|
||||
--- postgresql-8.3.6.orig/src/include/c.h 2008-02-23 14:11:55.000000000 -0500
|
||||
+++ postgresql-8.3.6/src/include/c.h 2009-03-10 21:17:26.000000000 -0400
|
||||
@@ -57,7 +57,6 @@
|
||||
#include "pg_config_os.h" /* must be before any system header files */
|
||||
#endif
|
||||
#include "postgres_ext.h"
|
||||
-#include "pg_trace.h"
|
||||
|
||||
#if _MSC_VER >= 1400
|
||||
#define errcode __msvc_errcode
|
@ -83,8 +83,8 @@
|
||||
|
||||
Summary: PostgreSQL client programs and libraries
|
||||
Name: postgresql
|
||||
Version: 8.3.6
|
||||
Release: 4%{?dist}
|
||||
Version: 8.3.7
|
||||
Release: 1%{?dist}
|
||||
License: BSD
|
||||
Group: Applications/Databases
|
||||
Url: http://www.postgresql.org/
|
||||
@ -98,7 +98,7 @@ Source7: ecpg_config.h
|
||||
Source14: postgresql.pam
|
||||
Source15: postgresql-bashprofile
|
||||
Source16: filter-requires-perl-Pg.sh
|
||||
Source17: http://www.postgresql.org/docs/manuals/postgresql-8.3.6-US.pdf
|
||||
Source17: http://www.postgresql.org/docs/manuals/postgresql-8.3.7-US.pdf
|
||||
Source18: ftp://ftp.pygresql.org/pub/distrib/PyGreSQL-3.8.1.tgz
|
||||
Source19: http://pgfoundry.org/projects/pgtclng/pgtcl1.6.2.tar.gz
|
||||
Source20: http://pgfoundry.org/projects/pgtclng/pgtcldocs-20070115.zip
|
||||
@ -109,7 +109,6 @@ Patch3: postgresql-logging.patch
|
||||
Patch4: postgresql-test.patch
|
||||
Patch5: pgtcl-no-rpath.patch
|
||||
Patch6: postgresql-perl-rpath.patch
|
||||
Patch7: postgresql-sdt-includes.patch
|
||||
|
||||
BuildRequires: perl(ExtUtils::MakeMaker) glibc-devel bison flex autoconf gawk
|
||||
BuildRequires: perl(ExtUtils::Embed), perl-devel
|
||||
@ -362,7 +361,6 @@ system, including regression tests and benchmarks.
|
||||
%patch4 -p1
|
||||
# patch5 is applied later
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
|
||||
#call autoconf 2.53 or greater
|
||||
%aconfver
|
||||
@ -873,6 +871,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sat Mar 21 2009 Tom Lane <tgl@redhat.com> 8.3.7-1
|
||||
- Update to PostgreSQL 8.3.7, for various fixes described at
|
||||
http://www.postgresql.org/docs/8.3/static/release-8-3-7.html
|
||||
notably the fix for CVE-2009-0922
|
||||
|
||||
* Tue Mar 10 2009 Tom Lane <tgl@redhat.com> 8.3.6-4
|
||||
- Prevent dependent packages from needing to include sys/sdt.h
|
||||
(unintended side effect of previous patch)
|
||||
|
4
sources
4
sources
@ -1,5 +1,5 @@
|
||||
4f8c67d802bd03b5b844e268bba7d44a postgresql-8.3.6.tar.bz2
|
||||
7b7e91a2221e55fe1b167e663217a96d postgresql-8.3.7.tar.bz2
|
||||
5575979dac93c9c5795d7693a8f91c86 PyGreSQL-3.8.1.tgz
|
||||
abf26e3cd7f8229f468045ed1fb7e748 pgtcl1.6.2.tar.gz
|
||||
8ce98e93b238c3329d0fe43810442c44 pgtcldocs-20070115.zip
|
||||
c0a875cb8694315fcbf87bf973a3169c postgresql-8.3.6-US.pdf
|
||||
cf36036b0a973f793b2ba25dfdbcf879 postgresql-8.3.7-US.pdf
|
||||
|
Loading…
Reference in New Issue
Block a user