Replace whole repo with latest content from branch stream-12-rhel-8.8.0
Content corresponds with RHEL dist-git commit cc65109
This commit is contained in:
parent
1fe0de53cb
commit
b56a8848c7
32
.gitignore
vendored
Normal file → Executable file
32
.gitignore
vendored
Normal file → Executable file
@ -1,8 +1,28 @@
|
||||
SOURCES/postgresql-10.21.tar.bz2
|
||||
SOURCES/postgresql-12.12-US.pdf
|
||||
SOURCES/postgresql-12.12.tar.bz2
|
||||
SOURCES/postgresql-setup-8.6.tar.gz
|
||||
/postgresql-10.21.tar.bz2
|
||||
/postgresql-12.12-US.pdf
|
||||
/postgresql-10.6.tar.bz2
|
||||
/postgresql-10.6.tar.bz2.sha256
|
||||
/postgresql-9.2.24.tar.bz2
|
||||
/postgresql-9.2.24.tar.bz2.sha256
|
||||
/postgresql-setup-8.2.tar.gz
|
||||
/postgresql-10.6-US.pdf
|
||||
/postgresql-12.1-US.pdf
|
||||
/postgresql-12.5.tar.bz2
|
||||
/postgresql-12.5.tar.bz2.sha256
|
||||
/postgresql-12.5-US.pdf
|
||||
/postgresql-10.15.tar.bz2
|
||||
/postgresql-10.15.tar.bz2.sha256
|
||||
/postgresql-setup-8.4.tar.gz
|
||||
/postgresql-12.7.tar.bz2
|
||||
/postgresql-12.7.tar.bz2.sha256
|
||||
/postgresql-10.17.tar.bz2
|
||||
/postgresql-10.17.tar.bz2.sha256
|
||||
/postgresql-12.7-US.pdf
|
||||
/postgresql-12.11.tar.bz2
|
||||
/postgresql-12.11.tar.bz2.sha256
|
||||
/postgresql-12.11-US.pdf
|
||||
/postgresql-12-12-US.pdf
|
||||
/postgresql-12.12.tar.bz2
|
||||
/postgresql-12.12.tar.bz2.sha256
|
||||
/postgresql-10.21.tar.bz2
|
||||
/postgresql-10.21.tar.bz2.sha256
|
||||
/postgresql-setup-8.6.tar.gz
|
||||
/postgresql-12.12-US.pdf
|
||||
|
@ -1,6 +0,0 @@
|
||||
--- !Policy
|
||||
product_versions:
|
||||
- rhel-9
|
||||
decision_context: osci_compose_gate
|
||||
rules:
|
||||
- !PassingTestCaseRule {test_case_name: baseos-ci.brew-build.tier1.functional}
|
13
generate-sources-and-gitignore.sh
Executable file
13
generate-sources-and-gitignore.sh
Executable file
@ -0,0 +1,13 @@
|
||||
#! /bin/sh
|
||||
|
||||
rm sources .gitignore
|
||||
set -e
|
||||
spectool -S *.spec | cut -d' ' -f2 \
|
||||
| grep -E -e 'postgresql-.*\.tar\.*' -e 'postgresql.*\.pdf' | sort | \
|
||||
while read line
|
||||
do
|
||||
base=`basename "$line"`
|
||||
echo " * handling $base"
|
||||
sha512sum --tag "$base" >> sources
|
||||
echo "/$base" >> .gitignore
|
||||
done
|
@ -1 +0,0 @@
|
||||
d32198856d52a9a6f5d50642ef86687ac058bd6efca5c9ed57be7808496f45d1 postgresql-10.21.tar.bz2
|
@ -1 +0,0 @@
|
||||
34b3f1c69408e22068c0c71b1827691f1c89153b0ad576c1a44f8920a858039c postgresql-12.12.tar.bz2
|
@ -1,12 +0,0 @@
|
||||
diff -up postgresql-13.1/src/interfaces/Makefile.patch10 postgresql-13.1/src/interfaces/Makefile
|
||||
--- postgresql-13.1/src/interfaces/Makefile.patch10 2021-02-02 21:33:23.235292305 +0100
|
||||
+++ postgresql-13.1/src/interfaces/Makefile 2021-02-02 21:33:30.281365440 +0100
|
||||
@@ -12,7 +12,7 @@ subdir = src/interfaces
|
||||
top_builddir = ../..
|
||||
include $(top_builddir)/src/Makefile.global
|
||||
|
||||
-SUBDIRS = libpq ecpg
|
||||
+SUBDIRS = libpq
|
||||
|
||||
$(recurse)
|
||||
|
33
postgresql-no-libs.patch
Normal file
33
postgresql-no-libs.patch
Normal file
@ -0,0 +1,33 @@
|
||||
diff --git a/src/Makefile b/src/Makefile
|
||||
index febbced..9737b55 100644
|
||||
--- a/src/Makefile
|
||||
+++ b/src/Makefile
|
||||
@@ -20,7 +20,6 @@ SUBDIRS = \
|
||||
backend/utils/mb/conversion_procs \
|
||||
backend/snowball \
|
||||
include \
|
||||
- interfaces \
|
||||
backend/replication/libpqwalreceiver \
|
||||
backend/replication/pgoutput \
|
||||
fe_utils \
|
||||
diff --git a/src/Makefile.global.in b/src/Makefile.global.in
|
||||
index 4ed5174..d0e0dae 100644
|
||||
--- a/src/Makefile.global.in
|
||||
+++ b/src/Makefile.global.in
|
||||
@@ -457,7 +457,7 @@ endif
|
||||
|
||||
# This macro is for use by libraries linking to libpq. (Because libpgport
|
||||
# isn't created with the same link flags as libpq, it can't be used.)
|
||||
-libpq = -L$(libpq_builddir) -lpq
|
||||
+libpq = -lpq
|
||||
|
||||
# This macro is for use by client executables (not libraries) that use libpq.
|
||||
# We force clients to pull symbols from the non-shared libraries libpgport
|
||||
@@ -483,7 +483,6 @@ endif
|
||||
# Commonly used submake targets
|
||||
|
||||
submake-libpq:
|
||||
- $(MAKE) -C $(libpq_builddir) all
|
||||
|
||||
submake-libpgport:
|
||||
$(MAKE) -C $(top_builddir)/src/port all
|
@ -1,102 +0,0 @@
|
||||
diff -ur postgresql-13.4/contrib/pgcrypto/expected/pgp-decrypt.out postgresql-13.4.patched/contrib/pgcrypto/expected/pgp-decrypt.out
|
||||
--- postgresql-13.4/contrib/pgcrypto/expected/pgp-decrypt.out 2021-08-09 16:49:05.000000000 -0400
|
||||
+++ postgresql-13.4.patched/contrib/pgcrypto/expected/pgp-decrypt.out 2021-09-01 08:16:48.138600886 -0400
|
||||
@@ -4,20 +4,6 @@
|
||||
-- Checking ciphers
|
||||
select pgp_sym_decrypt(dearmor('
|
||||
-----BEGIN PGP MESSAGE-----
|
||||
-Comment: dat1.blowfish.sha1.mdc.s2k3.z0
|
||||
-
|
||||
-jA0EBAMCfFNwxnvodX9g0jwB4n4s26/g5VmKzVab1bX1SmwY7gvgvlWdF3jKisvS
|
||||
-yA6Ce1QTMK3KdL2MPfamsTUSAML8huCJMwYQFfE=
|
||||
-=JcP+
|
||||
------END PGP MESSAGE-----
|
||||
-'), 'foobar');
|
||||
- pgp_sym_decrypt
|
||||
------------------
|
||||
- Secret message.
|
||||
-(1 row)
|
||||
-
|
||||
-select pgp_sym_decrypt(dearmor('
|
||||
------BEGIN PGP MESSAGE-----
|
||||
Comment: dat1.aes.sha1.mdc.s2k3.z0
|
||||
|
||||
jA0EBwMCci97v0Q6Z0Zg0kQBsVf5Oe3iC+FBzUmuMV9KxmAyOMyjCc/5i8f1Eest
|
||||
diff -ur postgresql-13.4/contrib/pgcrypto/expected/pgp-pubkey-decrypt.out postgresql-13.4.patched/contrib/pgcrypto/expected/pgp-pubkey-decrypt.out
|
||||
--- postgresql-13.4/contrib/pgcrypto/expected/pgp-pubkey-decrypt.out 2021-08-09 16:49:05.000000000 -0400
|
||||
+++ postgresql-13.4.patched/contrib/pgcrypto/expected/pgp-pubkey-decrypt.out 2021-09-01 08:05:27.750172653 -0400
|
||||
@@ -594,13 +594,6 @@
|
||||
(1 row)
|
||||
|
||||
select pgp_pub_decrypt(dearmor(data), dearmor(seckey))
|
||||
-from keytbl, encdata where keytbl.id=2 and encdata.id=2;
|
||||
- pgp_pub_decrypt
|
||||
------------------
|
||||
- Secret msg
|
||||
-(1 row)
|
||||
-
|
||||
-select pgp_pub_decrypt(dearmor(data), dearmor(seckey))
|
||||
from keytbl, encdata where keytbl.id=3 and encdata.id=3;
|
||||
pgp_pub_decrypt
|
||||
-----------------
|
||||
diff -ur postgresql-13.4/contrib/pgcrypto/Makefile postgresql-13.4.patched/contrib/pgcrypto/Makefile
|
||||
--- postgresql-13.4/contrib/pgcrypto/Makefile 2021-08-09 16:49:05.000000000 -0400
|
||||
+++ postgresql-13.4.patched/contrib/pgcrypto/Makefile 2021-09-01 08:26:47.207164873 -0400
|
||||
@@ -5,7 +5,7 @@
|
||||
INT_TESTS = sha2
|
||||
|
||||
OSSL_SRCS = openssl.c pgp-mpi-openssl.c
|
||||
-OSSL_TESTS = sha2 des 3des cast5
|
||||
+OSSL_TESTS = sha2
|
||||
|
||||
ZLIB_TST = pgp-compression
|
||||
ZLIB_OFF_TST = pgp-zlib-DISABLED
|
||||
@@ -49,12 +49,13 @@
|
||||
pgcrypto--1.0--1.1.sql
|
||||
PGFILEDESC = "pgcrypto - cryptographic functions"
|
||||
|
||||
-REGRESS = init md5 sha1 hmac-md5 hmac-sha1 blowfish rijndael \
|
||||
+REGRESS = init md5 sha1 hmac-md5 hmac-sha1 rijndael \
|
||||
$(CF_TESTS) \
|
||||
- crypt-des crypt-md5 crypt-blowfish crypt-xdes \
|
||||
+ crypt-md5 \
|
||||
pgp-armor pgp-decrypt pgp-encrypt $(CF_PGP_TESTS) \
|
||||
pgp-pubkey-decrypt pgp-pubkey-encrypt pgp-info
|
||||
|
||||
+#REGRESS = init pgp-pubkey-decrypt pgp-decrypt \
|
||||
EXTRA_CLEAN = gen-rtab
|
||||
|
||||
ifdef USE_PGXS
|
||||
diff -ur postgresql-13.4/contrib/pgcrypto/sql/pgp-decrypt.sql postgresql-13.4.patched/contrib/pgcrypto/sql/pgp-decrypt.sql
|
||||
--- postgresql-13.4/contrib/pgcrypto/sql/pgp-decrypt.sql 2021-08-09 16:49:05.000000000 -0400
|
||||
+++ postgresql-13.4.patched/contrib/pgcrypto/sql/pgp-decrypt.sql 2021-09-01 08:16:12.525212175 -0400
|
||||
@@ -5,16 +5,6 @@
|
||||
-- Checking ciphers
|
||||
select pgp_sym_decrypt(dearmor('
|
||||
-----BEGIN PGP MESSAGE-----
|
||||
-Comment: dat1.blowfish.sha1.mdc.s2k3.z0
|
||||
-
|
||||
-jA0EBAMCfFNwxnvodX9g0jwB4n4s26/g5VmKzVab1bX1SmwY7gvgvlWdF3jKisvS
|
||||
-yA6Ce1QTMK3KdL2MPfamsTUSAML8huCJMwYQFfE=
|
||||
-=JcP+
|
||||
------END PGP MESSAGE-----
|
||||
-'), 'foobar');
|
||||
-
|
||||
-select pgp_sym_decrypt(dearmor('
|
||||
------BEGIN PGP MESSAGE-----
|
||||
Comment: dat1.aes.sha1.mdc.s2k3.z0
|
||||
|
||||
jA0EBwMCci97v0Q6Z0Zg0kQBsVf5Oe3iC+FBzUmuMV9KxmAyOMyjCc/5i8f1Eest
|
||||
diff -ur postgresql-13.4/contrib/pgcrypto/sql/pgp-pubkey-decrypt.sql postgresql-13.4.patched/contrib/pgcrypto/sql/pgp-pubkey-decrypt.sql
|
||||
--- postgresql-13.4/contrib/pgcrypto/sql/pgp-pubkey-decrypt.sql 2021-08-09 16:49:05.000000000 -0400
|
||||
+++ postgresql-13.4.patched/contrib/pgcrypto/sql/pgp-pubkey-decrypt.sql 2021-09-01 08:06:18.963732342 -0400
|
||||
@@ -606,9 +606,6 @@
|
||||
from keytbl, encdata where keytbl.id=1 and encdata.id=1;
|
||||
|
||||
select pgp_pub_decrypt(dearmor(data), dearmor(seckey))
|
||||
-from keytbl, encdata where keytbl.id=2 and encdata.id=2;
|
||||
-
|
||||
-select pgp_pub_decrypt(dearmor(data), dearmor(seckey))
|
||||
from keytbl, encdata where keytbl.id=3 and encdata.id=3;
|
||||
|
||||
select pgp_pub_decrypt(dearmor(data), dearmor(seckey))
|
@ -1226,14 +1226,9 @@ make -C postgresql-setup-%{setup_version} check
|
||||
|
||||
%changelog
|
||||
* Fri Sep 30 2022 Filip Januš <fjanus@redhat.com> - 12.12-1
|
||||
- Resolves: #2131177
|
||||
- Resolves: #2114732
|
||||
- Update to version 12.12
|
||||
|
||||
* Thu May 19 2022 Filip Januš <fjanus@redhat.com> - 12.11-2
|
||||
- Resolves: CVE-2022-1552
|
||||
- Release bump due to wrongly reported CVE of libpq
|
||||
Build after reverted changes in libpq package
|
||||
|
||||
* Mon May 16 2022 Filip Januš <fjanus@redhat.com> - 12.11-1
|
||||
- Resolves: CVE-2022-1552
|
||||
- Update to 12.11
|
||||
|
@ -1,9 +0,0 @@
|
||||
---
|
||||
# Forbidden function symbols found:
|
||||
# inet_net_ntop
|
||||
# inet_net_pton
|
||||
# This is not a problem because the older version is only used for upgrade
|
||||
# purposes and communicates through unix socket only
|
||||
badfuncs:
|
||||
ignore:
|
||||
- /usr/lib*/pgsql/postgresql-*/bin/postgres
|
4
sources
Normal file → Executable file
4
sources
Normal file → Executable file
@ -1,4 +1,6 @@
|
||||
SHA512 (postgresql-10.21.tar.bz2) = 1053e15505c0448df491119c9aad1617889b66118628a2155e3ec87e6648b2071a0a54e10d8fbbe00161b2aa86d1a6194d932a8cf5808c626e7972d135bb05c5
|
||||
SHA512 (postgresql-12.12-US.pdf) = 59d4ec5197cf540f61f482776eddab2c3513ce6545d74202aa60890e64497c899a23808cfc74e6b23e793c4ae548c0c8c3d833a103931b3396dd70b190b2f7fe
|
||||
SHA512 (postgresql-12.12.tar.bz2) = eeff79279ac11db04fdddeb2c52ba1ec6b549223b862222540e1f659fbfc3617130699c22694b465bde46b1a4a665c01aef70b68b86d80e58a5657efd019407d
|
||||
SHA512 (postgresql-12.12.tar.bz2.sha256) = 0308314d40df499c5cb96e927658d96a9e23edeb5b61b936ae4507db5eff1d60191d77aa1dcdeb56e826cfb3cbf6c2209f44d4a2a75645b71a92123cf097e4d2
|
||||
SHA512 (postgresql-10.21.tar.bz2) = 1053e15505c0448df491119c9aad1617889b66118628a2155e3ec87e6648b2071a0a54e10d8fbbe00161b2aa86d1a6194d932a8cf5808c626e7972d135bb05c5
|
||||
SHA512 (postgresql-10.21.tar.bz2.sha256) = 6be0e022142577f9681db3bd2c7afb3a9a363751fccdd2b616d8ac4af53c05c8209a80bbd6eb218ddafbaf14eb2c6414bab8bba9fb6a481563b2a93879854a35
|
||||
SHA512 (postgresql-setup-8.6.tar.gz) = dc687670cd58070512833271d8f3e7e4308c47cba1ad4c93e3d5f61acf07f390ed048f4d7f1567d2826f19a253562e13e56407dcf81a42f42c61ac96d8fe3178
|
||||
|
@ -1,16 +0,0 @@
|
||||
# This package uses external repositories for maintaining CI test cases.
|
||||
# Please don't edit this file if possible.
|
||||
|
||||
- hosts: localhost
|
||||
roles:
|
||||
- role: standard-test-beakerlib
|
||||
repositories:
|
||||
- repo: https://src.fedoraproject.org/tests/postgresql.git
|
||||
dest: postgresql
|
||||
# TODO: minimize: https://pagure.io/standard-test-roles/issue/294
|
||||
fmf_filter: "tier: 1"
|
||||
# TODO: minimize: https://pagure.io/standard-test-roles/issue/294
|
||||
tags:
|
||||
- classic
|
||||
- container
|
||||
- atomic
|
Loading…
Reference in New Issue
Block a user