Update to PostgreSQL 8.4.1
This commit is contained in:
parent
10587f4e78
commit
a8e2f35299
@ -1,5 +1,5 @@
|
|||||||
postgresql-8.4.0.tar.bz2
|
postgresql-8.4.1.tar.bz2
|
||||||
PyGreSQL-3.8.1.tgz
|
PyGreSQL-3.8.1.tgz
|
||||||
pgtcl1.6.2.tar.gz
|
pgtcl1.6.2.tar.gz
|
||||||
pgtcldocs-20070115.zip
|
pgtcldocs-20070115.zip
|
||||||
postgresql-8.4.0-US.pdf
|
postgresql-8.4.1-US.pdf
|
||||||
|
@ -4,12 +4,12 @@ for PostgreSQL, but it's not very tenable in the Fedora/RHEL world.
|
|||||||
Dike out the check.
|
Dike out the check.
|
||||||
|
|
||||||
|
|
||||||
diff -Naur postgresql-8.4.0.orig/configure.in postgresql-8.4.0/configure.in
|
diff -Naur postgresql-8.4.1.orig/configure.in postgresql-8.4.1/configure.in
|
||||||
--- postgresql-8.4.0.orig/configure.in 2009-06-26 20:14:47.000000000 -0400
|
--- postgresql-8.4.1.orig/configure.in 2009-09-03 20:36:50.000000000 -0400
|
||||||
+++ postgresql-8.4.0/configure.in 2009-08-12 23:09:31.000000000 -0400
|
+++ postgresql-8.4.1/configure.in 2009-09-04 13:03:07.000000000 -0400
|
||||||
@@ -19,10 +19,6 @@
|
@@ -19,10 +19,6 @@
|
||||||
|
|
||||||
AC_INIT([PostgreSQL], [8.4.0], [pgsql-bugs@postgresql.org])
|
AC_INIT([PostgreSQL], [8.4.1], [pgsql-bugs@postgresql.org])
|
||||||
|
|
||||||
-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.61], [], [m4_fatal([Autoconf version 2.61 is required.
|
-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.61], [], [m4_fatal([Autoconf version 2.61 is required.
|
||||||
-Untested combinations of 'autoconf' and PostgreSQL versions are not
|
-Untested combinations of 'autoconf' and PostgreSQL versions are not
|
||||||
|
@ -59,8 +59,9 @@
|
|||||||
Summary: PostgreSQL client programs and libraries
|
Summary: PostgreSQL client programs and libraries
|
||||||
Name: postgresql
|
Name: postgresql
|
||||||
%define majorversion 8.4
|
%define majorversion 8.4
|
||||||
Version: 8.4.0
|
Version: 8.4.1
|
||||||
Release: 3.2%{?dist}
|
Release: 1%{?dist}
|
||||||
|
# PG considers their license to be simplified BSD, but it's more nearly MIT
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: Applications/Databases
|
Group: Applications/Databases
|
||||||
Url: http://www.postgresql.org/
|
Url: http://www.postgresql.org/
|
||||||
@ -74,7 +75,7 @@ Source7: ecpg_config.h
|
|||||||
Source14: postgresql.pam
|
Source14: postgresql.pam
|
||||||
Source15: postgresql-bashprofile
|
Source15: postgresql-bashprofile
|
||||||
Source16: filter-requires-perl-Pg.sh
|
Source16: filter-requires-perl-Pg.sh
|
||||||
Source17: http://www.postgresql.org/docs/manuals/postgresql-8.4.0-US.pdf
|
Source17: http://www.postgresql.org/docs/manuals/postgresql-8.4.1-US.pdf
|
||||||
Source18: ftp://ftp.pygresql.org/pub/distrib/PyGreSQL-3.8.1.tgz
|
Source18: ftp://ftp.pygresql.org/pub/distrib/PyGreSQL-3.8.1.tgz
|
||||||
Source19: http://pgfoundry.org/projects/pgtclng/pgtcl1.6.2.tar.gz
|
Source19: http://pgfoundry.org/projects/pgtclng/pgtcl1.6.2.tar.gz
|
||||||
Source20: http://pgfoundry.org/projects/pgtclng/pgtcldocs-20070115.zip
|
Source20: http://pgfoundry.org/projects/pgtclng/pgtcldocs-20070115.zip
|
||||||
@ -90,10 +91,6 @@ BuildRequires: perl(ExtUtils::Embed), perl-devel
|
|||||||
# for /sbin/ldconfig
|
# for /sbin/ldconfig
|
||||||
Prereq: glibc initscripts
|
Prereq: glibc initscripts
|
||||||
|
|
||||||
%ifarch s390 s390x
|
|
||||||
%define sdt 0
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%if %python || %plpython
|
%if %python || %plpython
|
||||||
BuildRequires: python-devel
|
BuildRequires: python-devel
|
||||||
%endif
|
%endif
|
||||||
@ -369,10 +366,11 @@ CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS
|
|||||||
|
|
||||||
# Strip out -ffast-math from CFLAGS....
|
# Strip out -ffast-math from CFLAGS....
|
||||||
CFLAGS=`echo $CFLAGS|xargs -n 1|grep -v ffast-math|xargs -n 100`
|
CFLAGS=`echo $CFLAGS|xargs -n 1|grep -v ffast-math|xargs -n 100`
|
||||||
# use -O1 on sparc64, s390x and alpha
|
# let's try removing this kluge, it may just be a workaround for bz#520916
|
||||||
%ifarch sparc64 alpha s390x s390
|
# # use -O1 on sparc64 and alpha
|
||||||
CFLAGS=`echo $CFLAGS| sed -e "s|-O2|-O1|g" `
|
# %ifarch sparc64 alpha
|
||||||
%endif
|
# CFLAGS=`echo $CFLAGS| sed -e "s|-O2|-O1|g" `
|
||||||
|
# %endif
|
||||||
|
|
||||||
%configure --disable-rpath \
|
%configure --disable-rpath \
|
||||||
%if %beta
|
%if %beta
|
||||||
@ -856,6 +854,13 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Sep 9 2009 Tom Lane <tgl@redhat.com> 8.4.1-1
|
||||||
|
- Update to PostgreSQL 8.4.1, for various fixes described at
|
||||||
|
http://www.postgresql.org/docs/8.4/static/release-8-4-1.html
|
||||||
|
including two security issues
|
||||||
|
Related: #522085
|
||||||
|
Related: #522092
|
||||||
|
|
||||||
* Tue Sep 01 2009 Karsten Hopp <karsten@redhat.com> 8.4.0-3.2
|
* Tue Sep 01 2009 Karsten Hopp <karsten@redhat.com> 8.4.0-3.2
|
||||||
- bump release and build again with the correct libssl
|
- bump release and build again with the correct libssl
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,5 +1,5 @@
|
|||||||
1f172d5f60326e972837f58fa5acd130 postgresql-8.4.0.tar.bz2
|
f2015af17bacbbfe140daf0d1067f9c9 postgresql-8.4.1.tar.bz2
|
||||||
5575979dac93c9c5795d7693a8f91c86 PyGreSQL-3.8.1.tgz
|
5575979dac93c9c5795d7693a8f91c86 PyGreSQL-3.8.1.tgz
|
||||||
abf26e3cd7f8229f468045ed1fb7e748 pgtcl1.6.2.tar.gz
|
abf26e3cd7f8229f468045ed1fb7e748 pgtcl1.6.2.tar.gz
|
||||||
8ce98e93b238c3329d0fe43810442c44 pgtcldocs-20070115.zip
|
8ce98e93b238c3329d0fe43810442c44 pgtcldocs-20070115.zip
|
||||||
bbed2a7dad711eef335701391b9f112d postgresql-8.4.0-US.pdf
|
37ebde274743cc5ed3cf3d49c3f84119 postgresql-8.4.1-US.pdf
|
||||||
|
Loading…
Reference in New Issue
Block a user