Update to PostgreSQL 9.1.2
This commit is contained in:
parent
9c2d09be8c
commit
a60f809e42
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,3 +1,3 @@
|
||||
/postgresql-9.1.1.tar.bz2
|
||||
/postgresql-9.1.1-US.pdf
|
||||
/postgresql-9.1.2.tar.bz2
|
||||
/postgresql-9.1.2-US.pdf
|
||||
/postgresql-9.0.4.tar.bz2
|
||||
|
@ -13,9 +13,10 @@
|
||||
# You will need to have the docbook packages installed to run this.
|
||||
# Expect it to take about 20 minutes and use about 160MB of disk.
|
||||
|
||||
# Extract version from specfile
|
||||
set -e
|
||||
|
||||
VERSION=`sed -n 's/^Version: //p' postgresql.spec`
|
||||
# Pass package version (e.g., 9.1.2) as argument
|
||||
VERSION=$1
|
||||
|
||||
TARGETFILE=postgresql-$VERSION-US.pdf
|
||||
|
||||
@ -23,17 +24,19 @@ echo Building $TARGETFILE ...
|
||||
|
||||
# Unpack and configure postgresql
|
||||
|
||||
tar xfj postgresql-$VERSION.tar.bz2 || exit 1
|
||||
rm -rf postgresql-$VERSION
|
||||
|
||||
cd postgresql-$VERSION || exit 1
|
||||
tar xfj postgresql-$VERSION.tar.bz2
|
||||
|
||||
./configure >/dev/null || exit 1
|
||||
cd postgresql-$VERSION
|
||||
|
||||
./configure >/dev/null
|
||||
|
||||
# Build the PDF docs
|
||||
|
||||
cd doc/src/sgml
|
||||
|
||||
make postgres-US.pdf >make.log || exit 1
|
||||
make postgres-US.pdf >make.log
|
||||
|
||||
mv -f postgres-US.pdf ../../../../$TARGETFILE
|
||||
|
||||
|
@ -1,20 +0,0 @@
|
||||
We can't run the contrib/sepgsql regression tests during build, because they
|
||||
assume that some root-privilege-requiring hacks have been made to the SELinux
|
||||
configuration. So just dike out the settings that would cause them to be run.
|
||||
Something similar to this will probably be done upstream for PG 9.1.2 and
|
||||
later.
|
||||
|
||||
|
||||
diff -Naur postgresql-9.1.1.orig/contrib/sepgsql/Makefile postgresql-9.1.1/contrib/sepgsql/Makefile
|
||||
--- postgresql-9.1.1.orig/contrib/sepgsql/Makefile 2011-09-22 17:57:57.000000000 -0400
|
||||
+++ postgresql-9.1.1/contrib/sepgsql/Makefile 2011-09-26 16:47:53.772278112 -0400
|
||||
@@ -5,9 +5,6 @@
|
||||
schema.o relation.o proc.o
|
||||
DATA_built = sepgsql.sql
|
||||
|
||||
-REGRESS = label dml misc
|
||||
-REGRESS_OPTS = --launcher $(top_builddir)/contrib/sepgsql/launcher
|
||||
-
|
||||
EXTRA_CLEAN = -r tmp *.pp sepgsql-regtest.if sepgsql-regtest.fc
|
||||
|
||||
ifdef USE_PGXS
|
@ -52,8 +52,8 @@
|
||||
Summary: PostgreSQL client programs
|
||||
Name: postgresql
|
||||
%global majorversion 9.1
|
||||
Version: 9.1.1
|
||||
Release: 2%{?dist}
|
||||
Version: 9.1.2
|
||||
Release: 1%{?dist}
|
||||
|
||||
# The PostgreSQL license is very similar to other MIT licenses, but the OSI
|
||||
# recognizes it as an independent license, so we do as well.
|
||||
@ -89,7 +89,6 @@ Source15: postgresql-bashprofile
|
||||
Patch1: rpm-pgsql.patch
|
||||
Patch2: postgresql-logging.patch
|
||||
Patch3: postgresql-perl-rpath.patch
|
||||
Patch4: postgresql-no-sepsql-test.patch
|
||||
|
||||
BuildRequires: perl(ExtUtils::MakeMaker) glibc-devel bison flex gawk
|
||||
BuildRequires: perl(ExtUtils::Embed), perl-devel
|
||||
@ -301,7 +300,6 @@ benchmarks.
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
|
||||
# We used to run autoconf here, but there's no longer any real need to,
|
||||
# since Postgres ships with a reasonably modern configure script.
|
||||
@ -918,6 +916,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Dec 5 2011 Tom Lane <tgl@redhat.com> 9.1.2-1
|
||||
- Update to PostgreSQL 9.1.2, for various fixes described at
|
||||
http://www.postgresql.org/docs/9.1/static/release-9-1-2.html
|
||||
|
||||
* Wed Nov 02 2011 Honza Horak <hhorak@redhat.com> 9.1.1-2
|
||||
- Create a symlink of pg_regress instead of full copy;
|
||||
Don't strip symbols from regress libs
|
||||
|
4
sources
4
sources
@ -1,3 +1,3 @@
|
||||
061a9f17323117c9358ed60f33ecff78 postgresql-9.1.1.tar.bz2
|
||||
a085e5da2adf53e3979c3a16b58eee12 postgresql-9.1.1-US.pdf
|
||||
7dbff52221954c46595313eb7f92c3e0 postgresql-9.1.2.tar.bz2
|
||||
41e90d2e3b1ba88801fed96d553d9417 postgresql-9.1.2-US.pdf
|
||||
80390514d568a7af5ab61db1cda27e29 postgresql-9.0.4.tar.bz2
|
||||
|
Loading…
Reference in New Issue
Block a user