Replace whole repo with latest content from branch stream-15-rhel-8.8.0
Content corresponds with RHEL dist-git commit dca2250
This commit is contained in:
parent
d1cb34de7c
commit
87e6a9cfbe
10
.gitignore
vendored
Normal file → Executable file
10
.gitignore
vendored
Normal file → Executable file
@ -1,8 +1,6 @@
|
|||||||
SOURCES/postgresql-13.7.tar.bz2
|
|
||||||
SOURCES/postgresql-15.2-US.pdf
|
|
||||||
SOURCES/postgresql-15.2.tar.bz2
|
|
||||||
SOURCES/postgresql-setup-8.8.tar.gz
|
|
||||||
/postgresql-13.7.tar.bz2
|
|
||||||
/postgresql-15.2-US.pdf
|
|
||||||
/postgresql-15.2.tar.bz2
|
/postgresql-15.2.tar.bz2
|
||||||
|
/postgresql-15.2.tar.bz2.sha256
|
||||||
/postgresql-setup-8.8.tar.gz
|
/postgresql-setup-8.8.tar.gz
|
||||||
|
/postgresql-15.2-US.pdf
|
||||||
|
/postgresql-13.7.tar.bz2
|
||||||
|
/postgresql-13.7.tar.bz2.sha256
|
||||||
|
@ -1,6 +0,0 @@
|
|||||||
--- !Policy
|
|
||||||
product_versions:
|
|
||||||
- rhel-9
|
|
||||||
decision_context: osci_compose_gate
|
|
||||||
rules:
|
|
||||||
- !PassingTestCaseRule {test_case_name: baseos-ci.brew-build.tier1.functional}
|
|
13
generate-sources-and-gitignore.sh
Executable file
13
generate-sources-and-gitignore.sh
Executable file
@ -0,0 +1,13 @@
|
|||||||
|
#! /bin/sh
|
||||||
|
|
||||||
|
rm sources .gitignore
|
||||||
|
set -e
|
||||||
|
spectool -S *.spec | cut -d' ' -f2 \
|
||||||
|
| grep -E -e 'postgresql-.*\.tar\.*' -e 'postgresql.*\.pdf' | sort | \
|
||||||
|
while read line
|
||||||
|
do
|
||||||
|
base=`basename "$line"`
|
||||||
|
echo " * handling $base"
|
||||||
|
sha512sum --tag "$base" >> sources
|
||||||
|
echo "/$base" >> .gitignore
|
||||||
|
done
|
0
hstore-plperl-data-dumper.patch
Normal file → Executable file
0
hstore-plperl-data-dumper.patch
Normal file → Executable file
@ -1,13 +0,0 @@
|
|||||||
diff --git a/contrib/dblink/expected/dblink.out b/contrib/dblink/expected/dblink.out
|
|
||||||
index 6ceabb453c..6516d4f131 100644
|
|
||||||
--- a/contrib/dblink/expected/dblink.out
|
|
||||||
+++ b/contrib/dblink/expected/dblink.out
|
|
||||||
@@ -879,7 +879,7 @@ $d$;
|
|
||||||
CREATE USER MAPPING FOR public SERVER fdtest
|
|
||||||
OPTIONS (server 'localhost'); -- fail, can't specify server here
|
|
||||||
ERROR: invalid option "server"
|
|
||||||
-HINT: Valid options in this context are: user, password
|
|
||||||
+HINT: Valid options in this context are: user, password, sslpassword
|
|
||||||
CREATE USER MAPPING FOR public SERVER fdtest OPTIONS (user :'USER');
|
|
||||||
GRANT USAGE ON FOREIGN SERVER fdtest TO regress_dblink_user;
|
|
||||||
GRANT EXECUTE ON FUNCTION dblink_connect_u(text, text) TO regress_dblink_user;
|
|
@ -1 +0,0 @@
|
|||||||
1b905bf4f3d83614a393b3c51fd345910fd261e4f5124a68d9a1fdd3a2a46399 postgresql-13.7.tar.bz2
|
|
@ -1 +0,0 @@
|
|||||||
72ec74f4a7c16e684f43ea42e215497fcd4c55d028a68fb72e99e61ff40da4d6 postgresql-15.0.tar.bz2
|
|
@ -1 +0,0 @@
|
|||||||
99a2171fc3d6b5b5f56b757a7a3cb85d509a38e4273805def23941ed2b8468c7 postgresql-15.2.tar.bz2
|
|
0
postgresql-man.patch
Normal file → Executable file
0
postgresql-man.patch
Normal file → Executable file
33
postgresql-no-libs.patch
Executable file
33
postgresql-no-libs.patch
Executable file
@ -0,0 +1,33 @@
|
|||||||
|
diff --git a/src/Makefile b/src/Makefile
|
||||||
|
index febbced..9737b55 100644
|
||||||
|
--- a/src/Makefile
|
||||||
|
+++ b/src/Makefile
|
||||||
|
@@ -20,7 +20,6 @@ SUBDIRS = \
|
||||||
|
backend/utils/mb/conversion_procs \
|
||||||
|
backend/snowball \
|
||||||
|
include \
|
||||||
|
- interfaces \
|
||||||
|
backend/replication/libpqwalreceiver \
|
||||||
|
backend/replication/pgoutput \
|
||||||
|
fe_utils \
|
||||||
|
diff --git a/src/Makefile.global.in b/src/Makefile.global.in
|
||||||
|
index 4ed5174..d0e0dae 100644
|
||||||
|
--- a/src/Makefile.global.in
|
||||||
|
+++ b/src/Makefile.global.in
|
||||||
|
@@ -457,7 +457,7 @@ endif
|
||||||
|
|
||||||
|
# This macro is for use by libraries linking to libpq. (Because libpgport
|
||||||
|
# isn't created with the same link flags as libpq, it can't be used.)
|
||||||
|
-libpq = -L$(libpq_builddir) -lpq
|
||||||
|
+libpq = -lpq
|
||||||
|
|
||||||
|
# This macro is for use by client executables (not libraries) that use libpq.
|
||||||
|
# We force clients to pull symbols from the non-shared libraries libpgport
|
||||||
|
@@ -483,7 +483,6 @@ endif
|
||||||
|
# Commonly used submake targets
|
||||||
|
|
||||||
|
submake-libpq:
|
||||||
|
- $(MAKE) -C $(libpq_builddir) all
|
||||||
|
|
||||||
|
submake-libpgport:
|
||||||
|
$(MAKE) -C $(top_builddir)/src/port all
|
@ -1,102 +0,0 @@
|
|||||||
diff -ur postgresql-13.4/contrib/pgcrypto/expected/pgp-decrypt.out postgresql-13.4.patched/contrib/pgcrypto/expected/pgp-decrypt.out
|
|
||||||
--- postgresql-13.4/contrib/pgcrypto/expected/pgp-decrypt.out 2021-08-09 16:49:05.000000000 -0400
|
|
||||||
+++ postgresql-13.4.patched/contrib/pgcrypto/expected/pgp-decrypt.out 2021-09-01 08:16:48.138600886 -0400
|
|
||||||
@@ -4,20 +4,6 @@
|
|
||||||
-- Checking ciphers
|
|
||||||
select pgp_sym_decrypt(dearmor('
|
|
||||||
-----BEGIN PGP MESSAGE-----
|
|
||||||
-Comment: dat1.blowfish.sha1.mdc.s2k3.z0
|
|
||||||
-
|
|
||||||
-jA0EBAMCfFNwxnvodX9g0jwB4n4s26/g5VmKzVab1bX1SmwY7gvgvlWdF3jKisvS
|
|
||||||
-yA6Ce1QTMK3KdL2MPfamsTUSAML8huCJMwYQFfE=
|
|
||||||
-=JcP+
|
|
||||||
------END PGP MESSAGE-----
|
|
||||||
-'), 'foobar');
|
|
||||||
- pgp_sym_decrypt
|
|
||||||
------------------
|
|
||||||
- Secret message.
|
|
||||||
-(1 row)
|
|
||||||
-
|
|
||||||
-select pgp_sym_decrypt(dearmor('
|
|
||||||
------BEGIN PGP MESSAGE-----
|
|
||||||
Comment: dat1.aes.sha1.mdc.s2k3.z0
|
|
||||||
|
|
||||||
jA0EBwMCci97v0Q6Z0Zg0kQBsVf5Oe3iC+FBzUmuMV9KxmAyOMyjCc/5i8f1Eest
|
|
||||||
diff -ur postgresql-13.4/contrib/pgcrypto/expected/pgp-pubkey-decrypt.out postgresql-13.4.patched/contrib/pgcrypto/expected/pgp-pubkey-decrypt.out
|
|
||||||
--- postgresql-13.4/contrib/pgcrypto/expected/pgp-pubkey-decrypt.out 2021-08-09 16:49:05.000000000 -0400
|
|
||||||
+++ postgresql-13.4.patched/contrib/pgcrypto/expected/pgp-pubkey-decrypt.out 2021-09-01 08:05:27.750172653 -0400
|
|
||||||
@@ -594,13 +594,6 @@
|
|
||||||
(1 row)
|
|
||||||
|
|
||||||
select pgp_pub_decrypt(dearmor(data), dearmor(seckey))
|
|
||||||
-from keytbl, encdata where keytbl.id=2 and encdata.id=2;
|
|
||||||
- pgp_pub_decrypt
|
|
||||||
------------------
|
|
||||||
- Secret msg
|
|
||||||
-(1 row)
|
|
||||||
-
|
|
||||||
-select pgp_pub_decrypt(dearmor(data), dearmor(seckey))
|
|
||||||
from keytbl, encdata where keytbl.id=3 and encdata.id=3;
|
|
||||||
pgp_pub_decrypt
|
|
||||||
-----------------
|
|
||||||
diff -ur postgresql-13.4/contrib/pgcrypto/Makefile postgresql-13.4.patched/contrib/pgcrypto/Makefile
|
|
||||||
--- postgresql-13.4/contrib/pgcrypto/Makefile 2021-08-09 16:49:05.000000000 -0400
|
|
||||||
+++ postgresql-13.4.patched/contrib/pgcrypto/Makefile 2021-09-01 08:26:47.207164873 -0400
|
|
||||||
@@ -5,7 +5,7 @@
|
|
||||||
INT_TESTS = sha2
|
|
||||||
|
|
||||||
OSSL_SRCS = openssl.c pgp-mpi-openssl.c
|
|
||||||
-OSSL_TESTS = sha2 des 3des cast5
|
|
||||||
+OSSL_TESTS = sha2
|
|
||||||
|
|
||||||
ZLIB_TST = pgp-compression
|
|
||||||
ZLIB_OFF_TST = pgp-zlib-DISABLED
|
|
||||||
@@ -49,12 +49,13 @@
|
|
||||||
pgcrypto--1.0--1.1.sql
|
|
||||||
PGFILEDESC = "pgcrypto - cryptographic functions"
|
|
||||||
|
|
||||||
-REGRESS = init md5 sha1 hmac-md5 hmac-sha1 blowfish rijndael \
|
|
||||||
+REGRESS = init md5 sha1 hmac-md5 hmac-sha1 rijndael \
|
|
||||||
$(CF_TESTS) \
|
|
||||||
- crypt-des crypt-md5 crypt-blowfish crypt-xdes \
|
|
||||||
+ crypt-md5 \
|
|
||||||
pgp-armor pgp-decrypt pgp-encrypt $(CF_PGP_TESTS) \
|
|
||||||
pgp-pubkey-decrypt pgp-pubkey-encrypt pgp-info
|
|
||||||
|
|
||||||
+#REGRESS = init pgp-pubkey-decrypt pgp-decrypt \
|
|
||||||
EXTRA_CLEAN = gen-rtab
|
|
||||||
|
|
||||||
ifdef USE_PGXS
|
|
||||||
diff -ur postgresql-13.4/contrib/pgcrypto/sql/pgp-decrypt.sql postgresql-13.4.patched/contrib/pgcrypto/sql/pgp-decrypt.sql
|
|
||||||
--- postgresql-13.4/contrib/pgcrypto/sql/pgp-decrypt.sql 2021-08-09 16:49:05.000000000 -0400
|
|
||||||
+++ postgresql-13.4.patched/contrib/pgcrypto/sql/pgp-decrypt.sql 2021-09-01 08:16:12.525212175 -0400
|
|
||||||
@@ -5,16 +5,6 @@
|
|
||||||
-- Checking ciphers
|
|
||||||
select pgp_sym_decrypt(dearmor('
|
|
||||||
-----BEGIN PGP MESSAGE-----
|
|
||||||
-Comment: dat1.blowfish.sha1.mdc.s2k3.z0
|
|
||||||
-
|
|
||||||
-jA0EBAMCfFNwxnvodX9g0jwB4n4s26/g5VmKzVab1bX1SmwY7gvgvlWdF3jKisvS
|
|
||||||
-yA6Ce1QTMK3KdL2MPfamsTUSAML8huCJMwYQFfE=
|
|
||||||
-=JcP+
|
|
||||||
------END PGP MESSAGE-----
|
|
||||||
-'), 'foobar');
|
|
||||||
-
|
|
||||||
-select pgp_sym_decrypt(dearmor('
|
|
||||||
------BEGIN PGP MESSAGE-----
|
|
||||||
Comment: dat1.aes.sha1.mdc.s2k3.z0
|
|
||||||
|
|
||||||
jA0EBwMCci97v0Q6Z0Zg0kQBsVf5Oe3iC+FBzUmuMV9KxmAyOMyjCc/5i8f1Eest
|
|
||||||
diff -ur postgresql-13.4/contrib/pgcrypto/sql/pgp-pubkey-decrypt.sql postgresql-13.4.patched/contrib/pgcrypto/sql/pgp-pubkey-decrypt.sql
|
|
||||||
--- postgresql-13.4/contrib/pgcrypto/sql/pgp-pubkey-decrypt.sql 2021-08-09 16:49:05.000000000 -0400
|
|
||||||
+++ postgresql-13.4.patched/contrib/pgcrypto/sql/pgp-pubkey-decrypt.sql 2021-09-01 08:06:18.963732342 -0400
|
|
||||||
@@ -606,9 +606,6 @@
|
|
||||||
from keytbl, encdata where keytbl.id=1 and encdata.id=1;
|
|
||||||
|
|
||||||
select pgp_pub_decrypt(dearmor(data), dearmor(seckey))
|
|
||||||
-from keytbl, encdata where keytbl.id=2 and encdata.id=2;
|
|
||||||
-
|
|
||||||
-select pgp_pub_decrypt(dearmor(data), dearmor(seckey))
|
|
||||||
from keytbl, encdata where keytbl.id=3 and encdata.id=3;
|
|
||||||
|
|
||||||
select pgp_pub_decrypt(dearmor(data), dearmor(seckey))
|
|
@ -1,9 +0,0 @@
|
|||||||
---
|
|
||||||
# Forbidden function symbols found:
|
|
||||||
# inet_net_ntop
|
|
||||||
# inet_net_pton
|
|
||||||
# This is not a problem because the older version is only used for upgrade
|
|
||||||
# purposes and communicates through unix socket only
|
|
||||||
badfuncs:
|
|
||||||
ignore:
|
|
||||||
- /usr/lib*/pgsql/postgresql-*/bin/postgres
|
|
6
sources
Normal file → Executable file
6
sources
Normal file → Executable file
@ -1,4 +1,6 @@
|
|||||||
SHA512 (postgresql-13.7.tar.bz2) = 9254f21519c8d4e926f70082503bb5593c91064a3d2a4ea18ac503dfd9aa94751d6f01ce00fca9fec9b2b7af40caf8d0951b661dd8be4d6aa87c1e35b6fa7a41
|
|
||||||
SHA512 (postgresql-15.2-US.pdf) = 9badd72b196a85e4ac8264c8f06ff3816716bedd7f235f1069b6a4651ca665737b68b571f0abda015aee6a06e6dc060c965a6db6c7a2fc3fc55d33b5fdd6587b
|
|
||||||
SHA512 (postgresql-15.2.tar.bz2) = 115a8a4234791bba4e6dcc4617e9dd77abedcf767894ce9472c59cce9d5d4ef2d4e1746f3a0c7a99de4fc4385fb716652b70dce9f48be45a9db5a682517db7e8
|
SHA512 (postgresql-15.2.tar.bz2) = 115a8a4234791bba4e6dcc4617e9dd77abedcf767894ce9472c59cce9d5d4ef2d4e1746f3a0c7a99de4fc4385fb716652b70dce9f48be45a9db5a682517db7e8
|
||||||
|
SHA512 (postgresql-15.2.tar.bz2.sha256) = b905d1d9c91bc5fe29852c8909046edb1ddcde2b2db427fade5aeda142a29491fde6b0f0577baa15c0d7ddcdaffb9615c55867c003c4bfd090babd1feb6ddba6
|
||||||
SHA512 (postgresql-setup-8.8.tar.gz) = 4569e5ba83b16556312b89cd6762eb55902eb9265ce9ceb0e0fe18755e1ab7217ea748df465c4402e24d19b55b25702deab92030510dc722db8fcbc0cb639053
|
SHA512 (postgresql-setup-8.8.tar.gz) = 4569e5ba83b16556312b89cd6762eb55902eb9265ce9ceb0e0fe18755e1ab7217ea748df465c4402e24d19b55b25702deab92030510dc722db8fcbc0cb639053
|
||||||
|
SHA512 (postgresql-15.2-US.pdf) = 9badd72b196a85e4ac8264c8f06ff3816716bedd7f235f1069b6a4651ca665737b68b571f0abda015aee6a06e6dc060c965a6db6c7a2fc3fc55d33b5fdd6587b
|
||||||
|
SHA512 (postgresql-13.7.tar.bz2) = 9254f21519c8d4e926f70082503bb5593c91064a3d2a4ea18ac503dfd9aa94751d6f01ce00fca9fec9b2b7af40caf8d0951b661dd8be4d6aa87c1e35b6fa7a41
|
||||||
|
SHA512 (postgresql-13.7.tar.bz2.sha256) = a6e3601c6f8370318631820cb0f9858e49ea7d672652fe68ca0c0603e4fd28851fe1966a0825c8dafab11e15a0856486d82406f5b2d033917da0328089ca3f37
|
||||||
|
@ -1,16 +0,0 @@
|
|||||||
# This package uses external repositories for maintaining CI test cases.
|
|
||||||
# Please don't edit this file if possible.
|
|
||||||
|
|
||||||
- hosts: localhost
|
|
||||||
roles:
|
|
||||||
- role: standard-test-beakerlib
|
|
||||||
repositories:
|
|
||||||
- repo: https://src.fedoraproject.org/tests/postgresql.git
|
|
||||||
dest: postgresql
|
|
||||||
# TODO: minimize: https://pagure.io/standard-test-roles/issue/294
|
|
||||||
fmf_filter: "tier: 1"
|
|
||||||
# TODO: minimize: https://pagure.io/standard-test-roles/issue/294
|
|
||||||
tags:
|
|
||||||
- classic
|
|
||||||
- container
|
|
||||||
- atomic
|
|
Loading…
Reference in New Issue
Block a user