rebase: update to 11.0
Per release notes: https://www.postgresql.org/docs/11/static/release-11-0.html Version: 11.0-1
This commit is contained in:
parent
6111911b25
commit
626e81aa1d
9
.gitignore
vendored
9
.gitignore
vendored
@ -1,6 +1,3 @@
|
||||
/postgresql-10.5.tar.bz2
|
||||
/postgresql-10.5.tar.bz2.sha256
|
||||
/postgresql-9.6.10.tar.bz2
|
||||
/postgresql-9.6.10.tar.bz2.sha256
|
||||
/postgresql-setup-8.2.tar.gz
|
||||
/postgresql-10.5-US.pdf
|
||||
/postgresql-*.tar.bz2*
|
||||
/postgresql-setup-*.tar.gz
|
||||
/postgresql-*-US.pdf
|
||||
|
@ -1,6 +1,6 @@
|
||||
#! /bin/sh
|
||||
|
||||
rm sources .gitignore
|
||||
rm sources
|
||||
set -e
|
||||
spectool -S *.spec | cut -d' ' -f2 \
|
||||
| grep -E -e 'postgresql-.*\.tar\.*' -e 'postgresql.*\.pdf' | sort | \
|
||||
@ -9,5 +9,4 @@ do
|
||||
base=`basename "$line"`
|
||||
echo " * handling $base"
|
||||
sha512sum --tag "$base" >> sources
|
||||
echo "/$base" >> .gitignore
|
||||
done
|
@ -6,7 +6,7 @@ in sync!
|
||||
Related: rhbz#1618698
|
||||
|
||||
diff --git a/src/Makefile b/src/Makefile
|
||||
index febbced..9737b55 100644
|
||||
index bcdbd95..4bea236 100644
|
||||
--- a/src/Makefile
|
||||
+++ b/src/Makefile
|
||||
@@ -20,7 +20,6 @@ SUBDIRS = \
|
||||
@ -18,10 +18,10 @@ index febbced..9737b55 100644
|
||||
backend/replication/pgoutput \
|
||||
fe_utils \
|
||||
diff --git a/src/Makefile.global.in b/src/Makefile.global.in
|
||||
index 4ed5174..d0e0dae 100644
|
||||
index 9a4a8a3..2bdfb77 100644
|
||||
--- a/src/Makefile.global.in
|
||||
+++ b/src/Makefile.global.in
|
||||
@@ -457,7 +457,7 @@ endif
|
||||
@@ -513,7 +513,7 @@ endif
|
||||
|
||||
# This macro is for use by libraries linking to libpq. (Because libpgport
|
||||
# isn't created with the same link flags as libpq, it can't be used.)
|
||||
@ -30,11 +30,11 @@ index 4ed5174..d0e0dae 100644
|
||||
|
||||
# This macro is for use by client executables (not libraries) that use libpq.
|
||||
# We force clients to pull symbols from the non-shared libraries libpgport
|
||||
@@ -483,7 +483,6 @@ endif
|
||||
@@ -539,7 +539,6 @@ endif
|
||||
# Commonly used submake targets
|
||||
|
||||
submake-libpq:
|
||||
submake-libpq: | submake-generated-headers
|
||||
- $(MAKE) -C $(libpq_builddir) all
|
||||
|
||||
submake-libpgport:
|
||||
submake-libpgport: | submake-generated-headers
|
||||
$(MAKE) -C $(top_builddir)/src/port all
|
||||
|
@ -7,7 +7,7 @@ that we'll have to fix only a minimal set of packages which really build
|
||||
PostgreSQL server modules.
|
||||
|
||||
diff --git a/src/bin/pg_config/Makefile b/src/bin/pg_config/Makefile
|
||||
index c410087..e546b7b 100644
|
||||
index 02e6f9d..f7c844f 100644
|
||||
--- a/src/bin/pg_config/Makefile
|
||||
+++ b/src/bin/pg_config/Makefile
|
||||
@@ -11,28 +11,30 @@
|
||||
@ -48,12 +48,12 @@ index c410087..e546b7b 100644
|
||||
|
||||
check:
|
||||
diff --git a/src/bin/pg_config/nls.mk b/src/bin/pg_config/nls.mk
|
||||
index 1d41f90ee0..0f34f371cc 100644
|
||||
index 1d41f90..0f34f37 100644
|
||||
--- a/src/bin/pg_config/nls.mk
|
||||
+++ b/src/bin/pg_config/nls.mk
|
||||
@@ -1,4 +1,4 @@
|
||||
# src/bin/pg_config/nls.mk
|
||||
-CATALOG_NAME = pg_config
|
||||
+CATALOG_NAME = pg_server_config
|
||||
AVAIL_LANGUAGES = cs de es fr he it ja ko nb pl pt_BR ro ru sv ta tr zh_CN zh_TW
|
||||
AVAIL_LANGUAGES = cs de es fr he it ja ko nb pl pt_BR ro ru sv ta tr vi zh_CN zh_TW
|
||||
GETTEXT_FILES = pg_config.c ../../common/config_info.c ../../common/exec.c
|
||||
|
@ -57,9 +57,9 @@
|
||||
|
||||
Summary: PostgreSQL client programs
|
||||
Name: postgresql
|
||||
%global majorversion 10
|
||||
Version: 10.5
|
||||
Release: 4%{?dist}
|
||||
%global majorversion 11
|
||||
Version: 11.0
|
||||
Release: 1%{?dist}
|
||||
|
||||
# The PostgreSQL license is very similar to other MIT licenses, but the OSI
|
||||
# recognizes it as an independent license, so we do as well.
|
||||
@ -71,8 +71,8 @@ Url: http://www.postgresql.org/
|
||||
# in-place upgrade of an old database. In most cases it will not be critical
|
||||
# that this be kept up with the latest minor release of the previous series;
|
||||
# but update when bugs affecting pg_dump output are fixed.
|
||||
%global prevversion 9.6.10
|
||||
%global prevmajorversion 9.6
|
||||
%global prevversion 10.5
|
||||
%global prevmajorversion 10
|
||||
%global prev_prefix %{_libdir}/pgsql/postgresql-%{prevmajorversion}
|
||||
%global precise_version %{?epoch:%epoch:}%version-%release
|
||||
|
||||
@ -714,10 +714,8 @@ rm $RPM_BUILD_ROOT/%{_datadir}/man/man1/ecpg.1
|
||||
pushd $RPM_BUILD_ROOT%{_libdir}/pgsql/postgresql-%{prevmajorversion}
|
||||
rm bin/clusterdb
|
||||
rm bin/createdb
|
||||
rm bin/createlang
|
||||
rm bin/createuser
|
||||
rm bin/dropdb
|
||||
rm bin/droplang
|
||||
rm bin/dropuser
|
||||
rm bin/ecpg
|
||||
rm bin/initdb
|
||||
@ -799,7 +797,8 @@ find_lang_bins ()
|
||||
}
|
||||
find_lang_bins devel.lst pg_server_config
|
||||
find_lang_bins server.lst \
|
||||
initdb pg_basebackup pg_controldata pg_ctl pg_resetwal pg_rewind plpgsql postgres
|
||||
initdb pg_basebackup pg_controldata pg_ctl pg_resetwal pg_rewind plpgsql \
|
||||
postgres pg_verify_checksums
|
||||
find_lang_bins contrib.lst \
|
||||
pg_archivecleanup pg_test_fsync pg_test_timing pg_waldump
|
||||
find_lang_bins main.lst \
|
||||
@ -901,7 +900,6 @@ make -C postgresql-setup-%{setup_version} check
|
||||
%{_datadir}/pgsql/extension/bloom*
|
||||
%{_datadir}/pgsql/extension/btree_gin*
|
||||
%{_datadir}/pgsql/extension/btree_gist*
|
||||
%{_datadir}/pgsql/extension/chkpass*
|
||||
%{_datadir}/pgsql/extension/citext*
|
||||
%{_datadir}/pgsql/extension/cube*
|
||||
%{_datadir}/pgsql/extension/dblink*
|
||||
@ -915,6 +913,16 @@ make -C postgresql-setup-%{setup_version} check
|
||||
%{_datadir}/pgsql/extension/intagg*
|
||||
%{_datadir}/pgsql/extension/intarray*
|
||||
%{_datadir}/pgsql/extension/isn*
|
||||
%if %{plperl}
|
||||
%{_datadir}/pgsql/extension/jsonb_plperl*
|
||||
%endif
|
||||
%if %{plpython}
|
||||
%{_datadir}/pgsql/extension/jsonb_plpythonu*
|
||||
%{_datadir}/pgsql/extension/jsonb_plpython2u*
|
||||
%endif
|
||||
%if %{plpython3}
|
||||
%{_datadir}/pgsql/extension/jsonb_plpython3u*
|
||||
%endif
|
||||
%{_datadir}/pgsql/extension/lo*
|
||||
%{_datadir}/pgsql/extension/ltree*
|
||||
%{_datadir}/pgsql/extension/moddatetime*
|
||||
@ -946,7 +954,6 @@ make -C postgresql-setup-%{setup_version} check
|
||||
%{_libdir}/pgsql/bloom.so
|
||||
%{_libdir}/pgsql/btree_gin.so
|
||||
%{_libdir}/pgsql/btree_gist.so
|
||||
%{_libdir}/pgsql/chkpass.so
|
||||
%{_libdir}/pgsql/citext.so
|
||||
%{_libdir}/pgsql/cube.so
|
||||
%{_libdir}/pgsql/dblink.so
|
||||
@ -964,6 +971,12 @@ make -C postgresql-setup-%{setup_version} check
|
||||
%endif
|
||||
%{_libdir}/pgsql/insert_username.so
|
||||
%{_libdir}/pgsql/isn.so
|
||||
%if %plperl
|
||||
%{_libdir}/pgsql/jsonb_plperl.so
|
||||
%endif
|
||||
%if %plpython
|
||||
%{_libdir}/pgsql/jsonb_plpython2.so
|
||||
%endif
|
||||
%{_libdir}/pgsql/lo.so
|
||||
%{_libdir}/pgsql/ltree.so
|
||||
%if %plpython
|
||||
@ -1026,6 +1039,7 @@ make -C postgresql-setup-%{setup_version} check
|
||||
%{_bindir}/pg_recvlogical
|
||||
%{_bindir}/pg_resetwal
|
||||
%{_bindir}/pg_rewind
|
||||
%{_bindir}/pg_verify_checksums
|
||||
%{_bindir}/postgres
|
||||
%{_bindir}/postgresql-setup
|
||||
%{_bindir}/postmaster
|
||||
@ -1066,6 +1080,7 @@ make -C postgresql-setup-%{setup_version} check
|
||||
%{_mandir}/man1/pg_receivewal.*
|
||||
%{_mandir}/man1/pg_resetwal.*
|
||||
%{_mandir}/man1/pg_rewind.*
|
||||
%{_mandir}/man1/pg_verify_checksums.*
|
||||
%{_mandir}/man1/postgres.*
|
||||
%{_mandir}/man1/postgresql-new-systemd-unit.*
|
||||
%{_mandir}/man1/postgresql-setup.*
|
||||
@ -1085,6 +1100,8 @@ make -C postgresql-setup-%{setup_version} check
|
||||
|
||||
%files server-devel -f devel.lst
|
||||
%{_bindir}/pg_server_config
|
||||
%dir %{_datadir}/pgsql
|
||||
%{_datadir}/pgsql/errcodes.txt
|
||||
%dir %{_includedir}/pgsql
|
||||
%{_includedir}/pgsql/server
|
||||
%{_libdir}/pgsql/pgxs/
|
||||
@ -1158,6 +1175,10 @@ make -C postgresql-setup-%{setup_version} check
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Oct 16 2018 Pavel Raiskup <praiskup@redhat.com> - 11.0-1
|
||||
- new upstream release, per release notes:
|
||||
https://www.postgresql.org/docs/11/static/release-11-0.html
|
||||
|
||||
* Wed Sep 05 2018 Pavel Raiskup <praiskup@redhat.com> - 10.5-4
|
||||
- build without postgresql-libs; libraries moved to libpq and libecpg
|
||||
|
||||
|
6
sources
6
sources
@ -1,6 +1,6 @@
|
||||
SHA512 (postgresql-10.5.tar.bz2) = 1bad30ae88beca66f7e8b99b82e7f02aac1e9230b328e6e5a762a704cdd9dc767d924f5a66c68c93586badfef91b7ff336120a567ce970eaa58bb44c662ad48c
|
||||
SHA512 (postgresql-10.5.tar.bz2.sha256) = f4b2bf3c6454905caf4bd5a9a53dec33e7ac6c7593e6464bf75bcd12b185bc1c54f925a088122d8819840a17bbda84e8b42c311a639d7457090ace74725971f9
|
||||
SHA512 (postgresql-9.6.10.tar.bz2) = 960a32c86466f9d5f5491ef163f5c4a99cb5de7312d13371e2223b1d156e31eb2a23ed478e6654bcbb7bd19db9470aaf63473ff661c11c60971b92af5e9daf82
|
||||
SHA512 (postgresql-9.6.10.tar.bz2.sha256) = 1dbdcf7e26128a721cb309624c1f8c368f5e3c65c15ed08aaf93c27819d2e36ba43f3c5a4ce893a079a95f7579c7dbb27b17a90c0cdf98fb9a470d7ebf3ad001
|
||||
SHA512 (postgresql-11.0.tar.bz2) = 2cf471618dfaabdcbcbd68be3b85b6083376c97fdadce36d2ceb28438b7c736816118eacb1d4f12d48c39f584d78d7ffa89fa6d65858d440045a53921429970a
|
||||
SHA512 (postgresql-11.0.tar.bz2.sha256) = e1fb5c4ed7f584a813ac4f81d056dc3b0e3568c64c243b18cc57715d6bfefbcd159f442c8f2671278bf633751acb9251bd2e24cf97ce8044fae63a6c4592ef1e
|
||||
SHA512 (postgresql-setup-8.2.tar.gz) = b21ec508e207074ae1f5259479415f99301ae58a766d476a16fec620b7778ef6e5d32fa1d2cc0060cbfc5eee328a9495182500a8f2f8573ef20c359c290d8430
|
||||
SHA512 (postgresql-10.5-US.pdf) = 2605f575be109be9327ac4cc2615354e1a30daf03176888d97e928dbc43613ee45f8e47aed40a623f7b3db5a063c2c44cb3ce1616b5ac20315f611987890fbfa
|
||||
SHA512 (postgresql-11.0-US.pdf) = ffd39ea5ac3682284ccd00186d7be093bc8b264e71c5a8715a50d933b67ceb337ab6cb6ace03d06e92b5f42ecf4cbdbcf71035d36f9c37708b0680a557cf70a6
|
||||
|
Loading…
Reference in New Issue
Block a user