Import from CS git
This commit is contained in:
parent
cae5e8066a
commit
55335b9dbb
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,4 +1,4 @@
|
||||
SOURCES/postgresql-10.23.tar.bz2
|
||||
SOURCES/postgresql-12.17-US.pdf
|
||||
SOURCES/postgresql-12.17.tar.bz2
|
||||
SOURCES/postgresql-12.20-US.pdf
|
||||
SOURCES/postgresql-12.20.tar.bz2
|
||||
SOURCES/postgresql-setup-8.7.tar.gz
|
||||
|
@ -1,4 +1,4 @@
|
||||
2df7b4b3751112f3cb543c3ea81e45531bebc7a1 SOURCES/postgresql-10.23.tar.bz2
|
||||
7cc63d1d9c026cd0b5731f5e015c63c611ed5388 SOURCES/postgresql-12.17-US.pdf
|
||||
2fc3eda69a9d4b4f215428b77d70da0b83586f0d SOURCES/postgresql-12.17.tar.bz2
|
||||
985592db6377799663a0287d8f11aeb9ac65638c SOURCES/postgresql-12.20-US.pdf
|
||||
53f918639e4f0ee456c09586c5528d31a84e3934 SOURCES/postgresql-12.20.tar.bz2
|
||||
fb97095dc9648f9c31d58fcb406831da5e419ddf SOURCES/postgresql-setup-8.7.tar.gz
|
||||
|
@ -1 +0,0 @@
|
||||
93e8e1b23981d5f03c6c5763f77b28184c1ce4db7194fa466e2edb65d9c1c5f6 postgresql-12.17.tar.bz2
|
1
SOURCES/postgresql-12.20.tar.bz2.sha256
Normal file
1
SOURCES/postgresql-12.20.tar.bz2.sha256
Normal file
@ -0,0 +1 @@
|
||||
2d543af3009fec7fd5af35f7a70c95085d3eef6b508e517aa9493e99b15e9ea9 postgresql-12.20.tar.bz2
|
@ -4,12 +4,6 @@ This patch is used on two places; postgresql.spec and libecpg.spec -- keep those
|
||||
in sync!
|
||||
|
||||
Related: rhbz#1618698
|
||||
Signed-Off-By: Tianyue Lan <tianyue.lan@oracle.com>
|
||||
|
||||
---
|
||||
src/Makefile | 1 -
|
||||
src/Makefile.global.in | 3 +--
|
||||
2 files changed, 1 insertion(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/Makefile b/src/Makefile
|
||||
index bcdbd95..4bea236 100644
|
||||
@ -24,10 +18,10 @@ index bcdbd95..4bea236 100644
|
||||
backend/replication/pgoutput \
|
||||
fe_utils \
|
||||
diff --git a/src/Makefile.global.in b/src/Makefile.global.in
|
||||
index a05f7ce..36be499 100644
|
||||
index b9d86ac..29df69f 100644
|
||||
--- a/src/Makefile.global.in
|
||||
+++ b/src/Makefile.global.in
|
||||
@@ -546,7 +546,7 @@ endif
|
||||
@@ -549,7 +549,7 @@ endif
|
||||
# How to link to libpq. (This macro may be used as-is by backend extensions.
|
||||
# Client-side code should go through libpq_pgport or libpq_pgport_shlib,
|
||||
# instead.)
|
||||
@ -36,7 +30,7 @@ index a05f7ce..36be499 100644
|
||||
|
||||
# libpq_pgport is for use by client executables (not libraries) that use libpq.
|
||||
# We want clients to pull symbols from the non-shared libraries libpgport
|
||||
@@ -589,7 +589,6 @@ endif
|
||||
@@ -579,7 +579,6 @@ endif
|
||||
# Commonly used submake targets
|
||||
|
||||
submake-libpq: | submake-generated-headers
|
||||
@ -45,5 +39,5 @@ index a05f7ce..36be499 100644
|
||||
submake-libpgport: | submake-generated-headers
|
||||
$(MAKE) -C $(top_builddir)/src/port all
|
||||
--
|
||||
2.39.3
|
||||
2.21.0
|
||||
|
||||
|
@ -59,7 +59,7 @@
|
||||
Summary: PostgreSQL client programs
|
||||
Name: postgresql
|
||||
%global majorversion 12
|
||||
Version: %{majorversion}.17
|
||||
Version: %{majorversion}.20
|
||||
Release: 1%{?dist}
|
||||
|
||||
# The PostgreSQL license is very similar to other MIT licenses, but the OSI
|
||||
@ -1225,15 +1225,25 @@ make -C postgresql-setup-%{setup_version} check
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Dec 15 2023 Tianyue Lan <tianyue.lan@oracle.com> - 12.17-1
|
||||
* Mon Aug 12 2024 Ales Nezbeda <anezbeda@redhat.com> - 12.20-1
|
||||
- Update to 12.20
|
||||
- Fix CVE-2024-7348
|
||||
|
||||
* Fri Feb 9 2024 Filip Janus <fjanus@redhat.com> - 12.18-1
|
||||
- Update to 12.18
|
||||
- Fix CVE-2024-0985
|
||||
|
||||
* Tue Nov 28 2023 Dominik Rehák <drehak@redhat.com> - 12.17-1
|
||||
- Update to version 12.17
|
||||
- Resolves: Fix: CVE-2023-5868, CVE-2023-5869, CVE-2023-5870, CVE-2023-39417
|
||||
Fix: CVE-2023-5868, CVE-2023-5869, CVE-2023-5870
|
||||
|
||||
* Tue Aug 08 2023 David Sloboda <david.x.sloboda@oracle.com> - 12.15-1.0.1
|
||||
- Fixed postgresql port binding issue during bootup [Orabug: 35103668]
|
||||
|
||||
* Tue Aug 08 2023 David Sloboda <david.x.sloboda@oracle.com> - 12.15-1
|
||||
* Wed Jul 12 2023 Dominik Rehák <drehak@redhat.com> - 12.15-3
|
||||
- Update postgresql-setup to 8.7 (https://github.com/devexp-db/postgresql-setup/pull/35)
|
||||
|
||||
* Tue Jul 11 2023 Dominik Rehák <drehak@redhat.com> - 12.15-2
|
||||
- Fix PostgreSQL 10 version used in specfile
|
||||
|
||||
* Mon Jun 12 2023 Dominik Rehák <drehak@redhat.com> - 12.15-1
|
||||
- Resolves: #2207932
|
||||
- Update to version 12.15
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user