import OL ostgresql-12.17-1.0.1.module+el8.9.0+90107+c48bae1a
This commit is contained in:
parent
fef0d3b262
commit
55240a7cc3
@ -0,0 +1,38 @@
|
||||
From df5ba865eb8a42147d23100b37322921ad98248a Mon Sep 17 00:00:00 2001
|
||||
From: sagar sagar <sagar.sagar@oracle.com>
|
||||
Date: Thu, 11 May 2023 15:49:37 +0530
|
||||
Subject: [PATCH] Fixed postgresql service network binding issue during bootup
|
||||
|
||||
During the bootup, the postgresql service requires port bind to network
|
||||
address to assign configured in /var/lib/pgsql/data/postgresql.conf but the
|
||||
service is not able to do if the network service has not yet assigned an IP
|
||||
address to the network interface.
|
||||
By using "network-online.target" parameter in
|
||||
/usr/lib/systemd/system/postgresql.service we are postponing the postgresql
|
||||
service to run until we have not got the IP address assinged.
|
||||
|
||||
For more info :-
|
||||
https://www.freedesktop.org/wiki/Software/systemd/NetworkTarget/
|
||||
Orabug: 35103668
|
||||
|
||||
Signed-off-by: sagar sagar <sagar.sagar@oracle.com>
|
||||
---
|
||||
postgresql-setup-8.7/postgresql.service.in | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/postgresql-setup-8.7/postgresql.service.in b/postgresql-setup-8.7/postgresql.service.in
|
||||
index c73c42a..893e6fa 100644
|
||||
--- a/postgresql-setup-8.7/postgresql.service.in
|
||||
+++ b/postgresql-setup-8.7/postgresql.service.in
|
||||
@@ -6,7 +6,7 @@
|
||||
|
||||
[Unit]
|
||||
Description=PostgreSQL database server
|
||||
-After=network.target
|
||||
+After=network-online.target
|
||||
|
||||
[Service]
|
||||
Type=notify
|
||||
--
|
||||
2.31.1
|
||||
|
@ -1 +0,0 @@
|
||||
bb5206e2864c1c4579938b96ea6096d155f22abf2d2cc2aa57571e3c4cb12b36 postgresql-12.15.tar.bz2
|
1
SOURCES/postgresql-12.17.tar.bz2.sha256
Normal file
1
SOURCES/postgresql-12.17.tar.bz2.sha256
Normal file
@ -0,0 +1 @@
|
||||
93e8e1b23981d5f03c6c5763f77b28184c1ce4db7194fa466e2edb65d9c1c5f6 postgresql-12.17.tar.bz2
|
@ -4,6 +4,12 @@ This patch is used on two places; postgresql.spec and libecpg.spec -- keep those
|
||||
in sync!
|
||||
|
||||
Related: rhbz#1618698
|
||||
Signed-Off-By: Tianyue Lan <tianyue.lan@oracle.com>
|
||||
|
||||
---
|
||||
src/Makefile | 1 -
|
||||
src/Makefile.global.in | 3 +--
|
||||
2 files changed, 1 insertion(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/Makefile b/src/Makefile
|
||||
index bcdbd95..4bea236 100644
|
||||
@ -18,10 +24,10 @@ index bcdbd95..4bea236 100644
|
||||
backend/replication/pgoutput \
|
||||
fe_utils \
|
||||
diff --git a/src/Makefile.global.in b/src/Makefile.global.in
|
||||
index b9d86ac..29df69f 100644
|
||||
index a05f7ce..36be499 100644
|
||||
--- a/src/Makefile.global.in
|
||||
+++ b/src/Makefile.global.in
|
||||
@@ -549,7 +549,7 @@ endif
|
||||
@@ -546,7 +546,7 @@ endif
|
||||
# How to link to libpq. (This macro may be used as-is by backend extensions.
|
||||
# Client-side code should go through libpq_pgport or libpq_pgport_shlib,
|
||||
# instead.)
|
||||
@ -29,8 +35,8 @@ index b9d86ac..29df69f 100644
|
||||
+libpq = -lpq
|
||||
|
||||
# libpq_pgport is for use by client executables (not libraries) that use libpq.
|
||||
# We force clients to pull symbols from the non-shared libraries libpgport
|
||||
@@ -579,7 +579,6 @@ endif
|
||||
# We want clients to pull symbols from the non-shared libraries libpgport
|
||||
@@ -589,7 +589,6 @@ endif
|
||||
# Commonly used submake targets
|
||||
|
||||
submake-libpq: | submake-generated-headers
|
||||
@ -39,5 +45,5 @@ index b9d86ac..29df69f 100644
|
||||
submake-libpgport: | submake-generated-headers
|
||||
$(MAKE) -C $(top_builddir)/src/port all
|
||||
--
|
||||
2.21.0
|
||||
2.39.3
|
||||
|
||||
|
@ -59,8 +59,8 @@
|
||||
Summary: PostgreSQL client programs
|
||||
Name: postgresql
|
||||
%global majorversion 12
|
||||
Version: %{majorversion}.15
|
||||
Release: 1%{?dist}
|
||||
Version: %{majorversion}.17
|
||||
Release: 1.0.1%{?dist}
|
||||
|
||||
# The PostgreSQL license is very similar to other MIT licenses, but the OSI
|
||||
# recognizes it as an independent license, so we do as well.
|
||||
@ -76,7 +76,7 @@ Url: http://www.postgresql.org/
|
||||
%global prev_prefix %{_libdir}/pgsql/postgresql-%{prevmajorversion}
|
||||
%global precise_version %{?epoch:%epoch:}%version-%release
|
||||
|
||||
%global setup_version 8.6
|
||||
%global setup_version 8.7
|
||||
|
||||
%global service_name postgresql.service
|
||||
|
||||
@ -110,6 +110,9 @@ Patch8: postgresql-external-libpq.patch
|
||||
Patch9: postgresql-server-pg_config.patch
|
||||
Patch10: postgresql-12.5-contrib-dblink-expected-out.patch
|
||||
|
||||
#Oracle Patches
|
||||
Patch1001: 1001-Fixed-postgresql-service-network-binding-issue.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: perl(ExtUtils::MakeMaker) glibc-devel bison flex gawk
|
||||
BuildRequires: perl(ExtUtils::Embed), perl-devel
|
||||
@ -371,6 +374,8 @@ benchmarks.
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
|
||||
%patch1001 -p1
|
||||
|
||||
# We used to run autoconf here, but there's no longer any real need to,
|
||||
# since Postgres ships with a reasonably modern configure script.
|
||||
|
||||
@ -1225,10 +1230,15 @@ make -C postgresql-setup-%{setup_version} check
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jul 11 2023 Dominik Rehák <drehak@redhat.com> - 12.15-2
|
||||
- Fix PostgreSQL 10 version used in specfile
|
||||
* Fri Dec 15 2023 Tianyue Lan <tianyue.lan@oracle.com> - 12.17-1.0.1
|
||||
- Update to version 12.17
|
||||
- Resolves: Fix: CVE-2023-5868, CVE-2023-5869, CVE-2023-5870, CVE-2023-39417
|
||||
|
||||
* Mon Jun 12 2023 Dominik Rehák <drehak@redhat.com> - 12.15-1
|
||||
* Tue Aug 08 2023 David Sloboda <david.x.sloboda@oracle.com> - 12.15-1.0.1
|
||||
- Fixed postgresql port binding issue during bootup [Orabug: 35103668]
|
||||
|
||||
* Tue Aug 08 2023 David Sloboda <david.x.sloboda@oracle.com> - 12.15-1
|
||||
- Update postgresql-setup to 8.7 (https://github.com/devexp-db/postgresql-setup/pull/35)
|
||||
- Resolves: #2207932
|
||||
- Update to version 12.15
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user