import CS postgresql-10.23-2.module_el8+572+929c87ac
This commit is contained in:
parent
6b32df45d6
commit
52521430de
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,4 +1,4 @@
|
|||||||
SOURCES/postgresql-10.23-US.pdf
|
SOURCES/postgresql-10.23-US.pdf
|
||||||
SOURCES/postgresql-10.23.tar.bz2
|
SOURCES/postgresql-10.23.tar.bz2
|
||||||
SOURCES/postgresql-9.2.24.tar.bz2
|
SOURCES/postgresql-9.2.24.tar.bz2
|
||||||
SOURCES/postgresql-setup-8.6.tar.gz
|
SOURCES/postgresql-setup-8.7.tar.gz
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
a416c245ff0815fbde534bc49b0a07ffdd373894 SOURCES/postgresql-10.23-US.pdf
|
a416c245ff0815fbde534bc49b0a07ffdd373894 SOURCES/postgresql-10.23-US.pdf
|
||||||
2df7b4b3751112f3cb543c3ea81e45531bebc7a1 SOURCES/postgresql-10.23.tar.bz2
|
2df7b4b3751112f3cb543c3ea81e45531bebc7a1 SOURCES/postgresql-10.23.tar.bz2
|
||||||
63d6966ccdbab6aae1f9754fdb8e341ada1ef653 SOURCES/postgresql-9.2.24.tar.bz2
|
63d6966ccdbab6aae1f9754fdb8e341ada1ef653 SOURCES/postgresql-9.2.24.tar.bz2
|
||||||
9e12ee26bf41d3831f83049b51ae5da76de2ce12 SOURCES/postgresql-setup-8.6.tar.gz
|
fb97095dc9648f9c31d58fcb406831da5e419ddf SOURCES/postgresql-setup-8.7.tar.gz
|
||||||
|
249
SOURCES/postgresql-10.23-CVE-2023-2454.patch
Normal file
249
SOURCES/postgresql-10.23-CVE-2023-2454.patch
Normal file
@ -0,0 +1,249 @@
|
|||||||
|
From 681d9e4621aac0a9c71364b6f54f00f6d8c4337f Mon Sep 17 00:00:00 2001
|
||||||
|
From 8d525d7b9545884a3e0d79adcd61543f9ae2ae28 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Noah Misch <noah@leadboat.com>
|
||||||
|
Date: Mon, 8 May 2023 06:14:07 -0700
|
||||||
|
Subject: Replace last PushOverrideSearchPath() call with
|
||||||
|
set_config_option().
|
||||||
|
|
||||||
|
The two methods don't cooperate, so set_config_option("search_path",
|
||||||
|
...) has been ineffective under non-empty overrideStack. This defect
|
||||||
|
enabled an attacker having database-level CREATE privilege to execute
|
||||||
|
arbitrary code as the bootstrap superuser. While that particular attack
|
||||||
|
requires v13+ for the trusted extension attribute, other attacks are
|
||||||
|
feasible in all supported versions.
|
||||||
|
|
||||||
|
Standardize on the combination of NewGUCNestLevel() and
|
||||||
|
set_config_option("search_path", ...). It is newer than
|
||||||
|
PushOverrideSearchPath(), more-prevalent, and has no known
|
||||||
|
disadvantages. The "override" mechanism remains for now, for
|
||||||
|
compatibility with out-of-tree code. Users should update such code,
|
||||||
|
which likely suffers from the same sort of vulnerability closed here.
|
||||||
|
Back-patch to v11 (all supported versions).
|
||||||
|
|
||||||
|
Alexander Lakhin. Reported by Alexander Lakhin.
|
||||||
|
|
||||||
|
Security: CVE-2023-2454
|
||||||
|
---
|
||||||
|
contrib/seg/Makefile | 2 +-
|
||||||
|
contrib/seg/expected/security.out | 32 ++++++++++++++++++
|
||||||
|
contrib/seg/sql/security.sql | 32 ++++++++++++++++++
|
||||||
|
src/backend/catalog/namespace.c | 4 +++
|
||||||
|
src/backend/commands/schemacmds.c | 37 ++++++++++++++------
|
||||||
|
src/test/regress/expected/namespace.out | 45 +++++++++++++++++++++++++
|
||||||
|
src/test/regress/sql/namespace.sql | 24 +++++++++++++
|
||||||
|
7 files changed, 165 insertions(+), 11 deletions(-)
|
||||||
|
create mode 100644 contrib/seg/expected/security.out
|
||||||
|
create mode 100644 contrib/seg/sql/security.sql
|
||||||
|
|
||||||
|
diff --git a/src/backend/catalog/namespace.c b/src/backend/catalog/namespace.c
|
||||||
|
index 14e57adee2..73ddb67882 100644
|
||||||
|
--- a/src/backend/catalog/namespace.c
|
||||||
|
+++ b/src/backend/catalog/namespace.c
|
||||||
|
@@ -3515,6 +3515,10 @@ OverrideSearchPathMatchesCurrent(OverrideSearchPath *path)
|
||||||
|
/*
|
||||||
|
* PushOverrideSearchPath - temporarily override the search path
|
||||||
|
*
|
||||||
|
+ * Do not use this function; almost any usage introduces a security
|
||||||
|
+ * vulnerability. It exists for the benefit of legacy code running in
|
||||||
|
+ * non-security-sensitive environments.
|
||||||
|
+ *
|
||||||
|
* We allow nested overrides, hence the push/pop terminology. The GUC
|
||||||
|
* search_path variable is ignored while an override is active.
|
||||||
|
*
|
||||||
|
diff --git a/src/backend/commands/schemacmds.c b/src/backend/commands/schemacmds.c
|
||||||
|
index 48590247f8..b6a71154a8 100644
|
||||||
|
--- a/src/backend/commands/schemacmds.c
|
||||||
|
+++ b/src/backend/commands/schemacmds.c
|
||||||
|
@@ -30,6 +30,7 @@
|
||||||
|
#include "commands/schemacmds.h"
|
||||||
|
#include "miscadmin.h"
|
||||||
|
#include "parser/parse_utilcmd.h"
|
||||||
|
+#include "parser/scansup.h"
|
||||||
|
#include "tcop/utility.h"
|
||||||
|
#include "utils/acl.h"
|
||||||
|
#include "utils/builtins.h"
|
||||||
|
@@ -53,14 +54,16 @@ CreateSchemaCommand(CreateSchemaStmt *stmt, const char *queryString,
|
||||||
|
{
|
||||||
|
const char *schemaName = stmt->schemaname;
|
||||||
|
Oid namespaceId;
|
||||||
|
- OverrideSearchPath *overridePath;
|
||||||
|
List *parsetree_list;
|
||||||
|
ListCell *parsetree_item;
|
||||||
|
Oid owner_uid;
|
||||||
|
Oid saved_uid;
|
||||||
|
int save_sec_context;
|
||||||
|
+ int save_nestlevel;
|
||||||
|
+ char *nsp = namespace_search_path;
|
||||||
|
AclResult aclresult;
|
||||||
|
ObjectAddress address;
|
||||||
|
+ StringInfoData pathbuf;
|
||||||
|
|
||||||
|
GetUserIdAndSecContext(&saved_uid, &save_sec_context);
|
||||||
|
|
||||||
|
@@ -153,14 +156,26 @@ CreateSchemaCommand(CreateSchemaStmt *stmt, const char *queryString,
|
||||||
|
CommandCounterIncrement();
|
||||||
|
|
||||||
|
/*
|
||||||
|
- * Temporarily make the new namespace be the front of the search path, as
|
||||||
|
- * well as the default creation target namespace. This will be undone at
|
||||||
|
- * the end of this routine, or upon error.
|
||||||
|
+ * Prepend the new schema to the current search path.
|
||||||
|
+ *
|
||||||
|
+ * We use the equivalent of a function SET option to allow the setting to
|
||||||
|
+ * persist for exactly the duration of the schema creation. guc.c also
|
||||||
|
+ * takes care of undoing the setting on error.
|
||||||
|
*/
|
||||||
|
- overridePath = GetOverrideSearchPath(CurrentMemoryContext);
|
||||||
|
- overridePath->schemas = lcons_oid(namespaceId, overridePath->schemas);
|
||||||
|
- /* XXX should we clear overridePath->useTemp? */
|
||||||
|
- PushOverrideSearchPath(overridePath);
|
||||||
|
+ save_nestlevel = NewGUCNestLevel();
|
||||||
|
+
|
||||||
|
+ initStringInfo(&pathbuf);
|
||||||
|
+ appendStringInfoString(&pathbuf, quote_identifier(schemaName));
|
||||||
|
+
|
||||||
|
+ while (scanner_isspace(*nsp))
|
||||||
|
+ nsp++;
|
||||||
|
+
|
||||||
|
+ if (*nsp != '\0')
|
||||||
|
+ appendStringInfo(&pathbuf, ", %s", nsp);
|
||||||
|
+
|
||||||
|
+ (void) set_config_option("search_path", pathbuf.data,
|
||||||
|
+ PGC_USERSET, PGC_S_SESSION,
|
||||||
|
+ GUC_ACTION_SAVE, true, 0, false);
|
||||||
|
|
||||||
|
/*
|
||||||
|
* Report the new schema to possibly interested event triggers. Note we
|
||||||
|
@@ -215,8 +230,10 @@ CreateSchemaCommand(CreateSchemaStmt *stmt, const char *queryString,
|
||||||
|
CommandCounterIncrement();
|
||||||
|
}
|
||||||
|
|
||||||
|
- /* Reset search path to normal state */
|
||||||
|
- PopOverrideSearchPath();
|
||||||
|
+ /*
|
||||||
|
+ * Restore the GUC variable search_path we set above.
|
||||||
|
+ */
|
||||||
|
+ AtEOXact_GUC(true, save_nestlevel);
|
||||||
|
|
||||||
|
/* Reset current user and security context */
|
||||||
|
SetUserIdAndSecContext(saved_uid, save_sec_context);
|
||||||
|
diff --git a/src/test/regress/expected/namespace.out b/src/test/regress/expected/namespace.out
|
||||||
|
index 2564d1b080..a62fd8ded0 100644
|
||||||
|
--- a/src/test/regress/expected/namespace.out
|
||||||
|
+++ b/src/test/regress/expected/namespace.out
|
||||||
|
@@ -1,6 +1,14 @@
|
||||||
|
--
|
||||||
|
-- Regression tests for schemas (namespaces)
|
||||||
|
--
|
||||||
|
+-- set the whitespace-only search_path to test that the
|
||||||
|
+-- GUC list syntax is preserved during a schema creation
|
||||||
|
+SELECT pg_catalog.set_config('search_path', ' ', false);
|
||||||
|
+ set_config
|
||||||
|
+------------
|
||||||
|
+
|
||||||
|
+(1 row)
|
||||||
|
+
|
||||||
|
CREATE SCHEMA test_schema_1
|
||||||
|
CREATE UNIQUE INDEX abc_a_idx ON abc (a)
|
||||||
|
CREATE VIEW abc_view AS
|
||||||
|
@@ -9,6 +17,43 @@ CREATE SCHEMA test_schema_1
|
||||||
|
a serial,
|
||||||
|
b int UNIQUE
|
||||||
|
);
|
||||||
|
+-- verify that the correct search_path restored on abort
|
||||||
|
+SET search_path to public;
|
||||||
|
+BEGIN;
|
||||||
|
+SET search_path to public, test_schema_1;
|
||||||
|
+CREATE SCHEMA test_schema_2
|
||||||
|
+ CREATE VIEW abc_view AS SELECT c FROM abc;
|
||||||
|
+ERROR: column "c" does not exist
|
||||||
|
+LINE 2: CREATE VIEW abc_view AS SELECT c FROM abc;
|
||||||
|
+ ^
|
||||||
|
+COMMIT;
|
||||||
|
+SHOW search_path;
|
||||||
|
+ search_path
|
||||||
|
+-------------
|
||||||
|
+ public
|
||||||
|
+(1 row)
|
||||||
|
+
|
||||||
|
+-- verify that the correct search_path preserved
|
||||||
|
+-- after creating the schema and on commit
|
||||||
|
+BEGIN;
|
||||||
|
+SET search_path to public, test_schema_1;
|
||||||
|
+CREATE SCHEMA test_schema_2
|
||||||
|
+ CREATE VIEW abc_view AS SELECT a FROM abc;
|
||||||
|
+SHOW search_path;
|
||||||
|
+ search_path
|
||||||
|
+-----------------------
|
||||||
|
+ public, test_schema_1
|
||||||
|
+(1 row)
|
||||||
|
+
|
||||||
|
+COMMIT;
|
||||||
|
+SHOW search_path;
|
||||||
|
+ search_path
|
||||||
|
+-----------------------
|
||||||
|
+ public, test_schema_1
|
||||||
|
+(1 row)
|
||||||
|
+
|
||||||
|
+DROP SCHEMA test_schema_2 CASCADE;
|
||||||
|
+NOTICE: drop cascades to view test_schema_2.abc_view
|
||||||
|
-- verify that the objects were created
|
||||||
|
SELECT COUNT(*) FROM pg_class WHERE relnamespace =
|
||||||
|
(SELECT oid FROM pg_namespace WHERE nspname = 'test_schema_1');
|
||||||
|
diff --git a/src/test/regress/sql/namespace.sql b/src/test/regress/sql/namespace.sql
|
||||||
|
index 6b12c96193..3474f5ecf4 100644
|
||||||
|
--- a/src/test/regress/sql/namespace.sql
|
||||||
|
+++ b/src/test/regress/sql/namespace.sql
|
||||||
|
@@ -2,6 +2,10 @@
|
||||||
|
-- Regression tests for schemas (namespaces)
|
||||||
|
--
|
||||||
|
|
||||||
|
+-- set the whitespace-only search_path to test that the
|
||||||
|
+-- GUC list syntax is preserved during a schema creation
|
||||||
|
+SELECT pg_catalog.set_config('search_path', ' ', false);
|
||||||
|
+
|
||||||
|
CREATE SCHEMA test_schema_1
|
||||||
|
CREATE UNIQUE INDEX abc_a_idx ON abc (a)
|
||||||
|
|
||||||
|
@@ -13,6 +17,26 @@ CREATE SCHEMA test_schema_1
|
||||||
|
b int UNIQUE
|
||||||
|
);
|
||||||
|
|
||||||
|
+-- verify that the correct search_path restored on abort
|
||||||
|
+SET search_path to public;
|
||||||
|
+BEGIN;
|
||||||
|
+SET search_path to public, test_schema_1;
|
||||||
|
+CREATE SCHEMA test_schema_2
|
||||||
|
+ CREATE VIEW abc_view AS SELECT c FROM abc;
|
||||||
|
+COMMIT;
|
||||||
|
+SHOW search_path;
|
||||||
|
+
|
||||||
|
+-- verify that the correct search_path preserved
|
||||||
|
+-- after creating the schema and on commit
|
||||||
|
+BEGIN;
|
||||||
|
+SET search_path to public, test_schema_1;
|
||||||
|
+CREATE SCHEMA test_schema_2
|
||||||
|
+ CREATE VIEW abc_view AS SELECT a FROM abc;
|
||||||
|
+SHOW search_path;
|
||||||
|
+COMMIT;
|
||||||
|
+SHOW search_path;
|
||||||
|
+DROP SCHEMA test_schema_2 CASCADE;
|
||||||
|
+
|
||||||
|
-- verify that the objects were created
|
||||||
|
SELECT COUNT(*) FROM pg_class WHERE relnamespace =
|
||||||
|
(SELECT oid FROM pg_namespace WHERE nspname = 'test_schema_1');
|
||||||
|
diff --git a/contrib/sepgsql/expected/ddl.out b/contrib/sepgsql/expected/ddl.out
|
||||||
|
index e8da587564..15d2b9c5e7 100644
|
||||||
|
--- a/contrib/sepgsql/expected/ddl.out
|
||||||
|
+++ b/contrib/sepgsql/expected/ddl.out
|
||||||
|
@@ -24,7 +24,6 @@ LOG: SELinux: allowed { create } scontext=unconfined_u:unconfined_r:sepgsql_reg
|
||||||
|
CREATE USER regress_sepgsql_test_user;
|
||||||
|
CREATE SCHEMA regtest_schema;
|
||||||
|
LOG: SELinux: allowed { create } scontext=unconfined_u:unconfined_r:sepgsql_regtest_superuser_t:s0 tcontext=unconfined_u:object_r:sepgsql_schema_t:s0 tclass=db_schema name="regtest_schema"
|
||||||
|
-LOG: SELinux: allowed { search } scontext=unconfined_u:unconfined_r:sepgsql_regtest_superuser_t:s0 tcontext=system_u:object_r:sepgsql_schema_t:s0 tclass=db_schema name="public"
|
||||||
|
GRANT ALL ON SCHEMA regtest_schema TO regress_sepgsql_test_user;
|
||||||
|
SET search_path = regtest_schema, public;
|
||||||
|
CREATE TABLE regtest_table (x serial primary key, y text);
|
||||||
|
--
|
||||||
|
2.41.0
|
||||||
|
|
114
SOURCES/postgresql-10.23-CVE-2023-2455.patch
Normal file
114
SOURCES/postgresql-10.23-CVE-2023-2455.patch
Normal file
@ -0,0 +1,114 @@
|
|||||||
|
From ca73753b090c33bc69ce299b4d7fff891a77b8ad Mon Sep 17 00:00:00 2001
|
||||||
|
From: Tom Lane <tgl@sss.pgh.pa.us>
|
||||||
|
Date: Mon, 8 May 2023 10:12:44 -0400
|
||||||
|
Subject: Handle RLS dependencies in inlined set-returning
|
||||||
|
functions properly.
|
||||||
|
|
||||||
|
If an SRF in the FROM clause references a table having row-level
|
||||||
|
security policies, and we inline that SRF into the calling query,
|
||||||
|
we neglected to mark the plan as potentially dependent on which
|
||||||
|
role is executing it. This could lead to later executions in the
|
||||||
|
same session returning or hiding rows that should have been hidden
|
||||||
|
or returned instead.
|
||||||
|
|
||||||
|
Our thanks to Wolfgang Walther for reporting this problem.
|
||||||
|
|
||||||
|
Stephen Frost and Tom Lane
|
||||||
|
|
||||||
|
Security: CVE-2023-2455
|
||||||
|
---
|
||||||
|
src/backend/optimizer/util/clauses.c | 7 ++++++
|
||||||
|
src/test/regress/expected/rowsecurity.out | 27 +++++++++++++++++++++++
|
||||||
|
src/test/regress/sql/rowsecurity.sql | 20 +++++++++++++++++
|
||||||
|
3 files changed, 54 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/src/backend/optimizer/util/clauses.c b/src/backend/optimizer/util/clauses.c
|
||||||
|
index a9c7bc342e..11269fee3e 100644
|
||||||
|
--- a/src/backend/optimizer/util/clauses.c
|
||||||
|
+++ b/src/backend/optimizer/util/clauses.c
|
||||||
|
@@ -5205,6 +5205,13 @@ inline_set_returning_function(PlannerInfo *root, RangeTblEntry *rte)
|
||||||
|
*/
|
||||||
|
record_plan_function_dependency(root, func_oid);
|
||||||
|
|
||||||
|
+ /*
|
||||||
|
+ * We must also notice if the inserted query adds a dependency on the
|
||||||
|
+ * calling role due to RLS quals.
|
||||||
|
+ */
|
||||||
|
+ if (querytree->hasRowSecurity)
|
||||||
|
+ root->glob->dependsOnRole = true;
|
||||||
|
+
|
||||||
|
return querytree;
|
||||||
|
|
||||||
|
/* Here if func is not inlinable: release temp memory and return NULL */
|
||||||
|
diff --git a/src/test/regress/expected/rowsecurity.out b/src/test/regress/expected/rowsecurity.out
|
||||||
|
index 38f53ed486..e278346420 100644
|
||||||
|
--- a/src/test/regress/expected/rowsecurity.out
|
||||||
|
+++ b/src/test/regress/expected/rowsecurity.out
|
||||||
|
@@ -4427,6 +4427,33 @@ SELECT * FROM rls_tbl;
|
||||||
|
|
||||||
|
DROP TABLE rls_tbl;
|
||||||
|
RESET SESSION AUTHORIZATION;
|
||||||
|
+-- CVE-2023-2455: inlining an SRF may introduce an RLS dependency
|
||||||
|
+create table rls_t (c text);
|
||||||
|
+insert into rls_t values ('invisible to bob');
|
||||||
|
+alter table rls_t enable row level security;
|
||||||
|
+grant select on rls_t to regress_rls_alice, regress_rls_bob;
|
||||||
|
+create policy p1 on rls_t for select to regress_rls_alice using (true);
|
||||||
|
+create policy p2 on rls_t for select to regress_rls_bob using (false);
|
||||||
|
+create function rls_f () returns setof rls_t
|
||||||
|
+ stable language sql
|
||||||
|
+ as $$ select * from rls_t $$;
|
||||||
|
+prepare q as select current_user, * from rls_f();
|
||||||
|
+set role regress_rls_alice;
|
||||||
|
+execute q;
|
||||||
|
+ current_user | c
|
||||||
|
+-------------------+------------------
|
||||||
|
+ regress_rls_alice | invisible to bob
|
||||||
|
+(1 row)
|
||||||
|
+
|
||||||
|
+set role regress_rls_bob;
|
||||||
|
+execute q;
|
||||||
|
+ current_user | c
|
||||||
|
+--------------+---
|
||||||
|
+(0 rows)
|
||||||
|
+
|
||||||
|
+RESET ROLE;
|
||||||
|
+DROP FUNCTION rls_f();
|
||||||
|
+DROP TABLE rls_t;
|
||||||
|
--
|
||||||
|
-- Clean up objects
|
||||||
|
--
|
||||||
|
diff --git a/src/test/regress/sql/rowsecurity.sql b/src/test/regress/sql/rowsecurity.sql
|
||||||
|
index 0fd0cded7d..3d664538a6 100644
|
||||||
|
--- a/src/test/regress/sql/rowsecurity.sql
|
||||||
|
+++ b/src/test/regress/sql/rowsecurity.sql
|
||||||
|
@@ -2127,6 +2127,26 @@ SELECT * FROM rls_tbl;
|
||||||
|
DROP TABLE rls_tbl;
|
||||||
|
RESET SESSION AUTHORIZATION;
|
||||||
|
|
||||||
|
+-- CVE-2023-2455: inlining an SRF may introduce an RLS dependency
|
||||||
|
+create table rls_t (c text);
|
||||||
|
+insert into rls_t values ('invisible to bob');
|
||||||
|
+alter table rls_t enable row level security;
|
||||||
|
+grant select on rls_t to regress_rls_alice, regress_rls_bob;
|
||||||
|
+create policy p1 on rls_t for select to regress_rls_alice using (true);
|
||||||
|
+create policy p2 on rls_t for select to regress_rls_bob using (false);
|
||||||
|
+create function rls_f () returns setof rls_t
|
||||||
|
+ stable language sql
|
||||||
|
+ as $$ select * from rls_t $$;
|
||||||
|
+prepare q as select current_user, * from rls_f();
|
||||||
|
+set role regress_rls_alice;
|
||||||
|
+execute q;
|
||||||
|
+set role regress_rls_bob;
|
||||||
|
+execute q;
|
||||||
|
+
|
||||||
|
+RESET ROLE;
|
||||||
|
+DROP FUNCTION rls_f();
|
||||||
|
+DROP TABLE rls_t;
|
||||||
|
+
|
||||||
|
--
|
||||||
|
-- Clean up objects
|
||||||
|
--
|
||||||
|
--
|
||||||
|
2.41.0
|
||||||
|
|
@ -59,7 +59,7 @@ Summary: PostgreSQL client programs
|
|||||||
Name: postgresql
|
Name: postgresql
|
||||||
%global majorversion 10
|
%global majorversion 10
|
||||||
Version: %{majorversion}.23
|
Version: %{majorversion}.23
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
|
|
||||||
# The PostgreSQL license is very similar to other MIT licenses, but the OSI
|
# The PostgreSQL license is very similar to other MIT licenses, but the OSI
|
||||||
# recognizes it as an independent license, so we do as well.
|
# recognizes it as an independent license, so we do as well.
|
||||||
@ -76,7 +76,7 @@ Url: http://www.postgresql.org/
|
|||||||
%global prev_prefix %{_libdir}/pgsql/postgresql-%{prevmajorversion}
|
%global prev_prefix %{_libdir}/pgsql/postgresql-%{prevmajorversion}
|
||||||
%global precise_version %{?epoch:%epoch:}%version-%release
|
%global precise_version %{?epoch:%epoch:}%version-%release
|
||||||
|
|
||||||
%global setup_version 8.6
|
%global setup_version 8.7
|
||||||
|
|
||||||
%global service_name postgresql.service
|
%global service_name postgresql.service
|
||||||
Source0: https://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
|
Source0: https://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
|
||||||
@ -108,6 +108,8 @@ Patch6: postgresql-man.patch
|
|||||||
Patch8: postgresql-no-libs.patch
|
Patch8: postgresql-no-libs.patch
|
||||||
Patch9: postgresql-server-pg_config.patch
|
Patch9: postgresql-server-pg_config.patch
|
||||||
Patch10: postgresql-10.15-contrib-dblink-expected-out.patch
|
Patch10: postgresql-10.15-contrib-dblink-expected-out.patch
|
||||||
|
Patch11: postgresql-10.23-CVE-2023-2454.patch
|
||||||
|
Patch12: postgresql-10.23-CVE-2023-2455.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: perl(ExtUtils::MakeMaker) glibc-devel bison flex gawk
|
BuildRequires: perl(ExtUtils::MakeMaker) glibc-devel bison flex gawk
|
||||||
@ -367,6 +369,8 @@ benchmarks.
|
|||||||
%patch8 -p1
|
%patch8 -p1
|
||||||
%patch9 -p1
|
%patch9 -p1
|
||||||
%patch10 -p1
|
%patch10 -p1
|
||||||
|
%patch11 -p1
|
||||||
|
%patch12 -p1
|
||||||
|
|
||||||
# We used to run autoconf here, but there's no longer any real need to,
|
# We used to run autoconf here, but there's no longer any real need to,
|
||||||
# since Postgres ships with a reasonably modern configure script.
|
# since Postgres ships with a reasonably modern configure script.
|
||||||
@ -1171,9 +1175,13 @@ make -C postgresql-setup-%{setup_version} check
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jul 19 2023 Dominik Rehák <drehak@redhat.com> - 10.23-2
|
||||||
|
- Backport fixes for CVE-2023-2454 and CVE-2023-2455
|
||||||
|
- Update postgresql-setup to 8.7 (https://github.com/devexp-db/postgresql-setup/pull/35)
|
||||||
|
- Resolves: #2207931
|
||||||
|
|
||||||
* Wed Nov 16 2022 Filip Januš <fjanus@redhat.com> - 10.23-1
|
* Wed Nov 16 2022 Filip Januš <fjanus@redhat.com> - 10.23-1
|
||||||
- Fix CVE-2022-2625
|
- Resolves: CVE-2022-2625
|
||||||
- Resolves: #2143167
|
|
||||||
- Rebase to 10.23
|
- Rebase to 10.23
|
||||||
|
|
||||||
* Mon May 16 2022 Filip Januš <fjanus@redhat.com> - 10.21-1
|
* Mon May 16 2022 Filip Januš <fjanus@redhat.com> - 10.21-1
|
||||||
|
Loading…
Reference in New Issue
Block a user