Update to PostgreSQL 8.3.3
This commit is contained in:
parent
6e3b5a3bca
commit
493aa00b1a
@ -1,5 +1,5 @@
|
|||||||
postgresql-8.3.1.tar.bz2
|
postgresql-8.3.3.tar.bz2
|
||||||
PyGreSQL-3.8.1.tgz
|
PyGreSQL-3.8.1.tgz
|
||||||
pgtcl1.6.2.tar.gz
|
pgtcl1.6.2.tar.gz
|
||||||
pgtcldocs-20070115.zip
|
pgtcldocs-20070115.zip
|
||||||
postgresql-8.3.1-US.pdf
|
postgresql-8.3.3-US.pdf
|
||||||
|
@ -1,20 +0,0 @@
|
|||||||
This patch hacks the Postgres configure script to prefer libncurses over
|
|
||||||
libtermcap. This is needed in the current Fedora environment because while
|
|
||||||
both are available, libtermcap is deprecated and will be removed in the
|
|
||||||
fairly near future. Because the need for this is short-term, I'm not
|
|
||||||
going to try to push it upstream; this patch can go away once libtermcap
|
|
||||||
is no longer present in the standard build environment.
|
|
||||||
|
|
||||||
|
|
||||||
diff -Naur postgresql-8.2.1.orig/config/programs.m4 postgresql-8.2.1/config/programs.m4
|
|
||||||
--- postgresql-8.2.1.orig/config/programs.m4 2006-05-23 15:28:45.000000000 -0400
|
|
||||||
+++ postgresql-8.2.1/config/programs.m4 2007-01-10 18:42:22.000000000 -0500
|
|
||||||
@@ -88,7 +88,7 @@
|
|
||||||
fi
|
|
||||||
for pgac_rllib in $READLINE_ORDER ; do
|
|
||||||
AC_MSG_CHECKING([for ${pgac_rllib}])
|
|
||||||
- for pgac_lib in "" " -ltermcap" " -lncurses" " -lcurses" ; do
|
|
||||||
+ for pgac_lib in "" " -lncurses" " -ltermcap" " -lcurses" ; do
|
|
||||||
LIBS="${pgac_rllib}${pgac_lib} $pgac_save_LIBS"
|
|
||||||
AC_TRY_LINK_FUNC([readline], [[
|
|
||||||
# Older NetBSD, OpenBSD, and Irix have a broken linker that does not
|
|
@ -1,30 +0,0 @@
|
|||||||
This patch is needed to build successfully on PPC, where the linker is
|
|
||||||
evidently pickier about functions vs variables than on other Fedora
|
|
||||||
platforms. Note it is already committed upstream, so we won't need it
|
|
||||||
in postgres 8.3.2 and later.
|
|
||||||
|
|
||||||
|
|
||||||
Index: configure.in
|
|
||||||
===================================================================
|
|
||||||
RCS file: /cvsroot/pgsql/configure.in,v
|
|
||||||
retrieving revision 1.546.2.3
|
|
||||||
diff -c -r1.546.2.3 configure.in
|
|
||||||
*** configure.in 14 Mar 2008 03:23:22 -0000 1.546.2.3
|
|
||||||
--- configure.in 28 Apr 2008 22:41:54 -0000
|
|
||||||
***************
|
|
||||||
*** 795,801 ****
|
|
||||||
fi
|
|
||||||
|
|
||||||
if test "$with_libxslt" = yes ; then
|
|
||||||
! AC_CHECK_LIB(xslt, xsltLibxmlVersion, [], [AC_MSG_ERROR([library 'xslt' is required for XSLT support])])
|
|
||||||
fi
|
|
||||||
|
|
||||||
# for contrib/uuid-ossp
|
|
||||||
--- 795,801 ----
|
|
||||||
fi
|
|
||||||
|
|
||||||
if test "$with_libxslt" = yes ; then
|
|
||||||
! AC_CHECK_LIB(xslt, xsltCleanupGlobals, [], [AC_MSG_ERROR([library 'xslt' is required for XSLT support])])
|
|
||||||
fi
|
|
||||||
|
|
||||||
# for contrib/uuid-ossp
|
|
@ -82,8 +82,8 @@
|
|||||||
|
|
||||||
Summary: PostgreSQL client programs and libraries
|
Summary: PostgreSQL client programs and libraries
|
||||||
Name: postgresql
|
Name: postgresql
|
||||||
Version: 8.3.1
|
Version: 8.3.3
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: Applications/Databases
|
Group: Applications/Databases
|
||||||
Url: http://www.postgresql.org/
|
Url: http://www.postgresql.org/
|
||||||
@ -97,7 +97,7 @@ Source7: ecpg_config.h
|
|||||||
Source14: postgresql.pam
|
Source14: postgresql.pam
|
||||||
Source15: postgresql-bashprofile
|
Source15: postgresql-bashprofile
|
||||||
Source16: filter-requires-perl-Pg.sh
|
Source16: filter-requires-perl-Pg.sh
|
||||||
Source17: http://www.postgresql.org/docs/manuals/postgresql-8.3.1-US.pdf
|
Source17: http://www.postgresql.org/docs/manuals/postgresql-8.3.3-US.pdf
|
||||||
Source18: ftp://ftp.pygresql.org/pub/distrib/PyGreSQL-3.8.1.tgz
|
Source18: ftp://ftp.pygresql.org/pub/distrib/PyGreSQL-3.8.1.tgz
|
||||||
Source19: http://pgfoundry.org/projects/pgtclng/pgtcl1.6.2.tar.gz
|
Source19: http://pgfoundry.org/projects/pgtclng/pgtcl1.6.2.tar.gz
|
||||||
Source20: http://pgfoundry.org/projects/pgtclng/pgtcldocs-20070115.zip
|
Source20: http://pgfoundry.org/projects/pgtclng/pgtcldocs-20070115.zip
|
||||||
@ -108,8 +108,6 @@ Patch3: postgresql-logging.patch
|
|||||||
Patch4: postgresql-test.patch
|
Patch4: postgresql-test.patch
|
||||||
Patch5: pgtcl-no-rpath.patch
|
Patch5: pgtcl-no-rpath.patch
|
||||||
Patch6: postgresql-perl-rpath.patch
|
Patch6: postgresql-perl-rpath.patch
|
||||||
Patch8: postgresql-prefer-ncurses.patch
|
|
||||||
Patch9: postgresql-xslt.patch
|
|
||||||
|
|
||||||
BuildRequires: perl(ExtUtils::MakeMaker) glibc-devel bison flex autoconf gawk
|
BuildRequires: perl(ExtUtils::MakeMaker) glibc-devel bison flex autoconf gawk
|
||||||
BuildRequires: perl(ExtUtils::Embed), perl-devel
|
BuildRequires: perl(ExtUtils::Embed), perl-devel
|
||||||
@ -358,8 +356,6 @@ system, including regression tests and benchmarks.
|
|||||||
%patch4 -p1
|
%patch4 -p1
|
||||||
# patch5 is applied later
|
# patch5 is applied later
|
||||||
%patch6 -p1
|
%patch6 -p1
|
||||||
%patch8 -p1
|
|
||||||
%patch9 -p0
|
|
||||||
|
|
||||||
#call autoconf 2.53 or greater
|
#call autoconf 2.53 or greater
|
||||||
%aconfver
|
%aconfver
|
||||||
@ -855,6 +851,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jun 11 2008 Tom Lane <tgl@redhat.com> 8.3.3-1
|
||||||
|
- Update to PostgreSQL 8.3.3.
|
||||||
|
- Remove postgresql-prefer-ncurses.patch, no longer needed in recent
|
||||||
|
Fedora releases because libtermcap is gone.
|
||||||
|
|
||||||
* Sat May 17 2008 Tom Lane <tgl@redhat.com> 8.3.1-5
|
* Sat May 17 2008 Tom Lane <tgl@redhat.com> 8.3.1-5
|
||||||
- rebuild because of buildsystem hiccup
|
- rebuild because of buildsystem hiccup
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,5 +1,5 @@
|
|||||||
a5e0ed6a85b450dc217ec71da93243a7 postgresql-8.3.1.tar.bz2
|
0ae4bd9620e84d3e08dcf923808d14d0 postgresql-8.3.3.tar.bz2
|
||||||
5575979dac93c9c5795d7693a8f91c86 PyGreSQL-3.8.1.tgz
|
5575979dac93c9c5795d7693a8f91c86 PyGreSQL-3.8.1.tgz
|
||||||
abf26e3cd7f8229f468045ed1fb7e748 pgtcl1.6.2.tar.gz
|
abf26e3cd7f8229f468045ed1fb7e748 pgtcl1.6.2.tar.gz
|
||||||
8ce98e93b238c3329d0fe43810442c44 pgtcldocs-20070115.zip
|
8ce98e93b238c3329d0fe43810442c44 pgtcldocs-20070115.zip
|
||||||
5b8a011a414c7af37938cd45a98a0ed0 postgresql-8.3.1-US.pdf
|
62043e967e738d93e6f0402ba152f6de postgresql-8.3.3-US.pdf
|
||||||
|
Loading…
Reference in New Issue
Block a user